Format text

  1. InDesign User Guide
  2. Get to know InDesign
    1. Introduction to InDesign
      1. What's New in InDesign
      2. System requirements
      3. Common questions
      4. Use Creative Cloud libraries
    2. Workspace
      1. Workspace basics
      2. Toolbox
      3. Set preferences
      4. Touch workspace
      5. Default keyboard shortcuts
      6. Document recovery and undo
      7. Capture extension
  3. Create and lay out documents
    1. Documents and pages
      1. Create documents
      2. Work with parent pages
      3. Work with document pages
      4. Set page size, margins, and bleed
      5. Work with files and templates
      6. Create book files
      7. Add basic page numbering
      8. Number pages, chapters, and sections
      9. Convert QuarkXPress and PageMaker documents
      10. Share content
      11. Understand a basic managed-file workflow
      12. Save documents
    2. Grids
      1. Grids
      2. Format grids
    3. Layout aids
      1. Rulers
  4. Add content
    1. Text
      1. Add text to frames
      2. Threading text
      3. Arabic and Hebrew features in InDesign
      4. Create type on a path
      5. Bullets and numbering
      6. Glyphs and special characters
      7. Text composition
      8. Text variables
      9. Generate QR codes
      10. Edit text
      11. Align text
      12. Wrap text around objects
      13. Anchored objects
      14. Linked content
      15. Format paragraphs
      16. Format characters
      17. Find/Change
      18. Spell check and language dictionaries
    2. Typography
      1. Using fonts in InDesign
      2. Kerning and tracking
    3. Format text
      1. Format text
      2. Tabs and indents
    4. Review text
      1. Track and review changes
      2. Add editorial notes in InDesign
      3. Import PDF comments
    5. Add references
      1. Create a table of contents
      2. Footnotes
      3. Create an index
      4. Endnotes
      5. Captions
    6. Styles
      1. Paragraph and character styles
      2. Object styles
      3. Drop caps and nested styles
      4. Work with styles
      5. Leading
    7. Tables
      1. Format tables
      2. Create tables
      3. Table and Cell styles
      4. Select and edit tables
      5. Table strokes and fills
    8. Interactivity
      1. Hyperlinks
      2. Dynamic PDF documents
      3. Bookmarks
      4. Buttons
      5. Forms
      6. Animation
      7. Cross-references
      8. Structure PDFs
      9. Page transitions
      10. Movies and sounds
      11. Forms
    9. Graphics
      1. Understand paths and shapes
      2. Draw with the Pencil tool
      3. Draw with the Pen tool
      4. Apply line (stroke) settings 
      5. Compound paths and shapes
      6. Edit paths
      7. Clipping paths
      8. Change corner appearance
      9. Align and distribute objects
      10. Linked and embedded graphics
      11. Integrate AEM assets
    10. Color and transparency
      1. Apply color
      2. Use colors from imported graphics
      3. Work with swatches
      4. Mix inks
      5. Tints
      6. Undertand spot and process colors
      7. Blend colors
      8. Gradients
      9. Flatten transparent artwork
      10. Add transparency effects
  5. Share
    1. Share and collaborate        
    2. Share for Review
    3. Review a shared InDesign document
    4. Manage feedback 
  6. Publish
    1. Export and publish
      1. Publish Online
      2. Export content for EPUB
      3. Adobe PDF options
      4. Export content to HTML
      5. Export to Adobe PDF
      6. Export to JPEG format
      7. Export HTML
      8. DPS and AEM Mobile overview
    2. Printing
      1. Print booklets
      2. Printer's marks and bleeds
      3. Print documents
      4. Inks, separation, and screen frequency
      5. Overprinting
      6. Create PostScript and EPS files
      7. Preflight files before handoff
      8. Print thumbnails and oversized documents
      9. Prepare PDFs for service providers
      10. Prepare to print separations
  7. Extend InDesign
    1. Automation
      1. Data merge
      2. Plug-ins
      3. Capture extension in InDesign
      4. Scripting

Format text

Use the Control panel to change the appearance of text. When text is selected or when the insertion point is placed in text, the Control panel displays either the character formatting controls or the paragraph formatting controls, or a combination of both, depending on your monitor resolution. These same text formatting controls appear in the Character panel and Paragraph panel. You can also use the Character panel and Paragraphs panel to change the appearance of text.

Note the following methods of formatting text:

  • To format characters, you can use the Type tool  to select characters, or you can click to place the insertion point, select a formatting option, and then begin typing.

  • To format paragraphs, you don’t need to select an entire paragraph—selecting any word or character, or placing the insertion point in a paragraph will do. You can also select text in a range of paragraphs.

  • To set the formatting for all future text frames that you’ll create in the current document, make sure that the insertion point is not active and that nothing is selected, and then specify text formatting options. To set default text formatting for all new documents, close all documents, and then specify the text settings. See Set defaults.

  • Select a frame to apply formatting to all text inside it. The frame cannot be part of a thread.

  • Use paragraph styles and character styles to format text quickly and consistently.

  1. Select the Type tool  .
  2. Click to place an insertion point, or select the text that you want to format.
  3. In the Control panel, click the Character Formatting Control icon  or the Paragraph Formatting Control icon  .
    Control panel

    A. Character formatting controls B. Paragraph formatting controls 

  4. Specify formatting options.

Text formatting precedence

Copy type attributes (Eyedropper)

You can use the Eyedropper tool to copy type attributes such as character, paragraph, fill, and stroke settings, and then apply those attributes to other type. By default, the Eyedropper tool copies all type attributes. To customize the attributes you want to copy with the Eyedropper tool, use the Eyedropper Options dialog box.

The Eyedropper tool is available only in Layout View.

Copy type attributes to unselected text

  1. With the Eyedropper tool  , click the text that is formatted with the attributes you want to copy. (The text can be in another open document.) The eyedropper pointer reverses direction, and appears full  , to indicate that it’s loaded with the attributes you copied. When you position the eyedropper pointer over text, an I-beam appears next to the loaded eyedropper  .
  2. With the Eyedropper tool, select the text you want to change.

    The selected text takes on the attributes loaded in the eyedropper. As long as the Eyedropper tool is selected, you can continue to select text to apply formatting.

  3. To deselect the Eyedropper tool, click another tool.
Note:

To clear the formatting attributes currently held by the eyedropper tool, press Alt (Windows) or Option (Mac OS) while the Eyedropper tool is loaded. The Eyedropper tool reverses direction and appears empty , to indicate that it’s ready to pick up new attributes. Click an object containing the attributes you want to copy, and then drop the new attributes on another object.

The eyedropper is clicked on formatted text to copy its formatting (left), and then dragged across unformatted text (middle) to apply that formatting (right).

If you use the Eyedropper tool to copy a paragraph style from text in one document to text in another, and the paragraph style has the same name but different sets of attributes, any style differences will appear as local overrides to the destination style.

Copy type attributes to selected text

  1. With the Type tool  or Path Type tool  , select the text to which you want to copy attributes.
  2. Using the Eyedropper tool  , click the text from which you want to copy attributes. (The text from which you want to copy attributes must be in the same InDesign document as the text you want to change.) The Eyedropper tool reverses direction and appears full  , to indicate that it’s loaded with the attributes you copied. The attributes are applied to the text you selected in step 1.
Type attributes copied to selected text

Change which text attributes the Eyedropper tool copies

  1. In the toolbox, double-click the Eyedropper tool.
  2. Choose Character Settings or Paragraph Settings in the Eyedropper Options dialog box.
  3. Select the attributes you want to copy with the Eyedropper tool, and then click OK.
Note:

To copy or apply paragraph attributes only without having to change settings in the Eyedropper Options dialog box, hold down Shift as you click text with the Eyedropper tool.

Use Quick Apply

Use Quick Apply to find and apply styles, menu commands, scripts, variables, and most other commands that can be found in the Keyboard Shortcuts dialog box.

  1. Select the text or frame to which you want to apply the style, menu command, script, or variable.
  2. Choose Edit > Quick Apply, or press Ctrl+Enter (Windows) or Command+Return (Mac OS).
  3. Start typing the name of the item you want to apply.

    The name you type doesn’t need to be an exact match. For example, typing he will locate styles such as Head 1, Head 2, and Subhead, as well as Help menu commands such as Help Menu > InDesign Help.

    Use Quick Apply to find styles, menu commands, scripts, and variables.

    Note:

    You can narrow the search to only a single category by typing the appropriate prefix at the beginning of the search, such as m: for menu or p: for paragraph styles. To view a list of prefixes, click the down arrow to the left of the Quick Apply text box. You can deselect categories in this list that you don’t want to appear.

  4. Select the item you want to apply, and then:
    • To apply a style, menu command, or variable, press Enter or Return.

    • To apply a paragraph style and remove overrides, press Alt+Enter (Windows) or Option+Return (Mac OS).

    • To apply a paragraph style and remove overrides and character styles, press Alt+Shift+Enter (Windows) or Option+Shift+Return (Mac OS).

    • To apply an item without closing the Quick Apply list, press Shift+Enter (Windows) or Shift+Return (Mac OS).

    • To close the Quick Apply list without applying an item, press Esc or click anywhere else in the document window.

    • To edit a style, press Ctrl+Enter (Windows) or Command+Return (Mac OS).

Note:

When the Quick Apply list is displayed, press the left and right arrow keys to scroll through the edit field; press the up and down arrow keys to scroll through the list of items.

Adobe logo

Sign in to your account