Place (import) graphics

The Place command is the primary method used to insert graphics into InDesign because it provides the highest level of support for resolution, file formats, multipage PDF and INDD files, and color. To place graphics is also referred to as import images and insert pictures.

If you’re creating a document in which those characteristics aren’t critical, you can copy and paste to import graphics InDesign. Pasting, however, embeds a graphic in a document; the link to the original graphic file is broken and doesn’t appear in the Links panel, and you can’t update the graphic from the original file. However, pasting Illustrator graphics allows you to edit paths in InDesign. See Importing Adobe Illustrator graphics.

The options available to you when you place a graphics file depend on the type of graphic. These options appear when you select Show Import Options in the Place dialog box. If you don’t select Show Import Options, InDesign applies the default settings or the last settings used in placing a graphics file of that type.

The names of graphics you’ve placed (imported) appear in the Links panel.

Note:

If you place or drag a graphic from a removable media, such as a CD‑ROM, the link breaks when you remove that media from your system.

  1. Do one of the following:
    • To import a graphic without first creating a frame, make sure that nothing in the document is selected.

    • To import a graphic into an existing frame, select the frame. If the new image is larger than the frame, you can refit the frame later by choosing Object > Fitting > [fitting command].

    • To replace an existing image, select its graphics frame.

  2. Choose File > Place and select one or more graphics files of any available format.

    If you select multiple files, you can click or drag in the document to place the selected files one at a time. (See Place multiple graphics.)

  3. To replace an object you selected, select Replace Selected Item.
  4. To add a caption based on the image metadata, select Create Static Captions. See Generate a caption from an image.
  5. To set format-specific import options, do one of the following:
    • Select Show Import Options, and then click Open.

    • Hold down Shift as you click Open or Shift-double-click a filename.

    Note:

    When you place a graphic created in Illustrator 9.0 or later by using the Show Import Options dialog box, the options are identical to those for PDFs. When you place an Illustrator 5.5–8.x graphic, the options are identical to those for EPS files.

  6. If the Image Import Options dialog box appears (because you chose to set format-specific import options), select import options and click OK. (See Import options for graphics.)
  7. Do one of the following:
    • To import into a new frame, drag to create a frame. Or, click the loaded graphics icon  in the layout at the place where you want the upper-left corner of the graphic to appear.

    Note:

    When you drag to create a frame, the frame has the same proportions as the graphic unless you Shift-drag.

    • To import into an existing frame which is not selected, click the loaded graphics icon anywhere in that frame.
    • To import into an existing selected frame, you don’t have to do anything if Replace Selected Item is selected. The image automatically appears in that frame.
    • To replace an existing graphic, hold down Alt (Windows) or Option (Mac OS) and click the loaded graphics icon on the graphic you want to replace.
    • To place all the specified pages of a multipage file (such as a PDF or INDD file) at the same time, one overlapping another, hold down Alt (Windows) or Option (Mac OS) and click the loaded graphics icon where you want the pages to appear.

    Note:

    If you accidentally replace an existing graphic with an image you’re placing, press Ctrl+Z (Windows) or Command+Z (Mac OS) to return the original image to the frame and display the loaded graphics icon.

  8. To place the next graphic or the next page of a multipage PDF, click the loaded graphics icon in the layout where desired. If necessary, you can scroll to a different location or change pages without losing the loaded graphics icon.

Note:

The image you place may appear to have a low resolution, depending on your settings. The display setting of an image does not affect final output of the file. To change your image display settings, see Control graphics’ display performance.

Import options for graphics

The options for importing graphics vary depending on the type of image being imported. To display import options, make sure that Show Import Options is selected in the Place dialog box.

Encapsulated PostScript (.eps) import options

When you place an EPS graphic (or a file saved with Illustrator 8.0 or earlier) and select Show Import Options in the Place dialog box, you see a dialog box containing these options:

Read Embedded OPI Image Links

This option tells InDesign to read links from OPI comments for images included (or nested) in the graphic.

Deselect this option if you’re using a proxy-based workflow and plan to have your service providers perform the image replacement using their OPI software. When this option is deselected, InDesign preserves the OPI links but does not read them. When you print or export, the proxy and the links are passed on to the output file.

Select this option if you’re using a proxy-based workflow and you want InDesign, instead of your service provider, to perform image replacement when you output the final file. When you select this option, the OPI links appear in the Links panel.

Also select this option when you import EPS files containing OPI comments that are not part of a proxy-based workflow. For example, if you import an EPS file containing OPI comments for an omitted TIFF or bitmap image, you’ll want to select this option so that InDesign can access the TIFF information when you output the file.

Apply Photoshop Clipping Path

Regardless of whether this option is selected, a placed EPS file includes a clipping path in InDesign. However, deselecting this option may result in a different bounding box size.

Proxy Generation

This creates a low-resolution bitmap representation of an image when drawing the file to the screen. The following settings control how the proxy is generated:

Use TIFF Or PICT Preview

Some EPS images contain an embedded preview. Select this option to generate the proxy image of the existing preview. If a preview does not exist, the proxy is generated by rasterizing the EPS to an offscreen bitmap.

Rasterize The PostScript

Select this option to ignore the embedded preview. This option is typically slower but provides the highest-quality results.

Note:

When you import more than one single file into the same document, all instances share the proxy setting of the first instance of the imported file.

Bitmap import options

You can apply color-management options to individual imported graphics when using color-management tools with a document. You can also import a clipping path or an alpha channel saved with an image created in Photoshop. Doing so lets you directly select an image and modify its path without changing the graphics frame.

When you place a PSD, TIFF, GIF, JPEG, or BMP file and select Show Import Options in the Place dialog box, you see a dialog box containing these options:

Apply Photoshop Clipping Path

If this option isn’t available, the image wasn’t saved with a clipping path, or the file format doesn’t support clipping paths. If the bitmap image doesn’t have a clipping path, you can create one in InDesign.

Alpha channel

Select an alpha channel to import the area of the image saved as an alpha channel in Photoshop. InDesign uses the alpha channel to create a transparent mask on the image. This option is available only for images that contain at least one alpha channel.

Click the Color tab to view the following options:

Image imported without clipping path (left) and with clipping path (right)
Image imported without clipping path (left) and with clipping path (right)

Profile

If Use Document Default is selected, leave this option unchanged. Otherwise, choose a color source profile that matches the gamut of the device or software used to create the graphic. This profile enables InDesign to properly translate its color to the gamut of the output device.

Rendering Intent

Choose a method for scaling the color range of the graphic to the color range of the output device. Typically, you choose Perceptual (Images) because it accurately represents colors in photographs. The Saturation (Graphics), Relative Colorimetric, and Absolute Colorimetric options are better for areas of solid color; they don’t reproduce photographs well. Rendering Intent options aren’t available for bitmap, grayscale, and index-color mode images.

Portable Network Graphics (.png) import options

When you place a PNG image and select Show Import Options in the Place dialog box, you see a dialog box with three sections of import settings. Two sections contain the same options available for other bitmap image formats. The other section, PNG Settings, contains the following settings:

Use Transparency Information

This option is enabled by default when a PNG graphic includes transparency. If an imported PNG file contains transparency, the graphic interacts only where the background is transparent.

White Background

If a PNG graphic does not contain a file-defined background color, this option is selected by default. However, it is only enabled if Use Transparency Information is activated. If this option is selected, white is used as the background color when applying transparency information.

File Defined Background Color

If a PNG graphic was saved with a non-white background color, and Use Transparency Information is selected, this option is selected by default. If you don’t want to use the default background color, click White Background to import the graphic with a white background, or deselect Use Transparency Information to import the graphic without any transparency (displaying areas of the graphic that are currently transparent). Some image-editing programs can’t specify a non-white background color for PNG graphics.

Apply Gamma Correction

Select this option to adjust the gamma (midtone) values of a PNG graphic as you place it. This option lets you match image gamma to the gamma of the device you will use to print or display the graphic (such as a low-resolution or non‑PostScript printer or computer monitor). Deselect this option to place the image without applying any gamma correction. By default, this option is selected if the PNG graphic was saved with a gamma value.

Gamma Value

This option, available only if Apply Gamma Correction is selected, displays the gamma value that was saved with the graphic. To change the value, type a positive number from 0.01 to 3.0.

When PNG files are imported, the settings in the Image Import Options dialog box are always based on the selected file, not on the default or last-used settings.

Acrobat (.pdf) and Illustrator (.ai) import options

The layout, graphics, and typography in a placed PDF are preserved. As with other placed graphics, you cannot edit a placed PDF page within InDesign. You can control the visibility of layers in a layered PDF. You can also place more than one page of a multipage PDF.

When you place a PDF that was saved with passwords, you are prompted to enter the required passwords. If the PDF file was saved with usage restrictions (for example, no editing or printing), but no passwords, you can place the file.

When you place a PDF (or a file saved with Illustrator 9.0 or later) and select Show Import Options in the Place dialog box, you see a dialog box containing the following options:

Show Preview

Preview a page in the PDF before you place it. If you’re placing a page from a PDF that contains multiple pages, click the arrows, or type a page number under the preview image to preview a specific page.

Pages

Specify the pages you want to place: the page displayed in the preview, all pages, or a range of pages. For Illustrator files, you can specify which artboard to place.

Note:

If you specify multiple pages, hold down Alt (Windows) or Option (Mac OS) while placing the file to place them all at the same time, overlapping each other.

Crop To

Specify how much of the PDF page to place:

Bounding Box

Places the PDF page’s bounding box, or the minimum area that encloses the objects on the page, including page marks. The Bounding Box (Visible Layers Only) option uses the bounding box only of the visible layers of the PDF file. The Bounding Box (All Layers) option places the bounding box of the entire layer area of the PDF file, even if layers are hidden.

Art

Places the PDF only in the area defined by a rectangle that the author created as a placeable artwork (for example, clip art).

Crop

Places the PDF only in the area that is displayed or printed by Adobe Acrobat.

Trim

Identifies the place where the final produced page is physically cut in the production process, if trim marks are present.

Bleed

Places only the area that represents where all page content should be clipped, if a bleed area is present. This information is useful if the page is being output in a production environment. The printed page may include page marks that fall outside the bleed area.

Media

Places the area that represents the physical paper size of the original PDF document (for example, the dimensions of an A4 sheet of paper), including page marks.

Options for cropping placed PDFs
Options for cropping placed PDFs

A. Media B. Trim C. Bleed D. Content E. Crop F. Art 

Transparent Background

Select this option to reveal text or graphics that fall beneath the PDF page in the InDesign layout. Deselect this option to place the PDF page with an opaque white background.

Note:

If you make the background transparent in a frame containing a PDF graphic, you can make it opaque later by adding a fill to the frame.

InDesign (.indd) import options

InDesign preserves the layout, graphics, and typography in a placed INDD file. However, the file is treated as an object, and you can’t edit it, although you can control the visibility of layers and choose which pages of a multi-page INDD file to import.

When you place an InDesign file and select Show Import Options in the Place dialog box, you see a dialog box containing the following options:

Show preview

Preview a page before you place it. You can type a page number or click the arrows to preview a page in a multi-page document.

Pages

Specify the pages you want to place: the page displayed in the preview, all pages, or a range of pages.

Crop to

Specify how much of the page or pages to place, the page itself or the bleed or slug areas on the pasteboard.

Place multiple graphics

The Place command lets you import more than one item at a time.

  1. Create frames for the graphics if you want to place some or all of them in frames.
  2. Choose File > Place, and select files.

    You can select graphics files, text files, InDesign files, and other files you can add to InDesign documents.

  3. Optionally, select Show Import Options, click Open, and specify the import options for each file. (See Import options for graphics.)

    A thumbnail image of the first graphic you selected appears next to the loaded graphics icon. A number next to the loaded graphics icon tells you how many graphics are ready for importing. The names of the graphics appear in the Links panel, with the letters LP (for “loaded in place cursor”) next to the frontmost graphic.

    Placing four files into placeholder frames
    Placing four files into placeholder frames

    Note:

    Press an arrow key to cycle through the graphics; press Esc to unload the frontmost graphic from the loaded graphics icon without placing it in InDesign.

    Note:

    You can keep thumbnail images from appearing in the loaded graphics icon if displaying the images slows down your computer. In the Interface area of the Preferences dialog box, deselect Show Thumbnails On Place.

  4. Do one of the following:
    • To import into a new frame, click the loaded graphics icon where you want the upper left corner of the graphic to appear.

    • To create a frame of a certain size and import the graphic into the frame, drag to define the frame. The frame conforms to the proportions of the graphic being placed.

    • To import into an existing frame, click the loaded graphics icon in the frame. Hold down Alt (Windows) or Option (Mac OS) while clicking to replace the contents of an existing frame.

    • To import all the loaded graphics in a grid, start dragging, and press the arrow keys to determine the number of rows and columns. Use the Up Arrow key and Down Arrow key to change the number of rows and the Left Arrow key and Right Arrow key to change the number of columns. Release the mouse button to place the grid of images.

      To change the spacing between frames, press Page Up or Page Down or hold down Ctrl (Windows) or Command (Mac OS) while pressing the arrow keys.

      To change the spacing between frames, hold down Ctrl (Windows) or Command (Mac OS) while pressing the arrow keys.

    Note:

    You can load more graphics by choosing File > Place while the graphics icon is displayed.

Control layer visibility in imported images

When you import Photoshop PSD files, layered PDFs, and INDD files, you can control the visibility of top-level layers. Adjusting layer visibility in InDesign lets you vary an illustration depending on context. For example, in a multilanguage publication, you can create a single illustration that includes one text layer for each language.

You can adjust layer visibility either when you place a file or by using the Object Layer Options dialog box. In addition, if the Photoshop file contains layer comps, you can display the desired comp.

Set layer visibility

  1. Do one of the following:
    • To import a graphic without first creating a frame, make sure that nothing in the document is selected.

    • To import a graphic into an existing frame, select the frame.

    • To replace an existing image, select the graphics frame.

  2. Choose File > Place and select a graphics file.
  3. To replace a selected object, select Replace Selected Item.
  4. Select Show Import Options, and then click Open.
  5. In the Image Import Options or Place dialog box, click the Layers tab.
  6. To view a preview of the image, click Show Preview.
  7. (PDFs only) If you’re placing a page from a multipage PDF, click the arrows, or type a page number under the preview image to preview a specific page.
  8. (Photoshop PSD files only) If the image contains layer comps, choose the layer comp you want to display from the Layer Comp pop‑up menu.
  9. Do one of the following:
    • To open or close a layer set, click the triangle to the left of the folder icon.

    • To hide a layer or layer set, click the eye icon next to the layer or layer set.

    • To display the layer or layer set, click the empty eye column next to the layer or layer set.

    • To display only the content of a particular layer or layer set, hold down Alt (Windows) or Option (Mac OS) while clicking its eye icon. Hold down Alt or Option and click the eye icon again to restore the original visibility settings of the other layers.

    • To change the visibility of multiple items, drag through the eye column.

  10. Set the When Updating Link option as desired:

    Use Photoshop’s/PDF’s Layer Visibility

    Matches the layer visibility settings to those of the linked file when you update the link.

    Keep Layer Visibility Overrides

    Maintains the layer visibility settings as they were when the file was originally placed.

  11. Click OK.
  12. Click OK, and do one of the following:
    • To import into a new frame, click the loaded graphics icon  in the layout at the place where you want the upper left corner of the graphic to appear.

    • To import into an existing frame which is not selected, click the loaded graphics icon anywhere in that frame.

    • To import into an existing selected frame, you don’t need to do anything. The image automatically appears in that frame.

    Note:

    If you accidentally replace an existing graphic with an image you’re placing, press Ctrl+Z (Windows) or Command+Z (Mac OS) to return the original image to the frame and display the loaded graphics icon.

Set layer visibility for placed AI, PSD, PDF, and INDD files

After you place a Photoshop PSD or layered PDF, an Illustrator AI file, or an InDesign INDD file, you can control the visibility of its layers by using the Object Layer Options dialog box. If the Photoshop PSD file contains layer comps, you can choose which comp you want to display. In addition, you can choose whether to maintain the visibility settings or match the settings of the original file each time you update the link.

  1. Select the file in the InDesign document.
  2. Choose Object > Object Layer Options.
  3. To view a preview of the image, select Preview.
  4. (Photoshop PSD files only) If the image contains layer comps, choose the layer comp you want to display from the Layer Comp pop‑up menu.
  5. Do one of the following:
    • To open or close a layer set, click the triangle to the left of the folder icon.

    • To hide a layer or layer set, click the eye icon next to the layer or layer set.

    • To display the layer or layer set, click the empty eye column next to the layer or layer set.

    • To display only the content of a particular layer or layer set, hold down Alt (Windows) or Option (Mac OS) while clicking its eye icon. Hold down Alt or Option and click the eye icon again to restore the original visibility settings of the other layers.

    • To change the visibility of multiple items, drag through the eye column.

  6. Set the Updating Link Options as desired:

    Use Layer Visibility

    Matches the layer visibility settings to those of the linked file when you update the link.

    Keep Layer Visibility Overrides

    Maintains the layer visibility settings as they were when the file was originally placed.

  7. Click OK.

Paste or drag graphics

When you copy and paste or drag a graphic into an InDesign document, some attributes of the original object may be lost, depending on the limitations of the operating system and the range of data types the other application makes available for transfer, and the InDesign Clipboard preferences. Pasting or dragging Illustrator graphics lets you select and edit paths within the graphic.

Copying and pasting or dragging between two InDesign documents, or within a single document, however, preserves all of the graphics attributes that were imported or applied. For example, if you copy a graphic from one InDesign document and paste it into another, the new copy is an exact duplicate of the original, even including the original’s link information, so you can update the graphic when the file on disk changes.

Copy and paste graphics

When copying and pasting a graphic from another document into an InDesign document, InDesign does not create a link to the graphic in the Links panel. The graphic may be converted by the system clipboard during the transfer, so both image quality and print quality may be lower in InDesign than in the graphic’s original application.

  1. In InDesign or another program, select the original graphic, and choose Edit > Copy.
  2. Switch to an InDesign document window, and choose Edit > Paste.

Drag-and-drop graphics

The drag-and-drop method works like the Place command, with images appearing in the Links panel after they’re imported. You cannot set import options for the files you drag-and-drop; however, you can drag-and-drop multiple files at once (the files are loaded in the graphics icon when you drag-and-drop more than one).

Select a graphic from Adobe Illustrator, Adobe Bridge, Explorer (Windows), the Finder (Mac OS), or your desktop, and drag it into InDesign. The image must be in a format that InDesign can import.

After dragging a file from any location other than Illustrator, it appears in the Links panel in InDesign. Using the Links panel, you can control versions and update as necessary.

  1. Select the original graphic.
  2. Drag the graphic into an open InDesign document window.

Note:

In Windows, if you try to drag an item from an application that does not support drag-and-drop, the pointer displays the Prohibited icon.

Note:

To cancel dragging a graphic, drop the graphic onto any panel title bar or the document title bar.

Fixing low-resolution images

Graphics you place in your document may appear pixelated or fuzzy or grainy. In most cases, it’s because InDesign displays images in low-resolution by default to improve performance.

Check the display settings

To display graphics in high resolution, choose View > Display Performance > High Quality Display. For more details on changing these display performance settings, see Control graphics’ display performance.

Use Place instead of Paste

The image may still be of low resolution even though you changed the display performance settings. For these images, make sure that you use the Place command to insert the image into InDesign. In some instances, pasting an image from another application may result in the preview image being inserted instead of the original file.

Check your print settings

If your image appears in low resolution in print, check your print settings to make sure that graphics are printing properly. In the Graphics section of the Print dialog box, choose Send Data > All.

Avoid transformations in images of borderline quality

In addition, scaling or rotating an image could reduce its quality. You may want to choose Clear Transformations from the Control panel menu.

Improve the image resolution

In some cases, such as with an image copied from a web page, you may need to replace a low-resolution image with a high-resolution image.

Control graphics’ display performance

You can control the resolution of graphics placed in your document. You can change the display settings for the entire document or for individual graphics. You can also change a setting that either allows or overrides the display settings for individual documents.

Change a document’s display performance

A document always opens using the default Display Performance preferences. You can change the display performance of a document while it is open, but the setting is not saved with the document.

If you’ve set the display performance of any images separately, you can override the settings so all objects use the same settings.

  1. Choose View > Display Performance, and select an option from the submenu.
  2. To force objects that you have set individually to display using the document setting, deselect View > Display Performance > Allow Object-Level Display Settings. (A check mark indicates that it is selected.)

Change an object’s display performance

  1. To preserve the display performance for individual objects when the document is closed and reopened, make sure that Preserve Object-Level Display Settings is selected in Display Performance preferences.

  2. Choose View > Display Performance, and make sure that Allow Object-Level Display Settings is selected.

  3. With the Selection tool  or Direct Selection tool , select an imported graphic.
  4. Do one of the following:
    • Select Object > Display Performance, and choose a display setting.

    • Right-click (Windows) or Control-click (Mac OS) the image, and choose a display setting from the Display Performance submenu.

Note:

To remove an object’s local display setting, choose Use View Setting in the Display Performance submenu. To remove local display settings for all graphics in the document, select Clear Object-Level Display Settings in the View > Display Performance submenu.

Display performance options

These options control how graphics are displayed on the screen, but they do not affect the print quality or exported output.

Use Display Performance preferences to set the default option used to open all documents, and customize the settings that define those options. Each display option has separate settings for displaying raster images, vector graphics, and transparencies.

Fast

Draws a raster image or vector graphic as a gray box (default). Use this option when you want to quickly page through spreads that have lots of images or transparency effects.

Typical

Draws a low-resolution proxy image (default) appropriate for identifying and positioning an image or vector graphic. Typical is the default option and is the fastest way to display an identifiable image.

High Quality

Draws a raster image or vector graphic at High Resolution (default). This option provides the highest quality but the slowest performance. Use this option when you want to fine-tune an image.

Note:

Image display options don’t affect output resolution when exporting or printing images within a document. When printing to a PostScript device, exporting to XHTML, or exporting to EPS or PDF, the final image resolution depends on the output options you choose when you print or export the file.

Set default display performance

The Display Performance preferences let you set the default display option, which InDesign uses for every document. You can change a document’s display performance using the View menu, or change the setting for individual objects using the Object menu. For example, if you work on projects that contain numerous high-resolution photos (such as a catalog), you may prefer to have all your documents open quickly. You can set the default display option to Fast. When you want to see the images in more detail, you can switch the document view to Typical or High Quality (leaving the preference set to Fast).

You can also choose to view or override display settings applied to individual objects. If Preserve Object-Level Display Settings is selected, any settings applied to objects are saved with the document.

  1. Select Edit > Preferences > Display Performance (Windows) or InDesign > Preferences > Display Performance (Mac OS).
  2. For Default View, select Typical, Fast, or High Quality. The display option you choose applies to all documents you open or create.
  3. Do one of the following:
    • To save display settings applied to individual objects, select Preserve Object-Level Display Settings.

    • To display all graphics using the default display option, deselect Preserve Object-Level Display Settings.

  4. For Adjust View Settings, choose the display option you want to customize, and then move the slider for Raster Images or Vector Graphics to the desired setting.
  5. Click OK.

Each display option has separate settings for raster (bitmap) images, vector graphics, and transparency effects.

Create contact sheets

A contact sheet is a grid of thumbnail images, often used for pre-press analysis. You can use a number of different Adobe applications to create a contact sheet. In Photoshop, you can use either the Contact Sheet or Picture Package command.

In previous versions of Adobe Bridge (CS2 and CS3), you can create a contact sheet for InDesign pages using the Create InDesign Contact Sheet feature. This feature does not appear in later versions of Adobe Bridge. Instead, you can use the Adobe Output Module in Adobe Bridge to create a PDF contact sheet.

You can also create a simple contact sheet in InDesign by placing multiple images in a grid.

  1. Choose File > Place, select multiple images, and choose Open.

    If you want to include captions with your images, select Create Static Captions. See Generate a caption from an image.

  2. Start dragging, and press the arrow keys to determine the number of rows and columns. Use the Up Arrow key and Down Arrow key to change the number of rows and the Left and Right Arrow keys to change the number of columns.

    To change the spacing between frames, press Page Up or Page Down or hold down Ctrl (Windows) or Command (Mac OS) while pressing the arrow keys.

    To change the spacing between frames, hold down Ctrl (Windows) or Command (Mac OS) while pressing the arrow keys.

  3. Release the mouse button to place the grid of images.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy