Creating a dynamic PDF document is a good way to create an interactive slideshow. You can create interactive documents with buttons, movies and sound clips, hyperlinks, bookmarks, and page transitions. You can also set up documents in InDesign that can be converted to forms in Acrobat.

Create interactive documents for PDF

You can export Adobe PDF documents that include the following interactive features.


Bookmarks you create in the InDesign document appear in the Bookmarks tab on the left side of the Adobe Acrobat or Adobe Reader window. Each bookmark jumps to a page, text, or graphic in the exported PDF file. See Bookmarks.

Movies and sound clips

You can add movies and sound clips to a document, or you can link to streaming video files on the Internet. These movies and sound clips can be played back in the exported PDF file. See Movies and sounds.


In an exported PDF document, clicking a hyperlink jumps to another location in the same document, to a different document, or to a website. See Hyperlinks.


A cross-reference refers readers from one part of your document to another in the exported PDF file. Cross-references are especially useful in user guides and reference manuals. When a document with cross-references is exported to PDF, the cross-references act as interactive hyperlinks. See Cross-references.

Page transitions

Page transitions apply a decorative effect, such as a dissolve or wipe, when you turn the page in the exported PDF while in Full Screen Mode. See Page transitions.

  1. Choose File > Export.

  2. Specify a name and location for the file.

  3. For Save As Type (Windows) or Format (Mac OS), choose Adobe PDF (Interactive), and then click Save.

  4. Specify options in the Export To Interactive PDF dialog box, and then click OK.

Export to interactive PDF options

The following options appear in the Export To Interactive PDF dialog.

General tab


Indicate whether all pages in the document, or a page range is included. If you select Range, specify a page range, such as 1-7, 9 to print pages 1 through 7 and 9. See Specifying pages to print.


Initial view settings of the PDF when it’s opened.


Initial layout of the PDF when it’s opened.


Select Opens In Full Screen Mode to display the PDF in Adobe Acrobat or Adobe Reader without menus or panels displayed. To advance the pages automatically, select Flip Pages Every and specify the number of seconds between page turns.

Page Transitions

Specify one page transition to apply to all pages during export. If you use the Page Transitions panel to specify transitions, choose the From Document option to use those settings.

Forms And Media

Select Include All to allow movies, sounds, and buttons to be interactive in the exported PDF file. Select Appearance Only to include the normal state of buttons and the video posters as static elements.

Embed Page Thumbnails

Embeds a thumbnail preview for each page in the PDF, increasing the file size. Deselect this setting when users of Acrobat 5.0 and later view and print the PDF; these versions generate thumbnails dynamically each time you click the Pages panel of a PDF.

View After Exporting

Opens the newly created PDF file in the default PDF viewing application.

Create Acrobat Layers

Saves each InDesign layer as an Acrobat layer within the PDF. The layers are fully navigable, which allows users of Acrobat 6.0 and later to generate multiple versions of the file from a single PDF.

Create Tagged PDF

During export, automatically tags elements in the story based on a subset of the Acrobat tags that InDesign supports. This includes recognition of paragraphs, basic text formatting, lists, and tables. (You can also insert and adjust tags in the document before exporting to PDF. See Adding structure to PDFs.)

Use Structure for Tab Order

During export, uses the Tab Order specified using Object > Interactive > Set Tab Order. This option is only available for tagged PDFs.

Compression tab


Choose JPEG (Lossy) to remove image data and possibly reduce image quality. However, file size is reduced with a minimal loss of information. Choose JPEG 2000 (Lossless) to export the file without lossy compression. Choose Automatic to let InDesign determine the best quality for color and grayscale images.

JPEG Quality

Specifies the amount of detail in the exported image. The higher the quality, the larger the file size. This option is dimmed if you choose JPEG 2000 (Lossless) for Compression.


Specify the resolution of bitmap images in the exported PDF. Choosing a high resolution is especially important to allow viewers to zoom in on pixel-based content within your exported PDF. Choosing a high resolution can significantly increase the file size.

Advanced tab

Display Title

Choose what to display in the title bar of Acrobat when it opens your PDF. Available options are Document Title and File Name.


Choose the document language for the PDF. This determines the default language for the exported PDF. If the required language is not in the list, you can also type the standard language ISO code.

Security tab

Require Password To Open The Document

Select this option to require users to type the password you specify to open the document.

Document Open Password

Specify the password that users must type to open the PDF file.

Use A Password To Restrict Printing, Editing, And Other Tasks

Restricts access to the PDF file’s security settings. If the file is opened in Adobe Acrobat, the user can view the file but must enter the specified Permissions password in order to change the file’s Security and Permissions settings. If the file is opened in Illustrator, Photoshop, or InDesign, the user must enter the Permissions password, since it is not possible to open the file in a view-only mode.

Permissions Password

Specify a password that is required to change the permissions settings. This option is available only if the previous option is selected.

Printing Allowed

Specifies the level of printing that users are allowed for the PDF document.


Prevents users from printing the document.

Low Resolution (150 dpi)

Lets users print at no higher than 150‑dpi resolution. Printing may be slower because each page is printed as a bitmap image.

High Resolution

Lets users print at any resolution, directing high-quality vector output to PostScript and other printers that support advanced high-quality printing features.

Changes Allowed

Defines which editing actions are allowed in the PDF document.


Prevents users from making any changes to the document that are listed in the Changes Allowed menu, such as filling in form fields and adding comments.

Inserting, Deleting, And Rotating Pages

Lets users insert, delete, and rotate pages, and create bookmarks and thumbnails.

Filling In Form Fields, And Signing

Lets users fill in forms and add digital signatures. This option doesn’t allow them to add comments or create form fields.

Commenting, Filling In Form Fields, And Signing

Lets users add comments and digital signatures, and fill in forms. This option doesn’t allow users to move page objects or create form fields.

Any Except Extracting Pages

Lets users edit the document, create and fill in form fields, and add comments and digital signatures.

Enable Copying Of Text, Images, And Other Content

Lets users to select and copy the contents of a PDF.

Enable Text Access For Screen Reader Devices For The Visually Impaired

Lets visually impaired users read the document with screen readers, but doesn’t allow users to copy or extract the document’s contents.

Enable Plaintext Metadata

Allows users to copy and extract content from the PDF. Selecting this option allows storage/search systems and search engines to access metadata stored in the document. 

Create PDF forms (CS5.5 and CS5)

Although InDesign does not provide tools for adding form fields, Adobe Acrobat does. You can create a form in InDesign that includes placeholders for fields such as radio buttons, check boxes, and text fields. Then you can export to PDF, and use Acrobat to convert the placeholders into form fields.

  1. In InDesign, create the document you want to use for the form. Use tables and text boxes to create the placeholders for the fields.

    You can also add interactive buttons in InDesign.

  2. Export the document to Adobe PDF.

  3. Start the form wizard to convert the placeholders into form fields. Use the form tools to add and edit the form. For more information, see the Adobe Acrobat documentation.

    • In Acrobat X, choose Tools > Forms > Create to start the form wizard.

    • In Adobe Acrobat 9, choose Forms > Start Form Wizard.

Additional Resources

The Acrobat team provides an article on Designing forms for auto field detection in Adobe Acrobat.

Michael Murphy provides a video tutorial about creating forms at Acrobat Friendly Form Design.

Bob Bringhurst provides an article about designing forms at Creating PDF Forms in InDesign.

Preview interactive documents

Use the Preview panel preview interactivity and animation of the current selection, the current spread, or the entire document. You can resize, dock, or float the Preview panel, or move it to a second monitor.

  1. Choose Window > Interactive > Preview.

  2. To preview the interactivity and animation, do any of the following actions:

    • Click the Set Preview Selection Mode button  to preview the current selection.

    • Click the Set Preview Spread Mode button  to preview the current spread.

    • Click the Set Preview Document Mode button  to preview the current document.

  3. Click the Play Preview button  to preview the selection, spread, or document. If necessary, click interactive items such as buttons in the Preview panel to test them.

    If you’re previewing the document, you can click the Go To Previous Page and Go To Next Page arrows at the bottom of the panel to move to different pages.


If you edit your document, you can refresh the preview by clicking the Play Preview button in the Preview panel.

Preview the document in a web browser

  1. Choose Test In Browser from the Preview panel menu.

  2. Click the interactive items in your document to test them.

Edit Preview settings

  1. Choose Edit Preview Settings from the Preview panel menu.

    The Preview Settings dialog box shows the current settings of the Export SWF dialog box.

  2. Edit the settings as needed. See SWF export options.

Use Presentation Mode

Presentation Mode displays the active InDesign document as a presentation. In Presentation Mode, the application menu, panels, guides, and frame edges are hidden. The background area has a dark color by default in case your document size is a different proportion from your current monitor dimensions.

Presentation Mode is a helpful companion feature to the Adobe Connect feature. You can start a web meeting by using the File > Share My Screen command. Once the screen sharing has started, you can put your InDesign document into Presentation Mode.

  1. Choose View > Screen Mode > Presentation.

  2. Use any of the following keystrokes.


    What it does

    Mouse click, Right arrow, or Page Down

    Next Spread

    Shift-click, Right-click, Left Arrow, or Page Up

    Previous Spread


    Exit Presentation Mode


    First Spread


    Last Spread


    Change background color to black


    Change background color to white


    Change background color to gray


You cannot edit the document in Presentation Mode. However with a dual screen monitor, you can have two windows open on the same document and put one of them into Presentation Mode. This approach lets you edit the document in the window set to Normal view and immediately see the results in the window set to Presentation Mode.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy