Animation effects let you make objects move in your exported SWF files. For example, you can apply a motion preset to an image that makes it appear to fly in from the left side of the screen while shrinking and spinning. Use the following tools and panels to animate documents.

Click the Play button to view animation
Click the Play button to view animation

Animation panel

Apply a motion preset and edit settings such as duration and speed.

Direct Selection tool and Pen tool

Edit the path on which the animated object travels.

Timing panel

Determine the order in which objects on a page are animated.

Preview panel

View the animation in an InDesign panel.

Note:

A related type of animation you can add in InDesign is a button rollover effect. For more information, see Create buttons.

Jeff Witchel from Infiniteskills.com provides a video overview on Animating layouts.

Animate a document with motion presets

Motion presets are pre-made animations that you can apply to objects quickly. Use the Animation panel to apply motion presets and change animation settings such as duration and speed. The Animation panel also lets you specify when an animated object plays.

These motion presets are the same as those found in Adobe Flash CS5 Professional. You can import any custom motion preset created in Flash Professional. You can also save motion presets you create and use them in InDesign or Flash Professional.

Note:

Animation features are supported only when exporting to the Adobe Flash Player (.SWF). They are not supported when exporting to Interactive PDF. To add animation effects to a PDF file, export a selection as a SWF file from InDesign and place that SWF file in the InDesign document.

  1. Place the object you want to animate in your document.

  2. In the Animation panel (Window > Interactive > Animation), choose a motion preset from the Preset menu.

  3. Specify motion preset options.

  4. To edit the motion path, use the Pen tool and Direct Selection tool.

  5. Use the Timing panel to determine the order of the animation effects.

  6. Use the Preview panel to preview the animation in InDesign.

To remove animation from an object, select the object and click the Delete icon in the Animation panel.

Note:

When certain animation effects such as Fade In are combined with a page transition or page curl, the animation may not behave as expected in the Preview panel or in the exported SWF file. For example, objects that are set to "fade in" are visible while turning the page when they should start as invisible. To avoid this conflict, do not use page transitions on those pages with animation, and turn off the Include Interactive Page Curl option in the SWF Export dialog box. Motion presets that may not work as expected with page transitions and page curl include Appear, Fade In, the various Fly-in presets, Zoom in 2D, and Swoosh.

Convert selected objects to a motion path

You can create animation by selecting an object and a path and converting it to a motion path. If you selected two closed paths, such as two rectangles, the path on top becomes the motion path.

  1. Select the object you want to animate and the path you want to use as the motion path.

    You cannot convert more than two selected objects.

  2. In the Animation panel, click the Convert To Motion Path button .

  3. Change the settings in the Animation panel.

Motion preset options

Motion preset options appear in the Animation panel. Click the Properties option to display advanced settings.

Name

Specify a name for the animation. Specifying a descriptive name is especially useful when setting up an action that triggers the animation.

Preset

Choose from a list of pre-defined motion settings.

Event(s)

By default, On Page Load is selected, which means the animated object plays when the page is opened in the SWF file. Choose On Page Click to trigger the animation when the page is clicked. Choose On Click (Self) or On Roll Over (Self) to trigger the animation when the object itself is clicked or moused over, respectively. If you create a button action that triggers the animation, On Button Event is selected. (See Add actions to buttons.) You can specify multiple events to start the animation.

If you select the On Roll Over (Self) event, you can also select Reverse On Roll Off. This option reverses the action of the animation when the mouse moves off the object.

Create Button Trigger

Click this button to trigger the animation from an existing object or button. After you click Create Button Trigger , click the object that triggers the animation. The object is converted to a button, if necessary, and the Buttons panel opens.

Duration

Specify how much time it takes for the animation to occur.

Play

Specify the number of times the animation is played, or select Loop to cause the animation to play repeatedly until it’s stopped.

Speed

Choose an option to determine whether the animation speed is a steady rate (None), starts slowly and speeds up (Ease In), or slows down at the end (Ease Out).

Note:

The following options are available when Properties is expanded.

Animate

Choose From Current Appearance to use the object’s current properties (scale percentage, rotation angle, and position) as the starting point of the animation.

Choose To Current Appearance to use the object’s properties as the ending point of the animation. Using this option is especially useful in slide shows. For example, objects that fly in from off the page can appear on the page rather than on the pasteboard, improving the appearance of the printed document.

Choose To Current Location to use the current object’s properties as the starting point of the animation and the object’s position as the ending point. This option is similar to From Current Appearance, only the object finishes in its current location and the motion path is offset. This option is especially useful for certain presets, such as blurs and fades, to prevent the object from appearing in an undesirable state at the end of the animation.

Note:

To display the proxy at the end of the motion path, click the Show Animation Proxy  at the bottom of the Animation panel.

Animate settings
Animate settings

A. Object and path before animation B. From Current Appearance C. To Current Appearance D. To Current Location 

Rotate

Specify a rotation angle that the object completes during the animation.

Origin

Use the proxy to specify the origin point of the motion path on the animated object.

Scale

Specify a percentage value to determine whether the object increases or decreases in size during playback.

Opacity

Choose an option to determine whether the animation remains solid (None), gradually becomes visible (Fade In), or gradually becomes invisible (Fade Out).

Visibility

Select Hide Until Animated or Hide After Animating to make an object invisible before or after playback.

Manage motion presets

You can save animation settings as motion presets that you can easily reuse in InDesign. You can also import presets from XML files that can be opened in Flash Professional or shared with other InDesign users.

Save motion presets for reuse

Custom presets appear at the top of the Presets menu in the Animation panel.

  1. In the Animation panel, change the settings as needed.

  2. Choose Save from the Animation panel menu.

  3. Type a name for the preset and click OK.

Delete custom motion presets

Use the Manage Presets dialog box to delete motion presets that you’ve saved, duplicated, or imported. You cannot delete the motion presets in brackets that were installed with InDesign. When you delete a motion preset, it is deleted both from the Presets menu and from the computer.

  1. Choose Manage Presets from the Animation panel menu.

  2. Select the preset you want to delete, and click Delete.

Duplicate motion presets

  1. Choose Manage Presets from the Animation panel menu.

  2. Select the preset you want to duplicate, and click Duplicate.

Save motion presets as XML files

Saving motion presets as XML files is useful if you want to share a motion preset with other InDesign users or open the motion preset in Flash Professional.

When you save a motion preset as an XML file, the motion path is saved, along with the Duration, Speed, Scale, Rotate, and Opacity settings.

  1. Choose Manage Presets from the Animation panel menu.

  2. Select a preset and click Save As.

  3. Specify the name and location of the motion preset, and click Save.

Import motion presets

You can import motion presets that have been exported from either InDesign or Flash Professionalas XML files.

  1. Choose Manage Presets from the Animation panel menu.

  2. Click Load.

  3. Double-click the .xml file you want to import.

Edit a motion path

When you select an object that has animation, the motion path appears next to the object.

Motion path
Motion path

A. Starting point B. Ending point 
  • To edit a motion path, do any of the following:

    • Use the Direct Selection tool and the Pen tool to edit a motion path using the same method you use to edit a path. See Editing paths.

    • To create a motion path from an existing path, select a path and an object, and click the Convert To Motion Path button  in the Animation panel.

    • To change the direction of the path, click Properties in the Animation panel, and then choose a setting from the Animate menu. (See Motion preset options.) You can also select the motion path and choose Object > Paths > Reverse Path. If you want to reverse the path without moving the object, remove the animation, reverse the path, and then redo the animation.

Use the Timing panel to change the animation order

Use the Timing panel to change the order of when animated objects play. The Timing panel lists the animations on the current spread based on the page event assigned to each animation. For example, you can change one set of animations that occur when the page is loaded, and then change another set of animations that occur when the page is clicked.

Animated objects are listed in the order they were created. Animations listed for the Page Load event occur sequentially by default. Animations listed for the Page Click event are played in sequence each time the page is clicked.

You can change the animation order, have objects play at the same time, and delay animation.

  1. Choose Window > Interactive > Timing to display the Timing panel.

  2. To determine whether to edit the timing of Page Load or Page Click events, choose an option from the Event menu.

    Page Load and Page Click appear only if one or more items are assigned to that event.

  3. To edit the timing, do any of the following:

    • To change the animation order, drag items up and down in the list. The top items are animated first.

    • To delay animation, select the item, and specify the number of seconds of delay.

    • To play multiple animated objects together, select the items in the list, and click the Play Together button  to link the items. Shift-click to select a range of items, and Ctrl-click (Windows) or Command-click (Mac OS) to select non-adjacent items.

    • If you decide you don’t want one or more linked items to play together, select them and click the Play Separately button .

    • To play links items a specific number of times or to loop them, select all the items that are linked together, and then specify the number of times the animations play back, or select Loop.

    • To change which event triggers the animation, select the item and choose Reassign To On Page Load or Reassign To On Page Click.

    • To remove an item from the currently selected event (such as Page Load or Page Click), choose Remove Item. If the item isn’t assigned to any event, it appears in the Unassigned category, which you can choose from the Event menu.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy