Save documents

Saving a document saves the current layout, references to source files, which page is currently displayed, and the zoom level. Protect your work by saving often. You can save a file as any of the following:

  • A regular document.

  • A copy of the document, which creates a duplicate of the document under a different name, leaving the original document active.

  • A template, which normally opens as an untitled document. A template can contain settings, text, and graphics that you preset as a starting point for other documents.

    Saving a document also updates the metadata (or file information) that is part of the InDesign document. This metadata includes a thumbnail preview, fonts used in the document, color swatches, and all metadata in the File Info dialog box, all of which enable efficient searching. For example, you might want to search for all documents that use a particular color.

    You can view this metadata in Bridge and in the Advanced area of the File Info dialog box. You can control whether to update the preview when you save by using a preference setting. The other metadata (fonts, colors, and links) are updated whenever you save a document.

    The Save, Save As, and Save a Copy commands store documents in the InDesign file format. For information about storing documents in other file formats, see the Index.

    If you’re saving a document in order to bring it to a prepress service provider for final output, InDesign can automatically collect all necessary files, such as linked graphics and fonts, in one folder. (See Package files.)


The information entered in the File > File Info dialog box gets updated in the Metadata tab when you export an EPUB in the following formats:

  • Fixed Layout EPUB
  • Reflowable EPUB

  • Do one of the following:
    • To save a document under a new name, choose File > Save As, specify a location and filename, and click Save. The newly named file becomes the active document. Using the Save As command might reduce the file size.

    • To save an existing document under the same name, choose File > Save.

    • To save all open documents to their existing locations and filenames, press Ctrl+Alt+Shift+S (Windows) or Command+Option+Shift+S (Mac OS).

    • To save a copy of a document under a new name, choose File > Save a Copy, specify a location and filename, and click Save. The saved copy does not become the active document.


To avoid problems, avoid reserved characters that have special meanings in some operating systems. For example, avoid filenames with spaces, tabs, or initial periods, or filenames that use these characters: / \ : ; * ? < > , $ %. Similarly, avoid using characters with accents (such as ü, ñ, or é), even when using a non-English version of InDesign. Problems may occur if the file is opened in a different platform.


If you have frequently work with several documents open at the same time and want to save them all at once, use a keyboard shortcut. Choose Edit > Keyboard Shortcuts, choose Views, Navigation from the Product Area menu, and select Save All in the Commands list. You can then edit or add a shortcut. You can use Quick Apply to specify the Save All command.

Include previews in saved documents

Thumbnail previews of documents and templates provide easy identification of those files in Adobe Bridge and Adobe Mini Bridge. A preview is created when you save a document or template. A document preview includes a JPEG image of only the first spread; a template preview includes a JPEG image of each page in the template. You can control the size of the preview and the number of pages to suit your needs. For example, Extra Large 1024x1024 enables you to quickly scan the contents of a page at high-resolution before you open the file.

You can enable the option in Preferences or in the Save As dialog box. Because previews increase both file size and the time it takes to save the document, you may prefer to enable the option on demand using the Save Asdialog box.

  1. Do one of the following:
    • To include a preview every time you save a document, choose Edit > Preferences > File Handling (Windows) or InDesign > Preferences > File Handling (Mac OS).

    • To include a preview for a specific document, choose File >Save As.

    • To include a preview for a specific document, choose File > Save Content As.

  2. Select Always Save Preview Images With Documents.
  3. If you are setting the preview using the Preferences dialog box, choose the number of preview pages from the Pages menu, and choose an option from the Preview Size menu.


    Selecting the preview option in the Save As dialog box also selects the option in the Preferences dialog box, and uses the default Pages and Preview Size settings.

Save an InDesign Markup (IDML) document

In some cases you may want to save an InDesign in interchange markup format. It’s especially useful to save in this format when you open a QuarkXPress or PageMaker publication in InDesign, when you open a document created in a previous version of InDesign, or when you’re experiencing problems with your document, such as not being able to delete color swatches.

  1. Choose File > Save (CS6) or File > Export (CS5).
  2. From the Save As Type (Windows) or Format (Mac OS) menu, choose InDesign Markup (IDML).
  3. Click Save.

You can open the saved IDML file in InDesign CS5 and InDesign CS4 but not in any previous version of InDesign.

For information on using IDML for development purposes, see

Save backwards to the previous InDesign version

To open an InDesign CS6 document in InDesign CS5, in InDesign CS6, Save (File > Save) the document to the InDesign Markup Language (IDML). (The IDML format replaces the Interchange INX format used for saving backwards in previous versions.)

To open an InDesign CS5 document in InDesign CS4, in InDesign CS5, export (File > Export) the document to the InDesign Markup Language (IDML). (The IDML format replaces the Interchange INX format used for saving backwards in previous versions.)

Ensure that the computer running the previous version of InDesign is updated with the appropriate plug-ins so that it can open the exported IDML file. The person running the previous version of InDesign can obtain the compatibility plug-ins by choosing Help > Updates and following the prompts. Plug-ins can also be installed from the Adobe website: Visit Product updates page on the Adobe website, and choose InDesign from the product list.

Opening a document in a previous version of InDesign is also referred to as “saving down.”


Content created using features specific to the later version of InDesign may be modified or omitted when you open the document in a previous version of InDesign.

  1. Choose File > Save (CS6) or File > Export (CS5).
  2. From the File Type (Windows) or Format (Mac OS) menu, choose InDesign Markup (IDML).
  3. Click Save.

You can open the .idml file in previous version of InDesign to convert it to an untitled InDesign document.


To open the InDesign CS5 document in InDesign CS3, open the exported IDML file in InDesign CS4, save it and export it to InDesign CS3 Interchange (INX), and then open the exported INX file in InDesign CS3. Make sure that all InDesign versions are up to date.

Work with metadata

Metadata is a set of standardized information about a file, such as author name, resolution, color space, copyright, and keywords applied to it. You can use metadata to streamline your workflow and organize your files.

About the XMP standard

Metadata information is stored using the Extensible Metadata Platform (XMP) standard, on which Adobe Bridge , Adobe Illustrator, Adobe InDesign, and Adobe Photoshop are built. XMP is built on XML, and in most cases the metadata is stored in the file. If it isn’t possible to store the information in the file, metadata is stored in a separate file called a sidecar file. XMP facilitates the exchange of metadata between Adobe applications and across publishing workflows. For example, you can save metadata from one file as a template, and then import the metadata into other files.

Metadata that is stored in other formats, such as Exif, IPTC (IIM), GPS, and TIFF, is synchronized and described with XMP so that it can be more easily viewed and managed. Other applications and features also use XMP to communicate and store information such as version comments, which you can search using Adobe Bridge.

In most cases the metadata remains with the file even when the file format changes, for example, from PSD to JPG. Metadata is also retained when files are placed in an Adobe document or project.


You can use the XMP Software Development Kit to customize the creation, processing, and interchange of metadata. For example, you can use the XMP SDK to add fields to the File Infodialog box. For more information on XMP and the XMP SDK, visit the Adobe website.

Working with metadata in Adobe Bridge and Adobe Creative Suite components

Many of the powerful Adobe Bridge features that allow you to organize, search, and keep track of your files and versions depend on XMP metadata in your files. Adobe Bridge provides two ways of working with metadata: through the Metadata panel and through the File Infodialog box (InDesign) or the Content File Info dialog box (InCopy).

In some cases, multiple views exist for the same metadata property. For example, a property may be labeled Author in one view and Creator in another, but both refer to the same underlying property. Even if you customize these views for specific workflows, they remain standardized through XMP.

Add metadata using the File Info dialog box

The File Info dialog box displays camera data, file properties, an edit history, copyright, and author information of the current document. The File Info dialog box also displays custom metadata panels. You can add metadata directly in the File Information dialog box. Any information you enter in a field overrides existing metadata and applies the new value to all selected files.

  1. Choose File > File Info (InDesign) or File > Content File Info (InCopy).
  2. Select any of the following from the tabs at the top of the dialog box:


    Use the Right and Left arrows to scroll the tabs, or click the down-pointing arrow and choose a category from the list.


    Lets you enter document information about the file, such as document title, author, description, and keywords that can be used to search for the document. To specify copyright information, select Copyrighted from the Copyright Status pop-up menu. Then enter the copyright owner, notice text, and the URL of the person or company holding the copyright.


    Includes four areas: IPTC Content describes the visual content of the image. IPTC Contact lists the contact information for the photographer. IPTC Image lists descriptive information for the image. IPTC Status lists workflow and copyright information.

    Camera Data

    Includes two areas: Camera Data 1 displays read-only information about the camera and settings used to take the photo, such as make, model, shutter speed, and f‑stop. Camera Data 2 lists read-only file information about the photo, including pixel dimensions and resolution

    Video Data

    Lists information about the video file, including video frame width and height, and lets you enter information such as tape name and scene name.

    Audio Data

    Lets you enter information about the audio file, including the title, artist, bit rate, and loop settings.

    Mobile SWF

    Lists information about mobile media files, including title, author, description, and content type.


    Lets you enter information based on Associated Presscategories.


    Lets you enter file information that is useful for news outlets, including when and where the file was created, transmission information, special instructions, and headline information.


    Lists patient, study, series, and equipment information for DICOM images.


    Displays Adobe Photoshop history log information for images saved with Photoshop. The History tab appears only if Adobe Photoshop is installed.


    Lets you apply a document profile for print, web, or mobile output.


    Displays fields and structures for storing metadata by using namespaces and properties, such as file format and XMP, Exif, and PDF properties.

    Raw Data

    Displays XMP text information about the file.

  3. Type the information to add in any displayed field.
  4. Click OK to apply the changes.

Export metadata as an XMP file

You can save metadata in an XMP file to share with other users. These XMP files can be used as templates for populating InDesign documents and other documents created with XMP-enabled applications. Templates you export are stored in a shared location that all XMP-enabled applications can access. They also appear in the pop-up menu at the bottom of the File Infodialog box.

  1. Choose File >File Info (InDesign) or File > Content File Info (InCopy).
  2. Choose Export from the pop-up menu at the bottom of the dialog box.
  3. Type a filename, choose a location for the file, and click Save.


    To view metadata templates in Explorer (Windows) or the Finder (Mac OS), click the pop-up menu at the bottom of the File Info dialog box and choose Show Templates Folder.

Import metadata from an XMP file

When you import metadata into a document from an exported XMP template file, you can specify whether to clear all metadata in the current document and add the new metadata, keep all but the matching metadata, or add matching metadata to the existing metadata.

  • Choose File >File Info (InDesign) or File > Content File Info (InCopy).
    • Choose an XMP file from the pop-up menu at the bottom of the dialog box, select an import option, and click OK.

    • Choose Import from the pop-up menu at the bottom of the dialog box, select an import option, and click OK. Then double-click the XMP template file you want to import.

Edit metadata in image files

When you generate captions of placed images in InDesign, the metadata from the placed image is used. Although you can edit the metadata of InDesign documents, you cannot edit the metadata of placed files in InDesign. Instead, change the metadata of placed images using their original applications, using Finder or Explorer, or using Adobe Bridge or Adobe Mini Bridge.

  1. In InDesign, right-click (Windows) or Control-click (Mac OS) the image, and then choose Edit Original.

    You can also choose Edit With and then choose an application such as Adobe Illustrator or Adobe Photoshop.

  2. In the original application, choose File > File Info.

  3. Edit the metadata, and then click OK.

You can also select an image in Adobe Bridge and choose File > File Info to edit the image metadata. See Add metadata using the File Info dialog box.

Resolving shared network protective shutdown

  • Any document that is <100 MB in size and is opened from a network location, InDesign will not perform protective shutdown even if network connection is lost. When network connection is restored after temporary network loss, you can continue to work and will be able to save the document on the network. if you try to save the document while the network is lost, you get an option to save the document locally.
  • Documents >100 MB continue to exhibit the existing behavior - InDesign will perform protective shutdown if network connectivity is lost for such documents.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy