If you’re writing a manual or reference document, you may want to include a cross-reference to refer the reader from one part of your document to another. Example: For more information, see “Field mice” on page 249. You can specify whether a cross-reference derives from a paragraph style, such as a heading style, or from a text anchor you’ve created. You can also determine the cross-reference format, such as Page Number Only or Full Paragraph & Page Number.

Insert cross-references

Use the Cross-References panel to insert cross-references into your document. To open the panel, choose Window > Type & Tables > Cross-References.

Cross-References panel
A. Click the green visual indicator to go to destination. B. Click the page number to select source. C. Click the icon to create a cross-reference. 

The text being referred to is the destination text. The text that is generated from the destination text is the source cross-reference.

When you insert a cross-reference in your document, you can choose from several predesigned formats, or you can create your own custom format. You can apply a character style to the entire cross-reference source, or to text within the cross-reference. Cross-reference formats can be synchronized across a book.

Cross-reference source text is editable and can break across lines.

Note:

Cross-references are included in exported Adobe PDF files if Hyperlinks is selected in the Export Adobe PDF dialog box in InDesign. Cross-references are included in the exported SWF file if Include Hyperlinks is selected in the Export SWF dialog box.

Inserting cross-references
Inserting cross-references

A. Selected destination paragraph B. Click here to create or edit cross-reference format. 
  1. Place the insertion point where you want the cross-reference to be inserted.
  2. Do any of the following to open the New Cross-Reference dialog box:

    • Choose Type > Hyperlinks & Cross-References > Insert Cross-Reference.

    • Choose Window > Type & Tables > Cross-References, and then choose Insert Cross-Reference from the panel menu.

    • Click the Create New Cross-Reference button in the panel.

  3. In the dialog box, choose Paragraph or Text Anchor from the Link To menu.

    If you choose Paragraph, you can create a cross-reference to any paragraph in the document you specify.

    If you choose Text Anchor, you can create a cross-reference to any text in which you have created a hyperlink destination. (See Create a hyperlink destination.) Creating a text anchor is especially useful if you want to use different text than the actual destination paragraph.

  4. For Document, select the document containing the destination that you want to refer to. All open documents that have been saved are listed in the pop‑up menu. If the document you’re looking for isn’t open, choose Browse, locate the file, and then click Open.
  5. Click a paragraph style (such as Head1) in the left box to narrow down the choices, and then select the paragraph you want to refer to. (Or, if Text Anchor is selected, choose the text anchor.)
  6. Choose the cross-reference format you want to use from the Format menu.

    You can edit these cross-reference formats or create your own. See Using cross-reference formats.

  7. Specify the PDF appearance options for the cross-reference.

  8. Click OK.

When you insert a cross-reference, a text anchor marker appears at the beginning of the destination paragraph. You can view this marker when you choose Type > Show Hidden Characters. If this marker is moved or deleted, the cross-reference becomes unresolved.

Use cross-reference formats

Several cross-reference formats appear in the New Cross-Reference dialog box by default. You can edit these formats, delete them, or create your own.

Note:

If you’ve deleted or edited cross-reference formats in your document and want to return them to the default formats, you can choose Load Cross-Reference Formats from the panel menu and choose a document with unedited formats. You can also synchronize cross-reference formats in a book.

Create or edit cross-reference formats

Unlike other presets, cross-reference formats can be edited or deleted. When you edit a cross-reference format, any source cross-reference that uses that format is automatically updated.

  1. Do any of the following:
    • Choose Define Cross-Reference Formats from the Cross-References panel menu.

    • While creating or editing a cross-reference, click the Create Or Edit Cross-Reference Formats button .

  2. In the Cross-Reference Formats dialog box, do one of the following:
    • To edit a format, select the format on the left.

    • To create a format, select a format to base the new format on, and then click the Create Format button . This creates a duplicate of the selected format.

  3. For Name, specify the name of the format.
  4. In the Definition text box, add or remove any text as needed. Click the Building Block icon  to insert building blocks from a menu. Click the Special Characters icon  to select dashes, spaces, quotation marks, and other special characters.
  5. To apply a character style to the entire cross-reference, select Character Style For Cross-Reference, and then choose or create the character style from the menu.

    You can also use the Character Style building block to apply a character style to text within the cross-reference.

  6. Click Save to save the changes. Click OK when finished.

Cross-reference building blocks

Building block

What it does

Example

Page Number

Inserts the page number.

on page <pageNum/>

on page 23

Paragraph Number

Inserts the paragraph number in a cross-reference to a numbered list.

See <paraNum/>

See 1

In this example, only “1” is used from the paragraph, “1. Animals.”

Paragraph Text

Inserts the paragraph text without the paragraph number in a cross-reference to a numbered list.

See “<paraText/>”

See “Animals”

In this example, only “Animals” is used from the paragraph, “1. Animals.”

Full Paragraph

Inserts the entire paragraph, including paragraph number and paragraph text.

See “<fullPara/>”

See “1. Animals”

Partial Paragraph

Lets you create a cross-reference to the first part of a paragraph, up to the specified delimiter, such as a colon or em dash.

See <fullPara delim=”:” includeDelim=”false”/>

See Chapter 7

In this example, only “Chapter 7” is used from the title “Chapter 7: Dogs and Cats.”

Specify the delimiter (such as : in this example), and indicate whether the delimiter is excluded (“false” or “0”) or included (“true” or “1”) in the source cross-reference.

See Creating cross-references to partial paragraphs.

Text Anchor Name

Inserts the text anchor name. You can create text anchors by choosing New Hyperlink Destination from the Hyperlinks panel menu.

See <txtAnchrName/>

See Figure 1

Chapter Number

Inserts the chapter number.

in chapter <chapNum/>

in chapter 3

File Name

Inserts the filename of the destination document.

in <fileName/>

in newsletter.indd

Character Style

Applies a character style to text within a cross-reference.

See <cs name=”bold”><fullPara/></cs> on page <pageNum>

See Animals on page 23.

Specify the character style name, and include the text you want to apply the character style to between the <cs name=””> and </cs> tags.

See Apply character styles within a cross-reference.

Creating cross-references to partial paragraphs

You can design cross-reference formats to include only the first part of a paragraph. For example, if you have headings in your document that look like, “Chapter 7—Granada to Barcelona,” you can create a cross-reference that refers only to “Chapter 7.”

Cross-reference to partial paragraph
Cross-reference to partial paragraph

A. The cross-reference source ends at an em dash (^_) B. “false” excludes the em dash from the source 

When you insert the Partial Paragraph building block, you must do two things. First, specify the delimiter between the quotation marks. The delimiter is the character that ends the paragraph. Common delimiters include colons (Chapter 7: Granada), periods (Chapter 7. Granada), and dashes (Chapter 7—Granada). To insert special characters such as em dashes (^_), em spaces (^m), and bullet characters (^8), choose an option from the menu that appears when you click the Special Characters icon.

Second, indicate whether the delimiter character is excluded (Chapter 7) or included (Chapter 7—). Use includeDelim=”false” to exclude the delimiter and includeDelim=”true” to include the delimiter. Instead of “false” or “true,” you can use “0” or “1,” respectively.

Apply character styles within a cross-reference

If you want to emphasize a section of text within a cross-reference, you can use the Character Style building block. This building block consists of two tags. The <cs name=”stylename”> tag indicates which style is applied, and the </cs> tag ends the character style. Any text or building blocks between these tags is formatted in the specified style.

Applying a character style
Applying a character style to a section of the cross-reference

A. This tag applies a character style named “Red.”  B. This tag ends the character style formatting. C. A character style named “Bold” is applied to the rest of the cross-reference source. 
  1. Create the character style you want to use.
  2. In the Cross-Reference Formats dialog box, create or edit the format you want to apply.
  3. Under Definition, select the text and building blocks to which you want to apply the character style.
  4. Choose Character Style from the menu to the right of the definition list.
  5. Type the name of the character style between the quotation marks exactly as it appears in the Character Styles panel.

    Style names are case sensitive. If the character style is in a group, type the name of the group followed by a colon before the character style, such as Style Group 1: Red.

  6. Click Save to save the format, and then click OK.

Load (import) cross-reference formats

When you load cross-reference formats from another document, the incoming formats replace any existing formats that share the same name.

In InCopy, you can import cross-reference formats only in standalone documents. You cannot import formats from an InCopy document into an InDesign document. If the new or modified format in InCopy conflicts with a format in the InDesign document when the story is checked in, the InDesign format takes precedence.

  1. Choose Load Cross-Reference Formats from the Cross-References panel menu.

  2. Double-click the document containing the cross-reference formats you want to import.

You can also share cross-reference formats across documents by synchronizing a book.

Delete cross-reference formats

You cannot delete a cross-reference format that has been applied to cross-references in the document.

  1. In the Cross-Reference Formats dialog box, select the format you want to delete.
  2. Click the Delete Format button .

Manage cross-references

When you insert a cross-reference, the Cross-References panel indicates the status of the cross-reference. For example, icons indicate if the destination text appears on the pasteboard , a master page , a hidden layer , in overset text , or in hidden text . Cross-references that link to such destination areas are unresolved. The panel also lets you know if the destination paragraph has been edited  (also called out-of-date) or is missing  . Destination text is missing if either the destination text or the file containing the destination text cannot be found. Hold the mouse pointer over any icon to view a tool tip description.

In InCopy, you can manage cross-references only if the story is checked out for editing.

Update cross-references

An update icon indicates that the cross-reference destination text has changed or that the cross-reference source text has been edited. You can easily update the cross-reference. If the destination moves to a different page, the cross-reference is updated automatically.

When you update a cross-reference, any formatting changes you’ve made to the source text are removed.

When printing or outputting, you are notified if cross-references are out of date or unresolved.

Note:

You can also use the Preflight panel to notify you when cross-references are out of date or unresolved. When defining a profile, select Cross-References in the Text section. See Define preflight profiles.

  1. Select one or more out-of-date cross-references. To update all cross-references, make sure that none are selected.
  2. Do any of the following:
    • Click the Update Cross-References button  in the Cross-References panel.

    • Choose Update Cross-Reference from the Cross-References panel menu.

    • Choose Type > Hyperlinks & Cross-References > Update Cross-Reference.

To update all cross-references in a book, choose Update All Cross-References from the book panel menu. You are notified if any cross-references remain unresolved.

If the missing destination text has been moved to a different document, or if the document containing the destination text is renamed, you can relink the cross-reference. When you relink, any changes made to the source cross-reference are removed.

  1. In the Cross-References panel, select the cross-reference you want to relink.

  2. Choose Relink Cross-Reference from the panel menu.

  3. Locate the document in which the destination text appears, and then click Open.

If any other destination text appears in that document, you can relink additional cross-references.

Edit cross-references

To change the appearance of the source cross-reference or specify a different format, you can edit the cross-reference. If you edit a cross-reference that links to a different document, the document is opened automatically.

  1. Do any of the following:
    • Choose Type > Hyperlinks & Cross References > Cross-Reference Options.

    • In the Cross-References panel, double-click the cross-reference you want to edit.

    • Select the cross-reference, and choose Cross-Reference Options from the Cross-References panel menu.

  2. Edit the cross-reference, and then click OK.

Delete cross-references

When you delete a cross-reference, the source cross-reference is converted to text.

  1. In the Cross-References panel, select the cross-reference or cross-references you want to delete.

  2. Click the Delete icon, or choose Delete Cross-Reference from the panel menu.

  3. Click Yes to confirm.

To completely remove a cross-reference, you can also select the cross-reference source and delete it.

Editing cross-reference source text

You can edit cross-reference source text. The advantage of editing cross-reference text is that you can change tracking or word spacing as needed for copyfitting, or make other changes. The disadvantage is that if you update or relink the cross-reference, any local formatting changes are removed.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy