You create and manipulate your documents and files using various elements, such as panels, bars, and windows. Any arrangement of these elements is called a workspace. The workspaces of the different applications in Adobe Creative Cloud share the same appearance so that you can move between the applications easily. You can also adapt each application to the way you work by selecting from several preset workspaces or by creating one of your own.

Start workspace

The Start workspace in InDesign gives you convenient access to your recently used files, libraries, and presets.  

The Start workspace is displayed when:

  • InDesign is launched
  • No documents are open

Use the Start workspace to:

  • Get started quickly
    • Click Recent to view the files that you have recently modified.
    • Click CC Libraries to view a list of Libraries associated (own and shared) with your Creative Cloud account. The assets in your Libraries are displayed in the integrated Libraries panel.
    • Click Presets to view the available starter templates for new InDesign documents. Click a template to start a new document with a predefined canvas size.
  • View assets conveniently
    • List view . view a list of asset names.
    • Thumbnail view . View thumbnails of assets.
  • Interact with your Libraries
    • Use the integrated Libraries panel to quickly view, work with, or edit assets in your own or shared Creative Cloud Libraries.
Start workspace
Start workspace

Note:

To disable the Start workspace from the Preferences dialog, deselect the Show Start Workspace When No Documents Are Open check box (Preferences > General). The keyboard shortcuts Ctrl/Cmd + O and Ctrl/Cmd + N continue to be available for use.

Create documents

When you create a document in InDesign, instead of beginning with a blank document, you can choose from a wide variety of templates, including templates from Adobe Stock. Templates include assets that you can build on to complete your project. When you open a template in InDesign, you can work with it just as you would work with any other InDesign document.

In addition to templates, you can also create a document by selecting one of the numerous presets available in InDesign.

For more information, see Create documents.
 

New Document dialog
New Document dialog | Templates from Adobe Stock and presets

Recent Files workspace

Use the Recent Files workspace to review a list or thumbnail view of the files you have been working on recently. Select Recent Files from the Workspace Switcher menu to view Recent Files workspace.

To set the number of files you want to view, modify the value of Number Of Recent Items To Display text box (Preferences > File Handling > Saving InDesign Files).

Recent Files workspace
Recent Files workspace

Note:

This feature is disabled by default. To enable the Recent Files workspace from the Preferences dialog, select the Show The Recent Files Workspace While Opening A File check box (Preferences > General).

Workspace overview

  • The Application frame groups all the workspace elements in a single, integrated window that lets you treat the application as a single unit. When you move or resize the Application frame or any of its elements, all the elements within it respond to each other so none overlap. Panels don’t disappear when you switch applications or when you accidentally click out of the application. If you work with two or more applications, you can position each application side by side on the screen or on multiple monitors. If you are using a Mac and prefer the traditional, free-form user interface, you can turn off the Application frame. Select Window > Application Frame to toggle it on or off.
  • The Application bar across the top contains a workspace switcher, menus (Windows only), and other application controls. On Mac, the application bar is available only when Application frame is off. You can toggle it on or off using the Window menu.
  • The Tools panel contains tools for creating and editing images, artwork, page elements, and so on. Related tools are grouped.
  • The Control panel displays options for the currently selected object.
  • The Document window displays the file you’re working on. Document windows can be tabbed and, in certain cases, grouped and docked.
  • Panels help you monitor and modify your work. Panels can be grouped, stacked, or docked.
Workspace
Default InDesign workspace

A. Tabbed Document windows B. Publish Online C. Switch to Touch workspace D. Workspace switcher E. Panel title bar F. Search bar G. Control panel H. Collapse To Icons button I. Panel groups in vertical dock J. Status bar K. Tools panel 

Set UX color

You can change the interface to one of the four available color options: Dark, Medium Dark, Medium Light, and Light.

  1. Do one of the following:

    • (Windows) Choose Edit > Preferences > Interface
    • (macOS) Choose InDesign > Preferences > Interface
  2. Choose the desired interface color from the following Color Themes: Dark, Medium Dark, Medium Light, and Light.

    Color Themes
    Available color themes

  3. Select Match Pasteboard To Theme Color to set the color of the pasteboard to the selected color theme. Deselect to set the color of the pasteboard to white.

Manage windows and panels

Hide or show all panels

  • To hide or show all panels, including the Tools panel and Control panel, press Tab.

  • To hide or show all panels except the Tools panel and Control panel, press Shift+Tab.

Note:

You can temporarily display hidden panels if Auto-Show Hidden Panels is selected in Interface preferences. Move the pointer to the edge of the application window (Windows) or to the edge of the monitor (macOS) and hover over the strip that appears.

Display panel options

  • Click the panel menu icon in the upper-right corner of the panel.

Note:

You can open a panel menu even when the panel is minimized.

Adjust panel brightness

  • In Interface preferences, you can customize the interface to sport one of the four available color themes designed for optimal user experience: Dark, Medium Dark, Medium Light, and Light.

Note:

The pasteboard color in InDesign is matched to the theme color by default. Deselect Preferences > Interface > Appearance > Match Pasteboard To Theme Color option to change the pasteboard color to white.

Reconfigure the Tools panel

You can display the tools in the Tools panel in a single column, or side by side in two columns.

  • Click the double arrow at the top of the Tools panel.

Note:

You also can switch from single-column to double-column or single-row from Preferences > Interface > Panels > Floating Tools Panel.

Rearrange, dock, or float document windows

When you open more than one file, the Document windows are tabbed.

  • To rearrange the order of tabbed Document windows, drag a window’s tab to a new location in the group.
  • To undock (float or untab) a Document window from a group of windows, drag the window’s tab out of the group.
  • To dock a Document window to a separate group of Document windows, drag the window into the group.

  • To create groups of stacked or tiled documents, drag the window to one of the drop zones along the top, bottom, or sides of another window. You can also select a layout for the group by using the Layout button on the Application bar.

  • To switch to another document in a tabbed group when dragging a selection, drag the selection over the document’s tab for a moment.

Dock and undock panels

A dock is a collection of panels or panel groups displayed together, generally in a vertical orientation. You dock and undock panels by moving them into and out of a dock.

  • To dock a panel, drag it by its tab into the dock, at the top, bottom, or in between other panels.

  • To dock a panel group, drag it by its title bar (the solid empty bar above the tabs) into the dock.

  • To remove a panel or panel group, drag it out of the dock by its tab or title bar. You can drag it into another dock or make it free-floating.

Links panel dragged out to new dock
Links panel being dragged out to new dock, indicated by blue vertical highlight

Links panel in its own dock
Links panel now in its own dock

Note:

You can prevent panels from filling all the space in a dock. Drag the bottom edge of the dock up so it no longer meets the edge of the workspace.

Move panels

As you move panels, you see blue highlighted drop zones, areas where you can move the panel. For example, you can move a panel up or down in a dock by dragging it to the narrow blue drop zone above or below another panel. If you drag to an area that is not a drop zone, the panel floats freely in the workspace.

Note:

The position of the mouse (rather than the position of the panel), activates the drop zone, so if you can’t see the drop zone, try dragging the mouse to the place where the drop zone should be.

  • To move a panel, drag it by its tab.

  • To move a panel group, drag the title bar.

Color panel docked above the Layers panel group
Narrow blue drop zone indicates Color panel will be docked on its own above the Layers panel group.

Note:

Press Ctrl (Windows) or Command (Mac OS) while moving a panel to prevent it from docking. Press Esc while moving the panel to cancel the operation.

Add and remove panels

If you remove all panels from a dock, the dock disappears. You can create a dock by moving panels to the right edge of the workspace until a drop zone appears.

  • To remove a panel, right-click (Windows) or Control-click (Mac) its tab and then select Close, or deselect it from the Window menu.

  • To add a panel, select it from the Window menu and dock it wherever you want.

Manipulate panel groups

  • To move a panel into a group, drag the panel’s tab to the highlighted drop zone in the group.

Add a panel to a panel group
Adding a panel to a panel group

  • To rearrange panels in a group, drag a panel’s tab to a new location in the group.

  • To remove a panel from a group so that it floats freely, drag the panel by its tab outside the group.

  • To move a group, drag the title bar (the area above the tabs).

Stack floating panels

When you drag a panel out of its dock but not into a drop zone, the panel floats freely. The floating panel allows you to position it anywhere in the workspace. You can stack floating panels or panel groups so that they move as a unit when you drag the topmost title bar.

  • To stack floating panels, drag a panel by its tab to the drop zone at the bottom of another panel.

  • To change the stacking order, drag a panel up or down by its tab.

Note:

Be sure to release the tab over the narrow drop zone between panels, rather than the broad drop zone in a title bar.

  • To remove a panel or panel group from the stack, so that it floats by itself, drag it out by its tab or title bar.

Resize panels

  • To minimize or maximize a panel, panel group, or stack of panels, double-click a tab. You can also double-click the tab area (the empty space next to the tabs).

  • To resize a panel, drag any side of the panel. Some panels, such as the Color panel in Photoshop, cannot be resized by dragging.

Collapse and expand panel icons

You can collapse panels to icons to reduce clutter on the workspace. In some cases, panels are collapsed to icons in the default workspace.

Panels collapsed to icons
Panels collapsed to icons

Panels expanded from icons
Panels expanded from icons

  • To collapse or expand all panel icons in a column, click the double arrow at the top of the dock.
  • To expand a single panel icon, click it.
  • To resize panel icons so that you see only the icons (and not the labels), adjust the width of the dock until the text disappears. To display the icon text again, make the dock wider.
  • To collapse an expanded panel back to its icon, click its tab, its icon, or the double arrow in the panel’s title bar.

Note:

If you select Auto-Collapse Icon Panels from Preferences > Interface > Panels, an expanded panel icon collapses automatically when you click away from it.

  • To add a floating panel or panel group to an icon dock, drag it in by its tab or title bar. (Panels are automatically collapsed to icons when added to an icon dock.)

  • To move a panel icon (or panel icon group), drag the icon. You can drag panel icons up and down in the dock, into other docks (where they appear in the panel style of that dock), or outside the dock (where they appear as floating icons).

Use panel menus

Access the panel menus using the icon on the upper-right corner of the panel.

Panel menu (Swatches panel)
Panel menu (Swatches panel)

Save and switch workspaces

By saving the current size and position of panels as a named workspace, you can restore that workspace even if you move or close a panel. The names of saved workspaces appear in the workspace switcher in the Application bar.

Save a custom workspace

  1. Choose Window > Workspace > New Workspace.

  2. Type a name for the workspace.

  3. Under Capture, select one or more options:

    Panel Locations

    Saves the current panel locations.

    Menus or Menu Customization

    Saves the current set of menus.

Display or switch workspaces

  • Select a workspace from the workspace switcher in the Application bar.

Delete a custom workspace

  • Select Delete Workspace from the workspace switcher, select the workspace, and then click Delete.

  • Choose Window > Workspace >Delete Workspace, select the workspace, and then click Delete.

Restore the default workspace

  • Select Window > Workspace > Reset [Workspace Name].

About screen modes

You can change the visibility of the document window using the Mode buttons at the bottom of the toolbox or by choosing commands from the View > Screen Mode menu. When the toolbox is displayed in a single column, you can select view modes by clicking the current mode button and selecting a different mode from the menu that appears.

Normal Mode 

Displays artwork in a standard window with all visible grids and guides showing, non-printing objects showing, and a white pasteboard.

Preview Mode 

Displays artwork as if it were output, with all non-printing elements suppressed (grids, guides, non-printing objects), and the pasteboard set to the preview background color defined in Preferences.

Bleed Mode 

Displays artwork as if it were output, with all non-printing elements suppressed (grids, guides, non-printing objects), the pasteboard set to the preview background color defined in Preferences, and any printing elements within the document's bleed area (defined in Document Setup) showing.

Slug Mode 

Displays artwork as if it were output, with all non-printing elements suppressed (grids, guides, non-printing objects), the pasteboard set to the preview background color defined in Preferences, and any printing elements within the document's slug area (defined inDocument Setup) showing.

Presentation Mode 

Displays artwork as if it were a slideshow presentation, with no menus, panels, or tools displayed. See Use Presentation Mode.

Use the status bar

The status bar at the lower left of a document window shows information about the status of a file and lets you turn to a different page. Click the status bar menu to do any of the following:

  • Show the current file in the file system by choosing Reveal In Explorer (Windows) or Reveal In Finder (macOS).

  • Show the current file in Adobe Bridge by choosing Reveal in Bridge.

Note:

In macOS, you can display the zoom percentage in the status bar by hiding the application bar (Window > Application Bar). In Windows, you cannot hide the application bar.

Control panel overview

The Control panel (Window > Control) offers quick access to options, commands, and other panels related to the current page item or objects you select. By default, the Control panel is docked to the top of the document window; however, you can dock it to the bottom of the window, convert it to a floating panel, or hide it altogether.

Options displayed in the Control panel vary depending on the type of object or tool you select:

  • When you select a frame, the Control panel displays options for resizing, repositioning, skewing, and rotating the frame, or applying an object style.

  • When you select text inside a frame, the Control panel displays either character or paragraph options. Click the paragraph and character icons on the left side of the Control panel to determine whether paragraph or character options are displayed. If your monitor size and resolution allows, the Control panel displays additional options. For example, if the character icon is selected, all the character options are displayed, and some paragraph options appear on the right of the Control panel. If you click the paragraph icon, all paragraph options are displayed, and some character options appear on the right.

  • When you select a table cell, the Control panel displays options for adjusting row and column dimensions, merging cells, aligning text, and adding strokes.

As the options in the Control panel change, you can get more information about each option by using tool tips—pop‑up descriptions that appear when you hover over an icon or option label with the pointer.

Control panel with tool tip displayed
Control panel with tool tip displayed

Control panel menu
Control panel menu

To open dialog boxes associated with Control panel icons, Alt‑click (Windows) or Option‑click (Mac OS) as you click a Control panel icon. For example, when a frame is selected, hold down Alt or Option and click the Rotation Angle icon  to open the Rotate dialog box.

Dock or float the Control panel

  • Do one of the following:
    • Drag the vertical bar on the left side of the Control panel until the toolbar is docked to the top or bottom of the application window (Windows) or screen (Mac OS).

    • Choose Dock At Top, Dock At Bottom, or Float from the Control panel menu.

Customize the Control panel

  1. To open the Customize Control Panel dialog box, do one of the following:

    • Click Customize Control Panel icon located on the right side of the Control panel.
    • Choose Customize from the Control panel menu located on the right side of the Control panel.
  2. Specify options that you want to display or hide, and then click OK.

Use context menus

Unlike the menus that appear at the top of your screen, context-sensitive menus display commands related to the active tool or selection. You can use context menus as a quick way to choose commonly used commands.

  1. Position the pointer over the document, object, or panel.
  2. Click the right mouse button.

Note:

(macOS) If you don’t have a two-button mouse, you can display a context menu by pressing the Control key as you click with the mouse.

Change Interface preferences

  1. Choose Edit > Preferences > Interface (Windows) or InDesign > Preferences > Interface (macOS).

  2. Choose the settings you want to specify, and click OK.

Color Theme

Select the color theme for InDesign interface. Choose from Dark, Medium Dark, Medium Light, or Light Color Theme.

Match Pasteboard To Theme Color

Select this option to match pasteboard color with the theme color of interface.

Tool Tips

Tool tips appear when you hold the pointer over interface items such as tools in the toolbar and options in the Control panel. Choose None to turn off tool tips.

Show Thumbnails On Place

When you place a graphic, a thumbnail of the image appears in the loaded graphics cursor. Similarly, a thumbnail of the first few lines of text appears in the loaded text cursor. Deselect this option if you don’t want thumbnails to appear when placing graphics or text.

Show Transformation Values

When you’re creating, sizing, or rotating an object, the cursor displays the [x,y] coordinates, width and height, or rotation information.

Enable Multi-Touch Gestures

Select this option to allow Windows and Mac OS multi-touch mouse gestures to work in InDesign. For example, when you use the Magic Mouse in Mac OS, the swipe gesture scrolls up or down or moves to the previous or next page or spread, and the rotate gesture rotates the spread.

Highlight Object Under Selection Tool

Select this option to highlight the frame edges of objects when the direct selection tool is moved over it.

Floating Tools Panel

Specify whether the toolbar appears as a single column, double column, or single row.

Auto-Collapse Icon Panels

When this option is selected, clicking the document window closes the open panel automatically.

Auto-Show Hidden Panels

When you hide panels by pressing Tab, holding the pointer over the side of the document window temporarily reveals the panels if this option is selected. If this option is not selected, you must press Tab again to display panels.

Open Documents As Tabs

When this option is deselected, documents you create or open appear as floating windows rather than tabbed windows.

Enable Floating Document Window Docking

If this option is selected, you can dock floating documents with each other as tabbed windows. If this option is deselected, floating document windows aren’t docked with other document windows, unless you hold down Ctrl (Windows) or Command (Mac OS) while dragging.

Large Tabs

Select this option to increase the height of panel and document tabs.

Hand Tool

To control whether to greek text and images when you scroll a document, drag the Hand Tool slider to the desired level of performance versus quality.

Live Screen Drawing

Select an option to determine whether the image redraws as you drag an object. If Immediate is selected, the image redraws while you drag. If Never is selected, dragging an image moves only the frame, and then image is moved when you release the mouse button. If Delayed is selected, the image redraws only if you pause before dragging. Delayed offers the same behavior as in InDesign CS4.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy