Select text

  • Using the Type tool, do one of the following:
    • Drag the I‑bar cursor over a character, word, or an entire text block to select it.
    • Double-click a word to select it. Spaces next to the word are not selected.
    • Triple-click anywhere in a line to select a line. If the Triple Click To Select A Line preferences option is deselected, triple-clicking selects the entire paragraph.

    • If the Triple Click To Select A Line option is selected, quadruple-click anywhere in a paragraph to select the entire paragraph.

    • Quintuple-click to select the entire story, or click anywhere in a story and choose Edit > Select All.

Note:

If you select text that contains a note anchor, using any of the above procedures, the note and its contents are also selected.

If you cannot select text in a frame, the text frame could be on a locked layer or on a master page. Try unlocking the layer or going to the master page. The text frame may also be beneath another text frame or transparent object. See Select text in a frame that is covered.

Change what triple-clicking does

  1. Choose Edit > Preferences > Type (Windows) or InDesign > Preferences > Type (Mac OS).
  2. Select Triple Click To Select A Line to enable triple-clicking to select a line (this is the default). Deselect this option if you want triple-clicking to select a paragraph.

Select text in a frame that is covered

  1. Using the Selection tool , hold down Ctrl (Windows) or Command (Mac OS) and click to select the text frame.
  2. Select the Type tool, and then click inside the text frame or select text.

View hidden (nonprinting) characters

  1. Choose Type > Show Hidden Characters.
  2. If hidden characters still do not appear, turn off preview mode. Choose View > Screen Mode > Normal and choose View >Overprint Preview to deselect it.

Nonprinting characters such as those for spaces, tabs, ends of paragraphs, index markers, and ends of stories appear. These special characters are visible only in a document window and a story editor window; they don’t print or output to formats such as PDF and XML. The hidden characters appear in the same color as the layer color.

Nonprinting characters hidden (top) and visible (bottom)
Nonprinting characters hidden (top) and visible (bottom)

Anne Marie Concepcion provides a comprehensive list of special characters at Free Guide to InDesign Special Characters.

List of hidden characters

Hidden character

What it represents

End of Paragraph

Soft return (line break)

Space

End of Story

Discretionary Hyphen

Nonbreaking Hyphen

Tab

Right Indent Tab

Indent to Here

End Nested Style Here

Non-Joiner

Ideographic Space

Em Space

En Space

Nonbreaking Space

Nonbreaking Space (Fixed Width)

Hair Space

Sixth Space

Thin Space

Quarter Space

Third Space

Punctuation Space

Figure Space

Flush Space

Column Break

Frame Break

Page Break

Odd Page Break

Even Page Break

Forced Line Break

InCopy Note

InCopy Note (in Story Editor)

Position marker (InCopy only)

Index marker

Index marker (in Story Editor)

Hidden conditional text

Hidden conditional text (in Story Editor)

Bookmark or hyperlink destination marker (often a text anchor)

Bookmark or hyperlink destination marker (in Story Editor)

Hyperlink destination (in Story Editor)

Cross-referenced paragraph

Cross-reference hyperlink (in Story Editor)

Anchored object

Anchored object (in Story Editor)

XML tag

XML tag (in Story Editor)

Footnote (in Story Editor)

Table (in Story Editor)

Variable (in Story Editor)

Index marker (in Story Editor)

Add column, frame, and page breaks

Control column, frame, and page breaks by inserting special break characters in the text.

  1. Using the Type tool, click to place the insertion point where you want the break to occur.
  2. Choose Type > Insert Break Character, and then choose a break option from the submenu.

Note:

You can also create breaks by using the Enter key on the numeric keypad. For a column break, press Enter; for a frame break, press Shift+Enter; and for a page break, press Ctrl+Enter (Windows) or Command+Return (Mac OS).

To remove a break character, choose Type > Show Hidden Characters so that you can see nonprinting characters, and then select and delete the break character.

Note:

If you create a break by changing paragraph settings (as in the Keep Options dialog box), the break precedes the paragraph that contains the setting. If you create a break using a special character, the break occurs immediately after the special character.

Break options

The following options appear on the Type > Insert Break Character menu:

Column break 

Flows text to the next column in the current text frame. If the frame has only one column, the text goes to the next threaded frame.

Frame break 

Flows text to the next threaded text frame, regardless of the current text frame’s column setup.

Page break 

Flows text to the next page with a text frame threaded to the current text frame.

Odd page break 

Flows text to the next odd-numbered page with a text frame threaded to the current text frame.

Even page break 

Flows text to the next even-numbered page with a text frame threaded to the current text frame.

Paragraph Return 

Inserts a paragraph return (the same as pressing Enter or Return).

Forced Line Break 

Forces a line to break where the character is inserted, starting a new line without starting a new paragraph (the same as pressing Shift+Enter or Shift+Return). A forced line break is also called a soft return.

Discretionary Line Break 

Indicates where a line of text should break if the line needs to break. A discretionary line break is similar to a discretionary hyphen, only no hyphen is added where the line breaks.

Related break options are available in the Keep Options dialog box and in the Paragraph Style Options dialog box.

Use the Story Editor

You can edit text in InDesign either on the layout page or in the story editor window. Writing and editing in a story editor window allows the entire story to appear in the typeface, size, and spacing that you specify in Preferences, without layout or formatting distractions. The Story Editor is also where you can view track changes to text.

Each story appears in a different story editor window. All the text in the story appears in the story editor, including overset text. You can open several story editor windows simultaneously, including multiple instances of the same story. A vertical depth ruler indicates how much text is filling the frame, and a line indicates where text is overset.

When you edit a story, changes are reflected in the layout window. Open stories are listed in the Window menu. You cannot create a new story in a story editor window.

Story Editor window
Story Editor window

A. Paragraph styles B. Drag divider to adjust column width C. Vertical depth ruler D. Overset text indicator 

You can view and edit tables in Story Editor, where text is displayed in sequential columns and rows for easy editing. Quickly expand or collapse tables, and decide whether to view them by row or column.

The Story Editor also displays text that has been added, removed, or edited if you turn on Track Changes. See Tracking and reviewing changes.

Open the Story Editor

  1. Select the text frame, click an insertion point in the text frame, or select multiple frames from different stories.
  2. Choose Edit > Edit In Story Editor.

Note:

To open another instance of the same story editor window, make the story editor active, and choose Window > Arrange > New Window.

Return to the layout window

  • In Story Editor, do one of the following:
    • Choose Edit > Edit In Layout. When you use this method, the layout view displays the same text selection or insertion-point location as last appeared in the story editor, and the story window remains open but moves behind the layout window.

    • Click in the layout window. The story window remains open but moves behind the layout window.

    • Close the story editor window.

    • Choose the document name from the bottom of the Window menu.

Show or hide Story Editor items

You can show or hide the style name column and the depth ruler, expand or collapse footnotes, and show or hide paragraph break marks to indicate the start of new paragraphs. These settings affect all open story editor windows, as well as all subsequently opened windows.

  • With the story editor active, choose View > Story Editor > Show Style Name Column or Hide Style Name Column. You can also adjust the width of the style name column by dragging the vertical bar. Subsequent story editor windows have the same column width.
  • With the Story Editor active, choose View > Story Editor > Show Depth Ruler or Hide Depth Ruler.
  • With the Story Editor active, choose View > Story Editor > Expand All Footnotes or Collapse AllFootnotes.
  • With the Story Editor active, choose View > Story Editor > Show Paragraph Break Marks or Hide Paragraph Break Marks.

Story Editor preferences

Use Story Editor Display preferences to change the appearance of the Story Editor. Although the Story Editor suppresses all but the most basic text styling attributes, some objects and attributes are represented, including the following:

Attribute

Icon

Table

Inline objects

XML tags

Variables

Hyperlink sources

Hyperlink anchors

Cross-reference

Hidden conditional text

Note

Footnotes

Index markers

Deleted text

Added text

Moved text

 

Text Display Options

Choose a display font, size, line spacing, text color, and background. You can also specify a different theme, such as selecting Classic System to view yellow text on a black background. These settings affect the display of text in the story editor window, not how they appear in layout view.

Enable Anti-Aliasing

Smooth the jagged edges of type, and choose the Type of anti-aliasing: LCD Optimized, Soft, or the Default setting, which uses shades of gray to smooth text. LCD Optimized uses colors, rather than shades of gray, to smooth text, and works best on light-colored backgrounds with black text. Soft uses shades of gray, but produces a lighter, fuzzier appearance than Default.

Cursor Options

Change the appearance of the text cursor. For example, select Blink if you want the cursor to blink.

Text from inline frames does not appear in the parent story editor window, but it can appear in its own story editor window.

Use conditional text

Conditional text is a way to create different versions of the same document. After you create conditions, you apply them to ranges of text. You can then create different versions of documents by showing and hiding conditions. For example, if you’re creating a computer manual, you can create separate conditions for Mac OS and Windows. Before you print the Mac OS version of the user guide, you can show all text to which the “Mac” condition is applied and hide all text to which the “Windows” condition is applied. You can then reverse the condition states for printing the user guide for Windows.

Conditional text
Conditional text shown

A. All conditions shown B. Conditional indicators 
Conditional text hidden
Conditional text hidden

A. “Mac” condition hidden B. Hidden condition symbols 

Conditions can be applied only to text. You can make anchored objects conditional, but only by selecting the anchored object marker. You can apply conditions to text within table cells, but you cannot apply conditions to table cells, columns, or rows. You cannot apply conditions to text in locked InCopy stories.

Planning conditional documents

When planning a project with conditional text, examine the nature of the material and look at how several people can take turns working with it if the document is handed off. Plan to treat conditional text consistently to make the document easier to use and maintain. Use the following guidelines.

Number of versions

Define how many versions your finished project will contain. For example, if you’re creating a manual that describes a program that runs on both Windows and Mac OS platforms, you might want to produce at least two versions: a Windows version and a Mac OS version. If you want to produce these versions with editorial comments sprinkled in the text during the review process, you’ll want even more versions: Mac OS with comments, Mac OS without comments, Windows with comments, and Windows without comments.

For documents with many conditions, you can define condition sets that can be applied to the document for quick versioning.

Number of condition tags required

Decide how many condition tags you need to produce the desired versions. A version of a document is defined by a unique set of condition tags. For example, a version of a finished Windows manual might be defined by having a Windows condition tag showing, a Mac OS condition tag hidden, and a Comments condition tag hidden. In this example, you would need to decide whether to use one condition tag for Windows comments and another for Mac OS comments, or whether to use a single condition tag for both Windows and Mac OS comments.

Organization of content

Evaluate the extent to which the document can be conditional and how you can organize the material to simplify development and maintenance. For example, you might be able to organize a book so that conditional text is limited to a few documents. Or you might choose to keep versions of a particular chapter in separate files rather than in conditional text, and then use a different book file for each version of the book.

In some instances, such as when working with multiple languages, you may want to create separate layers that you can show or hide rather than using conditions, with each layer including text from a different language.

Tagging strategy

Determine the smallest unit of conditional text. For example, if a document will be translated to another language, a whole sentence should be the smallest amount of text you make conditional. Because word order often changes during translation, using conditional text for part of a sentence could complicate translation.

Inconsistency in applying conditions to spaces and punctuation can result in extra spacing or misspelled words. Decide whether to make spaces and punctuation conditional. If conditional text begins or ends with punctuation, make the punctuation conditional too. This makes the text easier to read when you're viewing more than one version.

To avoid word spacing problems, such as having an unconditional space followed by a conditional space, set standards for handling spaces following conditional text (either always conditional or always unconditional).

To avoid confusion, decide the order in which conditional text will appear and use this order throughout the document.

Indexes and cross-references

When indexing a document, pay attention to whether index markers are placed inside or outside conditional text. Keep in mind that index markers in hidden conditional text are not included in the generated index.

If you create a cross-reference to conditional text, make sure that the source text has the same condition. For example, if you add a cross-reference in a “Windows” paragraph and the text anchor appears in a “Mac” condition, the cross-reference is unresolved when the “Mac” condition is hidden. “HT” appears next to the cross-reference in the Hyperlinks panel.

If you create a cross-reference to a paragraph in which some text is conditional and then change the visibility settings of that condition, update the cross-reference.

Create conditions

Conditions you create are saved in the current document. If no documents are open when you create a condition, that condition appears in all new documents you create.

You can make conditional text easy to identify by specifying condition indicators, such as wavy red underlines.

  1. Choose Window > Type & Tables > Conditional Text to display the Conditional Text panel.
  2. Choose New Condition from the Conditional Text panel menu, and type a name for the condition.
  3. In the Indicator group, specify the appearance of the indicator to which the condition is applied.

    By default, indicators (such as wavy red lines) are set to appear in the document but not be printed or output. You can choose an option from the Indicators menu in the Conditional Text panel to hide indicators or to print and output them, which can be useful for review purposes.

  4. Click OK.

Apply conditions to text

You can apply multiple conditions to the same text. By default, condition indicators identify conditional text. However, if indicators are hidden, you can use the Conditional Text panel to determine which conditions have been applied to the current text. A solid check mark indicates the condition is applied to the current text. A dim check mark indicates that the condition is applied only to part of the selection.

  1. Select the text to which you want to apply the condition.
  2. In the Conditional Text panel (Windows > Type & Tables > Conditional Text), do any of the following:
    • To apply a condition, click the condition, or click the box next to the condition name.

    • To apply a condition and remove other conditions applied to the text, Alt-click (Windows) or Option-click (Mac OS) a condition.

    • To remove a condition, click the box next to the condition name to remove the check mark. Or, click [Unconditional] to remove all conditions from the selected text.

Note:

You cannot apply keyboard shortcuts to specific conditions. However, you can apply conditions using Quick Apply.

Show or hide conditions

When you hide a condition, all text to which that condition is applied is hidden. Hiding conditions often causes the page numbering to change in a document or book. You can use the Smart Text Reflow feature to add and remove pages automatically as you hide and show conditions.

Hidden conditional text is generally ignored in the document. For example, hidden text is not printed or exported, index markers in hidden conditional text are not included in a generated index, and hidden conditional text is not included when searching or spell-checking text.

When you hide a condition, the hidden text is stored in a hidden condition symbol . If you select text that contains a hidden condition symbol and try to delete it, InDesign prompts you to confirm that you want to delete the hidden conditional text. You cannot apply other conditions, styles, or formatting to hidden conditional text.

If text has several conditions applied to it and at least one of those conditions is shown while another is hidden, the text is not hidden.

  • To show or hide individual conditions, click the visibility box next to a condition name. The eye icon indicates the condition is shown.
  • To show or hide all conditions, choose Show All or Hide All from the Conditional Text panel menu.

Use condition sets

A condition set captures the visibility settings for all conditions so that you can quickly apply different document renditions. For example, suppose you have a complex document with platform conditions for Mac OS, Windows XP, Vista, UNIX , language conditions for English, French, German, and Spanish, and editorial conditions such as Editorial Review and Internal Comments. For reviewing the Vista version in French, you can create a set that shows only the Vista, French, and Editorial Review conditions, and hides all the rest.

While sets aren’t necessary to do this, they help you quickly and reliably change different condition visibility settings.

  1. Apply conditions to text as necessary.
  2. If the Set menu doesn’t appear in the Conditional Text panel, choose Show Options from the Conditional Text panel menu.
  3. In the Conditional Text panel, make the conditions visible or hidden as needed.
  4. Choose Create New Set from the Set menu, specify a name for the set, and click OK.

    The new set becomes the active set.

  5. Do any of the following:
    • To apply the condition set to a document, choose the condition set name from the Set menu.

    • To override a condition set, select the set to make it active, and change the visibility setting of any condition. A plus sign (+) appears next to the condition set. Choose the condition set again to remove overrides. Choose Redefine “[Condition Set]” to update the condition set with the new visibility settings.

    • To delete a condition set, select the condition set, and then choose Delete “[Condition Set].” Deleting a condition set does not delete the set’s conditions, nor does it remove the conditions from wherever they are applied.

Manage conditions

  • Do any of the following:

    Delete a condition

    Select a condition and click the Delete Condition icon at the bottom of the Conditional Text panel. Specify a condition to replace the deleted condition and click OK. The condition you specify is applied to all text to which the deleted condition was applied.

    To delete multiple conditions, Shift-click to select contiguous conditions, or Ctrl-click (Windows) or Command-click (Mac OS) to select non-contiguous conditions, and then click the Delete Condition icon.

    Remove a condition from text

    Removing a condition tag from text is different from deleting a tag from a document. When you remove a tag from text, the tag remains in the document so it can be applied again later.

    To remove a condition from text, select the text and click the box next to the condition to remove the check mark, or click [Unconditional] to remove all conditions from the selected text.

    Load (import) conditions

    Choose Load Conditions (to load only conditions) or Load Conditions And Sets from the Conditional Text panel menu. Select the InDesign document from which you want to import the conditions, and click Open. Loaded conditions and sets replace any condition or set that has an identical name.

    You cannot load conditions from an InCopy file in InDesign, but you can load conditions from an InDesign file in both InDesign and InCopy.

    Loaded sets ignore the visibility settings of the conditions currently in the Conditional Text panel.

    Synchronize conditions in a book

    To make sure you’re using the same conditions in all documents in a book, create the conditions you want in the style source document, select Conditional Text Settings in the Synchronize Options dialog box, and then synchronize the book.

    Show or hide condition indicators

    Choose Show or Hide from the Indicators menu in the Conditional Text panel to show or hide condition indicators. If you’re showing one version and want to see which areas are conditional, show the condition indicators. If you find the condition indicators distracting while viewing the layout, hide the condition indicators. Choose Show And Print if you want the condition indicators to be printed and output.

    Change a condition name

    In the Conditional Text panel, click a condition, pause, and then click the condition name to select it. Type a different name.

    Edit condition indicators

    In the Conditional Text panel, double-click a condition, or select a condition and choose Condition Options from the panel menu. Specify indicator settings, and click OK.

Find and change conditional text

Use the Find/Change dialog box to find text to which one or more conditions have been applied and replace it with one or more other conditions.

  1. Show any conditional text you want included in the search.

    Hidden text is excluded from the search.

  2. Choose Edit > Find/Change.
  3. If the Find Format and Change Format boxes don’t appear at the bottom of the dialog box, click More Options.
  4. Click the Find Format box to display the Find Format Settings dialog box. Under Conditions, select [Any Condition] to search for text in which any conditon is applied, [Unconditional] to search for text in which no condition is applied, or select the specific condition or conditions you want to search for. Click OK.

    This feature finds text that perfectly matches the selected conditions. For example, if you select both Condition 1 and Condition 2, text to which only one of the conditions are applied isn’t found, nor is text found to which these two conditions and another is applied.

  5. Click the Change Format box to display the Change Format Settings dialog box. Specify the different formatting option, such as a condition or a character style, and then click OK.

    If you select the Conditions section in the Change Format Settings dialog box, the [Any Condition] makes no changes to the found conditional text. This option is useful if you want to apply different formatting, such as a character style. Select [Unconditional] to remove all conditions from the found text. If you select a specific condition, specify whether you want it to replace any condition applied to the found text or be added to it.

  6. Click Find, and then use the Change, Change/Find, or Change All buttons to replace the condition.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy