About selections

A selection is an area of a photo that you define. When you create a selection, the area is editable (for example, you can lighten one part of a photo without affecting the rest). You can make a selection with either a selection tool or a selection command. A selection border, which you can hide, surrounds the selection. You can change, copy, or delete pixels inside the selection border, but you can’t touch areas outside the selection border until you deselect the selection.

Adobe Photoshop Elements provides selection tools for different kinds of selections. For example, the Elliptical Marquee tool selects circular and elliptical areas, and the Magic Wand tool can select an area of similar colors with one click. More complex selections can be made with one of the Lasso tools. You can even smooth the edges of a selection with feathering and anti-aliasing.

Note:

Selections are limited to the active layer—to make changes to all layers at once, you first need to flatten the image.

Elliptical Marquee tool
Selection made with Elliptical Marquee tool, color adjusted in selected area

About the selection tools

The selection tools are located in the Tools panel, which is located, by default, on the left side of your screen.

In Photoshop Elements, you must be in Expert mode to see the selection tools.

Rectangular Marquee tool

Rectangular Marquee tool: Draws square or rectangular selection borders.

Elliptical Marquee tool

Elliptical Marquee tool: Draws round or elliptical selection borders.


Lasso Marquee tool

Lasso tool: Draws freehand selection borders, best for precision.



Polygonal Lasso tool

Polygonal Lasso tool: Draws multiple straight-edged segments of a selection border.

Magnetic Lasso tool

Magnetic Lasso tool: Draws a selection border that automatically snaps to edges when you drag over in the photo.


Magic Wand tool

Magic Wand tool: Selects pixels of similar color with one click



Quick Selection tool

Quick Selection tool: Quickly and automatically makes selection based on color and texture when you click or click-drag an area.

Selection Brush tool

Selection Brush tool: Automatically selects or deselects the area you paint, depending on whether you’re in Sselection or Mask mode.



Smart Brush tool

Smart Brush tool: Applies color and tonal adjustments and effects to a selection. The tool automatically creates an adjustment layer for non-destructive editing.



Use the Rectangular and Elliptical Marquee tools

The Rectangular Marquee tool draws square or rectangular selection borders, and the Elliptical Marquee tool draws round or elliptical selection borders.

Rectangular and Elliptical Marquee tool options
Rectangular and Elliptical Marquee tool options

A. Rectangular Marquee tool B. Elliptical Marquee tool C. New selection D. Add to selection E. Subtract from selection F. Intersect with selection 
  1. Select the Rectangular Marquee tool (A) or the Elliptical Marquee tool (B) in the toolbox.

  2. (Optional) Set marquee tool options in the Tool Options bar:

    • Specify whether to create a new selection, add to a selection, subtract from a selection, or select an area intersected by other selections.
    • To soften the selection border so that it blends into the area outside the selection, enter a Feather value.
    • To smooth the edges of your selection, select Anti-aliased (Elliptical Marquee tool only).
    • From the Mode pop‑up menu, choose Normal to visually set the size and proportions of the selection border; Fixed Ratio to set a width-to-height ratio for the selection border; or Fixed Size to specify the marquee’s height and width.
  3. Drag over the area you want to select. Hold down the Shift key as you drag to constrain the selection marquee to a square or circle.

    Note:

    To drag a marquee from the center, hold down Alt (Windows) or Option (Mac OS) after you begin dragging.

    Note:

    To reposition a marquee tool selection border, hold down the spacebar as you drag with the selection tool. Release the spacebar once the selection border is in the correct area.

  4. Click Refine Edge to make further adjustments to your selection and make it more precise. See how you can refine the edges of a selection.

Use the Lasso tool

The Lasso tool draws freehand selection borders. This tool lets you make very precise selections.

Lasso tool options
Lasso tool options

A. Lasso tool B. Polygonal Lasso tool C. Magnetic Lasso tool D. New selection E. Add to selection F. Subtract from selection G. Intersect with selection 
  1. Select the Lasso tool from the toolbox.

  2. (Optional) Set Lasso tool options in the Tool Options bar:

    • Specify whether to create a new selection, add to an existing selection, subtract from a selection, or select an area intersected by other selections.
    • To soften the selection border so that it blends into the area outside the selection, enter a Feather value.
    • To smooth the edges of your selection, select Anti-aliased.
  3. Drag to draw a freehand selection border:
    • To add to the selection, release the mouse button; then press Shift and, when the pointer changes to , drag.
    • To subtract from the selection, release the mouse button; then press Alt (Option in Mac OS) and when the pointer changes to , drag.
    • To add straight-edge segments, hold the mouse button and press Alt (Option in Mac OS); then release the mouse button and, when the pointer changes click where you want to position the end of the segment.
  4. To close the selection border, release the mouse button. A straight selection segment is drawn from where you released the mouse button to the starting point of your selection.
  5. Click Refine Edge to make further adjustments to your selection and make it more precise. See how you can refine the edges of a selection.

Use the Polygonal Lasso tool

The Polygonal Lasso tool draws straight-edged segments of a selection border. You can create as many segments as you need to draw a selection border.

Polygonal Lasso tool options
Polygonal Lasso tool options

A. Lasso tool B. Polygonal Lasso tool C. Magnetic Lasso tool D. New selection E. Add to selection F. Subtract from selection G. Intersect with selection 
  1. Select the Polygonal Lasso tool from the toolbox.

  2. (Optional) Set Polygonal Lasso tool options in the Tool Options bar:

    • Specify whether to create a new selection, add to an existing selection, subtract from a selection, or select an area intersected by other selections.
    • To soften the selection border so that it blends into the area outside the selection, enter a Feather value.
    • To smooth the edges of your selection, select Anti-aliased.
  3. Click where you want the first straight segment to begin, and click a second time where you want the segment to end and the next one to begin. Continue clicking to create segments.

    If you make a mistake, press the Delete key to erase segments. You can switch from creating straight-edge segments to drawing freehand by pressing Alt (Option in Mac OS).

  4. Close the selection border by doing one of the following:
    • Position the pointer over the starting point and click. A closed circle appears next to the pointer when you are over the starting point.
    • If the pointer is not over the starting point, double-click, or Ctrl-click (Command-click in Mac OS). A straight selection segment is drawn from your pointer to the starting point of your selection.
  5. Click Refine Edge to make further adjustments to your selection and make it more precise. See how you can refine the edges of a selection.

Use the Magnetic Lasso tool

The Magnetic Lasso tool draws a selection border that automatically snaps to the edges of objects you drag over in the photo. This makes it easy to draw precise selection borders. The Magnetic Lasso tool  is useful for quickly selecting objects with complex edges set against high-contrast backgrounds.

Magnetic Lasso tool options
Magnetic Lasso tool options

A. Lasso tool B. Polygonal Lasso tool C. Magnetic Lasso tool D. New selection E. Add to selection F. Subtract from selection G. Intersect with selection 
  1. Select the Magnetic Lasso tool from the toolbox.

    To switch between the Magnetic Lasso and other lasso tools when the Magnetic Lasso tool is selected, do one of the following:

    • To activate the Lasso tool, press Alt (Option in Mac OS) and drag.
    • To activate the Polygonal Lasso tool, press Alt (Option in Mac OS) and click.
  2. (Optional) Set Magnetic Lasso tool options in the Tool Options bar:

    • Specify whether to create a new selection, add to an existing selection, subtract from a selection, or select an area intersected by other selections.
    • To soften the selection border so that it blends into the area outside the selection, enter a Feather value.
    • To smooth the edges of your selection, select Anti-aliased.
    • To specify the area of edge detection, enter a pixel value between 1 and 256 for Width. The tool detects edges only within the specified distance from the pointer.

    Note:

    To change the Magnetic Lasso pointer so that it indicates the area of edge detection (the Width value), press the Caps Lock key.

    • To specify the Magnetic Lasso tool’s sensitivity to edges in the photo, enter a value between 1% and 100% for Edge Contrast. A higher value detects only edges that contrast sharply with their surroundings; a lower value detects lower-contrast edges.
    • To specify the rate at which the Magnetic Lasso tool sets fastening points, enter a value between 0 and 100 for Frequency. A higher value anchors the selection border in place more quickly.
  3. Add segments of a selection border by doing one of the following:
    • Click points along the edge.
    • Drag along the edge while pressing the mouse button.
    • The selection border snaps to the edge in the photo. If the border doesn’t snap to the desired edge, click once to add a point manually; then continue tracing the border and clicking points as needed. If you make a mistake, press the Delete key to erase points along the border.
  4. Close the selection border by doing one of the following:
    • To close the border manually, drag back over the starting point and click. A closed circle appears next to the pointer when you are over the starting point.
    • To close the border with a freehand magnetic segment, double-click or press Enter.
    • To close the border with a straight segment, double-click while pressing Alt (Option in Mac OS).

Use the Magic Wand tool

The Magic Wand tool selects pixels within a similar color range with one click. You specify the color range, or tolerance, for the Magic Wand tool’s selection. Use the Magic Wand tool when you have an area of similar colors, like a blue sky.

Magic Wand tool options
Magic Wand tool options

A. Magic Wand tool B. New selection C. Add to selection D. Subtract from selection E. Intersect with selection 
  1. Select the Magic Wand tool.

  2. (Optional) Set Magic Wand tool options in the Tool Options bar:

    • For Tolerance, enter a value between 0 to 255. Enter a low value to select colors very similar to the pixel you click, or enter a higher value to select a broader range of colors.
    • To define a smooth selection edge, select Anti-aliased.
    • To select only adjacent areas using the same colors, select Contiguous. When this option is deselected, pixels using the same colors are selected throughout the entire photo.
    • To select colors using data from all the visible layers, select Sample All Layers. When this option is deselected, the Magic Wand tool selects colors from only the active layer.
  3. In the photo, click the color you want to select.
  4. To add to the selection, Shift+click unselected areas. To remove an area from the selection, press Alt (Option in Mac OS) and click the area you want to remove.
  5. Click Refine Edge to make further adjustments to your selection and make it more precise. See how you can refine the edges of a selection.

Use the Quick Selection tool

The Quick Selection tool makes a selection based on color and texture similarity when you click or click-drag the area you want to select. The mark you make doesn’t need to be precise, because the Quick Selection tool automatically and intuitively creates a border.

Note:

The Smart Brush tool makes selections like the Quick Selection tool and simultaneously applies a color or tonal adjustment. See Apply the Smart Brush tools.

Quick Selection Brush tool
Quick Selection Brush tool options

A. Quick Selection tool B. New selection C. Add to selection D. Subtract from selection 
  1. Select the Quick Selection Brush tool.

  2. In the Tool Options bar, choose one of the following:

    New Selection

    Lets you draw a new selection. This option is selected by default.

    Add To Selection

    Lets you add to an existing selection.

    Subtract From Selection

    Lets you subtract from an existing selection. This option is only available after you make a selection.

  3. Choose a brush from the Brush Picker in the options bar. If you want to select a large area, you can use a larger brush. For more precise selections, choose a smaller brush size.
  4. Click or click-drag over the area that covers the range of colors in the object you want to select, and then release the mouse button.

    The selection border appears.

  5. Do any of the following to refine the selection:
    • To add to the selection, click the Add To Selection button in the options bar, and click or click-drag across the area you want to add.
    • To remove an area from the selection, click the Subtract From Selection button in the options bar, and click or click-drag across the area you want to subtract from the selection.
    • To start a new selection, click the New Selection button in the options bar, and click or draw to specify the new selection area.
  6. Click Refine Edge to make further adjustments to your selection and make it more precise. See how you can refine the edges of a selection.

Use the Selection Brush tool

The Selection Brush tool makes selections two ways: you can paint over the area you want to select in Selection mode, or you can paint over areas you don’t want to select using a semiopaque overlay in Mask mode.

You can first make a rough selection with a marquee tool, Quick Selection tool, or other selection tool, and then fine-tune your selection with the Selection Brush tool. You can add to the selection using the Selection Brush tool in Selection mode, or subtract from it in Mask mode.

Selection Brush tool options
Selection Brush tool options

A. Selection Brush B. Add to selection C. Subtract from selection D. Selection pop-up E. Brush pop-up F. Brush size G. Hardness H. Refine Edge dialog button 
  1. Select the Selection Brush tool from the toolbox. You may need to click the Quick Selection tool in the toolbox and select the Selection Brush from the list of hidden tools that appears.

  2. By default, the tool is set to Add To Selection . To subtract from the selection, click Subtract From Selection  in the options bar.
  3. (Optional) Set Selection Brush tool options in the Tool Options bar:

    • Choose a brush from the brush presets pop‑up panel.
    • Specify the brush size.
    • Choose Selection (to add to the selection) or Mask (to subtract from the selection) from the Mode menu.
    • Set the brush tip’s hardness to a value between 1% and 100%.

    Note:

    If you use a soft-edged brush with the Selection Brush tool, changing the Mode option to Mask can help you see the soft edges of the selection.

    • When using Mask mode, specify an Overlay Opacity between 1% and 100%.
    • When using Mask mode, click the Overlay Color swatch and select a color in the Color Picker to set the mask color. This is useful when the mask color (Overlay Color) is too similar to the colors in the photo.
  4. Draw in your photo to select or deselect areas.
    Selection Brush tool
    Adding to a selection while in Selection mode (left) and subtracting from a selection while in Mask mode (right)

Use the Magic Extractor

Note:

The Magic Extractor feature is not available in Adobe Photoshop Elements 12 and above.

Use the Magic Extractor to make accurate selections based on the appearance of foreground and background areas that you specify. You can specify these areas by placing colored marks in the areas you want to select. After you mark the areas and close the dialog box, only the foreground area appears in the photo.

The Magic Extractor makes it easy to select people or objects so that you can superimpose them on other backgrounds. For example, you can remove yourself from a photo of you on your bicycle at home, and superimpose it on a photo of cyclists in the Tour de France. You can save the extracted image as a file that you can use again and again.

Using the Magic Extractor
Using the Magic Extractor

A. Area you want to extract marked with red dots B. Background marked with blue dots C. Extracted image 
  1. Open the photo containing the object you want to extract.

  2. To limit what appears in the Magic Extractor dialog box, make a preliminary selection using the Oval or Rectangular selection tool.
  3. Choose Image > Magic Extractor.

    The Magic Extractor dialog box opens with the Foreground Brush tool  selected by default.

  4. Click multiple times or draw lines to mark the area you want to extract.
  5. Select the Background Brush tool and click multiple times or draw lines to mark the area that you do not want included in your selection.

    Note:

    When selecting objects with varied colors and textures, drag across all the colors and textures to ensure a more accurate selection.

  6. To help mark your selection, use the Zoom tool or the Hand tool to magnify and navigate around the photo. Press Alt (Option in Mac OS) as you use the Zoom tool to zoom out.

  7. To specify a different brush size or color, do one of the following:
    • Choose a new size from the Brush Size menu.
    • Click the Foreground Color or Background Color swatch, choose a new color in the Color Picker, and then click OK.
  8. Click Preview to see the current selection.
  9. To specify preview settings, do one of the following:
    • To change what is displayed in the preview area, choose either Selection Area or Original Photo from the Display menu. Or press the X key on your keyboard to switch between the two views.
    • To specify a different background, choose an option from the Background menu.
  10. Do any of the following to fine-tune the selection, and then preview the results again:
    • To add to or subtract from the selection, draw more dots or lines using either the Foreground or Background Brush tool.
    • To erase foreground or background dots, select the Point Eraser tool and click or drag over the marks you want to remove.
    • To add areas to a selection, select the Add To Selection tool, and click or drag over the area you want to add.
    • To remove areas from the selection, select the Remove From Selection tool and drag over the areas you want to remove.
    • To smooth the edges of your foreground selection, select the Smoothing Brush tool and drag over the areas you want to smooth.
    • To soften the edges of your selection, specify a higher value in the Feather box.
    • To fill remaining holes in the main selection, click Fill Holes.
    • To separate and remove an area from the main selection, select the Remove From Selection Tool and drag a line between the main selection and the area you want to remove. Then click Fill Holes.
    • To remove fringe colors left between the foreground and background, click Defringe. To increase or decrease the amount of fringe removed, specify a value from the Defringe Width menu.
  11. Click OK to extract the selected areas. If you want to start over, click Reset to remove all marks.

Refine edges of a selection

Refine edge options panel

In Photoshop Elements, you can fine-tune your selection using the Refine Edge (select a portion of an image, right-click the selection, and choose Refine Edge from the context menu) dialog box. You can also open the Refine Edge dialog by choosing Select > Refine Edge.

To open the Refine Edge dialog on a Mac, select a portion of an image, Control-click the selection, and choose Refine Edge.

View Mode. From the View pop-out menu, choose a view mode for your selection. Press F to cycle through the modes

Show Radius. Displays the radius of the edge refinement.

Refine Radius and Erase Refinements tools. Precisely adjust the border area in which edge refinement occurs. To quickly toggle from one tool to the other, press E. To change the brush size, press the bracket keys. Note: Brush over soft areas such as hair or fur, to add fine details to the selection.

Smart Radius. Automatically adjusts the radius for hard and soft edges found in the border region. Deselect this option if the border is uniformly hard- or soft-edged, or if you want to control the Radius setting and refinement brushes more precisely.

Radius. Determines the size of the selection border in which edge refinement occurs. Use a small radius for sharp edges, and a large one for softer edges.

Smooth. Reduces irregular areas (“hills and valleys”) in the selection border to create a smoother outline.

Feather. Blurs the transition between the selection and surrounding pixels.

Contrast. When increased, soft-edged transitions along the selection border become more abrupt.Typically, the Smart Radius option and refinement tools are more effective.

Shift Edge. Moves soft-edged borders inward with negative values or outward with positive ones. Shifting these borders inward can help remove unwanted background colors from selection edges.

Decontaminate Colors. Replaces color fringes with the color of fully selected pixels nearby. The strength of color replacement is proportionate to the softness of selection edges.

Important: Because this option changes pixel color, it requires output to a new layer or document. Retain the original layer so you can revert back to it if needed. (To easily see changes in pixel color, choose Reveal Layer for the View Mode.)

Amount. Changes the level of decontamination and fringe replacement.

Output To. Determines whether the refined selection becomes a selection or mask on the current layer, or produces a new layer or document.

Delete a selected area

When you delete a selection on a background layer, the selected area is replaced with the background color or checkerboard background pattern (transparent pixels).

Do any of the following:

  • Choose Edit > Delete to remove the selection. (If you delete a selection by mistake, you can choose Edit > Undo to get it back.)
  • Press the Backspace or Delete key to remove the selection.
  • Choose Edit > Cut to move the selection to the clipboard. You can then paste it elsewhere.

Select and deselect areas using commands

  1. Do any of the following:

    • To deselect selections, choose Select > Deselect.
    • To select all pixels in a layer, select the layer in the Layers panel and choose Select > All.
    • To reselect the most recent selection, choose Select > Reselect.
  2. To show or hide selection borders, choose View > Selection.

    Note:

    You can also deselect by clicking anywhere in the photo outside the selected area. However, you might accidentally make further selections if you’re using a selection tool that selects based on clicking, such as the Magic Wand tool.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy