Adobe Acrobat PDFMaker(PDFMaker 工具栏/选项卡中的“转换为 Adobe PDF”按钮)是一个可用于从 Microsoft Office 应用程序创建 PDF 文件的加载项。此功能随 Acrobat Professional 和 Standard 一起安装。

  • 在 MS Office 2003 及更低版本中,PDFMaker 使用 Adobe PDF 打印机创建 PostScript 文件。然后,Adobe PDF 打印机结合使用 Adobe Acrobat Distiller 应用程序来创建 PDF 文件。
  • 在 MS Office 200720102016365 中,PDFMaker 使用 AdobePDF 库将 Microsoft Office 文档转换为 PDF。
  • 也可以单独使用 Acrobat Distiller 或 Adobe PDF 打印机来创建 PDF 文件。

此文档可帮助您解决在尝试使用 Acrobat PDFMaker 从 Office 应用程序创建 PDF 文件时发生的问题。尽管此文档特定于 Microsoft Word,但大部分疑难解答步骤也适用于 Microsoft PowerPoint 和 Microsoft Excel。

 

Acrobat Ribbon 在运行于 Windows 上的 Office 2016 或 Office 365 应用程序中不可用

适用于 Office 2016 或 Office 365 版的 Word、Excel 及 PowerPoint

请尝试通过以下步骤解决此问题:

  1. 右键单击 Word 图标,然后选择以管理员身份运行

    如果看到“用户帐户控制”提示,请单击

  2. 通过选择空白文档模板,打开一个空白文档。或者,您可以打开一个现有的 Word 文档。

  3. 在“文件”菜单中,选择选项。此时将显示“Word 选项”对话框。

  4. 在选项列表中选择加载项。在管理下拉菜单中,选择 COM 加载项,然后单击转到

    Word 加载项
  5. 在“COM 加载项”对话框中,如果未选中 Acrobat PDFMaker Office COM 加载项复选框,请选中此复选框,然后单击确定

    PDFMaker Office COM 加载项

PDFMaker 在 Windows 上的 Office 2016 和 Office 365 中使用时崩溃

安装 2 月份的 Office 2016 更新之后,Acrobat PDFMaker 在 Windows 上的 Office 2016 和 Office 365 中使用时会崩溃。

Adobe 正在调查该问题并将与 Microsoft 合作以尽快解决。同时,要创建 PDF,请参阅此处的解决方法。

检查 Acrobat 与 Microsoft Office 的兼容性

在开始解决问题之前,请确保您运行的 Acrobat 版本与运行的 Office 版本兼容。有关详细信息,请参阅兼容的 Web 浏览器和 PDFMaker 应用程序 | Acrobat、Reader

解决 Acrobat Distiller 和 Adobe PDF 打印机问题(仅适用于 MS Office 2003 及更低版本的 PDFMaker)

Acrobat PDFMaker(MS Office 2003 及更低版本)使用 Adobe PDF 打印机,该打印机又使用 Acrobat Distiller 应用程序转换 Word 文档。因此,解决问题的第一步是确定 Acrobat Distiller 是否正常工作:

尝试使用 Adobe PDF 打印机从 Word 创建 PDF 文件

  1. 在 Word 中打开一个文档,然后选择“文件”>“打印”。
  2. 从“打印机名称”菜单中选择“Adobe PDF”,然后单击“确定”。

尝试使用 Acrobat Distiller 应用程序创建 PDF

注意此方法不支持高级 PDFMaker 功能,如保持链接和文档结构。

  1. 打开一个 Word 文档,然后选择“文件”>“打印”。
  2. 在“打印”对话框中,选择一种 PostScript 打印机(例如,Adobe PDF 打印机),再选择“打印到文件”,然后单击“确定”。

    此时将创建 PostScript(.ps 或 .prn)文件。

    注意:如果没有 PostScript 打印机,您可以从 Adobe 网站下载 PostScript 打印机驱动程序。安装驱动程序后,完成步骤 2。如果选择 Adobe PDF 打印机,请取消选择“不将字体发送到‘Adobe PDF’”以创建 PostScript 文件。

  3. 在 Acrobat 中,选择“高级”>“Acrobat Distiller”。
  4. 从“默认设置”列表中选择一个设置(或保留默认值)。
  5. 选择“文件”>“打开”,在“文件类型”菜单中选择“所有文件”,选择您创建的 PS 或 PRN 文件,然后单击“打开”。
  6. 为 PDF 文件指定名称和位置,然后单击“保存”。
    • 如果 Acrobat Distiller 创建了 PDF 文件,请继续执行解决 Acrobat PDFMaker 问题中的步骤。
    • 如果 Acrobat Distiller 未创建 PDF 文件,请继续执行下一个步骤。
  7. 在 Windows(NT、2000、XP、Vista、7)的以下文件夹中打开 messages.log 文件:%AppData%\Adobe\Acrobat\Distiller [版本号]

  8. 在 messages.log 文件中查找用于解决问题的信息:

    • 如果该文件指示了 Acrobat Distiller 未能创建 PDF 文件的原因,则使用 Acrobat 帮助和支持上的搜索文本框搜索相关文档。例如,如果该文件列出了 PostScript 错误,则根据解决 PostScript 错误中的建议解决该错误。
    • 如果该文件未指示 Acrobat Distiller 未能创建 PDF 文件的原因,则创建一个仅包含几个词语的 Word 文档。然后,尝试使用 Adobe PDF 打印机和 Acrobat Distiller 应用程序从该文档创建 PDF 文件:
    • 如果可以从新文档创建 PDF 文件,则表示问题可能与 PDFMaker 有关。接着,继续执行解决 Acrobat PDFMaker 问题中的步骤。
    • 如果无法从新文档创建 PDF 文件,请使用其他应用程序中的文件。然后,尝试使用 Acrobat Distiller 创建 PDF 文件。如果其他应用程序中的文件发生问题,请重新安装 Acrobat Distiller。如果其他应用程序中的文件未发生问题,请使用“相关内容”中列出的文档解决特定的行为。或者,搜索 Acrobat 帮助。如果您需要进一步帮助,请联系 Acrobat 技术支持部门。

解决 Acrobat PDFMaker 问题

如果可以使用 Adobe PDF 打印机或 Acrobat Distiller 创建 PDF 文件,但无法使用 Acrobat PDFMaker 创建 PDF 文件,则表示可能是 Acrobat PDFMaker 功能存在问题。要确定以下任意功能是否为导致问题的原因,请禁用这些功能。然后,尝试创建 PDF 文件:

  1. 在 Word 中,选择“Adobe PDF”>“更改转换设置”。
  2. 从“转换设置”菜单中选择“最小文件大小”。
  3. 单击“Word”选项卡,然后取消选择所有选项。
  4. 单击“书签”选项卡,然后取消选择所有书签选项。
  5. 单击“安全性”选项卡,然后取消选择所有安全性选项。
  6. 单击“确定”。
  7. 尝试创建 PDF 文件:
  • 如果无法创建 PDF 文件,请继续执行解决特定于文档的问题中的步骤。
  • 如果可以创建 PDF 文件,请确定有哪些功能会导致此问题:启用一项功能,然后尝试创建 PDF 文件。重复此过程,直到问题再次出现。然后,创建一个仅包含几个词语的 Word 文档。尝试使用相同的 Acrobat PDFMaker 设置从该文档创建 PDF 文件:
  • 如果可以从新文档创建 PDF 文件,则表示问题是特定于文档的。请继续执行解决特定于文档的问题中的步骤。
  • 如果无法从新文档创建 PDF 文件,则表示最近启用的功能继续导致出现问题。重新安装 Acrobat PDFMaker。如果问题仍然存在,请联系 Acrobat 支持部门

解决特定于文档的问题

如果确定问题是特定于文档的,请按照如下方式解决问题。

仅启用文档所使用的 Acrobat PDFMaker 功能

例如,如果文档仅包含标题样式“标题 1”和“标题 2”,则在“Acrobat PDFMaker”对话框中禁用其他标题样式。

在 Word 中切换到“普通”文档视图,然后使用 Acrobat PDFMaker 创建 PDF 文件

重新创建 Word 文档以消除任何损坏

执行以下任一操作:

  • 复制 Word 文档的内容并将其粘贴到新文档中,然后创建 PDF 文件。
  • 选择文档中的所有文本,更改其字体,然后使用新名称保存文档。Word 会重新写入文档,这样可以消除与 Acrobat PDFMaker 发生冲突的元素。保存文档后,可以使用所需的字体重新设置其格式。
  • 如果创建文档时所用的 Word 版本不同于用来创建 PDF 文件的版本,请对文档进行细微更改。然后,使用新名称保存文档。此过程会强制 Word 重新写入文档,这样或许可以消除与 Acrobat PDFMaker 发生冲突的任何元素。

在文档中重新创建任何自定义标题样式,然后创建 PDF 文件

识别文档中发生冲突的元素

  1. 创建一个 Word 文档。
  2. 将原始 Word 文档的一半内容复制到新 Word 文档中。
  3. 使用 Acrobat PDFMaker 将新 Word 文档转换为 PDF
  • 如果问题再次出现,则表示发生冲突的元素存在于新 Word 文档中。要进一步排查发生冲突的元素,请重复执行步骤 1-3,将第二个 Word 文档的一半内容复制到另一个新 Word 文档中。
  • 如果问题没有出现,则表示发生冲突的元素存在于原始 Word 文档中。要进一步排查问题,请重复执行步骤 1-3,将原始 Word 文档的另一半内容复制到另一个新 Word 文档中。如果文档的这两部分内容均可正常转换,请关闭正在运行的其他程序,包括 Office 应用程序。删除 .tmp 文件(通常位于 Windows/Temp 文件夹中)。

重新安装程序

删除 Acrobat 和 Office 或特定的 Office 应用程序(Word、PowerPoint 或 Excel)。重新安装 Office 或特定的 Office 应用程序,然后重新安装 Acrobat。

要删除 Acrobat,请使用“添加/删除程序”控制面板。有关如何删除 Office 的说明,请参阅 Office 文档或联系 Microsoft。

如果 Word 文档受到保护,请取消保护

有关如何取消保护的说明,请参阅 Word 文档或联系 Microsoft。 

解决与 Microsoft Word 中其他宏的冲突

PDFMaker 可能与其他宏发生冲突,如病毒检查程序或传真软件。如果其他问题解决任务均失败,或者如果 PDFMaker 在安装第三方宏后出现问题,请解决与其他宏的冲突。已知会导致不兼容性的宏包括 Duden Korrektor Plus 2.0、ViaVoice 10 及更低版本、Personal Translator 2002 Office Plus、OfficeReady Stuffit、Leuchter Informatic AG WordPlus 和 GoldMine Link to Word。

要确定 PDFMaker 是否与其他宏发生冲突,请删除或停用其他宏,每次删除或停用一个(请参阅下面的适用链接)。然后,再次尝试使用 PDFMaker 将文档转换为 PDF。如果问题不再出现,请联系该宏的制造商。

解决 Microsoft Word 中的问题

下面的步骤基于 Microsoft 知识库文章:

有关 Microsoft Word 疑难解答的更多详细信息,请访问 Microsoft 网站,并搜索相关的文章。

使用 /a 开关启动 Word 并手动添加 PDFMaker

/a 开关可启动 Word 并防止自动加载加载项和全局模板(包括“Normal”模板)。/a 开关还可锁定设置文件;也就是说,如果使用此开关,则无法读取或修改设置文件。

注意:退出 Word 后,Word 的 /a 开关会话期间对首选项、自定义或宏所做的更改将会丢失。

使用 /a 开关启动 Word:

  1. 退出所有程序。
  2. 选择“开始”>“运行”。
  3. 在“运行”对话框中,键入 winword.exe /a
  4. 单击“确定”。此时将关闭“运行”对话框,并启动 Word。

手动加载 PDFMaker(仅限 Acrobat 6.x):

  1. 退出所有程序。
  2. 选择“工具”>“模板和加载项”。
  3. 选择 PDFMaker.dot(而不是 PDFMakerA.dot),并单击“确定”。

    此时将显示 PDFMaker 图标。

对于 Acrobat 7.x、8.x、9.x、X(如果适用)

手动加载 PDFMaker(MS Word 2003 或更低版本):

  1. 退出所有程序。
  2. 选择“工具”>“自定义”,然后单击“命令”选项卡。
  3. 在“类别”面板中单击“工具”。
  4. 按住鼠标按键,将“COM 加载项”从“命令”面板拖动到“工具”菜单中。在“工具”菜单显示菜单命令时,拖动“自定义”选项正下方的“COM 加载项”,然后松开鼠标按键。
  5. 单击“关闭”。
  6. 单击“工具”菜单上的“COM 加载项”。
  7. 单击“添加”,找到相应的加载项(PDFMaker 加载项位于 [Acrobat 安装路径]\PDFMaker\Office\PDFMOfficeAddIn.dll),然后单击“确定”。

  8. 按 Alt+F11 启动 Visual Basic 编辑器。
  9. 按 Ctrl+G 启动 Visual Basic 编辑器的“立即窗口”。
  10. 要在 Word 中启动 PDFMaker,请键入 Application.COMAddIns("PDFMaker.OfficeAddin").Connect = True。关闭 Visual Basic 编辑器。
  11. 确认 Adobe PDF 菜单现在显示在 Microsoft Word 菜单栏上“帮助”的右侧。

手动加载 PDFMaker(MS Word 2007 和 2010):

  1. 退出所有程序。
  2. 单击 Microsoft Office 按钮,然后单击 Word 选项。

  3. 单击“加载项”。

  4. 在“管理”列表中,单击“COM 加载项”,然后单击“转到”。

  5. 如果“COM 加载项”对话框中列出并选中了 Acrobat PDFMaker COM 加载项,请执行以下操作。否则,请转到步骤 6。

  6. 单击以取消选择 Acrobat PDFMaker COM 加载项复选框。

  7. 单击“确定”以关闭“COM 加载项”对话框。

  8. 重复执行步骤 1 到 3,然后在“COM 加载项”对话框中单击以选中 Acrobat PDFMaker COM 加载项复选框。

  9. 确认 MS Word 功能区中显示 Acrobat 选项卡。

  10. 如果 Acrobat PDFMaker COM 加载项未列在“COM 加载项”对话框中,请执行手动加载 PDFMaker(MS Word 2003 或更低版本)部分中的步骤 7 到 10。

创建测试 Word 文档并启动 PDFMaker:

  1. 在 Word 文档中键入一些文本。
  2. 选择“文件”>“保存”,将测试文档保存到桌面。
  3. 单击“转换为 Adobe PDF”。

如果使用 /a 开关启动 Word 后解决了问题,请删除 Word 启动过程中加载的每个组件。按这些组件在 Word 中出现的顺序删除这些组件,每次删除一个。Word 启动过程中将加载以下组件:

  • Word 自动宏
  • 全局模板 (Normal.dot)
  • 加载项 (WLL)
  • Word Startup 文件夹和 Office Startup 文件夹中的模板
  • COM 加载项
  • Windows 注册表中的 Word 数据键
  • Windows 注册表中的 Word 选项键
  • Word 自动宏

注意:有关其他 Word 启动疑难解答,请参阅以下 Microsoft 产品支持服务:

重命名 Normal.dot 模板文件

有关如何重命名全局模板文件的说明,请参阅 Microsoft 支持文章如何重置 Word 中的用户选项和注册表设置中的“全局模板(Normal.dotm 或 Normal.dot)”部分。向下滚动页面可查看该文章的相应部分。

重要:完成这些步骤后,请不要使用 /a 开关重新启动 Word。

如果重命名全局模板后解决了问题,则表示问题在于损坏的 Normal.dot 模板。有时需要更改多个设置才能恢复您的选项。如果重命名的 Normal.dot 文件包含无法轻松重新创建的自定义设置,如样式、宏或自动图文集项,请尝试使用管理器将这些自定义设置从旧 Normal.dot 文件复制到新 Normal.dot 文件。

有关如何使用管理器的详细信息,请按照以下步骤操作:

  1. 启动 Word。
  2. 选择“帮助”>“Microsoft Word 帮助”。
  3. 在 Office 助手或应答向导中,键入管理器

  4. 单击“搜索”以查看返回的主题。

如果无法解决问题,请考虑使用旧全局模板 (Normal.dot),而不是新全局模板。要使用旧 Normal.dot 模板,请将新 Normal.dot 模板重命名回 Normal.dot。如果使用此文档后仍遇到 PDFMaker 问题,请联系 Acrobat 支持部门

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略