Crear gráficos de datos

Última actualización el 2/11/2026

Usa variables y conjuntos de datos para generar varias versiones de una plantilla con texto e imágenes diferentes.

Los gráficos basados en datos te permiten crear varias variaciones de imagen a partir de una sola plantilla al definir qué elementos cambian y proporcionar el contenido de sustitución mediante conjuntos de datos.

Este flujo de trabajo se aplica cuando necesitas generar varias versiones de un diseño con texto, imágenes o visibilidad de capa variables, como banners web para distintos productos, certificados personalizados o materiales de marketing localizados.La plantilla debe usar capas independientes para cada elemento que quieras variar. Para importar conjuntos de datos desde archivos de texto externos, consulta el artículo relacionado sobre importación de conjuntos de datos.

Photoshop admite tres tipos de variables que controlan distintos aspectos de la plantilla.Las variables de visibilidad controlan si el contenido de la capa es visible.Las variables de reemplazo de texto sustituyen cadenas en las capas de texto.Las variables de reemplazo de píxeles sustituyen los píxeles de la capa por contenido de archivos de imagen.Puedes aplicar varios tipos de variables a una sola plantilla y vincular varias capas a la misma variable para coordinar los cambios.

Definir variables para elementos de la plantilla

Selecciona Imagen > Variables > Definir.

Elige en el menú Capa la capa que contiene el contenido que quieres variar.

Selecciona uno o varios tipos de variables: Visibilidad, Reemplazo de texto o Reemplazo de píxeles.

Introduce un nombre en el campo Nombre usando letras, guiones bajos, dos puntos, puntos o guiones, sin espacios.

Elige un método de escala (Ajustar, Rellenar, Como está o Conformar) para las Variables de reemplazo de píxeles.

Selecciona una posición de alineación y marca Recortar al cuadro delimitador.

Repite la operación con más capas y, a continuación, selecciona OK.

Las capas que contienen variables muestran un asterisco junto a su nombre en el cuadro de diálogo.Para cambiar el nombre de una Variable, vuelva a Imagen > Variables > Definir, seleccione la capa e introduzca un nombre nuevo en el campo Nombre.Para vincular varias capas a la misma Variable, elige un nombre de Variable existente en el menú desplegable Nombre al definir Variables para capas adicionales.

Crear y administrar conjuntos de datos

Seleccione Imagen > Variables > Conjuntos de datos.

Seleccione el icono de nuevo conjunto de datos para crear un conjunto de datos basado en los valores actuales.

Elija una variable en el menú Nombre.

Edite los datos de la variable:

  • Para las variables de Visibilidad: seleccione Visible o Invisible
  • Para las variables de Sustitución de píxeles: seleccione Archivo y elija la imagen de sustitución
  • Para las variables de Sustitución de texto: introduzca el texto en el campo Valor.

Repita este paso para cada variable del conjunto de datos.

Cree conjuntos de datos adicionales para cada variación de diseño que necesite.

Seleccione Aceptar cuando haya terminado.

Para ver una vista previa de cómo afecta cada conjunto de datos a tu diseño, ve a Imagen > Aplicar conjunto de datos, elige un conjunto de datos de la lista y selecciona Aplicar.También puedes marcar la casilla Vista previa en el cuadro de diálogo Conjuntos de datos para ver los cambios sin cerrar el cuadro de diálogo.

Utilice los iconos de flecha del cuadro de diálogo Conjuntos de datos para desplazarse entre los conjuntos de datos. Para modificar un conjunto de datos existente, selecciónelo en el menú Conjunto de datos y edite los valores de las variables. Para eliminar un conjunto de datos, selecciónelo y elija el icono de eliminar.

Generar archivos de salida a partir de conjuntos de datos

Seleccione Archivo > Exportar > Conjuntos de datos como archivos.

Introduzca un nombre base para los archivos generados en el campo de nomenclatura.

Seleccione Carpeta y elija un directorio de destino.

Elija en la lista los conjuntos de datos que desea exportar.

Seleccione Aceptar para generar los archivos.

Photoshop crea archivos PSD independientes para cada conjunto de datos, combinando el nombre base con el nombre del conjunto de datos. Cada archivo contiene la plantilla con los valores del conjunto de datos aplicados.

Si aplica un conjunto de datos directamente a la plantilla (Imagen > Aplicar conjunto de datos), se sobrescribe el documento original. Trabaje siempre en una copia o exporte los conjuntos de datos como archivos.