A Generator hiba javítása az Adobe Photoshop indításakor

Utoljára frissítve: 2026. okt. 29.

Ismerje meg, hogyan javíthatja ki a Generator hibát az Adobe Photoshopban a biztonsági beállítások ellenőrzésével, az ütköző beépülő modulok eltávolításával és a naplók átnézésével.

A Generator egy Node.js alkalmazás, amely a Photoshop és a Generator beépülő modulok közötti kommunikációt kezeli. Ez biztosítja az eszközlétrehozási logikát a Exportálás másként és a Image Assets funkciókhoz.

Amikor elindítja a Photoshopot, vagy kiválasztja a Fájl > Exportálás > Exportálás másként parancsot, megjelenik egy párbeszédpanel, amely ezt írja: „Probléma van a Generatorral. Lépjen ki a Photoshop programból, és próbálkozzon újra. Ha a probléma továbbra is fennáll, távolítsa el a külső beépülő modulokat, vagy telepítse újra a Photoshopot.”

Próbálja ki az alábbi megoldásokat az itt megadott sorrendben.

A biztonsági szoftver blokkolja a Generatort

A biztonsági vagy vírusvédelmi szoftver blokkolhatja a Generator kommunikációját a 8010-es porton, vagy megakadályozhatja a node folyamat futását.

Nyissa meg a biztonsági vagy vírusvédelmi beállításokat.

Adja hozzá a Photoshop alkalmazást az engedélyezett alkalmazások listájához.

Győződjön meg arról, hogy a 8010-es port nyitva van a Generator számára.

Windows esetén adja hozzá a node.exe fájlt az engedélyezett alkalmazások listájához itt: C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe.

macOS esetén engedélyezze a node folyamatot itt: /Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node.

Windows esetén engedélyezze, hogy a Photoshop hozzáférjen az ellenőrzött mappákhoz.

Indítsa újra a Photoshopot, majd válassza a Fájl > Exportálás > Exportálás másként parancsot a Generator teszteléséhez.

Egy külső beépülő modul ütközik a Generatorral

A Photoshop Generator mappájában található külső beépülő modulok nem kompatibilisek lehetnek a jelenlegi verzióval, vagy ütközhetnek az alapértelmezett Image Assets beépülő modullal.

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

Hozzon létre egy ideiglenes mappát az asztalon Disabled Generator Plug-ins néven.

Helyezze át a külső beépülő modul mappákat az ideiglenes mappába.Hagyja az alapértelmezett Image Assets beépülő modult a Generator mappában.

Indítsa el a Photoshopot, és válassza a Fájl > Exportálás > Exportálás másként parancsot.

Ha a hiba megszűnt, adja vissza a beépülő modulokat egyenként, és minden hozzáadás után indítsa újra a Photoshopot, amíg a hiba ismét meg nem jelenik.

Hagyja meg az alapértelmezett Image Assets beépülő modult a Generator mappában. Csak az önállóan telepített beépülő modulokat helyezze át.

A generátor nem indul el, és nincs rá szüksége

Ha nem használja az Exportálás másként vagy az Image Assets funkciót, megoldásként kapcsolja ki a Generator funkciót.

Indítsa el a Photoshop alkalmazást.

Windows rendszeren válassza a Szerkesztés > Beállítások > Beépülő modulok lehetőséget. macOS rendszeren válassza a Photoshop > Beállítások > Beépülő modulok lehetőséget.

Törölje a jelölést a Generátor engedélyezése jelölőnégyzetből.

Válassza az OK lehetőséget, majd indítsa újra a Photoshopot.

A Fájl > Exportálás > Exportálás másként lehetőség kiválasztása ismét bekapcsolja a Generator funkciót. Ha szüksége van az Exportálás másként funkcióra, oldja meg a Generator hibáját, ne hagyja kikapcsolva a Generator funkciót.

A Generator naplói indítási hibákat jelenítenek meg

A Generator naplói tartalmazhatnak információt a betöltési hibát okozó beépülő modulokról, illetve a Generator indítását akadályozó rendszerproblémákról.

Windows rendszeren navigáljon a C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator helyre.

macOS rendszeren navigáljon a /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator helyre.

Nyissa meg a legújabb Generator naplót, és keressen hibaüzeneteket.

Ha a Generator mappa nem létezik, ellenőrizze, hogy van-e írási jogosultsága a szülőmappához.

Ha további segítségre van szüksége, a diagnosztikai naplók összegyűjtéséhez használja az Adobe Log Collector Tool eszközt.

A Windows AppData és a macOS Library mappák alapértelmezés szerint rejtve vannak. A Rejtett fájlok és mappák megjelenítése Windows rendszeren útmutató segíthet megtalálni a Windows naplókat.

Generátor-hibák lépnek fel Apple Silicon rendszeren

Ha a generátor továbbra sem indul el Apple Silicon processzoros Mac gépen, a Photoshop Rosettával való futtatása segíthet meghatározni, hogy a problémát a natív módú kompatibilitás okozza-e.

Lépjen ki a Photoshopból.

A Finder programban nyissa meg az Alkalmazások mappát, és keresse meg az Adobe Photoshopot.

Control gombot lenyomva kattintson az Adobe Photoshopra, majd válassza a Get Info lehetőséget.

Válassza a Megnyitás Rosetta használatával lehetőséget, majd indítsa el a Photoshopot, és tesztelje a Generator funkciót.

Ha a hiba továbbra is fennáll, az Adobe ügyfélszolgálatának segítségkéréskor adja meg a Generator naplóit. A Generátorhoz nem kapcsolódó Exportálás másként problémák esetén használja az exportálási és mentési műveletekre vonatkozó hibaelhárítási útmutatót.