Eine Tabelle besteht aus in Zeilen und Spalten angeordneten Zellen. Eine Zelle ist vergleichbar mit einem Textrahmen, in den Sie Text, verankerte Rahmen oder andere Tabellen einfügen können. Erstellen Sie Tabellen in Adobe InDesign CS5 oder exportieren Sie sie aus anderen Anwendungen.

Hinweis:

Stellen Sie sicher, dass Sie sich in der Layoutansicht befinden, um Tabellen in Adobe InCopy zu erstellen, zu bearbeiten und zu formatieren.

Erstellung von Tabellen

Eine Tabelle besteht aus in Zeilen und Spalten angeordneten Zellen. Eine Zelle ist vergleichbar mit einem Textrahmen, in den Sie Text, eingebundene Grafiken oder andere Tabellen einfügen können. Sie können Tabellen vollständig neu erstellen oder vorhandenen Text in eine Tabelle konvertieren. Sie können auch eine Tabelle in eine Tabelle einbetten.

Wenn Sie eine Tabelle erstellen, nimmt die neue Tabelle die Breite des Textrahmens ein, in dem sie enthalten ist. Befindet sich die Einfügemarke am Anfang einer Zeile, wird die Tabelle in derselben Zeile eingefügt. Steht die Einfügemarke mitten in einer Zeile, wird die Tabelle in der nächsten Zeile eingefügt.

Tabellen fließen genau wie eingebundene Grafiken mit dem umgebenden Text. Eine Tabelle wird z. B. durch verkettete Rahmen bewegt, wenn die Punktgröße des Textes über der Tabelle verändert oder Text eingefügt oder gelöscht wird. Eine Tabelle kann jedoch nicht in einen Text-auf-Pfad-Rahmen gesetzt werden.

Der Artikel Mind Your Table Manners von Michael Murphy enthält Informationen zum Erstellen und Formatieren von Tabellen.

Jeff Witchel von InfiniteSkills.com bietet ein Video-Tutorial an unter: Die Grundlagen des Tabellenerstellens.

Erstellen einer neuen Tabelle

Wenn Sie eine Tabelle in InDesign erstellen, haben Sie die Möglichkeit, die Tabelle in einem vorhandenen Textrahmen zu erstellen (Verwenden der Option „Tabelle einfügen“). Alternativ können Sie eine Tabelle erstellen und zulassen, dass InDesign den umgebenden Textrahmen erstellt (Verwenden der Option „Tabelle erstellen“).

Verwenden der Option „Tabelle einfügen“

  1. Verwenden Sie das Text-Werkzeug, um eine Tabelle in einem vorhandenen Textrahmen zu zeichnen, und platzieren Sie die Einfügemarke an der Stelle, an der die Tabelle angezeigt werden soll.

  2. Wählen Sie „Tabelle“ > „Tabelle einfügen“.

    Hinweis:

    Wenn sich der Cursor gerade nicht in einem Textrahmen befindet, ist die Option „Tabelle erstellen“ verfügbar.

  3. Geben Sie die Zeilen- und Spaltenanzahl an.
  4. Wenn für den Tabelleninhalt mehrere Spalten oder Rahmen erforderlich sind, geben Sie an, in wie vielen Tabellenkopf- und -fußzeilen die Informationen wiederholt werden sollen.
  5. (Optional) Geben Sie ein Tabellenformat an.
  6. Klicken Sie auf „OK“.

    Die neue Tabelle füllt die gesamte Breite des Textrahmens.

Verwenden der Option „Tabelle erstellen“

Wenn Sie zum Erstellen einer Tabelle die Option „Tabelle erstellen“ verwenden, ist es nicht erforderlich, zuerst einen Textrahmen im Dokument zu erstellen. Wenn Sie die Tabelle im Dokument zeichnen, erstellt InDesign einen Textrahmen in der Größe der Tabelle, die Sie zeichnen.

  1. Wählen Sie „Tabelle“ > „Tabelle erstellen“.

    Hinweis:

    Wenn sich der Cursor gerade in einem Textrahmen befindet, ist die Option „Tabelle einfügen“ verfügbar.

  2. Geben Sie die Zeilen- und Spaltenanzahl an.
  3. Wenn für den Tabelleninhalt mehrere Spalten oder Rahmen erforderlich sind, geben Sie an, in wie vielen Tabellenkopf- und -fußzeilen die Informationen wiederholt werden sollen.
  4. (Optional) Geben Sie ein Tabellenformat an.
  5. Klicken Sie auf „OK“.
  6. Verwenden Sie den Tabellencursor, um die Tabelle zu zeichnen, die Sie benötigen.

    InDesign erstellt einen Textrahmen in der Größe des gezogenen Bereichs und platziert die Tabelle innerhalb des Textrahmens.

Die Zeilenhöhe einer Tabelle wird aus dem angegebenen Tabellenformat ermittelt. Mit einem Tabellenformat werden beispielsweise anhand der Zellenformate verschiedene Bereiche der Tabelle formatiert. Wenn eines der Zellenformate Absatzformate enthält, bestimmt der Wert „Zeilenabstand“ im Absatzformat die Zeilenhöhe für diesen Bereich. Wenn kein Absatzformat angewendet wurde, bestimmt die Schriftzeilenhöhe des Dokuments die Zeilenhöhe. (Die Schriftzeilenhöhe basiert auf dem Zeilenabstandswert. Hierbei entspricht die Schriftzeilenhöhe ungefähr der Höhe der Markierung bei ausgewähltem Text.)

Erstellung von Tabellen aus vorhandenem Text

Achten Sie vor dem Konvertieren von Text in eine Tabelle darauf, dass Sie den Text korrekt eingestellt haben.

  1. Bereiten Sie den Text vor, indem Sie Tabulatoren, Kommata, Absatzumbrüche oder andere Zeichen einfügen, um den Wechsel zu einer neuen Spalte zu kennzeichnen. Fügen Sie Tabulatoren, Kommata, Absatzumbrüche oder andere Zeichen ein, um den Wechsel zu einer neuen Zeilen zu kennzeichnen. (In vielen Fällen kann Text ohne vorherige Bearbeitung in eine Tabelle konvertiert werden.)
  2. Wählen Sie das Textwerkzeug  aus und markieren Sie den Text, der in eine Tabelle konvertiert werden soll.
  3. Wählen Sie „Tabelle“ > „Text in Tabelle umwandeln“.
  4. Geben Sie unter „Spaltentrennzeichen“ und „Zeilentrennzeichen“ an, wo neue Zeilen und Spalten beginnen sollen. Wählen Sie „Tabulator“, „Komma“ oder „Absatz“ oder geben Sie in die beiden Felder „Spaltentrennzeichen“ und „Zeilentrennzeichen“ das gewünschte Zeichen ein (z. B. ein Semikolon (;)). (Das von Ihnen eingegebene Zeichen wird das nächste Mal, wenn Sie Text in eine Tabelle konvertieren, im Menü angezeigt.)
  5. Wenn Sie für Spalten und Zeilen dasselbe Trennzeichen eingeben, legen Sie die gewünschte Spaltenanzahl für die Tabelle fest.
  6. Legen Sie ein Tabellenformat fest, um die Tabelle zu formatieren (optional).
  7. Klicken Sie auf „OK“.

Wenn die Anzahl der Elemente in einer Zeile kleiner ist als die Anzahl der Spalten in einer Tabelle, wird die Zeile mit leeren Zellen aufgefüllt.

Einbetten einer Tabelle in eine andere Tabelle

  1. Führen Sie einen der folgenden Schritte durch:
    • Wählen Sie die Zellen oder die Tabelle aus, die Sie einbetten möchten, und klicken Sie dann auf „Bearbeiten“ > „Ausschneiden“ oder „Bearbeiten“ > „Kopieren“. Setzen Sie die Einfügemarke in die Zelle, in der die Tabelle angelegt werden soll, und wählen Sie dann „Bearbeiten“ > „Einfügen“.

    • Klicken Sie in eine Zelle, wählen Sie „Tabelle“ > „Tabelle einfügen“, legen Sie die Anzahl der Zeilen und Spalten fest und klicken Sie auf „OK“.

  2. Korrigieren Sie ggf. den Zellversatz. (Siehe Formatieren von Text in einer Tabelle.)

Wenn Sie eine Tabelle in einer Zelle erstellen, kann kein Teil der Tabelle, der über die Zellgrenzen hinausläuft, mit der Maus ausgewählt werden. Erweitern Sie stattdessen die Zeile oder Spalte oder platzieren Sie die Einfügemarke in den ersten Teil der Tabelle und verwenden Sie Tastaturbefehle zum Verschieben der Einfügemarke und Auswählen von Text.

Importieren von Tabellen aus anderen Anwendungen

Wenn Sie mit dem Befehl „Platzieren“ ein Microsoft Word-Dokument mit einer Tabelle oder eine Microsoft Excel-Tabelle importieren, befinden sich die importierten Daten in einer bearbeitbaren Tabelle. Im Dialogfeld „Importoptionen“ können Sie die Formatierung einstellen.

Alternativ können Sie Daten aus einer Excel- oder Word-Tabelle per Kopieren und Einfügen ein InDesign- oder InCopy-Dokument einfügen. Mit den Voreinstellungen unter „Zwischenablageoptionen“ können Sie bestimmen, wie aus einer anderen Anwendung eingefügter Text formatiert wird. Wenn „Nur Text“ gewählt wurde, werden die Daten als nicht formatierter, tabulatorgetrennter Text angezeigt, den Sie dann in eine Tabelle konvertieren können. Wenn „Alle Informationen“ ausgewählt wurde, wird der eingefügte Text als formatierte Tabelle angezeigt.

Wenn Sie Text aus einer anderen Anwendung in eine vorhandene Tabelle einfügen, müssen Sie für den einzufügenden Text ausreichend Zeilen und Spalten erstellen. Wählen Sie dann unter „Voreinstellungen“ > „Zwischenablageoptionen“ die Option „Nur Text“ und vergewissern Sie sich, dass mindestens eine Zelle ausgewählt ist. (Es sei denn, Sie möchten die eingefügte Tabelle in eine Zelle einbetten.)

Wenn Sie mehr Kontrolle über die Formatierung der importierten Tabelle haben möchten oder wenn Sie die Formatierung der Kalkulationstabelle erhalten möchten, verwenden Sie zum Importieren der Tabelle den Befehl „Platzieren“. Wenn Sie eine Verknüpfung zur Tabelle aufrecht erhalten möchten, wählen Sie unter „Voreinstellungen“ > „Dateihandhabung“ die Option „Beim Platzieren von Text- und Tabellendateien Verknüpfungen erstellen“.

Hinweis:

Sie können Text mit Tabulatoren auch über eine Auswahl an Tabellenzellen hinweg kopieren und einfügen. Auf diese Weise können Sie mühelos Inhalte ersetzen, während die Formatierung beibehalten wird. Beispiel: Sie möchten den Inhalt einer formatierten Tabelle in einer monatlich erscheinenden Zeitschrift aktualisieren. Zum einen können Sie eine Verknüpfung zu einer Excel-Datei erstellen. Wenn Ihr Inhalt jedoch verschiedene Ursprünge hat, können Sie den tabulatorgetrennten Text, der den neuen Inhalt umfasst, kopieren, den gewünschten Zellenbereich in der formatierten InDesign-Tabelle auswählen und den Text einfügen.

Einfügen von Text in eine Tabelle

Sie können Tabellenzellen Text, verankerte Objekte, XML-Tags und andere Tabellen hinzufügen. Die Höhe einer Tabellenzeile wird vergrößert, um zusätzliche Textzeilen aufzunehmen, sofern Sie nicht eine feste Zeilenhöhe eingestellt haben. Sie können einer Tabelle keine Fußnoten hinzufügen.

  1. Wählen Sie das Textwerkzeug  aus und führen Sie einen der folgenden Schritte durch:
    • Setzen Sie die Einfügemarke in eine Zelle und geben Sie Text ein. Drücken Sie die Eingabetaste bzw. den Zeilenschalter, um einen neuen Absatz in derselben Zelle zu erstellen. Drücken Sie die Tabulatortaste, um durch Zellen nach vorn zu navigieren (durch Drücken der Tabulatortaste in der letzten Zelle wird eine neue Zeile eingefügt). Drücken Sie Umschalt + Tab, um durch Zellen nach hinten zu navigieren.

    • Kopieren Sie Text, setzen Sie die Einfügemarke in eine Zelle und wählen Sie dann „Bearbeiten“ > „Einfügen“.

    • Setzen Sie die Einfügemarke in eine Zelle, in die Sie Text einfügen möchten, wählen Sie „Datei“ > „Platzieren“ und doppelklicken Sie auf eine Textdatei.

Einfügen von Grafiken in eine Tabelle

  1. Setzen Sie die Einfügemarke in die Zelle, in die Sie das Bild einfügen möchten.

  2. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie „Datei“ > „Platzieren“ und wählen Sie eine oder mehr Grafikdateien aus.
    • Wählen Sie eine oder mehrere Grafiken aus der Kategorie „Grafiken“ im CC Libraries-Bedienfeld aus und legen Sie sie per Drag & Drop ab.

    Das Bild bzw. die Bilder sind über das Platzierungswerkzeug verfügbar.

  3. Klicken Sie in die jeweilige Tabellenzelle, um das Bild bzw. die Bilder zu platzieren.

  4. Führen Sie einen der folgenden Schritte aus:

Hinweis:

Sie können InDesign-Snippets nicht per Drag & Drop aus der Kategorie „Grafiken“ in das CC Libraries-Bedienfeld verschieben.

Wenn Sie eine Grafik einfügen, die größer als die Zelle ist, wird die Zellenhöhe vergrößert, um die Grafik aufzunehmen, die Zellenbreite ändert sich jedoch nicht. Die Grafik kann über den rechten Rand der Zelle hinausragen. Wenn die Zeile, in der die Grafik platziert wird, auf eine feste Höhe eingestellt ist, führt eine Grafik, die höher ist als die Zeile, zu Übersatz.

Hinweis:

Wenn Sie ein Bild außerhalb der Tabelle platzieren, die Größe des Bildes ändern und es anschließend in die Tabellenzelle einfügen, können Sie das Auftreten von Übersatzzellen verhindern.

Sie können mit den folgenden Methoden Bilder in Tabellenzellen platzieren:

  • Wählen Sie „Objekt“ > „Verankertes Objekt“ > „Einfügen“ aus und geben Sie die Einstellungen an. Sie können dem verankerten Objekt zu einem späteren Zeitpunkt eine Grafik hinzufügen.
  • Kopieren Sie eine Grafik oder einen Rahmen, setzen Sie die Einfügemarke an die gewünschte Stelle und wählen Sie „Bearbeiten“ > „Einfügen“.

Hinzufügen von Tabellenkopf- und -fußzeilen

Eine lange Tabelle kann sich über mehrere Spalten, Rahmen oder Seiten erstrecken. Mithilfe von Tabellenkopf- oder -fußzeilen können Sie bestimmte Informationen am Anfang und Ende jedes Tabellenteils wiederholen.

Kopf- und Fußzeilen können beim Erstellen der Tabelle eingefügt werden. Sie können sie auch mit dem Dialogfeld „Tabellenoptionen“ anlegen und ihr Erscheinungsbild ändern. Ferner lassen sich Tabellenkörperzellen in Kopf- oder Fußzeilen konvertieren.

Hinzufügen von Tabellenkopf- und -fußzeilen
Tabellenkopfzeile in jedem Rahmen einmal wiederholt

Hinweis:

Sie können Tabellen durchgehend nummerieren, z. B. Tabelle 1A, Tabelle 1B, indem Sie der Tabellenkopfzeile bzw. -fußzeile eine entsprechende Variable hinzufügen. (Siehe Erstellen von fortlaufenden Beschriftungen für Abbildungen und Tabellen.)

  1. Wählen Sie die Zeilen am oberen Tabellenrand aus, um Tabellenkopfzeilen zu erstellen bzw. die Zeilen am unteren Tabellenrand, um Tabellenfußzeilen zu erstellen.
  2. Wählen Sie „Tabelle“ > „Zeilen umwandeln“ > „In Tabellenkopf“ oder „In Tabellenfuß“.
  1. Setzen Sie die Einfügemarke in die Tabelle und wählen Sie dann „Tabelle“ > „Tabellenoptionen“ > „Tabellenkopf und -fuß“.
  2. Geben Sie die Anzahl der Tabellenkopf- oder -fußzeilen an. Am Anfang oder Ende der Tabelle können leere Zeilen eingefügt werden.
  3. Geben Sie an, ob die Informationen in der Tabellenkopf- oder -fußzeile in jeder Textspalte (falls Textrahmen mehrere Spalten haben), einmal pro Rahmen oder nur einmal pro Seite erscheinen sollen.
  4. Wählen Sie „Überspringen: Erste(n)“, wenn die Tabellenkopfzeilen-Informationen nicht in der ersten Zeile der Tabelle angezeigt werden sollen. Wählen Sie „Überspringen: Letzte(n)“, wenn die Tabellenfußzeilen-Informationen nicht in der letzten Zeile der Tabelle erscheinen sollen.

    Die Option „Erste überspringen“ ist vor allem dann nützlich, wenn Sie angeben möchten, dass die Kopf- oder Fußzeile fortgesetzt wird. Für eine Tabelle, die sich über mehrere Seiten erstreckt, soll der Kopfzeilentext beispielsweise „Tabelle 2 (Fortsetzung)“ lauten. Da „(Fortsetzung)“ nicht zu Beginn der Tabelle angezeigt werden soll, wählen Sie „Erste überspringen“ und geben Sie in die erste Zeile der Tabelle Tabelle 2 ein.

  5. Klicken Sie auf „OK“.

Sie können mehrere Aufgaben ausführen, um ähnliche Zeilen und Spalten zu erstellen oder zu duplizieren. 

Vor allem können Sie folgende Aufgaben für Zeilen und Spalten der Tabelle ausführen:

  • Ziehen und Ablegen von Tabellenzeilen und -spalten von einer Position zu einer anderen in derselben Tabelle
  • Duplizieren von Zeilen und Spalten
  • Einfügen von Zeilen und Spalten vor oder nach einer anderen Zeile/Spalte
  • Kopieren des Inhalts einer Zeile in eine Spalte oder einer Spalte in eine Zeile

Ziehen und Ablegen und Duplizieren von Zeilen/Spalten

Sie können Tabellenzeilen und -spalten von einer Position zu einer anderen in derselben Tabelle verschieben. Führen Sie folgende Schritte aus, um Zeilen/Spalten zu ziehen und abzulegen und zu duplizieren.

  1. Wählen Sie die Zeile bzw. Spalte aus, die Sie einer anderen Zeile bzw. Spalte durch Ziehen und Ablegen hinzufügen möchten. Stellen Sie sicher, dass die gesamte Spalte oder Zeile ausgewählt ist. Teilweise ausgewählte Zeilen oder Spalten können nicht durch Ziehen und Ablegen bewegt werden.

  2. Halten Sie den Mauszeiger über die ausgewählten Zeilen und ein spezieller Cursor erscheint, der anzeigt, dass die Auswahl verschoben werden kann.

  3. Die Elementzeile kann nun gezogen und abgelegt werden. Sie können Spalten und Zeilen austauschen. Eine gezogene Zeile wird nur als Zeile abgelegt und eine gezogene Spalte wird nur als Spalte abgelegt.

    Ziehen und Ablegen von Zeilen und Spalten
    Ziehen und Ablegen von Zeilen und Spalten

    Wenn Sie hier eine Zeile von einem Ort an einen anderen verschieben, bleibt die Gesamtzahl an Zeilen gleich – nur drei.

    Hinweis:

    Ziehen und Ablegen ist nur innerhalb derselben Tabelle möglich.

  4. Um eine Zeile oder Spalte zu duplizieren, drücken Sie die Alt- (Windows) bzw. Wahltaste (Mac), nachdem Sie die Zeile oder Spalte ausgewählt haben. Mehrere fortlaufend ausgewählte Zeilen oder Spalten können gleichzeitig gezogen und abgelegt werden.

  5. Ziehen Sie die ausgewählte Zeile oder Spalte an die gewünschte Stelle und legen Sie sie ab. Die Gesamtzahl der Zeilen oder Spalten erhöht sich, da das ausgewählte Element dupliziert wurde.

    Sie können den Inhalt der Kopf- und Fußzeilen auch in Tabellenkörperzeilen kopieren (indem Sie die Alt- bzw. Wahltaste drücken). Genauso können Textzeilen ebenfalls dupliziert und in Kopf- und Fußzeilen umgewandelt werden.

Sie können Tabellenkopfzeilen nur innerhalb der Kopfzeile ziehen und ablegen (nur anwendbar, wenn mehrere Kopfzeilen vorhanden sind), es sei denn, Sie verwenden die Alt-/Wahltaste zum Duplizieren der Zeilen. Textzeilen können nur in den Kopfzeilenbereich gezogen werden, wenn die Alt-/Wahltaste zum Duplizieren der Zeilen verwendet wird.

Kopieren von Zeilen/Spalten und Einfügen vor/nach

Sie können Zeilen vor oder nach einer ausgewählten Zeile einfügen. Über den Arbeitsablauf „Einfügen vor/nach“ können Sie auch Zeilen/Spalten aus einer Tabelle kopieren und sie in einer anderen Tabelle einfügen.

  1. Wählen Sie eine Zeile oder eine Spalte aus.

  2. Wählen Sie die Spalte oder Zeile aus.

  3. Wählen Sie „Tabelle“ > „Einfügen vor/Einfügen nach“ aus. 

  1. Führen Sie einen der folgenden Schritte aus:
    • Setzen Sie die Einfügemarke in die Tabellenkopf- oder -fußzeile und wählen Sie „Tabelle“ > „Zeilen umwandeln“ > „In Tabellenkörper“.

    • Wählen Sie „Tabelle“ > „Tabellenoptionen“ > „Tabellenkopf und -fuß“ und geben Sie eine andere Anzahl von Tabellenkopf- und -fußzeilen an.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie