Verwalten von Projekten

Erfahren Sie, wie Sie in RoboHelp auf Projekte zugreifen, sie speichern und zusammenführen können.

Projekteinstellungen

Um das Dialogfeld Projekteinstellungen zu starten, klicken Sie auf Datei > Projekteinstellungen.

Allgemein

  • Titel: Geben Sie einen Projekttitel ein. Dieser Titel erscheint in der Titelleiste des Ausgabefensters.
  • Sprache: Wählen Sie die Standardprojektsprache.
  • Standard-Stylesheet: Wählen Sie das Stylesheet aus, das für das Projekt verwendet werden soll. Sie können die Stile jedoch mithilfe von Inline- und internen Stylesheets überschreiben.
  • Standard-Word-Importeinstellungen: Wählen Sie die Word-Einstellungsdatei aus, die das Projekt verwendet, wenn es in Microsoft Word veröffentlicht wird.
  • Standard-FrameMaker-Importeinstellungen: Wählen Sie die FrameMakerSettings-Datei aus, die das Projekt verwendet, wenn es in Adobe FrameMaker veröffentlicht wird.
  • Inlineformatierung nicht zulassen: Wenn Sie diese Option aktivieren, werden alle Textformatierungseigenschaften im Bereich „Inhalteigenschaften“ eines Themas im Authoring-Modus deaktiviert.
  • Erweiterte HTML-Hilfeoptionen aktivieren: Aktivieren Sie diese Option, um die Inhaltsverzeichnissymbole für die CHM-Ausgabe anzupassen.

Themenstatus

Fügen Sie einen neuen Status für ein Thema hinzu.Es ist bereits eine Reihe von Status vorhanden. Um einen neuen Status hinzuzufügen, geben Sie den Namen ein und klicken Sie auf das Symbol +.

Farben

Legen Sie Farben für Schriften, Rahmen, Hintergründe usw. fest.Um eine neue Farbe hinzuzufügen, geben Sie den Namen ein und klicken Sie auf das Symbol +.

Wenn Sie ein Upgrade von der Classic-Version durchführen, werden die Farben angezeigt, die Sie zuvor definiert haben.

Tag-Gruppen

Fügen Sie benutzerdefinierte Tags hinzu, die Sie zum Erstellen von bedingtem Inhalt verwenden möchten.Um ein neues Tag hinzuzufügen, geben Sie den Namen ein und klicken Sie auf das Symbol +.

Schriftenliste

Fügen Sie die Schriften hinzu, z. B. Arial, Tahoma, sodass nur die Schriften, die Sie hinzugefügt haben, in der Liste der Schriftarten unter Inhaltseigenschaften > Schrift angezeigt werden. Wenn Sie eine Schrift falsch schreiben und dann hinzufügen, wird die falsch geschriebene Schrift in der Liste der Schriften angezeigt. Wenn Sie jedoch die falsch geschriebene Schrift auf einen Text anwenden, wird die Schrift auf die Standard-Browserschrift Times New Roman zurückgesetzt.Sie können auch mehrere Schriften in einer durch Kommas getrennten Liste hinzufügen.

Fenster

Aktivieren oder deaktivieren Sie die Bereiche, die Sie verwenden möchten. Wenn Sie einen Bereich nicht benötigen, deaktivieren Sie ihn.

Öffnen eines Projekts

Sie können auf Ihre Projekte in RoboHelp über den Startbildschirm zugreifen oder das Menü Datei verwenden.

Startbildschirm

Wenn Sie RoboHelp starten, ist der erste angezeigte Bildschirm der Startbildschirm. Auf diesem Bildschirm können Sie auf Ihre zuletzt bearbeiteten Projekte im Abschnitt Aktuelle zugreifen. RoboHelp zeigt bis zu zwei aktuelle Projekte an. Klicken Sie einfach auf eines der angezeigten Projekte, um es zu öffnen und beginnen Sie damit zu arbeiten.

Sie können ein Projekt auch aus dem Abschnitt aktuelle anheften, lösen oder entfernen:

  • Um ein Projekt anzuheften, bewegen Sie den Mauszeiger über den gewünschten Projektnamen und klicken Sie auf das Symbol . Ihre angehefteten Projekte erscheinen oben in der Liste Aktuelle
  • Um ein Projekt zu lösen, klicken Sie einfach auf das Symbol
  • Um ein Projekt aus der Liste Aktuelle zu entfernen, bewegen Sie den Mauszeiger über den gewünschten Projektnamen und klicken Sie auf das Symbol.

Dateimenü

Führen Sie einen der folgenden Schritte aus, um auf Ihr Projekt zuzugreifen:

  • Wählen Sie Datei > Aktuelle Projekte , wählen Sie Ihr gewünschtes Projekt und klicken Sie auf Öffnen.
  • Um ein kürzlich bearbeitetes Projekt zu öffnen, wählen Sie Datei > Aktuelle Projekte und wählen Sie Ihr gewünschtes Projekt.
  • Um ein Projekt von RoboHelp Classic zu öffnen, wählen Sie Datei > Upgrade von RoboHelp Classic Project. Sie können dann Ihr gewünschtes Projekt auswählen und auf Öffnen klicken.

Projekt speichern

Um Ihre Arbeit in RoboHelp zu speichern, folgen Sie diesen Schritten:

  1. Wählen Sie das Menü Datei .

  2. Wählen Sie in der Dropdown-Liste Alle speichern. Alternativ können Sie Ctrl+S drücken, um alle aktualisierten Dateien im Projekt zu speichern.

    Es wird empfohlen, dass Sie Ihr Projekt speichern, wenn Sie es aktualisieren, damit Sie keinen Inhalt verlieren.

Schließen Sie ein Projekt

Führen Sie nach dem Bearbeiten und Speichern Ihres Projekts die folgenden Schritte aus, um Ihr Projekt in RoboHelp zu schließen:

  1. Wählen Sie das Menü Datei .

  2. Wählen Sie Projekt schließen. Alternativ können Sie auch Alt+Strg+C drücken, um das Projekt zu schließen.

    Hinweis:

    Wenn Sie ein Projekt schließen, werden alle zugehörigen Dateien geschlossen. Die Anwendung (RoboHelp) bleibt jedoch geöffnet, sodass Sie ein Projekt öffnen oder erstellen und damit arbeiten können.

Zusammengeführte Projekte

Mit RoboHelp können Sie Projekte in einem Unternehmen oder einem verteilten Setup erstellen, in denen verschiedene Dokumentationsprojekte (untergeordnete Projekte) in ein gemeinsames Projekt (das Masterprojekt) einfließen. Sie können kollaboratives Authoring ohne die Verwendung von Quellcodeverwaltungssoftware durchführen, da mehrere Schreiber an ihren einzelnen untergeordneten Projekten arbeiten können. Im Inhaltsverzeichnis des Masterprojekts können Sie Verweise auf untergeordnete Projekte einfügen (das Masterprojekt enthält keine untergeordneten Projekte).

Fügen Sie jeden Verweis auf ein untergeordnetes Projekt als Platzhalter in das Inhaltsverzeichnis des Master-Projekts ein. Die Position des Platzhalters sollte an der Stelle liegen, an der das Inhaltsverzeichnis des untergeordneten Projekts in der Ausgabe angezeigt werden soll. Der Platzhalter behält die ursprüngliche Hierarchie des Inhaltsverzeichnisses des untergeordneten Projekts bei und wird in der Ausgabe erweitert.Das Zusammenführen erfolgt, nachdem die Ausgabe der Projekte generiert wurde. Durch die Verwendung von Skins und Vorlagen im Masterprojekt können Sie ein einheitliches Erscheinungsbild in den zusammengeführten Projekten erzielen.

Führen Sie die folgenden Schritte aus, um untergeordnete Projekte einzufügen:

  1. In Ihrem Master-Projekt, klicken Sie auf Inhaltsverzeichnis auf der Symbolleiste „Autor“. Der Bereich Inhaltsverzeichnis wird geöffnet.

  2. Wählen Sie im Bereich Inhaltsverzeichnis neben der entsprechenden Inhaltsverzeichnisdatei, Optionen () > Bearbeiten aus.

    Der Inhaltsverzeichniseditor wird als Registerkarte geöffnet und RoboHelp zeigt die Symbolleiste für das Inhaltsverzeichnis in der Mitte der Symbolleiste an.

  3. Klicken Sie im Inhaltsverzeichniseditor auf die Position, an der Sie den Platzhalter des untergeordneten Projekts einfügen möchten.

    Hinweis:

    Wenn Sie keinen Ort auswählen, wird der Platzhalter nach dem aktuell ausgewählten Thema eingefügt. Wenn ein Ordner zum Zeitpunkt des Einfügens ausgewählt ist, wird der Platzhalter am Ende der Liste der Themen im ausgewählten Ordner eingefügt.

  4. Führen Sie eine der folgenden Aktionen aus:

    • Klicken Sie in der Inhaltsverzeichnissymbolleiste auf .
    • Klicken Sie mit der rechten Maustaste in den Inhaltsverzeichnis-Editor und wählen Sie Einfügen > Untergeordnetes Projekt.
  5. Klicken Sie im Dialogfeld Untergeordnetes Projekt einfügen auf , um Ihr untergeordnetes Projekt auszuwählen (.rhpj-Datei). Klicken Sie auf Einfügen.

    Ein Platzhalter des Inhaltsverzeichnisses des untergeordneten Projekts wird eingefügt. 

  6. Informationen zum Ändern der Eigenschaften des Platzhalters für ein untergeordnetes Projekt finden Sie unter Mit den Eigenschaften des Inhaltsverzeichnisses arbeiten.

  7. Ausgabevorgabe konfigurieren.Geben Sie auf der Registerkarte Allgemein im Feld > Ausgabepfad den folgenden Speicherort an, an dem die Ausgabe aller untergeordneter Projekte generiert werden muss:

    [master_project_output_folder]/mergedProjects/[child_project_name]

Untergeordnete HTML-Hilfedatei

Sie können eine CHM-Datei in das ToC in Ihr Projekt aufnehmen, damit sie in Ihrer Ausgabe geöffnet werden kann. 

Führen Sie die folgenden Schritte aus, um Microsoft HTML-Hilfedateien (CHM) zusammenzuführen:

  1. In Ihrem Master-Projekt, klicken Sie auf Inhaltsverzeichnis auf der Symbolleiste „Autor“. Der Bereich Inhaltsverzeichnis wird geöffnet.

  2. Wählen Sie im Bereich Inhaltsverzeichnis neben der entsprechenden Inhaltsverzeichnisdatei, Optionen () > Bearbeiten aus.

    Der Inhaltsverzeichniseditor wird als Registerkarte geöffnet und RoboHelp zeigt die Symbolleiste für das Inhaltsverzeichnis in der Mitte der Symbolleiste an.

  3. Klicken Sie im Inhaltsverzeichniseditor auf die Position, an der Sie den HTML-Dateiplatzhalter einfügen möchten.

    Hinweis:

    Wenn Sie keinen Ort auswählen, wird der Platzhalter nach dem aktuell ausgewählten Thema eingefügt. Wenn ein Ordner zum Zeitpunkt des Einfügens ausgewählt ist, wird der Platzhalter am Ende der Liste der Themen im ausgewählten Ordner eingefügt.

  4. Führen Sie eine der folgenden Aktionen aus:

    • Klicken Sie in der Inhaltsverzeichnissymbolleiste auf .
    • Klicken Sie mit der rechten Maustaste in den Inhaltsverzeichnis-Editor und wählen Sie Neu > HTML-Hilfedatei.
  5. Klicken Sie im Dialogfeld HTML-Hilfedatei einfügen auf , um Ihre .chm-Datei auszuwählen. Klicken Sie auf Einfügen.

    Die Microsoft HTML-Hilfedatei wird im Inhalts-Explorer unter assets/chm/in das Projekt kopiert. Beispiel: assets/chm/xxxx.chm

  6. Informationen zum Ändern der Eigenschaften des HTML-Dateiplatzhalters finden Sie unter Mit den Eigenschaften des Inhaltsverzeichnisses arbeiten.

  7. Microsoft HTML-Hilfe-Ausgabe konfigurieren. Wählen Sie dasselbe Inhaltsverzeichnis (TOC)

Adobe-Logo

Bei Ihrem Konto anmelden

[Feedback V2 Badge]