La mise à jour d’After Effects CC 2015 (13.6) est désormais disponible. Dans cette vidéo, Karl Soule présente plusieurs des fonctionnalités nouvelles et modifiées.

Pour obtenir une présentation des nouveautés de toutes les applications audio et vidéo et de tous les services professionnels Adobe, consultez cette page. Pour plus d’informations sur les mises à jour de toutes les applications vidéo et audio professionnelles d’Adobe, reportez-vous à cette page.

Si vous êtes abonné à Creative Cloud, vous pouvez télécharger la nouvelle version en vérifiant les mises à jour via l’application de bureau Creative Cloud. Pour plus d’informations sur l’achat d’un abonnement Creative Cloud, consultez cette page sur les offres d’abonnement et cette page sur les offres promotionnelles actuelles.

Si vous souhaitez poser des questions sur ces fonctionnalités nouvelles et modifiées, rendez-vous sur le forum des utilisateurs d’After Effects.  Si vous souhaitez soumettre des demandes de fonctionnalités ou des rapports de bogues, vous pouvez le faire ici.

Comportements de l’aperçu et options du panneau Aperçu mis à jour

Depuis After Effects CC 2015 (13.5), l’équipe d’After Effects a tenu compte du point de vue des utilisateurs concernant les modifications apportées aux comportements de l’aperçu et aux contrôles du panneau Aperçu. Plusieurs modifications ont été apportées à la mise à jour d’After Effects CC 2015 (13.6) afin de répondre aux attentes des utilisateurs.

Les aperçus peuvent nécessiter presque deux fois autant de temps pour le même contenu (par rapport aux versions précédentes)

Nous avons optimisé la manière dont les images sont mises en cache et la manière dont elles sont transformées pour l’affichage à l’écran, de sorte que seulement environ la moitié de la mémoire est nécessaire pour le contenu typique. Bien que cette modification porte surtout sur l’efficacité de la mémoire, elle contribue également aux performances de rendu et de lecture.

Amélioration des comportements et des contrôles de la mise en cache

Le contrôle Privilèges de prévisualisation a été supprimé.L’objectif de cette option, qui était de modifier le comportement de la mise en cache, n’a pas été clairement apparent et la fonction a été très peu utilisée. Il existe désormais un seul comportement de mise en cache. Le nouveau comportement de mise cache est un hybride des anciennes fonctions Cadence de privilèges de prévisualisation et Longueur de privilèges de prévisualisation :

  • Tout comme la fonction Cadence de privilèges de prévisualisation, After Effects effectue le rendu et met les images en cache jusqu’à saturation du cache, et la mise en cache s’arrête alors. Il n’existe plus d’option pour qu’After Effects étende un aperçu au-delà des images mises en cache en supprimant les images les plus anciennes dans le cache, comme la fonction Longueur de privilèges de prévisualisation l’aurait fait.
  • Tout comme la fonction Longueur de privilèges de prévisualisation, le nouveau comportement de mise en cache stocke uniquement le cache d’affichage à l’écran (un cache secondaire utilisé pour transformer les images en vue de l’affichage à l’écran) pendant un bref moment avant l’indicateur de temps d’aperçu. Dans After Effects CC 2015 (13.5), le mode Cadence de privilèges de prévisualisation conservait le cache d’affichage à l’écran pour toutes les images mises en cache, ce qui n’était pas efficace et pouvait se traduire par une durée d’aperçu inopinément courte.

Une nouvelle option Mise en cache avant lecture a été ajoutée. Lorsque cette option est activée, After Effects met les images en cache avant de commencer la lecture. Ce comportement est identique à celui de la fonction Aperçu RAM dans les versions antérieures d’After Effects. Notez toutefois que les images ne sont pas affichées dans le panneau Composition, Calque ou Métrage à mesure qu’elles sont mises en cache. Par défaut, cette option n’est activée pour aucun des raccourcis d’aperçu. Si vous appuyez sur Option (Mac OS) ou sur Alt (Windows) tout en cliquant sur le bouton Réinitialiser dans le panneau Aperçu, la fonction Mise en cache avant lecture est activée pour la touche 0 du pavé numérique.

Modifications de l’aperçu audio

Le contrôle Durée d’aperçu audio de Préférences > Aperçus a été supprimé. Cette option était en conflit avec l’option Plage du panneau Aperçu. Lorsque le son doit être rendu pour un aperçu, il est désormais rendu pour la durée définie par le contrôle Plage. La nouvelle option de plage Lecture autour de l’heure actuelle est utilisée pour émuler le comportement de la préférence Durée d’aperçu audio.

Quelle que soit la plage, les durées audio plus longues nécessitent davantage de mémoire pour stocker les données audio rendues pour la lecture. Ceci peut se traduire par des durées d’aperçu globales plus courtes ainsi qu’un délai de pré-aperçu plus long pour préparer le son (le panneau Informations affiche « Mixage audio pour l’aperçu »).

La commande Composition > Aperçu > Aperçu audio a été supprimée. Ces commandes de menu, Aperçu audio (Avancé) et Aperçu audio (Zone de travail) décrivaient des comportements qui peuvent désormais être modifiés dans le panneau Aperçu, maintenant que les raccourcis clavier d’aperçu audio uniquement peuvent être configurés dans le panneau Aperçu (voir ci-dessous). Pour éviter toute confusion, ces commandes ont été supprimées. La commande restante Composition > Aperçu > Lire l’aperçu actuel peut toujours lancer un aperçu audio uniquement, s’il s’agit de l’état actuel du panneau Aperçu.

Le bouton Désactiver l’audio situé en haut du panneau Aperçu active ou désactive le volume audio pendant la lecture. Il active ou désactive également le bouton Inclure audio pour le raccourci clavier que vous avez utilisé afin de lancer cet aperçu.

Pour spécifier si l’audio est lu lorsque vous démarrez un aperçu, utilisez le nouveau bouton Inclure audio, décrit ci-dessous.

Nouveaux contrôles pour déterminer ce qui se produit lorsque vous arrêtez un aperçu

Dans les versions antérieures d’After Effects, notamment After Effects CC 2015 (13.5), les comportements observés lorsque vous arrêtiez un aperçu dépendaient du type de mise en cache utilisé par l’aperçu et du raccourci clavier que vous utilisiez pour arrêter l’aperçu. Ces comportements n’étaient pas configurables par l’utilisateur.

Avec la mise à jour d’After Effects CC 2015 (13.6), vous pouvez configurer les comportements d’arrêt pour chaque raccourci clavier à l’aide de nouveaux contrôles situés au bas du panneau Aperçu. Dans la section Arrêt sur (nom de raccourci) (par exemple, Arrêt sur (barre d’espace)), vous pouvez activer les options suivantes :

  • En cas de mise en cache, lire les images mises en cache : si cette option est activée et que vous utilisez ce raccourci clavier pour arrêter un aperçu avant la fin de la mise en cache, seule la mise en cache est arrêtée ; la lecture des images mises en cache recommence depuis le début de la plage. Lorsque cette option est désactivée, le fait d’arrêter un aperçu avec ce raccourci clavier arrête à la fois la mise en cache et la lecture.
  • Heure de déplacement vers heure d’aperçu : si cette option est activée et que vous utilisez ce raccourci clavier pour arrêter un aperçu, l’indicateur d’heure actuelle se déplace jusqu’à la position de l’heure d’aperçu (la dernière image prévisualisée). Lorsque cette option est désactivée, l’indicateur d’heure actuelle conserve sa position précédente.

Sur le raccourci de barre d’espace, l’option « En cas de mise en cache, lire les images mises en cache » est à présent désactivée par défaut. Dans After Effects CC (13.5), ce comportement était activé pour le raccourci de barre d’espace et suscitait de la confusion chez certains utilisateurs.

Nouveaux boutons Inclure pour la vidéo, l’audio, les incrustations et les contrôles de calque

Sous le contrôle Raccourci figurent trois boutons qui déterminent si un raccourci clavier lance un aperçu lisant la vidéo, lisant l’audio ou affichant les incrustations et les contrôles de calque. Vous pouvez maintenant configurer un raccourci d’aperçu pour lancer un aperçu avec ou sans vidéo, audio, incrustations et contrôles de calque.

  • Inclure la vidéo est nouveau dans la mise à jour d’After Effects CC 2015 (13.6). Lorsque cette option est activée, l’aperçu lit la vidéo. Lorsque cette option est désactivée, l’aperçu ne lit pas la vidéo.
  • Inclure l’audio remplace la fonctionnalité précédemment affectée au bouton Désactiver l’audio.Lorsque cette option est activée, l’aperçu lit l’audio. Lorsque cette option est désactivée, l’aperçu ne lit pas la séquence audio.
  • Inclure les incrustations et les contrôles de calque remplace l’option Contrôles de calque du panneau Aperçu. Lorsque cette option est activée, l’aperçu affiche les incrustations (par exemple, les grilles et les repères) et les contrôles de calque pour les calques sélectionnés, tel que défini dans la boîte de dialogue Affichage > Options d’affichage. Lorsque cette option est désactivée, l’aperçu n’affiche pas les incrustations. Notez que cette option peut être activée, que l’option Inclure la vidéo soit activée ou non.

Vous ne pouvez pas désactiver les trois boutons Inclure simultanément ; au moins un bouton doit rester activé. Si vous essayez de désactiver le troisième bouton, l’un des autres boutons passe à l’état désactivé.

Nouveaux raccourcis clavier configurables pour les aperçus

  • Raccourcis d’aperçu audio uniquement : les raccourcis clavier pour les aperçus audio uniquement, touche - du clavier numérique(décimal) et Option/Alt + touche - du clavier numérique(décimal), sont désormais configurables dans le panneau Aperçu.
  • Maj + barre d’espace : Un nouveau raccourci clavier, Maj + barre d’espace, a été ajouté aux raccourcis du clavier d’aperçu. Par défaut, Maj + barre d’espace est configuré comme la touche 0 du clavier numérique, à ceci près que Lire à partir de est défini sur Heure actuelle.
  • Nouvelles options de plage, y compris la possibilité d’exécuter la lecture autour de l’heure actuelle

    La préférence Durée d’aperçu audio dans la catégorie de préférences Aperçus a été supprimée. Cette option était en conflit avec l’option Plage du panneau Aperçu. Lorsque le son doit être rendu pour un aperçu, il est désormais rendu pour la durée définie par le contrôle Plage. La nouvelle option de plage Lecture autour de l’heure actuelle (voir ci-dessous) peut être utilisée pour émuler le comportement de la préférence Durée d’aperçu audio. Indépendamment de la plage, les durées audio plus longues exigent plus de mémoire afin de stocker les données audio rendues pour la lecture. Ceci peut se traduire par des durées d’aperçu globales plus courtes ainsi qu’un délai plus long avant lancement de l’aperçu pour préparer le son (le panneau Informations affiche « Mixage audio pour l’aperçu »).

    Le contrôle Plage comprend une nouvelle option, Lecture autour de l’heure actuelle. Cette option se comporte de la même façon que la commande Lecture autour de dans Premiere Pro. Lorsque vous lancez un aperçu avec l’option Lecture autour de l’heure actuelle activée, la valeur preroll est soustraite de l’heure actuelle, la valeur postroll est ajoutée à l’heure actuelle et les images intermédiaires sont prévisualisées.

    Pour définir les valeurs preroll et postroll, sélectionnez Lecture autour de l’heure actuelle dans le menu Plage. Définissez les valeurs preroll et postroll désirées en secondes, puis cliquez sur OK.

    L’option Lecture autour de l’heure actuelle est activée par défaut pourle raccourci clavier d’aperçu audio uniquement (décimal) de touche - du pavé numérique, avec une valeur preroll de 0 seconde et une valeur postroll de 30 secondes. Ceci émule la durée de cache par défaut définie par la préférence Durée d’aperçu audio qui a été supprimée.

    Modification de la couleur de l’indicateur d’heure actuelle

    L’indicateur d’heure actuelle (IHA) se trace désormais systématiquement en bleu sur toute sa longueur, y compris lorsque l’aperçu est arrêté. Ceci résout un problème de cohérence entre l’IHA et l’indicateur d’heure de prévisualisation (IHP) rouge qui apparaît uniquement lors des aperçus pour indiquer quelle image est prévisualisée.

    Améliorations de l’interface utilisateur pour les écrans tactiles, les périphériques multipoints et les petits écrans

    Alors que de plus en plus de personnes utilisent After Effects sur de petits ordinateurs portables et des tablettes (nombre d’entre elles disposant d’écrans tactiles et de périphériques de saisie multipoints), il est de plus en plus important qu’After Effects fonctionne efficacement sur ces petits écrans et tire pleinement parti de ces systèmes de saisie tactile.

    Groupes de panneaux empilés

    Les groupes de panneaux empilés vous permettent d’accéder en un seul clic aux panneaux tout en maintenant votre environnement de travail épuré et dégagé. Les groupes de panneaux empilés fonctionnent de la même manière que les panneaux d’Adobe Lightroom.

    Les panneaux figurant dans un groupe de panneaux empilés sont minimisés à leurs onglets de panneau et empilés verticalement. Cliquer sur un onglet de panneau développe le panneau et par défaut isole cet onglet en réduisant simultanément les autres panneaux du groupe.

    Les groupes de panneaux empilés sont le plus efficaces lorsqu’il s’agit d’afficher et de masquer rapidement les panneaux qui s’affichent généralement le long du côté droit de l’espace de travail d’After Effects (par exemple, les panneaux Caractères, Paragraphe, Peinture, Formes et Dispositif de suivi) et les autres panneaux que vous n’utilisez pas constamment.

    Pour créer un groupe de panneaux empilés, cliquez sur le menu de panneau dans l’onglet d’un panneau du groupe de panneaux, puis sélectionnez Groupe de panneaux empilés dans le menu Paramètres de groupe de panneaux.

    Pour restaurer le groupe de panneaux empilés vers un groupe de panneaux non empilés, désactivez l’option Groupe de panneaux empilés.

    Vous pouvez réorganiser et redimensionner des panneaux dans un groupe de panneaux empilés.

    Lorsque vous cliquez sur un panneau dans un groupe de panneaux empilés, les autres panneaux de ce groupe sont réduit à leurs onglets (mode solo). Pour que plusieurs panneaux d’un groupe de panneaux empilés puissent être développés simultanément, désactivez l’option Isoler les panneaux du groupe du menu Paramètres de groupe de panneaux correspondant à ce groupe de panneaux.

    Quel que soit le paramètre de mode solo, vous pouvez développer ou réduire simultanément tous les panneaux d’un groupe de panneaux empilés en cliquant tout en appuyant sur la touche Command (Mac OS) ou Ctrl (Windows) sur l’onglet d’un panneau de ce groupe.

    Espaces de travail et barre d’espace de travail

    La nouvelle barre d’espace de travail vous donne accès en un clic aux espaces de travail personnalisés ou par défaut. Elle opère de la même manière que le panneau Espaces de travail de Premiere Pro CC 2015. Veuillez lire cet article dans l’aide de Premiere Pro pour savoir comment modifier, organiser et choisir des espaces de travail dans la barre d’espace de travail.

    Dans les versions précédentes d’After Effects, les espaces de travail étaient disponibles via le menu Espace de travail situé à droite du panneau Outils. Ce menu a été remplacé par la barre d’espace de travail, qui occupe le côté droit du panneau Outils. Les espaces de travail qui ne tiennent pas dans l’espace disponible s’affichent dans le menu de dépassement (> >), à droite de la barre d’espace de travail.

    Lorsque le panneau Outils est déplacé de sa position dans la partie supérieure de l’espace de travail, la barre d’espace de travail est remplacée par le menu Espace de travail.

    Les espaces de travail et la nouvelle boîte de dialogue Modifier les espaces de travail sont également accessibles par l’intermédiaire du menu Fenêtre > Espace de travail.

    De nouveaux espaces de travail ont été ajoutés pour tirer parti des groupes de panneaux empilés et de la barre d’espace de travail, tandis que l’ordre des espaces de travail a été réorganisé. Par défaut, la barre d’espace de travail affiche trois espaces de travail : Informations essentielles, Standard et Petit écran. D’autres espaces de travail sont disponibles dans le menu de dépassement de la barre d’espace de travail.

    • L’espace de travail Informations essentielles est désormais l’espace de travail par défaut. Il présente le même agencement que l’espace de travail Standard, à ceci près que les panneaux figurant dans la partie droite de l’espace de travail se trouvent dans un groupe de panneaux empilés.
    • L’espace de travail Standard est le même espace de travail que dans les versions précédentes d’After Effects.
    • L’espace de travail Petit écran est optimisé pour être utilisé sur les périphériques ayant un écran de petite taille, y compris les petits ordinateurs portables, les projecteurs et les ordinateurs portables.

    Remarque :

    Du fait des modifications apportées aux espaces de travail, les espaces de travail personnalisés n’ont pas été migrés depuis les versions précédentes d’After Effects.

    Autres améliorations apportées aux panneaux et aux onglets

    Les onglets des panneaux peuvent être définis sur une taille plus grande pour être plus faciles à sélectionner sur un périphérique tactile. Afin d’activer cette fonctionnalité pour tous les onglets d’un groupe de panneaux, cliquez sur le menu de panneau d’un onglet du groupe, sélectionnez Paramètres de groupe de panneaux, puis désactivez l’option Petits onglets.

    Lorsque vous réorganisez des panneaux dans un groupe de panneaux à onglets, les autres panneaux s’écartent désormais automatiquement pour faire de la place au panneau déplacé. Ceci inclut le fait de faire automatiquement défiler les panneaux masqués lorsque vous faites glisser jusqu’à la fin d’un groupe de panneaux.

    Le menu de dépassement des groupes de panneaux à onglets affiche désormais tous les panneaux de ce groupe.

    Zoom multipoints, panoramique et mouvements de défilement

    Lorsque vous utilisez un périphérique de saisie multipoints (par exemple, un écran tactile tel que Microsoft Surface ou Wacom Cintiq Touch ou un pavé tactile multipoints), vous pouvez effectuer un zoom, un panoramique et un défilement dans les panneaux Composition, Calque, Métrage et Montage à l’aide de gestes multipoints.

    • Zoom : rapprochez deux doigts en les pinçant pour effectuer un zoom arrière ou écartez-les pour effectuer un zoom avant. Dans les panneaux de lecteur de contenu, cela revient presque à effectuer un zoom avant tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée pour effectuer un zoom centré autour du pointeur de la souris.
    • Panoramique et défilement : avec deux doigts, faites glisser pour effectuer un panoramique ou un défilement vers le haut, le bas, la gauche ou la droite dans la vue actuelle du panneau. Ce mouvement revient presque à effectuer un panorama avec l’outil Main.

    Meilleure fidélité des couleurs

    Plusieurs modifications ont été apportées avec la mise à jour d’After Effects CC 2015 (13.6) pour étendre le jeu de fonctionnalités de gestion des couleurs After Effects et améliorer la capacité d’introduire des ressources à partir de nombreuses sources différentes tout en préservant les informations de couleur le plus fidèlement possible. Vous trouverez ici dans le blog Premiere Pro plus d’informations sur les améliorations en cours dans nos applications pour la couleur ultra-HD et HDR (High Dynamic Range).

    Parmi les légères modifications apportées à la gestion des couleurs, l’interprétation automatique des données chromatiques a été améliorée de plusieurs façons : par exemple, les formats de pixels colorimétriques linéaires sont maintenant reconnus automatiquement, tandis que le métrage HD mi-résolution n’est plus balisé par des profils colorimétriques SD.

    Effet de couleur Lumetri

    La mise à jour d’After Effects CC 2015 (13.6) comprend l’effet de couleur Lumetri, qui a été ajouté afin que le travail d’étalonnage des couleurs effectué dans Premiere Pro puisse être préservé dans After Effects lors de la copie de clips de Premiere Pro vers After Effects, lors de l’importation d’un projet Premiere Pro dans After Effects ou lors de l’utilisation de la commande Remplacer par la composition After Effects de Premiere Pro.

    IMPORTANT : l’effet de couleur Lumetri dans After Effects vise à préserver les réglages de couleurs au niveau des clips importés de Premiere Pro vers After Effects. Reportez-vous à la documentation associée aux flux de couleur Premiere Pro pour obtenir une description des différents contrôles. Vous pouvez appliquer l’effet de couleur Lumetri à n’importe quel calque dans After Effects, mais notez que les contrôles ne sont pas tous entièrement répliqués.

    Pour obtenir les meilleurs résultats, définissez l’intensité de couleur du projet sur 32 bits par canal si vous activez l’option Plage dynamique élevée de l’effet de couleur Lumetri.

    Profils ICC supplémentaires pour la gestion des couleurs

    La mise à jour d’After Effects CC 2015 (13.6) comprend plusieurs nouveaux profils ICC pour interpréter correctement les couleurs issues d’une variété de sources (y compris le métrage ARRIRAW), ainsi que de nouveaux profils pour simuler la sortie couleur et choisir un espace colorimétrique de travail pour le projet :

    • Profils de gammes de couleur larges ARRI Log
    • Profils d’affichage HDTV et UHDTV, remplaçant le profil d’appareil photo 709 ancien
    • Profils DCDM et DCI P3, avec plus de points blancs, remplaçant les profils anciens inexacts
    • Profils d’espace de travail ACES et ACEScg
    • Profils d’affichage SDTV, recommandés à la place du profil Rec ancien. 601 profils

    Nouveaux importateurs pour les formats et codecs supplémentaires

    La mise à jour d’After Effects CC 2015 (13.6) peut importer en mode natif le métrage HEVC (H.265), les fichiers QuickTime (.mov) codés avec le codec Avid DNxHR.

    Flux de production rationalisé pour l’utilisation de Bibliothèques CC et d’Adobe Stock

    Les graphiques et les éléments vidéo peuvent être déplacés du panneau Bibliothèques directement vers les panneaux Composition et Montage. L’élément est automatiquement importé dans votre projet ; vous n’avez plus besoin de l’importer et de l’ajouter à la composition en tant qu’étapes distinctes.

    En haut du panneau Bibliothèques figure un nouveau champ de recherche ; dans le menu déroulant, vous pouvez choisir d’effectuer une recherche dans vos bibliothèques ou dans Adobe Stock. Lorsque vous effectuez une recherche dans Adobe Stock, les résultats s’affichent dans le panneau Bibliothèques.

    Lorsque vous passez la souris sur les résultats, des boutons Acheter et Enregistrer l’aperçu apparaissent sur l’image ou la vidéo. Le bouton Acheter permet d’acheter une licence pour cet élément et de l’enregistrer dans vos bibliothèques, tandis que le bouton Enregistrer l’aperçu ajoute un aperçu avec filigrane de cet élément à vos bibliothèques. De là, vous pouvez ajouter les éléments à votre projet After Effects.

    Si vous souhaitez attribuer une licence à une image d’aperçu ou à une vidéo après l’avoir ajoutée à vos bibliothèques, cliquez avec le bouton droit de la souris sur l’élément dans votre bibliothèque, puis sélectionnez Acheter l’image ou Acheter la vidéo. L’image d’aperçu ou la vidéo est automatiquement remplacée par la version sous licence sans filigrane.

    IMPORTANT : dans After Effects CC 2015 (13.6), les images fixes sous licence ne remplacent pas automatiquement les images fixes d’aperçu. Ceci sera corrigé dans une version ultérieure. Si vous avez utilisé une image fixe d’aperçu dans une composition pour laquelle vous avez acheté une licence, vous pouvez contourner ce problème : ajoutez l’image désormais sous licence à votre projet, puis maintenez la touche Option (Mac OS) ou Alt (Windows) enfoncée et faites glisser l’image sous licence du panneau Projet vers l’image d’aperçu de la composition pour la remplacer.

    Lorsque vous ajoutez une vidéo Adobe Stock à votre projet After Effects, la vidéo s’affiche d’abord comme espace réservé (barres de couleurs) pendant le téléchargement du fichier vidéo. Une fois le téléchargement terminé, cet espace réservé est remplacé par le fichier vidéo. Vous pouvez surveiller la progression du téléchargement dans le nouveau panneau Progression (Fenêtre > Panneau Progression). Lorsque vous achetez une licence pour une vidéo d’aperçu ayant été utilisée dans votre projet, la vidéo sous licence doit également être téléchargée avant le remplacement de la vidéo d’aperçu.

    Accès par script aux lignes de base du texte

    Vous pouvez lire les emplacements de ligne de base (x, y) d’un calque de texte à l’aide de scripts dans la mise à jour d’After Effects CC 2015 (13.6). Le nouvel attribut sourceText.value.baselineLocs des objets TextDocument renvoie un tableau d’éléments flottants indiquant la position de départ des valeurs x et y de chaque ligne de texte.

    Les retours à la ligne dans une zone de texte de paragraphe sont traités comme des lignes multiples.

    Le tableau renvoie des valeurs flottantes sous la forme : line0.start_x, line0.start_y, line0.end_x, line0.end_y, line1.start_x, line1.start_y, line1.end_x, line1.end_y … lineN-1.start_x, lineN-1.start_y, lineN-1.end_x, lineN-1.end_y

    Remarque : Si une ligne ne contient aucun caractère, les valeurs x et y de début et de fin sont égales à la valeur flottante maximale (3.402823466e+38F).

    Nouvelle méthode de script pour générer des nombres aléatoires

    Une nouvelle méthode de script, generateRandomNumber, permet de générer des nombres aléatoires. Nous vous recommandons d’utiliser cette fonction au lieu de Math.random pour générer des nombres aléatoires appliqués en tant que valeurs dans un projet (par exemple, lors de l’utilisation de setValue).

    Cette nouvelle méthode prévient un problème où Math.random ne renverrait pas de valeurs aléatoires dans After Effects CC 2015 (13.5.x) en raison d’un problème de simultanéité avec des thread d’unité centrale multiples.

    Utilisation d’exemple de la méthode generateRandomNumber :


    // remplace la position X de tous les calques par un numéro aléatoire

    var myComp = app.project.activeItem;
    var x = 0;

    for(var i = 1; i <= myComp.numLayers; i++){

    // Si vous utilisez Math.random(), ceci ne fonctionne pas
    // x = 400*(Math.random()) – 200;
    // utilisez la nouvelle méthode generateRandomNumber() à la place

    x = 400*(generateRandomNumber()) – 200;
    currentPos = myComp.layer(i).property(“Position”).value;
    myComp.layer(i).property(“Position”).setValue([currentPos[0]+x,currentPos[1]]);
    }

    Modules externes d’effets CycoreFX HD 1.8.1

    Le package de module externe CycoreFX HD 1.8.1 comprend les nouveaux effets suivants :

    • CC Vignette: supprime ou ajoute le vignettage. Inclut une option qui permet de préserver (épingler) les tons clairs pour un comportement plus réaliste.
    • CC HexTile : générateur de motifs de nid d’abeilles Il répète un motif hexagonal, avec plusieurs options comprenant un contrôle unique des « bavures ». Cet effet s’apparente à une extension de l’effet CC Kaleida et génère des arrière-plans et des effets dynamiques et stimulants.

    Améliorations apportées à Adobe Media Encoder

    Les améliorations intégrées à la prochaine version d’Adobe Media Encoder incluent des améliorations d’un grand intérêt aux utilisateurs d’After Effects, y compris la possibilité d’employer des séquences d’images dans les dossiers contrôlés, la possibilité de publier directement vers Facebook (ainsi que Vimeo et YouTube) et la possibilité d’exporter la vidéo HEVC (H.265). Voir cette page pour plus d’informations.

    Améliorations de Character Animator (Preview 3)

    Character Animator (Preview 3) ajoute de nombreuses fonctionnalités nouvelles et améliore les performances et la convivialité au niveau de plusieurs aspects. Voir cette page pour plus d’informations.

    Fonctionnalités nouvelles et modifiées diverses

    • L’option Accélération matérielle pour les panneaux Composition, Calque et Métrage dans Préférences > Affichage est à présent activée. Elle était désactivée pendant que les performances étaient revues dans After Effects CC 2015 (13.5).
    • L’image rendue dans la file d’attente de rendu est également affichée dans le panneau Composition. Elle était désactivée pendant que les performances étaient revues dans After Effects CC 2015 (13.5).
    • La bibliothèque OptiX de Nvidia est mise à jour sous Windows, ce qui permet d’utiliser les GPU d’architecture Maxwell (par exemple, GTX 970 et GTX 980) pour le rendu 3D par lancer de rayon sous Windows.
    • La commande Raccorder comp à la zone de travail comporte à présent un raccourci clavier : Commande+Maj+X (Mac OS) ou Ctrl+Maj+X (Windows).
    • La commande Nouvelle comp de la sélection comporte à présent un raccourci clavier : Option+\ (Mac OS) ou Alt+\ (Windows).
    • Le format MXF OP1a a été supprimé de la file d’attente de rendu d’After Effects. Pour exporter vers MXF OP1a, utilisez Adobe Media Encoder.
    • Les fichiers peuvent désormais être déplacés du Finder (Mac OS) ou de l’Explorateur Windows (Windows) directement vers les panneaux Composition et Montage. Le fichier est automatiquement importé dans votre projet et un calque est créé en fonction de l’élément de métrage ; il n’est plus nécessaire d’importer le fichier et d’ajouter un calque selon le métrage en tant qu’étapes distinctes.
    • L’indicateur d’heure actuelle (IHA) se trace désormais systématiquement en bleu sur toute sa longueur, y compris lorsque l’aperçu est arrêté. Ceci résout un problème de cohérence entre l’IHA et l’indicateur d’heure de prévisualisation (IHP) rouge qui apparaît uniquement lors des aperçus.
    • Les images clés itinérantes utilisent une nouvelle icône plus facile à distinguer.
    • Mise à jour du module externe Synthetic Aperture Color Finesse (3.0.14) avec plusieurs correctifs

    Corrections de bugs connus

    • Les pistes audio ne sont plus silencieuses lorsque vous exportez à partir de la file d’attente de rendu.
    • Le suivi de mouvement (programme de suivi de mouvement 2D) n’entraîne plus le blocage d’After Effects dans certaines conditions, le plus souvent avec les images haute résolution (par exemple, 4K).
    • Les panneaux ScriptUI s’affichent et se redimensionnent désormais correctement sur les écrans DPI élevé sous Windows.
    • Le panorama horizontal dans le panneau Montage fonctionne à nouveau lorsque le panneau se trouve sur un moniteur secondaire organisé à gauche du moniteur principal.
    • Faire glisser des images clés ou des points d’entrée et de sortie de calque dans le panneau Montage ne devrait à présent plus s’accompagner d’un retard au relâchement de la souris dans les compositions complexes.
    • La barre de progression de rendu dans les panneaux Composition et Calque est plus réactive lors des rendus d’image longs.
    • La modification du texte source d’un calque de texte ne provoque plus l’échec des expressions lorsque le nom du calque de texte était référencé.
    • Lorsqu’un fichier en cours d’utilisation par un projet ouvert est manquant, After Effects n’avertit désormais l’utilisateur qu’une seule fois à propos du problème, et non plus deux fois.
    • Les vues Plusieurs pages dans le panneau Composition affichent désormais les triangles de mise au point en bleu et non plus en jaune.
    • L’outil Panoramique arrière peut à nouveau saisir des axes 3D sur un calque 3D.
    • Les boutons de direction de tracé du calque de forme du panneau Montage présentent désormais une surbrillance et un contraste distincts, pour accroître la différence entre les états sélectionnés et non sélectionnés.
    • L’annulation après l’utilisation de l’option Modifier l’original sur des fichiers Camera Raw n’entraîne plus le blocage d’After Effects.
    • Les séquences DNG créées par le micrologiciel Magic Lantern pour les appareils photo Canon sont désormais mises à jour correctement lorsque vous modifiez les paramètres Camera Raw par le biais de la boîte de dialogue Interpréter le métrage.
    • Le rechargement d’une séquence Camera Raw après modification des paramètres Camera Raw de cette séquence dans une autre application (par exemple, Photoshop) charge maintenant les paramètres Camera Raw mis à jour comme prévu.
    • Modifier l’original fonctionne à nouveau comme prévu pour les fichiers Camera Raw uniques (non séquentiels).
    • Lors de l’application des paramètres Métrage mémorisés sur une séquence d’image fixe qui utilise des fichiers annexes XMP (c’est-à-dire, des formats Camera Raw), l’application des paramètres à la première image de la séquence n’échoue plus.
    • Un message d’erreur {pas de contexte actuel} n’est plus affiché lorsque vous définissez un calque de métrage comme calque de guide, si vous avez modifié sa cadence d’images de Métrage.
    • L’application d’une animation prédéfinie contenant l’effet Eclairs obsolète n’entraîne plus le blocage d’After Effects.
    • Le remplacement du métrage dupliqué n’affiche plus le cache pour le métrage ayant été remplacé.
    • L’application de l’effet Plage de couleurs à une composition imbriquée pour laquelle l’option Réduire les transformations est activée et qui contient un calque dont l’échelle est définie sur 0 % n’entraîne plus le blocage d’After Effects.
    • L’application de l’effet Plage de couleurs à un calque de réglage pour lequel l’option Pixellisation en continu est activée n’entraîne plus le blocage d’After Effects.
    • Les contrôles d’effet des effets Niveaux, Extraction, Clé colorimétrique linéaire et Clé de plage de couleurs sont désormais mis à jour correctement lors des interactions.
    • Les traits de tampons dupliqués ne se dégagent plus dans le temps de façon inattendue.
    • L’utilisation de la méthode de script copyToComp ne provoque plus le blocage d’After Effects lorsque le calque comporte un parent.
    • La méthode de script valueAtTime(time, false) attend maintenant que l’évaluation des expressions nécessitant du temps, telles que sampleImage, se termine avant de retourner le résultat.
    • After Effects ne se bloque plus lorsque vous cliquez sur les boutons OK ou Annuler dans une boîte de dialogue scriptUI comportant des panneaux à onglets.
    • Le chargement des liens symboliques dans le dossier des scripts After Effects sous Mac OS n’échoue désormais plus.
    • After Effects démarre désormais si des guillemets doubles vers la gauche ou vers la droite sont utilisés à la place du guillemet double non directionnel du fichier Interpretation Rules.txt. (Occurrence fréquente lorsque TextEdit et utilisé pour modifier le fichier sans désactiver la fonctionnalité Guillemets typographiques.)
    • La résolution de la matrice d’ombre n’est plus réinitialisée à la taille de la composition une fois que l’utilisateur a cliqué sur OK dans la boîte de dialogue Options de programme de rendu 3D classique.
    • After Effects ne se bloque plus lorsque l’éditeur graphique est affiché lors du traitement d’une expression de remappage temporel.
    • L’exportation vers le codec QuickTime Photo-JPEG n’introduit plus de changements de couleur. Un problème similaire a été résolu pour les codecs A et B QuickTime Motion JPEG. Dans les deux cas, le format de pixel correct pour le codec (c’est-à-dire YUV Rec.601 ou Rec.709) est utilisé.
    • Les canaux alpha prémultipliés dans le métrage de codec Apple ProRes 4444 sont à présent rendus comme prévu.
    • L’audio n’est plus rendu lorsqu’un aperçu est lancé avec le son coupé. « Mixage audio pour l’aperçu » ne s’affiche plus dans le panneau d’informations si le son est coupé. Si le son est activé au cours d’un aperçu, le rendu audio commence.
    • Les curseurs d’ajustement de la zone de travail aux points d’entrée et de sortie ne sont plus décalés.
    • Correction d’un problème où, lorsqu’un module externe provoque le blocage d’After Effects, la cause de l’erreur n’est pas signalée et l’utilisateur n’a pas la possibilité d’enregistrer le projet.
    • Les formats de pixels non carrés dans les fichiers DPX sont maintenant reconnus.
    • Coller des données de forme moka AE applique l’effet de forme moka comme prévu.
    • L’info-bulle du bouton Lecture/Stop dans le panneau Aperçu devient maintenant Lire/Arrêter le rendu/Arrêter la lecture si l’option « En cas de mise en cache, lire les images mises en cache » est activée.
    • Le métrage vidéo HD demie résolution n’est plus automatiquement balisé par un profil colorimétrique SDTV.
    • Amélioration des performances des expressions sur les calques remappés temporellement. Cela réduit également le temps de rendu audio sur les calques remappés temporellement avec expressions.
    • La duplication des éléments dans le panneau Projet n’a plus pour effet un rendu du résultat incorrect par les compositions.
    • Correction d’un problème où l’aperçu d’images dont le rendu est lent ne pouvait pas être interrompu.
    • Amélioration des performances de l’application de l’assistant d’image clé Echelle exponentielle à plusieurs images clés.
    • Mercury Transmit peut à présent s’afficher sur plusieurs moniteurs lorsque vous passez à une autre application puis revenez à After Effects sous Mac OS X v10.11 (El Capitan).
    • Le temps de montage dans le panneau Métrage ne tente plus de manière erronée un sous-échantillonnage à l’aide de la résolution adaptative.
    Si vous souhaitez nous indiquer quels aspects vous souhaiteriez voir abordés dans une mise à jour future, faites-le nous savoir via un rapport de bogue ou une demande de fonctionnalité ici. Vous pouvez également vous entretenir avec nous sur le forum des utilisateurs d’After Effects

    Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

    Mentions légales   |   Politique de confidentialité en ligne