Solutions aux principaux problèmes d’affichage de fichiers PDF à partir d’un site Web.

Symptômes 

Symptômes courants lorsqu’il est impossible d’afficher un fichier PDF dans un navigateur Web :

  • une page vierge sur le navigateur Web ;
  • une icône X rouge.
  • Un indicateur de lien rompu, tel qu’un carré rouge, un triangle bleu ou un cercle bleu
  • Erreur : « Le programme Adobe Acrobat/Reader en cours d’exécution ne peut pas être utilisé pour afficher les documents PDF dans un navigateur Web. La version 8 ou ultérieure d’Adobe Acrobat/Reader est nécessaire. Quittez l’application et réessayez ».

Pour résoudre certains des problèmes les plus fréquents d’affichage de fichier PDF, suivez les instructions ci-dessous dans l’ordre suivant : mettez à jour Reader ou Acrobat, corrigez les problèmes du fichier PDF, vérifiez les paramètres du navigateur, réparez ou réinstallez Reader ou Acrobat.

Mettez à jour Reader ou Acrobat.

Adobe publie des mises à jour de sécurité trimestrielles gratuites, Assurez-vous que votre version de Reader ou d’Acrobat est à jour. Les mises à jour permettent souvent de remédier à certains problèmes courants. Téléchargez la dernière mise à jour gratuite.

  1. Ouvrez Reader ou Acrobat.

  2. Sélectionnez Aide > Rechercher les mises à jour. 

    Acrobat 9 et versions antérieures : Si une nouvelle mise à jour est disponible, elle s’installe automatiquement.

    Acrobat X et XI : Cliquez sur Mettre à jour, puis sur Installer.

    Acrobat DC : Passez à l’étape suivante.

    Recherche de mises à jour
  3. Lorsque la boîte de dialogue Updater s’affiche, cliquez sur Télécharger.

    Mise à jour d’Acrobat
  4. Une fois le téléchargement terminé, cliquez sur l’icône d’installation d’Acrobat. Dans la fenêtre Acrobat Updater, cliquez sur Installer.

    La mise à jour est prête
  5. Une fois l’installation terminée, redémarrez votre ordinateur et essayez d’afficher le fichier PDF de nouveau.

Solutions PDF

Actualisation ou rechargement de la page

Souvent, il vous suffit d’actualiser la page dans votre navigateur pour que le fichier PDF puisse charger complètement.

  • Maintenez la touche Maj enfoncée et appuyez sur le bouton  Actualiser ou  Recharger dans le navigateur.

Essai d’affichage d’un autre fichier PDF

Essayez d’afficher au autre fichier PDF. Par exemple, vérifiez si cetexemple de formulaires’affiche dans votre navigateur. Si Acrobat ou Reader peut ouvrir l’exemple de formulaire, l’autre fichier PDF est peut-être endommagé ou le serveur web peut avoir des problèmes. Si possible, contactez la personne ou l’entreprise qui gère le site Web.

Essai d’affichage d’un fichier PDF présent sur votre disque dur

Déterminez si le navigateur Web peut ouvrir un fichier PDF à partir de votre disque dur local plutôt que depuis le Web : Pour ce test, il vous faut un fichier PDF enregistré sur votre ordinateur.

  1. Effectuez l’une des opérations suivantes dans votre navigateur Web :

    • Mac OS : Sélectionnez la commande Fichier > Ouvrir (ou Ouvrir un fichier).
    • Windows : Appuyez sur Ctrl+O.
  2. Cliquez sur Parcourir.

  3. (Windows uniquement) Dans le menu Fichiers de type, choisissez Tous les fichiers.

    Choisissez Tous les fichiers
  4. Recherchez un fichier PDF sur votre ordinateur, sélectionnez-le et cliquez sur Ouvrir.

    Si le fichier PDF s’ouvre, le site Web que vous consultiez peut avoir un problème. Contactez la personne ou l’entreprise qui gère(nt) le site Web.

Solutions de navigateur et de paramètres du navigateur

Utilisation d’un navigateur Web différent

Certaines conditions sur votre ordinateur, telles que les paramètres de sécurité ou les cookies d’un navigateur, peuvent empêcher l’affichage d’un fichier PDF. Souvent, la solution la plus rapide consiste à ouvrir la page à l’aide d’un navigateur différent. Essayez avec l’un des navigateurs suivants :

 Google Chrome
 Mozilla Firefox
 Microsoft Internet Explorer
 Apple Safari

Pour obtenir la liste des navigateurs compatibles avec Reader et Acrobat, voir la section Navigateurs Web compatibles.

Passage à l’affichage de compatibilité (Internet Explorer)

Certains sites Web s’affichent dans l’affichage de compatibilité d’Internet Explorer. L’affichage de compatibilité affiche une page comme dans une version antérieure du navigateur.

Pour obtenir des instructions sur la manière de passer à cette affichage, voir Correction des problèmes d’affichage dans l’affichage de compatibilité.

Redémarrez l’ordinateur et essayez d’ouvrir à nouveau le fichier PDF.

Redémarrez votre ordinateur, puis ouvrez de nouveau la page Web. Le redémarrage de l’ordinateur efface sa mémoire et sa mémoire cache. Un simple redémarrage de l’ordinateur corrige fréquemment les problèmes d’affichage.

Supprimez les fichiers Internet temporaires (Internet Explorer, Firefox et Chrome).

Effacez la mémoire cache du navigateur (parfois appelée fichiers internet temporaires) pour vous assurer qu’une nouvelle version de la page est affichée. 

Soyez attentifs au choix des options. Effacer uniquement la mémoire cache du navigateur. Si vous supprimez tous les fichiers Internet temporaires, les cookies qui contiennent les informations de connexion et les préférences peuvent être supprimés. La plupart des navigateurs offrent le choix du type de contenu à supprimer.

Effacer l’historique
La boîte de dialogue Supprimer l’historique récent dans Firefox vous permet d’effacer uniquement la mémoire cache du navigateur.

Pour obtenir des instructions sur l’effacement de la mémoire cache du navigateur, consultez les articles suivants : 

Firefox : Suppression de l’historique de navigation, de recherche et de téléchargement

Chrome : Suppression de vos données de cache, d’historique et autres données de navigation

Internet Explorer versions 8 à 11 : Affichage et suppression de l’historique du navigateur

Internet Explorer 7 : Suppression de l’historique des pages Web

Réinitialisation de la préférence Affichage d’un fichier PDF dans un navigateur (Acrobat/Reader X ou une version antérieure)

Essayez de réinitialiser la préférence d’affichage dans votre navigateur pour résoudre le problème d’affichage.

  1. Dans Reader ou Acrobat, cliquez avec le bouton droit de la souris sur la fenêtre de document, puis sélectionnez Préférences d’affichage de page.

    Préférences d’affichage de page
  2. Dans la liste située à gauche, sélectionnez Internet.

    Sélectionnez Préférences Internet
  3. Désélectionnez Afficher dans le navigateur, puis cliquez sur OK.

    Désélection de Afficher dans le navigateur
  4. Essayez d’afficher à nouveau le fichier PDF à partir du site Web.

Affichage du fichier PDF dans la version 32 bits d’Internet Explorer ou de Safari (Windows Vista uniquement)

Cette procédure s’applique uniquement aux utilisateurs de Windows Vista avec Internet Explorer 9 ou une version antérieure.

Acrobat et Reader sont des applications 32 bits fonctionnant sous Windows. Si vous essayez d’ouvrir un fichier PDF dans une version 64 bits d’Internet Explorer, le fichier PDF s’ouvre dans le Reader ou Acrobat autonome et non pas dans Internet Explorer.

Remarque :

Seules les versions 10.1 et ultérieures de Reader ou d’Acrobat prennent en charge Internet Explorer 9.

Pour vous assurer que vous utilisez une version 32 bits d’Internet Explorer, procédez comme suit :

  1. Dans Internet Explorer, choisissez Aide > À propos d’Internet Explorer (dans certaines versions d’Internet Explorer, sélectionnez le point d’interrogation situé dans le coin supérieur droit pour sélectionner À propos d’Internet Explorer.)

    À propos d’Internet Explorer 9

    Si « Édition 64 bit » est indiqué à côté de la version, alors passez à l’étape 2.

    Internet Explorer 64 bits
  2. Pour passer à la version 32 bits d’Internet Explorer, quittez tout d’abord la version 64 bits d’Internet Explorer. Ensuite, cliquez deux fois sur l’icône de la version 32 bits du programme :

    C:\Program Files (x86)\Internet Explorer\iexplore.exe

    Internet Explorer 32 bits

Solutions pour Reader et Acrobat

Réparez Reader ou Acrobat.

Reader ou Acrobat peut être endommagé. La réparation de l’installation est un moyen de dépannage rapide.

Réparation à partir de Reader ou d’Acrobat

Sélectionnez Aide > Réparer l’installation.

Aide, Réparer l’installation

Réparez à l’aide du Panneau de configuration (Windows).

Vous pouvez également réparer l’installation d’Acrobat ou de Reader à l’aide du panneau de configuration de Windows.

  1. Fermez Reader ou Acrobat.

  2. Cliquez sur Démarrer > Panneau de configuration.

    Démarrer Panneau de configuration
  3. Effectuez l’une des actions suivantes dans le Panneau de configuration en fonction de votre version de Windows :

    • (Windows 8/7/Vista) Cliquez sur Programmes, puis sur Programmes et fonctionnalités.
    • (Windows XP) Cliquez deux fois sur Ajouter ou supprimer des programmes.
  4. Dans la liste de programmes, sélectionnez Adobe Reader ou Adobe Acrobat.

  5. Cliquez sur Modifier et suivez les instructions pour réparer l’application.

    Cliquez sur Modifier pour réparer.
  6. A l’issue du processus, cliquez sur Terminer.

Solutions avancées

Si aucune des solutions proposées dans les sections précédentes ne permet de résoudre le problème d’affichage des fichiers PDF, vous pouvez essayer les étapes avancées suivantes.

Activez le module complémentaire Adobe PDF pour navigateur (Internet Explorer 8 et versions ultérieures)

Assurez-vous que le module complémentaire Adobe PDF pour navigateur est activé.

  1. Ouvrez Internet Explorer et sélectionnez Outils > Gérer les modules complémentaires.

  2. Sous Types de modules complémentaires, sélectionnez Barres d’outils et extensions.

  3. Dans le menu Afficher, sélectionnezTous les modules complémentaires.

    Tous les modules complémentaires
  4. Dans la liste des modules complémentaires, sélectionnez Adobe PDF Reader.

    Remarque :

    Si le module complémentaire Adobe PDF Reader n’est pas affiché, essayez les autres options du menu. Par exemple, sur certains systèmes, le module externe s’affiche lorsque vous sélectionnez Exécuter sans autorisation.

  5. Cliquez sur le bouton Activer.

    Remarque :

    Si le bouton indique Désactiver, le module complémentaire est déjà activé. Ce bouton permet de basculer entre l’activation et la désactivation du module complémentaire, selon l’état de ce dernier.

    Activer active le module complémentaire Adobe PDF Reader dans le navigateur pour l’ouverture des fichiers PDF.

    Désactiver désactive le module complémentaire dans le navigateur.

    Activer Acrobat Reader

Activez le module complémentaire Adobe PDF pour navigateur (Firefox)

Assurez-vous que le module complémentaire Adobe PDF pour navigateur (nppdf32.dll) est activé.

  1. Dans la barre d’adresse de Firefox, saisissezabout:plugins

  2. Faites défiler la liste jusqu’à la section nommée Adobe Acrobat.

    Activé dans Firefox
  3. Vérifiez que le nom de fichier correspond à « nppdf32.dll » et « Adobe Acrobat Plug-In for Netscape. »
    Si cette entrée n’est pas disponible, installez la dernière version de Reader ou d’Acrobat.

Exécutez Acrobat ou Reader dans un nouveau compte administrateur local

Créez un compte utilisateur doté des mêmes autorisations que le compte que vous utilisez lorsque le problème survient. Sinon, créez un compte d’administrateur local. Si le problème ne se reproduit pas lorsque vous vous connectez à ce compte, il se peut que le compte utilisateur d’origine soit endommagé.

Pour plus d’informations sur la configuration d’un compte utilisateur, reportez-vous aux ressources suivantes ou contactez votre administrateur réseau :

Windows XP : Ajout d’un nouvel utilisateur à l’ordinateur

Windows Vista/7/8 : Créer un compte utilisateur

Mac OS X : Configuration des utilisateurs sur votre Mac

Optimisez les fichiers PDF de grande taille.

Si la taille du fichier PDF est de 4 Mo ou supérieure, demandez au fournisseur d’optimiser le fichier PDF. Pour plus d’informations sur l’optimisation des fichiers PDF, voir Optimisation des fichiers PDF.

Vérifiez le chemin de registre pour Acrobat ou Reader (Windows)

Clause de non-responsabilité : le registre contient des informations système cruciales pour votre ordinateur et vos applications. Avant de modifier le registre, veuillez créer une copie de sauvegarde. Adobe ne fournit pas d’assistance pour les problèmes provenant d’une modification inappropriée du registre. Adobe vous conseille fortement d’avoir l’expérience de la modification des fichiers système avant de modifier la base de registre. Pour plus d’informations sur le registre, consultez ladocumentation de Windowsou contactezMicrosoft.

  1. Accédez à Démarrer > Exécuter.

  2. Saisissezregedit, puis cliquez sur OK.

  3. Accédez à la clé HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  4. Assurez-vous que la valeur (par défaut) est définie sur le chemin d’installation d’Acrobat ou de Reader.

    • Le chemin par défaut pour Reader est « C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe ».
    • Le chemin par défaut pour Acrobat est « C:\Program Files (x86)\Adobe\Acrobat DC\Acrobat\Acrobat.exe ».

    Remarque :

    Si l’application Acrobat ou Reader est installée dans un emplacement différent du chemin par défaut, assurez-vous que la valeur (par défaut) de la clé pointe vers l’emplacement réel.

Pour une démonstration vidéo de la procédure, voir Vérifier si le chemin de registre est correcte.

Si l’élément de registre ci-dessus n’existe pas sur le système, procédez comme suit :

  1. Accédez à Démarrer > Exécuter.

  2. Saisissez regedit, puis cliquez sur OK.

  3. Sauvegardez votre fichier de registre actuel :

    • Dans la boîte de dialogue Éditeur du Registre, sélectionnez Fichier > Exporter.
    • Saisissez le nom du fichier et choisissez l’emplacement.
    • Dans la zone Étendue de l’exportation, sélectionnez Tout.
    • Cliquez sur Enregistrer.
  4. Sélectionnez Edition > Nouveau > Clé, puis créez la clé manquante HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe.

  5. Sélectionnez Édition > Nouveau > Valeur chaîne et nommez cette clé (par défaut).

  6. Sélectionnez la clé (par défaut), puis cliquez sur Edition > Modifier. Saisissez le chemin par défaut (répertorié ci-dessus) dans les données de valeur pour votre produit.

  7. Redémarrez l’ordinateur.

Réparez la clé de registre HKCR\AcroExch.Document (Windows)

Il est possible que cette clé soit endommagée, pointe vers une version obsolète d’Acrobat ou de Reader ou vers une visionneuse PDF tierce.

Clause de non-responsabilité : le registre contient des informations système cruciales pour votre ordinateur et vos applications. Avant de modifier le registre, veuillez créer une copie de sauvegarde. Adobe ne fournit pas d’assistance pour les problèmes provenant d’une modification inappropriée du registre. Adobe vous conseille fortement d’avoir l’expérience de la modification des fichiers système avant de modifier la base de registre. Pour plus d’informations sur le registre, consultez ladocumentation de Windowsou contactezMicrosoft.

  1. Sélectionnez Démarrer > Exécuter, puis saisissezregeditdans la zone de texte Ouvrir de la boîte de dialogue Exécuter et cliquez sur OK.

  2. Sauvegardez votre fichier de registre actuel :

    • Dans la boîte de dialogue Éditeur du Registre, sélectionnez Fichier > Exporter.
    • Saisissez le nom du fichier et choisissez l’emplacement.
    • Dans la zone Étendue de l’exportation, sélectionnez Tout.
    • Cliquez sur Enregistrer.
  3. Naviguez jusqu’à HKEY_CLASSES_ROOT\AcroExch.Document.

  4. Cliquez avec le bouton droit de la souris sur AcroExch.Document et sélectionnez Supprimer ; vérifiez que vous avez sélectionné la bonne clé et cliquez sur Oui à chaque invite.

  5. Cliquez avec le bouton droit de la souris sur AcroExch.Document.7 et sélectionnez Supprimer ; vérifiez que vous avez sélectionné la bonne clé et cliquez sur Oui à chaque invite.

  6. La vidéo ci-dessous indique les étapes à suivre.

     

Modification de l’en-tête de type de contenu sur le serveur Web (administrateurs Web)

Si vous êtes un webmestre ou possédez des droits d’administration sur un site Web, configurez le serveur Web pour qu’il envoie des en-têtes de type de contenu d’« application/pdf » pour les fichiers PDF. Pour obtenir des instructions, consultez la documentation fournie avec le serveur Web ou voir cet article du support Microsoft.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne