當您置入圖形時,會在版面中看到檔案的螢幕解析度版本,供您檢視與調整位置。不過,實際的圖形檔案可能「連結」或「內嵌」。

  • 連結的圖稿只會連接到文件,本身保持獨立,所以產生的文件較小。您可以使用變形工具和效果修改連結的圖稿,但是不能選取和編輯圖稿中的個別元件。您可以多次使用連結的圖形,而不會大幅增加文件的大小;此外,您也可以一次更新全部連結。轉存或列印時,會擷取原始圖形,從原稿的最完整解析度建立最後輸出。

  • 嵌入的圖稿會以完整解析度拷貝至文件中,所以產生的文件較大。您可以依需要控制版本與更新檔案;只要圖稿是內嵌的,就可以單獨使用文件。

若要判斷圖稿是連結或嵌入,或是要由一種狀態變更為另一種,請使用「連結」面板。

如果所置入的點陣圖為 48K 或更小,InDesign 會自動嵌入完整解析度影像,而非版面中的螢幕解析度版本。InDesign 會在「連結」面板中顯示這些影像,因此您可以控制版本並隨時更新檔案;不過,最佳化輸出並不一定需要連結。

註解:

如果將文件移動至另一個檔案夾或磁碟 (例如將文件帶給服務供應商),請務必同時移動連結的圖形檔案;它們並不儲存於文件中。利用「預檢」和「封裝」功能,您可自動拷貝所有相關檔案。

「連結」面板會列出所有置入文件的檔案。這同時包括本機檔案 (磁碟上) 和伺服器上所管理的資產。不過,從 Internet Explorer 的網站所貼入的檔案不會顯示於此面板中。

在 InCopy 中,「連結」面板也會顯示連結的內文。在「連結」面板中選取連結的內文時,「連結資訊」區段會顯示資訊,例如註解數目、受管理狀態,以及追蹤修訂的狀態。

連結面板
連結面板

A. 類別欄 B. 顯示/隱藏連結資訊 C. 有一或多個實例已經過修改的圖示 D. 已修改圖示 E. 遺失連結圖示 F. 內嵌連結圖示 

當同一個圖形在文件中出現多次,其多個連結會合併於「連結」面板中的一個顯示三角形下。當連結的 EPS 圖形或 InDesign 文件包含連結時,其連結也會合併於一個顯示三角形下。

連結檔案可以使用下列任一方式出現在「連結」面板中:

最新版本

最新版本檔案的「狀態」欄會保持空白。

已修改

此圖示表示磁碟中的檔案版本較您文件中的為新。例如,將 Photoshop 圖形讀入 InDesign,然後您或其他人在 Photoshop 中編輯和儲存原始圖形時,就會出現此圖示。

當圖形經過修改,同時有一或多個實例已經過更新,而其他實例尚未更新時,會出現一個稍微不同的「已修改」圖示。

遺失

雖然仍存在於某處,此圖形不再位於其原始的讀入位置。如果有人刪除原本的檔案,或在讀入後將檔案移到別的檔案夾或伺服器,就有可能發生遺失連結的情形。在未找出原始檔案之前,無法得知遺失的檔案是否為最新狀態。如果在出現此圖示時列印或轉存文件,該檔案可能不會以完整解析度列印或轉存。

內嵌

嵌入連結檔案的內容,會暫停執行該連結的管理作業。如果所選取的連結正進行「就地編輯」作業,就不會啟動此選項。 取消嵌入檔案會復原連結的管理作業。

如果連結的物件沒有出現在特定的文件頁面上,以下代碼會指出物件出現在哪裡:PB (作業範圍)、MP (主版頁面)、OV (溢排文字) 和 HT (隱藏文字)。

如需有關使用「連結」面板的教學課程影片,請參閱 www.adobe.com/go/lrvid4027_id

InDesign Secrets 在利用「連結」面板節省時間中提供「連結」面板提示和技巧的影片廣播。

  • 如果要顯示「連結」面板,請選擇「視窗 > 連結」。各連結檔案與自動嵌入的檔案以名稱辨識。
  • 若要選取與檢視連結的圖形,請在「連結」面板中選取連結,然後按一下「跳至連結」按鈕 ,再按一下「頁面」欄中的連結頁碼,或在「連結」面板選單中選擇「跳至連結」。InDesign 會將選定圖形周圍的顯示範圍置中。如果要檢視隱藏的物件,您可以顯示圖層 (如果是錨定物件則是條件)。
  • 如果要展開或收合巢狀連結,就按一下連結左邊的三角形圖示。當同一個圖形在文件中出現多次,或者連結的 EPS 圖形或 InDesign 文件包含連結時,會出現巢狀連結。
  • 如果要在面板中排序連結,就按一下「連結」面板上方的類別標題,以該類別排序。再按一下同一個類別即可反轉順序。例如,如果您按一下「頁面」類別,連結會以由第一頁到最後一頁的順序顯示。如果您再按一次「頁面」,連結會由最後一頁排序至第一頁。您可以使用「面板選項」在「連結」面板中新增欄。

您可以顯示其他的類別,例如「建立日期」與「圖層」,在「連結」面板中顯示圖形的更多相關資訊。對於每個類別,您都可以決定是否要讓資訊顯示為「連結」面板中的欄,和顯示在「連結」面板底部的「連結資訊」區段。

  1. 從「連結」面板選單中選擇「面板選項」。
  2. 選取「顯示欄」下方的核取方塊,在「連結」面板中新增欄。

    「檔案夾 0」是包含連結檔案的檔案夾;「檔案夾 1」是包含「檔案夾 0」的檔案夾,以此類推。

  3. 選取「在連結資訊中顯示」下方的核取方塊,在「連結」面板底部的「連結資訊」區段中顯示資訊。
  4. 按一下「確定」。

您可以選取欄並拖移至另一個位置,變更欄的順序。拖移欄邊界可以變更欄寬。按一下類別標題,可以依照該類別,用遞增的順序排序連結。再按一下就會以遞減的順序排序。

  1. 從「連結」面板選單中選擇「面板選項」。
  2. 針對「列大小」,選取「小型列」、「一般列」或「大型列」。
  3. 針對「縮圖」,決定是否要讓縮圖圖示顯示在「名稱」欄,和顯示在「連結」面板底部的「連結資訊」區段中。
  4. 按一下「確定」。

「連結」面板的「連結資訊」區段會列出選取的連結檔案的相關資訊。

註解:

如果要變更「連結」面板的「連結資訊」區段中顯示的資訊,請從「連結」面板選單中選擇「面板選項」,然後在「在連結資訊中顯示」欄中選取核取方塊。

  1. 按兩下或選取連結,並按一下面板左側的三角形「顯示/隱藏連結資訊」圖示。

如果連結或嵌入檔案包含中繼資料,可以使用「連結」面板檢視中繼資料。 您無法編輯或取代與連結檔案相關的中繼資料。

  1. 在「連結」面板中選取檔案,並在面板選單中選擇「公用程式 > XMP 檔案資訊」。

在文件中嵌入影像

您可將檔案嵌入 (或儲存於) 文件中,而不用連結至您置入文件的檔案。 在嵌入檔案時,您會中斷至原始檔案的連結。少了連結,「連結」面板不會在原始檔案變更時提供警告,而且無法自動更新檔案。

嵌入檔案會增加文件檔案大小。

嵌入連結檔案

  1. 在「連結」面板中選取檔案。
  2. 執行下列任一項作業:
    • 在「連結」面板選單中選取「嵌入連結」。

    • 如果檔案有多個實例,就在「連結」面板選單中選擇「嵌入所有的「[檔案名稱]」實例」。若只要嵌入一個實例,請選取該實例並選擇「嵌入連結」。

檔案仍會留在「連結」面板中,並以嵌入的連結圖示 標示。

註解:

針對出現於「連結」面板中的文字檔案,選取「連結」面板選單中的「解除連結」。當您嵌入文字檔案時,其名稱會自「連結」面板中移除。

取消嵌入連結檔案

  1. 從「連結」面板中選取一或多個嵌入檔案。
  2. 執行下列任一項作業:
    • 在「連結」面板選單中選取「取消嵌入連結」。如果檔案有多個實例,就在「連結」面板選單中選擇「取消嵌入所有的「[檔案名稱]」實例」。

    • 按一下「重新連結」按鈕 ,或是選取「連結」面板選單中的「重新連結」。

  3. 選擇將檔案連結至,InDesign 依據儲存於文件中的內嵌資料所建立的原始檔案或檔案夾。

使用「連結」面板檢查任何連結的狀態,或是使用更新的或替代檔案取代檔案。

如果選擇「檔案處理」偏好設定中的「重新連結保留尺寸」,則當您更新或重新建立 (重新連結) 檔案的連結時,系統會保留所有在 InDesign 中進行的變形。例如,如果您讀入方形圖形,並旋轉 30 度,然後將其重新連結至未旋轉的圖形,InDesign 會將其旋轉 30 度,以符合所取代之圖形的版面。

註解:

置入的 EPS 檔案可能包含 OPI 連結,此連結會出現於「連結」面板中。請勿將 OPI 連結重新連結至 EPS 檔案建立者原來所要以外的檔案;此作法在下載字體或分色時會造成問題。

選擇縮放重新連結圖形的方式

當您重新連結,以不同來源檔案取代某個圖形時,可以保留所取代之檔案的影像尺寸,或以實際尺寸顯示傳入的檔案。

  1. 選擇「編輯 > 偏好設定 > 檔案處理」(Windows) 或「InDesign > 偏好設定 > 檔案處理」(Mac OS)。

  2. 如果您想讓影像與所取代影像使用相同的尺寸顯示,請選擇「重新連結時保留影像尺寸」。取消選取這個選項,重新連結的影像就會以實際大小顯示。

InDesign 首先會尋找檔案夾中遺失的連結,目前工作階段中已有其他檔案在該檔案夾中重新連結。接著,它會在文件所在的相同檔案夾中尋找連結。如果仍然找不到,它會查看文件的父檔案夾。

修改的連結又稱為「已過期」連結。

  1. 在「連結」面板中,執行下列任一項作業:
    • 若要更新特定連結,請選取標有修改後之連結圖示 的一或多個連結。接著,按一下「更新連結」按鈕 ,或是選擇「連結」面板選單中的「更新連結」。

    • 若要更新所有修改過的連結,就從「連結」面板選單中選擇「更新所有連結」,或選取已修改的連結,接著按住 Alt 鍵並按一下「更新連結」按鈕 (Windows),或按住 Option 鍵並按一下「更新連結」按鈕 (Mac OS)。

    • 如果對於出現在文件中數個位置的一個圖形,您只要更新其中的一個連結,就只選取該子連結,然後選擇「更新連結」。如果您選取「父」連結,就可以更新已修改圖形的所有連結。

  1. 選取「連結」面板中的任何連結,然後按一下「重新連結」按鈕 ,或是從「連結」面板選單中選擇「重新連結」。如果選取了多個實例的單一「父」連結,就從「連結」面板選單中選擇「重新連結所有的「[檔案名稱]」實例」。

    除非內文已簽出,否則在管理的內文中會停用重新連結。

  2. 如果您想要 InDesign 在檔案夾中搜尋與其他遺失的連結檔案名稱相同的檔案,請在出現的對話框中,選取「在這個檔案夾中搜尋遺失連結」。如果沒有選取這個選項,就只會重新連結選取的影像。
  3. 選擇「顯示讀入選項」來控制新來源檔案的讀入方式。
  4. 找到並按兩下新來源檔案。
  5. 如果您先前按了「顯示讀入選項」選項,請選擇讀入選項(請參閱圖形的讀入選項)。
  1. 若要復原遺失的連結,請在「連結」面板中選取任何標有遺失連結圖示 的連結,然後按一下「重新連結」按鈕
  2. 在出現的對話框中,選取「在這個檔案夾中搜尋遺失連結」,重新連結出現在指定檔案夾中的任何遺失檔案。找出並按兩下檔案。

InDesign 預設會檢查遺失的連結,並在您開啟文件時嘗試解析這些連結。有兩個偏好設定選項,可讓 InDesign 在您開啟文件時,自動檢查並找出遺失的連結。

開啟文件前檢查連結

如果您關閉這個選項,InDesign 會立即開啟文件,而連結狀態會保持擱置狀態,直到判斷連結為最新、遺失或已修改為止。如果您開啟這個選項,InDesign 會檢查已修改或遺失的連結。

開啟文件前尋找遺失連結

如果您關閉這個選項,InDesign 不會嘗試解析遺失的連結。如果連結導致伺服器效能緩慢,或發生未預期的連結,您可能會想關閉這個選項。如果「開啟文件前檢查連結」是關閉的,這個選項會顯示為暗灰色。

搜尋遺失的連結

使用「搜尋遺失的連結」指令,在您的文件中搜尋與解析遺失的連結。如果您關閉了在開啟文件時檢查遺失連結的偏好設定選項,而現在有了遺失連結,這個指令就很有用。如果您掛接了一部伺服器做為文件開啟後儲存影像的位置,則這個指令也會很有用。

  • 如果要變更連結設定,就開啟「偏好設定」對話框的「檔案處理」區段,然後判斷是否選取了「開啟文件前檢查連結」和「開啟文件前尋找遺失連結」選項。
  • 若要讓 InDesign 嘗試解析遺失的連結,請在「連結」面板選單中選擇「公用程式 > 搜尋遺失的連結」。

    如果文件不包含遺失的連結,這個指令就會是暗灰色的。

  1. 在「偏好設定」對話框中,選取「檔案處理」。
  2. 從「預設重新連結檔案夾」選單中,選擇下列任一選項,然後按一下「確定」:

    最近使用的重新連結檔案夾

    這個選項會顯示您最近在重新連結時選取使用的檔案夾,與 InDesign CS3 的行為相同。

    原始連結檔案夾

    這個選項會顯示連結檔案的原始位置,與 InDesign CS2 和舊版的行為相同。

使用「拷貝連結至」指令,將圖形檔案拷貝至別的檔案夾,並將連結重新導向至拷貝的檔案。這個指令在移動檔案至不同的磁碟機時特別有用,例如將檔案由 DVD 移至硬碟。

  1. 選取您想要拷貝的檔案的連結,然後從「連結」面板選單中選擇「公用程式 > 拷貝連結至」。
  2. 指定要拷貝連結的檔案至哪個檔案夾,然後選擇「選取」(Windows) 或「選擇」(Mac OS)。

使用「重新連結至檔案夾」指令時,您可以指向包含與您過期連結相同名稱的檔案所在的檔案夾。例如,如果您目前的連結指向低解析度的影像,您可以指定包含高解析度影像的其他檔案夾。您可以為檔案指定不同的副檔名,比方說,讓您將連結由「.jpg」變更為「.tiff」。

除非內文已簽出,否則在管理的 InCopy 內文中,「重新連結至檔案夾」指令會是暗灰色的。

  1. 在「連結」面板中選取一或多個連結。
  2. 從「連結」面板選單中選擇「重新連結至檔案夾」。
  3. 指定新檔案夾的位置。
  4. 如果要使用不同的副檔名,請選取「比對相同檔名與此副檔名」,然後指定新的副檔名 (例如 AI、TIFF 或 PSD)。
  5. 按一下「選取」(Windows) 或「選擇」(Mac OS)。

「重新連結副檔名」指令可讓您根據副檔名取代影像。例如,假使在您的文件中有數個 JPEG 影像,則可以使用 PSD 檔案取代它們。不同副檔名的檔案必須與要取代的連結檔案位於同一個檔案夾中。

  1. 確保不同副檔名的檔案和原始檔案出現在相同的檔案夾中。
  2. 在「連結」面板中選取一或多個連結。
  3. 從「連結」面板選單中選擇「重新連結副檔名」。
  4. 指定此副檔名以取代已選取的檔案,然後按一下「重新連結」。

使用置入指令取代讀入的檔案

  1. 執行下列任一項作業:
    • 如果要取代圖形框架的內容 (例如讀入的圖形),請使用「選取」工具 選取框架。

      如果要取代圖形框架的內容 (例如讀入的圖形),請使用「位置」工具選取影像。

    • 如果要取代文字框架的內容,請使用「文字」工具,按一下文字框架中的插入點,然後選擇「編輯 > 全部選取」。

  2. 選擇「檔案 > 置入」。
  3. 尋找並選取新檔案。
  4. 確認已選取「取代選取項目」,然後按一下「開啟」。
  5. 按一下「開啟」。

您可以拷貝連結影像的完整路徑或平台樣式路徑。拷貝影像的完整路徑,對通知小組成員圖像的所在位置很有用。例如,您可以拷貝完整路徑,然後貼上至電子郵件中。拷貝平台路徑對編寫指令碼,或在資料合併中指定影像欄位很有用。

  1. 從「連結」面板中選取連結。
  2. 從「連結」面板選單中,選擇「拷貝資訊 > 拷貝完整路徑 (或拷貝平台樣式路徑)」。
  3. 貼上路徑。

編輯原始圖稿

「編輯原稿」指令可以讓您在當初建立圖形的應用程式中開啟大部分的圖形,依需求修改它們。原始檔案一旦儲存後,連結該檔案的文件就會以新版本更新。

註解:

在 InDesign 中,如果取出並選取管理圖形框架 (已轉存至 InCopy 的框架),而非圖形本身,圖形會在 InCopy 中開啟。

使用預設應用程式編輯原始圖稿

InDesign 預設為根據作業系統判斷,在開啟原始檔案時要使用哪種應用程式。

  1. 在頁面上或「連結」面板中選取一個或多個影像。
  2. 執行下列任一項作業:
    • 在「連結」面板中,按一下「編輯原稿」按鈕

    • 選擇「編輯 > 編輯原稿」。

  3. 在原始應用程式中進行變更後,請儲存檔案。

使用其他應用程式編輯原始圖稿

  1. 選取影像。
  2. 選擇「編輯 > 編輯時使用」,然後指定您要使用哪項應用程式開啟檔案。如果應用程式沒有出現,請選擇「其他」,然後瀏覽至應用程式的位置。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策