選取文字

  1. 使用「文字」工具,執行下列任一項作業:
    • 在字元、單字或整個文字區塊上拖移 I 形游標加以選取。
    • 按兩下可以選取一個單字。單字旁的空格不會被選取。
    • 按三下文字行中的任何位置可以選取整行。如果取消選取「連按三下以選取整行」偏好設定選項,則按三下會選取整個段落。

    • 如果已選取「連按三下以選取整行」選項,則在段落中的任何位置按四下可以選取整個段落。

    • 按五下可以選取整個內文,或在內文中的任何位置按一下,然後選擇「編輯 > 全部選取」。

註解:

如果選取包含註解錨點的文字,則使用以上任何程序,也會選取註解及其內容。

如果無法選取框架中的文字,該文字框可能是在鎖定圖層或在主版頁面上。請嘗試解除圖層鎖定或到主版頁面。文字框也能在其他文字框或透明物件下層。請參閱在被覆蓋的框架中選取文字

變更按三下的作用

  1. 選擇「編輯 > 偏好設定 > 文字」(Windows) 或「InDesign > 偏好設定 > 文字」(Mac OS)。
  2. 選取「連按三下以選取整行」,啟動按三下可以選取整行文字的功能 (這是預設值)。如果您希望按三下可以選取一個段落,請取消選取這個選項。

在被覆蓋的框架中選取文字

  1. 使用「選取」工具 ,按住 Ctrl 鍵 (Windows) 或 Command 鍵 (Mac OS),然後按一下以選取文字框。
  2. 選取「文字」工具,然後在文字框內按一下或選取文字。

檢視隱藏 (非列印) 字元

  1. 選擇「文字 > 顯示隱藏字元」。
  2. 若隱藏字元仍未出現,請關閉預視模式。選擇「檢視 > 螢幕模式 > 正常」,然後選擇「檢視 > 疊印預視」以取消選取該選項。

出現非列印字元 (例如空格、定位點、段落結尾、索引標記和內文結尾等字元)。您只能在文件視窗和內文編輯器視窗中看見這些特殊字元,無法使用 PDF 和 XML 等格式列印或輸出這些字元。隱藏字元的顯示顏色與圖層顏色相同。

隱藏 (上圖) 及可見 (下圖) 非列印字元
隱藏 (上圖) 及可見 (下圖) 非列印字元

Anne Marie Concepcion 在 InDesign 特殊字元的免費指南中提供完整的特殊字元清單。

隱藏字元清單

隱藏字元

代表意義

段落結尾

彈性換行

色彩空間

內文結尾

選擇性連字號

不換行連字號

Tab

右邊縮排定位點

縮排到此處

在此結束輔助樣式

非結合子

全形空格

全形空格

半形空格

不斷行空格

不斷行空格 (固定寬度)

極細空格

1/6 空格

細空格

1/4 空格

1/3 空格

標點符號空格

數字空格

段末對齊用空格

分欄符號

框架分隔符號

分頁符號

奇數頁分頁符號

偶數頁分頁符號

強制分行符號

InCopy 註解

InCopy 註解 (在「內文編輯器」中)

位置標記 (僅限 InCopy)

索引標記

索引標記 (在「內文編輯器」中)

隱藏條件文字

隱藏條件文字 (在「內文編輯器」中)

書籤或超連結目的地標記 (通常是文字錨點)

書籤或超連結目的地標記 (在「內文編輯器」中)

超連結目的地 (在「內文編輯器」中)

交互參照段落

交互參照超連結 (在「內文編輯器」中)

錨定物件

錨定物件 (在「內文編輯器」中)

XML 標記

XML 標記 (在「內文編輯器」中)

註腳 (在「內文編輯器」中)

表格 (在「內文編輯器」中)

變數 (在「內文編輯器」中)

索引標記 (在「內文編輯器」中)

新增分欄符號、框架分隔符號和分頁符號

在文字中插入特殊換行字元,控制分欄符號、框架分隔符號和分頁符號。

  1. 使用「文字」工具,在想要換行之處按一下,置入插入點。
  2. 選擇「文字 > 插入換行字元」,然後從次選單中選擇換行選項。

註解:

您也可以使用數字鍵盤上的 Enter 鍵建立換行。如需插入分欄符號,請按 Enter 鍵;如需框架分隔符號,請按 Shift+Enter 鍵;如需分頁符號,請按 Ctrl+Enter 鍵 (Windows) 或 Command+Return 鍵 (Mac OS)。

如果要移除換行字元,請選擇「文字 > 顯示隱藏字元」,以便能看見非列印字元,然後選取並刪除換行字元。

註解:

如果藉由變更段落設定建立換行 (例如在「保留選項」對話框中),換行會在含有設定的段落前面發生。如果使用特殊字元建立換行,換行會在特殊字元後面緊接著發生。

換行選項

下列選項會出現在「文字 > 插入換行字元」選單中:

分欄符號

將文字排文到目前文字框中的下一欄。如果該框架只有一欄,則文字會放入下一個串連的框架中。

框架分隔符號

無論目前文字框的欄設定為何,都會將文字排文到下一個串連的文字框。

分頁符號

將文字排文到下一個含有與目前文字框串連的文字框之頁面。

奇數頁分頁符號

將文字排文到下一個含有與目前文字框串連的文字框之奇數頁。

偶數頁分頁符號

將文字排文到下一個含有與目前文字框串連的文字框之偶數頁。

段落切換符號

插入段落切換符號 (與按 Enter 或 Return 鍵相同)。

強制分行符號 

強迫在插入字元的地方分行,並且在不新增段落的情況下另起一行 (等於按下 Shift+Enter 或 Shift+Return)。強制分行符號亦稱為彈性換行。

選擇性分行符號 

表示文字行在需要分行的時候,應該分行的地方。選擇性分行符號與選擇性連字號類似,唯一的差別是連字號不會加到斷行的地方。

在「保留選項」對話框和「段落樣式選項」對話框中,有相關的換行選項可供使用。

使用內文編輯器

在 InDesign 中,您可以在版面頁面上或內文編輯器視窗中編輯文字。在內文編輯器視窗中書寫和編輯,可讓整個內文依「偏好設定」中指定的字體、大小和間距顯示,使您不會因版面或格式設定而分心。您也可以在「內文編輯器」中檢視文字的追蹤修訂。

每個內文會顯示在不同的內文編輯器視窗中。內文中的所有文字都會顯示在內文編輯器中,包括溢排文字在內。您可以同時開啟數個內文編輯器視窗,包括相同內文的多個實例。垂直深度尺規指示有多少文字填入框架,並有一條線段指示文字溢排之處。

編輯內文時,變更會反映在版面視窗中。開啟的內文會列在「視窗」選單中。您無法在內文編輯器視窗中建立新內文。

內文編輯器視窗
內文編輯器視窗

A. 段落樣式 B. 拖移分隔線可調整欄寬 C. 垂直深度尺規 D. 溢排文字指示符 

您可以在「內文編輯器」中檢視與編輯表格,文字在其中會循序顯示於欄與列中,方便編輯。您可以快速展開或收合表格,決定要以欄或列檢視。

如果您開啟「追蹤修訂」,則「內文編輯器」也會顯示已新增、移除,或編輯過的文字。請參閱追蹤及檢視修訂

開啟內文編輯器

  1. 選取文字框,在文字框中按一下插入點,或從不同內文選取多個框架。
  2. 選擇「編輯 > 在內文編輯器中編輯」。

註解:

如果要開啟相同內文編輯器視窗的另一個實例,請使內文編輯器成為使用中,並選擇「視窗 > 排列順序 > 新增視窗」。

返回版面視窗

  1. 在「內文編輯器」中,執行下列任一項作業:
    • 選擇「編輯 > 在版面中編輯」。使用此方法時,版面檢視中顯示的文字選取範圍或插入點位置,會與內文編輯器中上次所顯示的相同,且內文視窗會保持開啟,但是移到版面視窗後面。

    • 在版面視窗中按一下。內文視窗會保持開啟,但是移到版面視窗後面。

    • 關閉內文編輯器視窗。

    • 從「視窗」選單底部選擇文件名稱。

顯示或隱藏內文編輯器項目

您可以顯示或隱藏樣式名稱欄與深度尺標、展開或收合註腳,以及顯示或隱藏分段標記,指出新段落的起點。這些設定會影響所有開啟的內文編輯器視窗,以及所有接下來開啟的視窗。

  • 在使用「內文編輯器」時,選擇「檢視 > 內文編輯器 > 顯示樣式名稱欄 (或隱藏樣式名稱欄)」。您也可以拖移垂直軸,調整樣式名稱欄的寬度。後續的內文編輯器視窗都具有相同欄寬。
  • 在使用「內文編輯器」時,選擇「檢視 > 內文編輯器 > 顯示深度尺規 (或隱藏深度尺規)」。
  • 在使用「內文編輯器」時,選擇「檢視 > 內文編輯器 > 展開所有註腳 (或收合所有註腳)。
  • 在使用「內文編輯器」時,選擇「檢視 > 內文編輯器 > 顯示分段標記 (或隱藏分段標記)」。

內文編輯器偏好設定

使用「內文編輯器顯示」偏好設定,變更內文編輯器的外觀。雖然「內文編輯器」會抑制除最基本文字樣式屬性以外的所有屬性,不過還是會呈現一些物件和屬性,包括:

屬性

圖示

表格

內嵌物件

XML 標記

變數

超連結來源

超連結錨點

交互參照

隱藏條件文字

註解

註腳

索引標記

刪除的文字

新增的文字

移動的文字

 

文字顯示選項

選擇顯示字體、大小、行距、文字顏色和背景。您也可以指定不同主題,例如「傳統系統介面」,在黑色背景上檢視黃色文字。這些設定會影響文字在內文編輯器視窗中的顯示,不會影響在版面檢視中的顯示方式。

啟動消除鋸齒

使文字的鋸齒邊緣變平滑,並選擇消除鋸齒的「類型」:「LCD 最佳化」、「輕柔」或「預設」設定。「預設」會使用灰色陰影將文字平滑化; 「LCD 最佳化」使用顏色將文字平滑化,而不是使用灰色陰影,最適合用在淺色背景、黑色文字上; 「輕柔」也是使用灰色陰影,不過可以產生比「預設」更淺、更模糊的外觀。

游標選項

變更文字游標的外觀。例如,選取「閃爍」可以使游標閃爍。

內嵌框架中的文字不會顯示在父內文編輯器視窗中,但是可以顯示在其本身的內文編輯器視窗中。

使用條件文字

條件文字是建立同一文件不同版本的一個方法。您在建立條件後,套用至一些文字範圍。接著您可以顯示與隱藏條件,建立文件的不同版本。例如,如果您在建立電腦手冊,可以為 Mac OS 和 Windows 個別建立條件。在列印 Mac OS 版本的使用手冊前,您可以顯示所有套用「Mac」條件的文字,並隱藏所有套用「Windows」條件的文字。接著您可以反轉條件狀態,列印 Windows 的使用手冊。

條件文字
顯示「條件文字」

A. 顯示所有條件 B. 條件指示符 
隱藏「條件文字」
隱藏「條件文字」

A. 隱藏「Mac」條件 B. 隱藏條件符號 

條件只能套用至文字。您可以讓錨定物件成為條件,但只能透過選取錨定物件標記的方式。您可以將條件套用至表格儲存格中的文字,但無法套用條件至表格儲存格、欄或列。您無法將條件套用至鎖定的 InCopy 內文中的文字。

規劃條件文件

使用條件文字規劃專案時,請研判文件的屬性,思考如何讓文件在交出後可以供數個人輪流使用。規劃一致性處理條件文字的方法,讓文件更容易使用與維護。使用下列指引。

版本數

定義您完成的專案要包含幾個版本。例如,如果您建立的手冊,是說明可以在 Windows 和 Mac OS 平台上執行的程式,您可能想建立至少兩個版本:一個 Windows 版本和一個 Mac OS 版本。如果您想建立這些版本,同時在審閱過程中在文字間穿插編輯注釋,您可能會想要更多版本:有注釋的 Mac OS 版本、沒有注釋的 Mac OS 版本、有注釋的 Windows 版本和沒有注釋的 Windows 版本。

對於有許多條件的文件,您可以定義條件組合。條件組合可以套用至文件,快速建立版本。

需要的條件標記

決定您建立想要的版本時,需要的條件標記數。每個版本的文件由一組唯一的條件標記組定義。例如,一個完成的 Windows 手冊版本可以定義為顯示 Windows 條件標記、隱藏 Mac OS 條件標記,以及隱藏「注釋」條件標記。在這個範例中,您需要決定是否要對 Windows 注釋與 Mac OS 注釋使用個別的條件標記,或為 Windows 和 Mac OS 注釋使用同一個條件標記。

內容組織

評估文件能設條件的幅度,以及您組織文件的方法,簡化開發與維護的工作。例如,您可以組織書冊,讓條件文字限制於少數文件中。或者,您也可以選擇將特定章節的版本存放在個別的檔案中,而不要使用條件文字,再為每個版本的書冊使用不同的書冊檔案。

在某些情況中,如當使用多種語言時,對於每個包含不同語言之文字的圖層,您可能想建立個別可以顯示或隱藏的圖層,而不要使用條件。

標記策略

決定條件文字的最小單位。例如,如果文件會轉譯為別的語言,您設為條件的文字數量最少必須是一個完整的句子。因為文字順序在轉譯時經常會變更,將句子的一部分設為條件文字會讓轉譯過程更複雜。

空格和標點符號套用的條件不一致時,可能導致多餘空格或拼字錯誤。決定是否要為空格和標點設條件。如果條件文字以標點開始或結束,就將標點也設為條件。這樣當您在檢視一個以上的版本時,會讓文字更容易閱讀。

如果要避免單字間距的問題,例如無條件的空格後面接著條件的空格,就為接著條件文字的空格設定處理標準 (永遠設條件或永遠無條件)。

如果要避免混淆,就決定條件文字顯示的順序,並在整份文件中一致使用此順序。

索引與交互參照

當為文件編輯索引時,注意索引標記是置放於條件文字內或外。請注意,產生的索引中不會包含位於隱藏的條件文字中的索引標記。

如果您建立了條件文字的交互參照,請確認來源文字有一樣的條件。例如,如果您在「Windows」段落中加入了交互參照,而文字錨點出現在「Mac」條件中,當「Mac」條件隱藏時,交互參照不會解析。在「超連結」面板中,「HT」會出現在交互參照旁邊。

如果您建立了段落的交互參照,在其中有些文字為條件,同時您還變更該條件的可見度設定,請更新交互參照。

建立條件

您建立的條件儲存在目前的文件中。如果您建立條件時沒有開啟的文件,這個條件會出現在您建立的所有新文件中。

您可以指定條件「指示符」,例如紅色波浪底線,讓條件文字易於辨認。

  1. 選擇「視窗 > 文字與表格 > 條件文字」,顯示「條件文字」面板。
  2. 從「條件文字」面板選單中選擇「新增條件」,然後輸入條件的名稱。
  3. 在「指示符」群組中,指定套用條件的指示符的外觀。

    依預設,指示符 (例如紅色波浪線) 會設為顯示在文件中,但不會列印或輸出。您可以從「條件文字」面板中的「指示符」選單選擇一個選項,隱藏指示符或將其列印與輸出,在檢閱時會很有用。

  4. 按一下「確定」。

套用條件至文字

您可以將多個條件套用至相同的文字。依預設,條件指示符會識別條件文字。然而,如果指示符是隱藏的,您可以使用「條件文字」面板判斷目前的文字上套用了哪些條件。清楚的勾選記號表示該條件已套用至目前的文字。暗灰色的勾選記號表示條件只套用至選取範圍的一部分。

  1. 選取您要套用條件的文字。
  2. 在「條件文字」面板中 (「視窗> 文字與表格 > 條件文字」),執行下列任一項作業:
    • 如果要套用條件,按一下條件,或按一下條件名稱旁邊的方框。

    • 如果要套用條件並移除文字套用的其他條件,就按住 Alt 鍵並按一下一個條件 (Windows),或按住 Option 鍵並按一下一個條件 (Mac OS)。

    • 如果要移除條件,就按一下條件名稱旁邊的方框,移除勾選記號。或者,按一下「[無條件]」,由選取的文字移除所有的條件。

註解:

您無法對特定的條件套用鍵盤快速鍵。然而,您可以使用「快速套用」套用條件。

顯示或隱藏條件

當您隱藏條件時,套用該條件的所有文字都會隱藏。隱藏條件常常會造成文件或書冊的頁碼變更。您可以使用「智慧型文字重排」功能,在隱藏與顯示條件時自動新增和移除頁面。

文件中的隱藏文字一般會受到忽略。例如,隱藏文字不會列印或轉存、隱藏的條件文字中的索引標記不會包含在產生的索引中,而且當搜尋或對文字進行拼字檢查時,隱藏的條件文字不會包含在執行的範圍內。

當您隱藏條件時,隱藏的文字會儲存在隱藏的條件符號中 。如果您選取了包含隱藏條件符號的文字並嘗試刪除,InDesign 會提示您確認要刪除隱藏的條件文字。您無法對隱藏的條件文字套用其他條件、樣式或格式設定。

如果文字套用了幾種條件,而且當一種條件為隱藏狀態時,至少有一種其他的條件為顯示狀態,文字就不會隱藏。

  • 如果要顯示或隱藏個別的條件,按一下條件名稱旁邊的可見度方框。眼睛圖示表示條件為顯示狀態。
  • 如果要顯示或隱藏所有條件,請從「條件文字」面板選單中選擇「全部顯示」或「全部隱藏」。

使用條件組合

條件組合會擷取所有條件的可見度設定,因此您可以快速套用不同的文件轉譯。例如,假設您有一份複雜的文件,其中有 Mac OS、Windows XP、Vista、UNIX 的平台條件,英文、法文、德文和西班牙文的語言條件,還有像「編輯審閱」與「內部注釋」等編輯注釋。要檢視法文的 Vista 版本時,您可以建立一個條件組合,只顯示 Vista、法文和「編輯審閱」條件,並隱藏所有其他的條件。

要達到這個目的雖然不一定需要使用條件組合,但條件組合會協助您快速可靠地變更不同的條件可見度設定。

  1. 依需要套用條件至文字。
  2. 如果「組合」選單沒有出現在「條件文字」面板中,請從「條件文字」面板選單中選擇「顯示選項」。
  3. 在「條件文字」面板中,依需要讓條件可見或隱藏。
  4. 從「組合」選單中選擇「建立新組合」,為組合指定名稱,然後按一下「確定」。

    新的組合會變成使用中的組合。

  5. 執行下列任一項作業:
    • 如果要對文件套用條件組合,請從「組合」選單中選擇條件組合名稱。

    • 如果要置換條件組合,請選取組合讓其成為使用中狀態,然後變更任何條件的可見度設定。一個加號 (+) 會出現在條件組合的旁邊。再次選擇條件組合,移除優先選項。選擇「重新定義「[條件組合]」」,使用新的可見度設定更新條件組合。

    • 如果要刪除條件組合,請選取條件組合,然後選擇「刪除「[條件組合]」」。刪除一個條件組合並不會刪除此組合的條件,也不會從任何套用此條件組合處移除條件。

管理條件

  1. 執行下列任一項作業:

    刪除條件

    選取一個條件,然後按一下「條件文字」面板底部的「刪除條件」圖示。指定一個條件,取代被刪除的條件,然後按一下「確定」。在套用已刪除條件的所有文字上,都會套用您指定的條件。

    如果要刪除多個條件,按住 Shift 鍵並按一下以選取連續的條件,或按住 Ctrl 鍵並按一下條件 (Windows) 或按住 Command 鍵並按一下條件 (Mac OS),以選取非連續的條件,再按一下「刪除條件」圖示。

    移除文字的條件

    移除文字的條件標記,和刪除文件中的標記不同。當您移除文字的標記時,標記仍然會保留在文件中,因此稍後仍然可以再次套用。

    如果要移除文字的條件,請選取文字,然後按一下條件旁邊的方框移除勾選記號,或按一下「[無條件]」,移除選取文字的所有條件。

    載入 (讀入) 條件

    從「條件文字」面板選單,選擇「載入條件」(僅載入條件) 或「載入條件與組合」。選取您想讀入條件的 InDesign 文件,然後按一下「開啟」。載入的條件和組合會取代任何有相同名稱的條件或組合。

    在 InDesign 中,您無法由 InCopy 檔案載入條件,但是在 InDesign 和 InCopy 中,您都可以由 InDesign 檔案載入條件。

    載入的組合會忽略目前「條件文字」面板中的條件可見度設定。

    在書冊中同步化條件

    如果要確認您在書冊中的所有文件都使用相同的條件,請在樣式來源文件中建立您想要的條件,然後在「同步選項」對話框中選取「條件文字設定」,再同步化書冊。

    顯示或隱藏條件指示符

    從「條件文字」面板中的「指示符」選單中選擇「顯示」或「隱藏」,顯示或隱藏條件指示符。如果您顯示了一個版本,並想要看哪些區域為條件,請顯示條件指示符。如果在檢視版面時,您覺得條件指示符令人分心,可以隱藏條件指示符。如果要列印或輸出條件指示符,請選擇「顯示及列印」。

    變更條件名稱

    在「條件文字」面板中按一下條件,暫停,再按一下條件名稱加以選取。輸入別的名稱。

    編輯條件指示符

    在「條件文字」面板中按兩下條件,或選取條件,再從面板選單中選擇「條件選項」。指定指示符設定,然後按一下「確定」。

尋找與變更條件文字

您可以使用「尋找/變更」對話框尋找套用了一或多種條件的文字,並以一或多種其他的條件取代。

  1. 顯示您想包含在搜尋中的任何條件文字。

    隱藏文字不包含在搜尋中。

  2. 選擇「編輯 > 尋找/變更」。
  3. 如果對話框底部未顯示「尋找格式」和「變更格式」方框,請按一下「更多選項」。
  4. 按一下「尋找格式」方框,顯示「尋找格式設定」方框。在「條件」下選取「[任何條件]」,搜尋套用任何條件的文字,或選取「[無條件]」,搜尋沒有套用任何條件的文字,或選取您想要搜尋的特定單一條件或多個條件。按一下「確定」。

    這項功能可以找到與選取條件完全相符的文字。例如,如果您選取了「條件 1」和「條件 2」,就不會找到只套用其中一種條件的文字,也不會找到套用這兩種條件和另一種其他條件的文字。

  5. 按一下「變更格式」方框,顯示「變更格式設定」對話框。指定不同的格式設定選項,例如條件或字元樣式,然後按一下「確定」。

    如果您在「變更格式設定」對話框中選取了「條件」區段,「[任何條件]」不會對找到的條件文字做任何變更。如果您想要套用不同的格式設定,例如字元樣式,這個選項會很有用。選取「[無條件]」由找到的文字移除所有的條件。如果您選取了特定的條件,指定您是否要取代找到的文字所套用的任何條件,或新增條件。

  6. 按一下「尋找」,然後使用「變更」、「變更/尋找」或「全部變更」按鈕以取代條件。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策