Acerca de los formularios Web

Los formularios PDF pueden ser útiles para enviar y recopilar información a través de la Web. Para ello se ofrecen varias acciones de botón que realizan funciones similares a algunas macros de secuencias de comandos HTML. El servidor Web debe disponer de una aplicación CGI (Common Gateway Interface) para recopilar y enviar los datos a una base de datos. Se puede usar cualquier aplicación CGI existente que recopile los datos de formularios (en formato HTML, FDF o XML).

Antes de preparar los formularios para la Web, compruebe que los nombres de campo de su formulario coinciden con los especificados en la aplicación CGI.

Nota:

Las secuencias de comandos CGI deben crearse fuera de Acrobat DC ya que Adobe Acrobat DC no tiene la propiedad de su creación.

Agregar la funcionalidad Enviar

Use la acción Enviar un formulario para enviar datos de formularios a una dirección de correo electrónico o a un servidor Web especificando una dirección URL. También puede usar el botón Enviar para devolver otros archivos a un servidor o a una base de datos. Por ejemplo, puede adjuntar imágenes digitalizadas o archivos a un formulario. Los archivos se envían junto con el resto de los datos del formulario al hacer clic en el botón Enviar.

Nota:

Si el formulario PDF contiene un botón de envío por correo electrónico, puede utilizar el flujo de trabajo Distribuir para facilitar la distribución del formulario a terceros.

  1. Seleccione Herramientas > Preparar formulario y, a continuación, seleccione Botón en la barra de herramientas y cree un botón.

  2. Haga doble clic en el botón para abrir el cuadro de diálogo Propiedades del botón.
  3. Haga clic en la ficha Acciones y seleccione Ratón soltado en el menú Seleccionar desencadenador.

  4. Seleccione Enviar un formulario en el menú Seleccionar acción y haga clic en Agregar.

  5. En el cuadro de diálogo Enviar selecciones de formulario, introduzca un valor en Indique una URL para este vínculo:

    • Para enviar los datos del formulario a un servidor web, escriba la dirección URL de destino.

    • Para enviar los datos de formulario a una dirección de correo electrónico, escriba mailto: seguido de la dirección. Por ejemplo, escriba mailto:nadie@adobe.com.

  6. Haga los cambios que desee en las opciones disponibles y, a continuación, haga clic en Aceptar para cerrar el cuadro de diálogo.

    Para obtener información sobre las opciones disponibles, consulte la sección siguiente.

  7. Cambie los valores de las demás fichas del cuadro de diálogo Propiedades del botón según sea necesario y, a continuación, haga clic en Cerrar.

Opciones de Enviar selecciones de formulario

FDF

Exporta el archivo al formato FDF. Puede seleccionar una o más de las opciones disponibles: datos introducidos por el usuario, comentarios y cambios incrementales al archivo PDF. La opción Cambios incrementales en el PDF es útil para exportar una firma digital de modo que sea fácil de leer y reconstruir por un servidor.

Nota:

 Si el servidor devuelve datos al usuario en formato FDF o XFDF, la URL del servidor debe acabar con el sufijo #FDF; por ejemplo, http://miservidor/cgi-bin/miarchivo#FDF.

HTML

Exporta el archivo al formato HTML.

XFDF

Exporta el archivo al formato XML. Puede exportar los datos de los campos de formulario, los comentarios, o ambos elementos.

PDF El documento completo

Exporta el archivo PDF completo que constituye el formulario. Aunque con esta acción se crea un archivo mayor que con la opción FDF, es útil para conservar las firmas digitales.

Nota:

 Si los usuarios que rellenan el formulario PDF utilizan Adobe Reader, debe elegir FDF o XFDF para la opción de Formato de exportación.

Todos los campos

Exporta todos los campos del formulario, incluso si no contienen valores.

Sólo

Exporta solo los campos de formulario que especifique haciendo clic en Seleccionar campos e indicando los que desea incluir y si desea incluir campos vacíos.

Convertir fechas al formato estándar

Exporta todas las fechas del formulario en un formato único, con independencia de cómo se introdujeran en él.

Agregar un botón Restablecer formulario

Un botón Restablecer formulario borra todos los datos que el usuario ha introducido en éste. Es similar a la función Herramientas > Preparar formulario > Más > Borrar formulario, que puede usar al crear y editar formularios Acrobat DC. Si lo desea, puede configurar el botón Restablecer para que borre sólo determinados campos.

  1. Seleccione Herramientas > Preparar formulario y, a continuación, seleccione Botón en la barra de herramientas y cree un botón.

  2. Haga doble clic en el botón para abrir el cuadro de diálogo Propiedades del botón.
  3. Haga clic en la ficha Acciones y seleccione Ratón soltado en el menú Seleccionar desencadenador.

  4. Seleccione Restablecer un formulario en el menú Seleccionar acción y haga clic en Agregar.

  5. En el cuadro de diálogo Restablecer un formulario, realice una de las acciones siguientes y haga clic en Aceptar:

    • Haga clic en las distintas casillas de verificación para seleccionar o anular la selección de los campos que el botón debe restablecer.

    • Seleccionar todo.

    La lista de la ficha Acciones muestra ahora Restablecer un formulario anidado bajo la acción Ratón soltado.

  6. Haga clic en otra ficha del cuadro de diálogo Propiedades del botón para seguir definiendo las propiedades del botón, o haga clic en Cerrar.

Adición de un botón Importar datos

Utilice la acción Importar datos de formulario para permitir a los usuarios rellenar los campos de formulario habituales, como el nombre y la dirección de correo electrónico, con datos importados de otro formulario. Los usuarios pueden utilizar también el botón Importar datos para rellenar los campos de formulario comunes con la información de su perfil personal. Sólo se actualizan los campos de formulario que coinciden. Los campos que no coinciden se ignoran. Para poder crear una acción Importar datos de formulario, configure un formulario con campos que contengan información de uso común desde el que se exportarán los datos.

Nota:

La acción Importar datos de formulario busca el archivo de datos del que se importan los datos en distintas ubicaciones en Windows y en Mac OS. En Windows, la acción Importar datos de formulario busca en la carpeta Acrobat DC o Acrobat Reader DC, la carpeta actual, la carpeta System, la carpeta Windows, Mis documentos\Adobe\Acrobat y las carpetas que figuren en la instrucción PATH. En Mac OS, la acción Importar datos de formulario busca en la carpeta Acrobat DC o Acrobat Reader DC y la carpeta Preferencias del sistema.

  1. Seleccione Herramientas > Preparar formulario y, a continuación, seleccione Botón en la barra de herramientas y cree un botón.

  2. Haga doble clic en el botón para abrir el cuadro de diálogo Propiedades del botón.
  3. Haga clic en la ficha Acciones y seleccione Ratón soltado en el menú Seleccionar desencadenador.

  4. Seleccione Importar datos de formulario en el menú Seleccionar acción y haga clic en Agregar.

  5. Busque y seleccione un archivo FDF y haga clic en Abrir.

  6. Haga clic en otra ficha del cuadro de diálogo Propiedades del botón para seguir definiendo las propiedades del botón, o haga clic en Cerrar.

Valores de exportación CGI

Un valor de exportación es la información que se envía a una aplicación CGI para identificar un campo de formulario seleccionado por el usuario. Es necesario definir un valor de exportación sólo si se cumplen los requisitos siguientes:

  • Los datos se recopilan electrónicamente en una base de datos a través de una intranet de empresa o de Internet.

  • Los datos no coinciden con el elemento designado por el campo de formulario, o el campo de formulario es un botón de radio.

    Cuando se definan valores de exportación, tenga en cuenta las pautas siguientes:

  • Utilice el valor de exportación predeterminado (Sí) para indicar que se ha seleccionado una casilla de verificación o un botón de radio.

  • Introduzca un valor de exportación para listas desplegables solo si desea que el valor sea diferente del elemento que aparece en la lista (por ejemplo, para que coincida con el nombre de un campo de formulario de una base de datos). El elemento seleccionado en la lista desplegable se utilizará como valor de exportación a menos que en el cuadro de diálogo Propiedades se especifique explícitamente un valor de exportación diferente.

  • Los botones de radio relacionados deben tener exactamente el mismo nombre de campo de formulario pero valores de exportación diferentes. De este modo se garantiza que los botones sólo se puedan seleccionar alternativamente y que en la base de datos se reciban los valores correctos.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea