Ustawianie łamania wierszy w tekście koreańskim

Ostatnia aktualizacja 9 lis 2026

Dowiedz się, jak kontrolować łamanie wierszy w tekście koreańskim, aby uzyskać bardziej zrównoważony i czytelny układ tekstu.

Opcja Łamanie wiersza tekstu koreańskiego w każdym miejscu określa sposób zawijania tekstu koreańskiego przez program Illustrator na końcu wiersza. Gdy opcja jest wyłączona, łamanie wiersza następuje tylko między słowami oddzielonymi spacjami. Słowa, które się nie mieszczą, są przenoszone do następnego wiersza. Gdy opcja jest włączona, wiersze mogą być łamane między sylabami hangul, co pomaga zmniejszyć duże odstępy między słowami. Jest to szczególnie przydatne w wąskich ramkach tekstowych lub podczas pracy z tekstem wyjustowanym.

Opcja Łamanie wiersza tekstu koreańskiego w każdym miejscu jest domyślnie wyłączona. Można ją włączyć lub wyłączyć dla poszczególnych akapitów w opcjach Tekst w menu panelu Akapit.

Wybierz obiekt tekstowy lub kliknij w akapicie, aby zastosować opcję tylko do tego akapitu.

Wybierz polecenie Okno > Tekst > Akapit, aby otworzyć panel Akapit.

W panelu Akapit wybierz opcję Więcej opcji , aby otworzyć menu panelu, a następnie wybierz opcję Łamanie wiersza tekstu koreańskiego w każdym miejscu. Znacznik wyboru oznacza, że opcja jest włączona. Wybierz ją ponownie, aby ją wyłączyć.

Menu panelu Akapit w programie Illustrator z wybraną opcją Łamanie wiersza tekstu koreańskiego w każdym miejscu.

Zapisywanie ustawienia w stylu akapitu

Stan włączenia lub wyłączenia opcji Łamanie wiersza tekstu koreańskiego w każdym miejscu jest zapisywany w stylach akapitu, dzięki czemu jeden styl może zastosować to samo zachowanie łamania wiersza do wielu akapitów jednocześnie.

Wybierz Window > Type > Paragraph Styles, aby otworzyć panel Paragraph Styles.

Aby zapisać nowy styl, wybierz opcję Utwórz nowy styl w dolnej części panelu. Aby zaktualizować istniejący styl, wybierz go, a następnie wybierz opcję Przedefiniuj styl w menu panelu.

Kliknij dwukrotnie nazwę stylu, aby otworzyć okno Opcje stylu akapitu, a następnie wybierz opcję Ustawienia składu dla języków Azji Wschodniej.

W sekcji Ustawienia składu tekstu koreańskiego zaznacz lub usuń zaznaczenie opcji Łamanie wiersza tekstu koreańskiego w każdym miejscu, a następnie wybierz przycisk OK.

Okno dialogowe Opcje stylu akapitu z włączoną opcją Koreańskie łamanie wiersza w każdym miejscu w sekcji Ustawienia kompozycji dla języków wschodnioazjatyckich.
Ustaw opcje kompozycji wschodnioazjatyckiej dla stylu akapitu.

Zachowanie wyrazów razem za pomocą opcji Bez podziału

Nawet gdy opcja Koreańskie łamanie wiersza w każdym miejscu jest włączona, można użyć opcji Bez podziału, aby zachować wybrane wyrazy lub wyrażenia w jednym wierszu.

Program Illustrator traktuje zaznaczony tekst jako jedną jednostkę.Jeśli nie mieści się na końcu wiersza, całe zaznaczenie przechodzi do następnego wiersza.

Wybierz znaki, które mają zostać zachowane razem, na przykład imię i nazwisko osoby lub liczbę z jednostką (na przykład 25 kg).

Wybierz Okno > Tekst > Znak, aby otworzyć panel Znak.

W panelu Znak wybierz Więcej opcji , aby otworzyć menu panelu, a następnie wybierz opcję Bez podziału.Znacznik wyboru wskazuje, że opcja jest włączona.Wybierz ją ponownie, aby ją wyłączyć.

Obszary kompozycji w programie Adobe Illustrator przedstawiające zawijanie tekstu koreańskiego z wyłączoną i włączoną opcją Bez podziału, wraz z opcją Bez podziału w panelu Znak.
Zastosuj opcję Bez podziału z menu panelu Znak, aby zachować wybrany tekst koreański w jednym miejscu.

Spostrzeżenie

Opcja Bez podziału zachowuje wybrany zakres jako jedną jednostkę.Jeśli zakres jest dłuższy niż jeden wiersz ramki tekstowej, wykracza poza ramkę i nie jest wyświetlany, zamiast zostać zawinięty do następnego wiersza.

Zastosuj reguły Kinsoku do tekstu koreańskiego

Gdy opcja Koreańskie łamanie wiersza w każdym miejscu jest włączona, podziały wiersza mogą nie być zgodne z regułami Kinsoku.Aby zastosować te reguły, wybierz zestaw z opcji Zestaw Kinsoku w panelu Akapit.Można również dostosować zestawy Kinsoku do potrzeb układu.

Otwieranie plików we wcześniejszych wersjach

  • Otwarcie istniejącego dokumentu w programie Illustrator 31.0 lub nowszym nie włącza automatycznie opcji Koreańskie łamanie wiersza w każdym miejscu i nie zmienia układu.
  • Jeśli dokument korzystający z tej opcji zostanie otwarty w wersji wcześniejszej niż Illustrator 31.0, zapisany układ zostanie zachowany.Jeśli tekst zostanie edytowany we wcześniejszej wersji, może zostać wyświetlone ostrzeżenie, a układ tekstu może się zmienić.
  • Aby zachować układ, edytuj plik w programie Illustrator 31.0 lub nowszym.Jeśli konieczna jest edycja we wcześniejszej wersji, pracuj na kopii i sprawdź układ tekstu po edycji pliku.