Skapa och bearbeta bildstaplar

Senast uppdaterad den 2 nov. 2026

Använd Smart Objects för att kombinera flera bilder och minska brus eller ta bort oönskade objekt i Adobe Photoshop på datorn.

Bildstaplar ger exakt kontroll över hur flera exponeringar kombineras till ett enda förbättrat resultat.

En bildstapel kombinerar flera bilder med liknande inramning men olika egenskaper till ett Smart Object. Du kan sedan använda bearbetningsalternativ för stapellägen som analyserar motsvarande px över alla lager för att skapa en komposition som eliminerar brus, förvrängning eller oönskade objekt. Bildstaplar fungerar bäst med bilder med identiska mått som har tagits från en fast synvinkel, till exempel stillbilder från ett stativ eller bildrutor från en stillastående videokamera.

Du kan skapa bildstaplar manuellt för full kontroll över lagerjustering och val av läge, eller använda skriptet Statistics för att automatisera hela arbetsflödet.

Kombinera bilder till ett flerskiktsdokument

Välj Arkiv > Skript > Läs in filer i stapel, eller kopiera varje bild manuellt som ett nytt lager.

Om ditt lager Bakgrund ingår konverterar du det till ett vanligt lager genom att högerklicka på det och välja Lager från bakgrund.

Välj Markera > Alla lager för att markera alla lager i dokumentet.

Välj Redigera > Justera lager automatiskt, sedan Auto som justeringsalternativ och välj OK.

När alla lager fortfarande är markerade väljer du Lager > Smart Objects > Konvertera till Smart Object.

Välj Lager > Smart Objects > Stapelläge och välj ett renderingsläge som Medelvärde för brusreducering eller Median för att ta bort objekt.

Rendering med stapelläge är icke-förstörande. Du kan ändra lägen när som helst för att skapa olika effekter samtidigt som originalbildens data bevaras.Vanliga användningsområden är att minska brus i kriminaltekniska, medicinska eller astrofotografiska bilder och att ta bort tillfälliga element som fotgängare eller fordon från arkitekturfotografi. Den renderade kompositionen visas direkt.

Skapa och rendera en stack med skriptet Statistics

Välj Arkiv > Skript > Statistics.

Välj ett stapelläge på menyn Choose Stack Mode och ange sedan dina källbilder genom att välja Bläddra för att välja filer eller en mapp.

Välj Attempt To Automatically Align Source Images om dina bilder behöver registreras.

Välj OK. Photoshop kombinerar bilderna till ett Smart Object och använder det valda stapelläget automatiskt.

Statistics-skriptet slutför hela arbetsflödet för att skapa och rendera stacken i en enda åtgärd.

Redigera innehållet i en bildstack

Välj Smart objekt-lagret som innehåller stacken och välj sedan Lager > Smarta objekt > Redigera innehåll.

Gör ändringar i enskilda lager i stackdokumentet och spara och stäng sedan filen för att uppdatera den renderade kompositbilden.

Ta bort stapelåtergivning

Välj Smart Object-lagret och välj sedan Lager > Smarta objekt > Stapelläge > Inget.

Om du tar bort stapelläget förblir Smart objekt intakt, men kompositrenderingen inaktiveras och endast det främsta lagret visas.

Konvertera en stack till ett vanligt lager

Välj Lager > Smarta objekt > Rastrera för att permanent tillämpa den aktuella stackrenderingen och konvertera det smarta objektet till ett standardlager.

Duplicera Smart objekt-lagret innan du rastrerar, så att du kan rendera om stacken med olika lägen senare.