Skapa och hantera lagerkompositioner

Senast uppdaterad den 2 nov. 2026

Capture flera designvariationer i en enda fil med hjälp av ögonblicksbilder av lagers synlighet, position och utseende.

Layer Comps låter dig visa flera designvariationer för kunder utan att skapa separata filer för varje version.

En lagerkomposition är en ögonblicksbild av panelen Layers vid en viss tidpunkt.Använd Layer Comps när du behöver visa olika layoutalternativ, färgscheman eller innehållsarrangemang i ett och samma dokument. Varje lagerkomposition kan registrera lagers synlighet (visa eller dölja lager), lagerposition, lagers utseende (stilar och blandningsläge) och lagerkompositionsmarkeringar för Smart Object.Layer Comps fungerar bäst när du vill utforska designalternativ innan du färdigställer din komposition.

Skapa en ny lagerkomposition

Välj Window > Layer Comps för att öppna panelen Layer Comps .

Ordna lagren så att de motsvarar det designläge du vill fånga.

Välj knappen Create New Layer Comp längst ned i panelen Layer Comps .

Ange ett beskrivande namn och valfria kommentarer i dialogrutan New Layer Comp .

Välj vilka lageregenskaper som ska registreras: Visibility, Position, Appearance (Layer Style) eller Layer Comp Selection For Smart Objects.

Välj OK.

De alternativ du väljer blir standardinställningar för framtida Layer Comps.

Tips

Duplicera en befintlig komposition genom att dra den till alternativet Create New Layer Comp i panelen Layer Comps.

Använda och visa lagerkompositioner

Öppna panelen Layer Comps genom att välja Window > Layer Comps.

Välj Apply Layer Comp på snabbmenyn för Layer Comps.

Använd kontrollerna Previous och Next längst ned i panelen för att växla mellan alla eller specifika kompositioner.

Välj alternativet Apply Layer Comp för att återställa dokumentet.

Uppdatera en lagerkomposition

Välj den lagerkomposition som ska uppdateras i panelen Lagerkompositioner.

Gör ändringar i lagrets synlighet, position eller utseende i panelen Layers.

Välj Layer Comp Options på menyn för panelen Layer Comps om du behöver ändra vilka egenskaper kompositionen registrerar.

Välj knappen Update Layer Comp längst ned i panelen Layer Comps.

Använd lagerkompositioner i smarta objekt

När du placerar ett dokument som innehåller lagerkompositioner som ett Smart Object i ett annat dokument kan du komma åt de lagerkompositionerna utan att öppna källfilen. Det gör att du kan växla mellan designvariationer på Smart Object -nivå.

Välj lagret Smart Object i panelen Lager i dokumentet.

Öppna panelen Egenskaper genom att välja Fönster > Egenskaper.

Välj den lagerkomposition du vill visa på menyn Lagerkomposition i panelen Egenskaper.

Menyn Lagerkomposition i egenskapspanelen i Adobe Photoshop visar en lista med lagerkompositioner med särskilda alternativ.

Det smarta objektet uppdateras så att den valda kompositionen visas, samtidigt som alla transformeringar eller effekter du har tillämpat på det bevaras.

Radera lagerkompositionsvarningar

En varningsikon visas bredvid en lagerkomposition när du tar bort, sammanfogar eller konverterar lager som kompositionen refererar till.Kompositionen kan inte längre återställas helt till sitt ursprungliga läge.

Välj varningsikonen bredvid kompositionsnamnet om du vill visa det specifika problemet.

Välj Rensa i meddelandet för att ta bort varningen och bevara återstående lageregenskaper.

Högerklicka på varningsikonen och välj Rensa varning för lagerkomposition för att rensa en enskild varning eller Rensa alla varningar för lagerkompositioner för att rensa alla varningar samtidigt.

Du kan också uppdatera kompositionen till dess aktuella läge eller ignorera varningen om du inte behöver informationen om det saknade lagret.

Ta bort en lagerkomposition

Markera lagerkompositionen på panelen Lagerkompositioner.

Välj ikonen Ta bort längst ned i panelen eller dra kompositionen till ikonen Ta bort.

Välj Ta bort lagerkomposition på panelmenyn om du vill använda en alternativ metod.

Exportera lagerkompositioner till filer

Välj Arkiv > Exportera > Lagerkompositioner till filer.

Välj målmapp i dialogrutan.

Välj filformat för dina exporterade kompositioner.

Välj Kör för att skapa enskilda filer för varje lagerkomposition.

Varje lagerkomposition exporteras som en separat fil med kompositionsnamnet tillagt i filnamnet.