堆疊物件

在圖層中,Animate 會根據物件建立的順序堆疊物件,並將最新建立的物件放在堆疊的最上方。物件的堆疊順序會決定物件重疊時的外觀。您可以隨時更改物件的堆疊順序。

繪製完成的線段和形狀,一定會出現在堆疊的群組和元件下面。若要將它們在堆疊中的順序往前移,必須將它們群組起來,或是將它們變成元件。

圖層也會影響堆疊順序。圖層 2 上的所有項目都會出現在圖層 1 上所有項目的前面,以此類推。若要更改圖層順序,請將時間軸上的圖層名稱拖曳到新位置。

  1. 選取物件。
  2. 請執行下列其中一項:
    • 選取「修改 > 排列 > 移至最前面」或「修改 > 排列 > 移至最後面」,將物件或群組移至堆疊順序的最前面或最後面。

    • 選取「修改 > 排列 > 往前移」或「修改 > 排列 > 往後移」,將物件或群組在堆疊順序中往前或往後推一個位置。

如果選取的群組超過一個,群組會移動到所有未選取群組的前面或後面,同時保持彼此之間的相對順序。

對齊物件

「對齊」面板可以讓您沿著水平軸或垂直軸,對齊選取的物件。您可以沿著選取物件的右邊、中心或左邊來垂直對齊物件,或是沿著選取物件的頂邊、中心或底邊來水平對齊物件。

如需關於使用 Animate 中的版面工具的教學課程,請參閱 Animate 教學課程頁面中的「使用版面工具」。

  1. 選取要對齊的物件。
  2. 選取「視窗 > 對齊」。
  3. 若要套用相對於「舞台」尺寸的對齊修改,請在「對齊」面板中選取「對齊舞台」。
  4. 若要修改選取的物件,請選取對齊按鈕。

群組物件

若要將多個元素當成單一物件加以操作,請將這些元素群組起來。例如,在建立繪圖之後,您可以將這些繪圖元素群組起來,如此一來即可輕鬆地選取或移動整個繪圖物件。

選取某個群組時,「屬性」檢測器會顯示該群組的 xy 座標及其像素尺寸。

您不必解散群組,就可以編輯群組。同時,您也不必解散這些群組物件,就可選取群組中的單一物件加以編輯。

  1. 選取要加以群組的物件。您可以選取形狀、其他群組、元件、文字等等。
    • 若要將物件加以群組,請選取「修改 > 群組」,或按 Control+G (Windows) 或 Command+G (Macintosh)。

    • 若要解散群組物件,請選取「修改 > 解散群組」,或按 Control+Shift+G (Windows) 或 Command+Shift+G (Macintosh)。

編輯群組或群組中的物件

  1. 選取群組,然後選取「編輯 > 編輯選取項目」,或用「選取」工具在該群組上按兩下。

    頁面上不屬於群組的項目都會變成灰色,表示無法存取該群組以外的元素。

  2. 請對群組內的任何一個元素進行編輯。
  3. 選取「編輯 > 編輯全部」,或用「選取」工具在「舞台」上的空白處按兩下。

    Animate 會將該群組還原至原本的單一項目狀態,這樣就可以處理「舞台」上的其他元素。

打散群組和物件

若要將群組、實體和點陣圖分散成已解散群組並可編輯的元素,您就必須將它們打散,這可以大大地減少所匯入圖像的檔案大小。

雖然您可以在將群組或物件打散之後立即選取「編輯 > 還原」,但打散命令不能完全復原。打散對物件的影響如下:

  • 切斷元件實體與其主元件的連結。

  • 放棄動畫元件中所有的影格,除了目前的影格以外。

  • 將點陣圖轉換成填色。

  • 套用到文字區塊時,將每個字元放入不同的文字區塊。

  • 套用至單一文字字元時,將字元轉換成外框。

    請勿混淆「打散」命令與「解散群組」命令。「解散群組」命令會將已經過群組的物件分離開來,讓群組元素回到群組之前的狀態。但它不會打散點陣圖、實體或類型,也不會將類型轉換成圖像外框。

  1. 選取想要打散的群組、點陣圖或元件。
  2. 選取「修改 > 打散」。

註解:

我們不建議您將動畫元件或漸變動畫內的群組打散,因為這可能會產生無法預期的結果。打散複雜的元件和大型文字區塊可能會花上一段時間。您可能需要增加應用程式的記憶體配置,才能正確打散複雜的物件。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策