還原、重做和操作記錄面板

  1. Adobe Animate 使用手冊
  2. Animate 簡介
    1. Animate 的新功能
    2. 視覺詞彙
    3. Animate 系統需求
    4. Animate 鍵盤快速鍵
    5. 在 Animate 中使用多個檔案類型
  3. 動畫
    1. Animate 中的動畫基本概念
    2. 如何在 Animate 中使用影格及關鍵影格
    3. Animate 中的逐格動畫
    4. 如何在 Animate 中使用傳統補間動畫
    5. 筆刷工具
    6. 移動導引線
    7. 移動補間動畫與 ActionScript 3.0
    8. 關於移動補間動畫
    9. 移動補間動畫
    10. 建立移動補間動畫
    11. 使用屬性關鍵影格
    12. 使用補間動畫將位置製成動畫
    13. 如何使用移動編輯器編輯移動補間動畫
    14. 編輯補間動畫的移動路徑
    15. 操作移動補間動畫
    16. 新增自訂加/減速
    17. 建立和套用移動預設效果
    18. 設定動畫補間動畫範圍
    19. 使用儲存為 XML 檔案的移動補間動畫
    20. 移動補間動畫與傳統補間動畫
    21. 形狀補間動畫
    22. 在 Animate 中使用骨塊工具動畫
    23. 在 Animate 進行角色製作
    24. 如何在 Adobe Animate 中使用遮色片圖層
    25. 如何在 Animate 中使用場景
  4. 互動
    1. 如何使用 Animate 建立按鈕
    2. 將 Animate 專案轉換成其他文件類型格式
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 在 Animate 中使用程式碼片段增加互動功能
    5. 建立自訂 HTML5 組件
    6. 在 HTML5 Canvas 中使用組件
    7. 建立自訂組件:範例
    8. 自訂組件的程式碼片段
    9. 最佳作法 - 使用 Animate 做廣告
    10. 虛擬實境編寫和發佈
  5. 工作區和工作流程
    1. 建立和管理繪圖筆刷
    2. 在 HTML5 Canvas 文件中使用 Google 字體
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作區
    6. 在 HTML5 Canvas 文件中使用網頁字體
    7. 時間軸與 ActionScript
    8. 使用多重時間軸
    9. 設定偏好設定
    10. 使用 Animate 編寫面板
    11. 使用 Animate 建立時間軸圖層
    12. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    13. 移動和複製物件
    14. 範本
    15. Animate 中的尋找和取代
    16. 還原、重做和操作記錄面板
    17. 鍵盤快速鍵
    18. 如何在 Animate 中使用時間軸
    19. 建立 HTML 擴充功能
    20. 影像和 GIF 動畫的最佳化選項
    21. 匯出影像和 GIF 的設定
    22. Animate 中的資源面板
  6. 多媒體和視訊
    1. 在 Animate 中變形及結合圖像物件
    2. 在 Animate 中建立並使用元件實體
    3. 影像描圖
    4. 如何在 Adobe Animate 中使用聲音
    5. 匯出 SVG 檔案
    6. 建立要在 Animate 中使用的視訊檔案
    7. 如何在 Animate 增加視訊
    8. 使用視訊提示點
    9. 使用 Animate 繪製及建立物件
    10. 調整線條和形狀
    11. 使用 Animate CC 中的筆畫、填色和漸層
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的色彩面板
    14. 使用 Animate 開啟 Flash CS6 檔案
    15. 在 Animate 中使用傳統文字
    16. 將圖案放入 Animate 中
    17. Animate 中匯入的點陣圖
    18. 3D 圖像
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 繪製線條和形狀
    21. 使用 Animate 中的元件庫
    22. 匯出聲音
    23. 在 Animate CC 中選取物件
    24. 在 Animate 中使用 Illustrator AI 檔案
    25. 使用噴刷工具套用圖樣
    26. 套用混合模式
    27. 排列物件
    28. 使用命令選單自動執行工作
    29. 多國語言文字
    30. 使用 Animate 中的攝影機
    31. 搭配使用 Animate 與 Adobe Scout
    32. 使用 Fireworks 檔案
    33. 圖像濾鏡
    34. 聲音和 ActionScript
    35. 繪圖偏好設定
    36. 使用鋼筆工具繪圖
  7. 平台
    1. 將 Animate 專案轉換成其他文件類型格式
    2. 自訂平台支援
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 建立並發佈 WebGL 文件
    5. 如何封裝 AIR for iOS 的應用程式
    6. 發佈 AIR for Android 應用程式
    7. Adobe AIR for Desktop 的發佈功能
    8. ActionScript 發佈設定
    9. 最佳作法 - 在應用程式中組織 ActionScript
    10. 如何搭配使用 ActionScript 與 Animate
    11. 最佳作法 - 輔助功能原則
    12. Animate 工作區中的輔助功能
    13. 撰寫和管理指令碼
    14. 啟用自訂平台的支援
    15. 自訂平台支援概觀
    16. 建立輔助功能內容
    17. 使用自訂平台支援外掛程式
    18. ActionScript 3.0 的除錯
    19. 啟用自訂平台的支援
  8. 匯出與發佈
    1. 如何從 Animate CC 匯出檔案
    2. OAM 發佈
    3. 匯出 SVG 檔案
    4. 使用 Animate 匯出圖像和視訊
    5. 發佈 AS3 文件
    6. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    7. 匯出聲音
    8. 匯出 QuickTime 視訊檔
    9. 使用 ActionScript 控制外部視訊播放
    10. 最佳作法 - 建立行動裝置內容的秘訣
    11. 最佳作法 - 視訊慣例
    12. 最佳作法 - SWF 應用程式編寫原則
    13. 最佳作法 - 建構 FLA 檔
    14. 最佳化 Animate 的 FLA 檔案的最佳作法
    15. ActionScript 發佈設定
    16. 指定 Animate 的發佈設定
    17. 匯出放映檔
    18. 匯出影像和 GIF 動畫
    19. HTML 發佈範本
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和發佈您的動畫

還原、重做和重複命令

若要針對個別的物件或目前文件內的所有物件還原或重做動作,請指定物件層級或文件層級的「還原」和「重做」命令 (「編輯 > 還原」或「編輯 > 重做」)。預設行為指令為文件層級「還原」和「重做」。

若要選擇物件層級或文件層級還原選項,請執行下列動作:

  1. 在 Animate CC 中,選取「編輯 > 偏好設定」。
  2. 在「一般」索引標籤上,選取「還原」下拉式清單中的「物件層級還原」。

請注意,使用物件層級「還原」時,無法還原某些動作。這些動作包括進入和退出「編輯」模式;選取、編輯和移動元件庫項目;以及建立、刪除和移動場景。

若要將步驟重新套用至相同或不同的物件,請使用「重複」命令。例如,如果您移動了名稱為 shape_A 的形狀,則可以選取「編輯 > 重複」以再次移動該形狀,或是選取另一個名稱為 shape_B 的形狀,並選取「編輯 > 重複」,將第二個形狀移動相同的單位。

根據預設,Animate 可提供「還原」選單命令 100 層的還原支援。請在 Animate 的「偏好設定」中選取還原及重做的層數 (2 至 300)。

根據預設,使用「編輯 > 還原」或「操作記錄」面板還原步驟時,文件的檔案大小不會變更,即使您刪除了文件中的項目亦然。例如,如果在文件中匯入視訊檔案,然後還原匯入動作,則這份文件的檔案大小仍然包括該視訊檔案的大小。執行「還原」命令時,從文件中刪除的所有項目都會保留下來,以讓您稍後使用「重做」命令復原這些項目。

使用操作記錄面板

「操作記錄」面板 (「視窗 > 操作記錄」) 的清單內會顯示從建立或開啟作用中文件開始,在該文件中執行過的步驟,並以指定的最大步驟數目作為上限 (「操作記錄」面板不會顯示您在其他文件中執行過的步驟)。「操作記錄」面板中的滑動軸一開始是指向您執行過的最後一個步驟。

  • 若要還原或重做個別步驟,或是一次還原或重做多個步驟,請使用「操作記錄」面板。您可以將「操作記錄」面板中的步驟套用至文件中的相同物件或不同物件。但是,無法重新安排「操作記錄」面板中的步驟順序。「操作記錄」面板會依照步驟執行的順序進行記錄。

    注意:若您在文件中還原了一個步驟或一系列的步驟,接著又執行了新的步驟,就無法在「操作記錄」面板重做這些步驟;這些步驟會從面板中消失。

  • 根據預設,Animate 可提供「操作記錄」面板 100 層的還原支援。請在 Animate 的「偏好設定」中選取還原及重做的層數 (2 至 300)。

  • 若要刪除目前文件的操作記錄清單,請清除「操作記錄」面板。清除操作記錄清單後,無法還原已經清除的步驟。清除操作記錄清單並不會還原步驟,只是將這些步驟的記錄從目前文件的記憶體中移除。

關閉文件時,也會一併清除操作記錄。若要在關閉文件後使用該文件中的步驟,請使用「複製步驟」命令,或是將這些步驟儲存成一道命令。

透過操作記錄面板還原步驟

還原步驟時,該步驟將會在「操作記錄」面板中呈現暗灰色。

  • 若要還原最後一個執行的步驟,請將「操作記錄」面板的滑動軸在清單中向上拖曳一個步驟。

  • 若要一次還原多個步驟,請拖曳滑動軸以指向任一個步驟,或沿著滑動軸的路徑,按一下該步驟的左邊。滑桿會自動捲動至該步驟,並隨著捲動還原後續的所有步驟。

注意:捲動至步驟 (並選取後續幾個步驟) 和選取個別步驟是不同的。若要捲動至某個步驟,請按一下該步驟的左邊。

使用操作記錄面板重播步驟

使用「操作記錄」面板重播步驟時,播放的步驟是「操作記錄」面板中選取的步驟 (以反白顯示);滑桿目前正指向的步驟則不一定會播放。

您可以將「操作記錄」面板中的步驟套用至您在文件中選取的任何物件。

重播一個步驟

  1. 請在「操作記錄」面板中選取一個步驟,接著按一下「重播」按鈕。

重播一系列連續的步驟

  1. 請執行下列步驟之一,在「操作記錄」面板中選取步驟:
    • 自某個步驟拖曳至另一個步驟。(不要拖曳滑動軸,請從某個步驟的文字標籤拖曳至另一個步驟的文字標籤)。

    • 選取第一個步驟,然後按 Shift + 按一下最後一個步驟;或是選取最後一個步驟,然後按 Shift + 按一下第一個步驟。

  2. 按一下「重播」。這些步驟將會依照順序進行重播,而一道標記為「重播步驟」的新步驟將會出現於「操作記錄」面板中。

重播非連續步驟

  1. 在「操作記錄」面板中選取步驟,然後按 Control + 按一下 (Windows) 或 Command + 按一下 (Macintosh),並在其他幾個步驟上按一下。若要取消選取所選取的步驟,請按 Control + 按一下或按 Command + 按一下。
  2. 按一下「重播」。

在文件間複製和貼上步驟

每一份已開啟的文件都有獨立的步驟操作記錄。若要複製文件中的步驟,並將其貼到另一份文件中,請使用「操作記錄」面板選項選單中的「複製步驟」命令。若您將步驟複製至文字編輯器中,則這些步驟將以 JavaScript™ 程式碼的形式貼上。

  1. 在含有要重複使用之步驟的文件中,選取「操作記錄」面板中的這些步驟。
  2. 在「操作記錄」面板的選項選單中,選取「複製步驟」。
  3. 開啟要將步驟貼入其中的文件。
  4. 選取要套用步驟的物件。
  5. 選取「編輯 > 貼上」,貼上這些步驟。當步驟貼入文件的「操作記錄」面板時,便會播放這些步驟。這些步驟在「操作記錄」面板中僅會顯示為一道名為「貼成步驟」的步驟。
Adobe 標誌

登入您的帳戶