Animate 工作區中的編寫面板具備編寫和發佈控制項,您可以根據您的喜好來安排這些控制項。此外,您也可以將任何面板拖離原本的位置、調整面板大小,並將面板放在畫面上的任何位置,以便取用。Animate 的彈出式選單也可讓您選擇將面板鎖定在畫面上的任何特定位置。如果鎖定,工作時若不小心拖曳面板,它也不會移動。 

具有鎖定選項的 Animate 面板
具有鎖定選項的 Animate 面板

關於屬性檢測器

「屬性」檢測器讓存取最常用的目前選取範圍特質更容易,包括舞台上和時間軸中的選取範圍特質。您可以在「屬性」檢測器中修改物件或文件的特質,而不需存取同時控制這些特質的選單或面板。

依目前選取的選項而定,「屬性」檢測器會顯示文件、文字、元件、形狀、點陣圖、視訊、群組、影格或工具的資訊與設定。當選取兩個或更多不同類型的物件時,「屬性」檢測器會顯示所選取物件的總數。

如果要顯示「屬性」檢測器,請選取「視窗 > 屬性」,或按 Control+F3 (Windows) 或 Command+F3 (Macintosh)。

Animate 2020 版提供現代化「屬性」檢測器,其中包含「工具」、「物件」、「影格」和「文件」四個索引標籤。每個索引標籤會對應至目前選取範圍的屬性。 

工具 - 表示選取的目前工具。如果工具沒有有效的 PI,則會顯示「文件」PI,並停用「工具」PI 索引標籤。此索引標籤會參照目前所選工具的屬性。

物件 - 表示舞台上所選的目前物件。如果未選取任何物件,則會停用此索引標籤。此索引標籤會參照目前所選物件的屬性。

影格 - 表示時間軸中所選的目前影格。如果未選取任何影格,則會停用此索引標籤。此索引標籤會參照目前所選影格的屬性。

文件 - 表示您正在處理的目前文件。此索引標籤會概述目前開啟之文件的特定屬性。

Doc-PI
文件屬性檢測器
工具屬性檢測器
工具屬性檢測器
影格 PI
影格屬性檢測器
物件 PI
物件屬性檢測器

屬性面板的其他屬性

移駐夾
可拖曳的區段

可拖曳的區段

「屬性」檢測器的區段現在可以拖曳和重新排列。將游標停留在可拖曳的區段上方時,就會出現移駐夾。

快速動作區段
快速動作區段

快速動作工具列

「屬性」面板具有新的快速動作區段和重整的標題區段,讓您可以探索並快速存取各種模式和相關的功能。

重整的標題區段
點陣圖的重整標題區段
現代化濾鏡設定
現代化濾鏡設定

現代化濾鏡設定

「濾鏡」區段已經升級,可讓您更輕鬆地套用濾鏡組合。此外,將一個濾鏡拖曳到另一個濾鏡的上方或下方,即可變更濾鏡的順序。  

顏色和樣式
顏色和樣式

現代化填色和筆畫

  • 「填色和筆畫」區段已重新命名為「顏色和樣式」。 
  • 「填色和筆畫」的 Alpha 選項顏色已預先增加,以便存取。
  • 為了提供不雜亂、不麻煩的使用體驗,「筆畫」設定中較少使用的選項已經移到「樣式」描述檔選項和「寬度」描述檔選項的 ... 圖示。按一下 ... 圖示即可選取這些選項。
  • 「端點」和「接合」選項已預先提供存取。
  • 「筆畫」選項或/及「填色」選項會根據選取的物件部分來顯示。 

移除補間動畫選項

移除補間動畫
移除補間動畫

「屬性」檢測器內的「補間動畫」區段現在具有移除補間動畫的選項。

符合內容選項

符合內容選項
符合內容選項

現在只要按一下文件設定區段,就能使用「符合內容」選項。

更新的攝影機工具 PI

更新的攝影機選項
更新的攝影機選項

「攝影機」現在具有所有的顏色特效和濾鏡。

更新的多邊星型、矩形、橢圓形、文字和魔術棒工具屬性

「屬性」檢測器面板已為「多邊星型工具、「矩形工具」、「橢圓形工具」、「文字工具」和「魔術棒工具」進行現代化,以便存取並提供不雜亂的使用者介面。

多邊星型
多邊星型
靜態文字
靜態文字

關於元件庫面板

「元件庫」面板 (「視窗 > 元件庫」) 是供您儲存與組織在 Animate 中所建立的元件的地方。您也可以儲存匯入的檔案,包括點陣圖像、聲音檔與視訊片段。「元件庫」面板可以讓您在資料夾中組織元件庫項目;它也讓您查看項目在文件中的使用頻率,以及根據名稱、類型、日期、使用次數或 ActionScript® 連結識別名稱來排序項目。例如,當您匯曾 GIF 動畫時,程式會在根資料底下建立名為 GIF 的資料夾,並將檔案放入其中。您也可以在搜尋欄位中輸入元件名稱或連結名稱來搜尋「元件庫」面板,還設定多數多物件選取範圍的屬性。

已選取音效剪輯的「元件庫」面板
已選取音效剪輯的「元件庫」面板

關於動作面板

「動作」面板可供您建立與編輯物件或影格的 ActionScript 程式碼。選取影格、按鈕或影片片段實體,即可讓「動作」面板變成作用中。依所選取的項目而定,「動作」面板標題會變成「按鈕動作」、「影片片段動作」或「影格動作」。

顯示影格 stop() 動作的「動作」面板。
顯示影格 stop() 動作的「動作」面板。

若要顯示「動作」面板,請選取「視窗 > 動作」或按 F9。如需「動作」面板的詳細資訊,請參閱動作面板概觀

使用影片結構檢視器 (已於 Animate 中被取代)

「影片結構檢視器」可以讓您檢視或組織文件的內容以及選取文件中要修改的元素。它包含一份目前已使用元素的顯示清單,排列於可瀏覽的階層式樹狀結構中。

使用「影片結構檢視器」執行下列動作:

  • 篩選文件裡要在「影片結構檢視器」中顯示的項目類別。

  • 您可以將選取的類別顯示為場景、元件定義或兩者。

  • 展開和收合可瀏覽的樹狀結構。

  • 依照名稱搜尋文件中的元素。

  • 熟悉其他開發人員所建立的 Animate 文件結構。

  • 找出特定元件或動作的所有實體。

  • 列印目前顯示在「影片結構檢視器」中的可瀏覽顯示清單。

「影片結構檢視器」具有「面板」選單以及快顯選單,兩者所提供的選項可以操作已選取的項目或修改「影片結構檢視器」的顯示方式。「影片結構檢視器」面板下方的三角形核取標記表示「面板」選單。

註解:

使用螢幕時,「影片結構檢視器」的功能有些許差異。

檢視影片結構檢視器

  1. 選取「視窗 > 影片結構檢視器」。

篩選影片結構檢視器中顯示的項目類別

  • 若要顯示文字、元件、ActionScript、已匯入的檔案或影格與圖層,請按一下「顯示」選項右方的一個或多個篩選按鈕。若要自訂顯示的項目,請按一下「自訂」按鈕。若要檢視這些元素,在「影片結構檢視器設定」對話方塊中的「顯示」區域中選取選項。

  • 如果要顯示場景中的項目,請從「影片結構檢視器面板」選單中選取「顯示影片元素」。

  • 如果要顯示元件的資訊,請從「影片結構檢視器面板」選單中選取「顯示元件定義」。

註解:

「影片元素」及「元件定義」兩個選項可以同時設定為作用中的選項。

使用尋找方塊搜尋項目

  1. 在「尋找」方塊中,輸入該項目的名稱、字體名稱、ActionScript 字串或影格編號。「尋找」功能會搜尋顯示在「影片結構檢視器」中的所有項目。

選取影片結構檢視器中的項目

  1. 在瀏覽樹狀結構中按一下該項目。Shift + 按一下可以選取一個以上的項目。

    選取項目的完整路徑會出現在「影片結構檢視器」的底部。在「影片結構檢視器」中選取場景時,會將該場景的第一個影格顯示於舞台上。若您並未鎖定含有元素的圖層,則當您在「影片結構檢視器」中選取該元素時,便會將舞台上的該元素一併選取。

使用影片結構檢視器面板選項或快顯選單命令

  1. 請執行下列其中一項:
    • 如果要檢視「面板」選單,請按一下「影片結構檢視器」面板中的「面板」選單控制項。

    • 若要檢視快顯選單,請在「影片結構檢視器」瀏覽樹狀結構中的項目上按一下右鍵 (Windows) 或按 Ctrl + 按一下 (Macintosh)。

  2. 從選單中選取選項:

    前往位置

    會跳到文件中所選取的圖層、場景或影格上。

    前往元件定義

    會跳到在「影片結構檢視器」的「影片元素」區域中所選取元件的元件定義上。元件定義會列出與該元件關聯的所有檔案 (您必須先選取「顯示元件定義」選項。請參閱本清單中的定義)。

    選取元件實體

    會跳到包含您在「影片結構檢視器」的「元件定義」區域中選取的元件實體的場景上 (您必須先選取「顯示影片元素」選項)。

    在元件庫中顯示

    在文件的元件庫中將選取的元件反白標示 (如果「元件庫」面板沒有出現,Animate 會將它開啟)。

    重新命名

    可以讓您為選取的元素輸入新名稱。

    在原地編輯

    可以讓您編輯舞台上選取的元件。

    在新視窗中編輯

    可以讓您在新視窗中編輯選取的元件。

    顯示影片元素

    顯示文件中已組織成場景的元素。

    顯示元件定義

    顯示與元件相關的所有元素。

    複製所有文字到剪貼簿

    它會複製選取的文字到剪貼簿。如果要於拼字檢查或其他編輯動作,請將文字貼入外部文字編輯程式。

    剪下、複製、貼上與清除

    在選取的元素上執行這些常用的功能。修改顯示清單中的項目時,也會修改文件中的對應項目。

    展開分支

    展開選取元素的瀏覽樹狀結構。

    收合分支

    收合選取元素的瀏覽樹狀結構。

    收合其他分支

    收合不包含選取元素的瀏覽樹狀結構分支。

    列印

    列印目前顯示在「影片結構檢視器」中的階層式顯示清單。

使用 Animate 組件和組件面板

Animate 中的組件是可重複使用、封裝的模組,可將特定的功能新增至 Animate 文件。組件可以包括圖像及程式碼,所以是預先建立的功能,您可以輕鬆地包含在您的 Animate 專案中。例如,組件可以是選項按鈕、對話方塊、預先載入列。它也可以是沒有圖像的東西,例如計時器、伺服器連線公用程式,或是自訂的 XML 剖析器。

如果比較缺乏編寫 ActionScript 的經驗,您可以將組件新增到文件中,然後在「屬性」檢測器或「組件」檢測器中設定其參數。使用「行為」面板處理其事件。使用「行為」面板處理其事件。例如,您可以將「前往網頁」行為指令附加到按鈕組件。可在按下按鈕時在網頁瀏覽器中開啟一個 URL,而不需要編寫任何 ActionScript 程式碼

如果您是想要建立更穩定應用程式的程式設計人員,您可以用動態方式建立組件。在執行階段使用 ActionScript 設定屬性和呼叫方法,並使用事件偵聽程式模型來處理事件。

使用組件面板插入組件

當您第一次將組件加入到文件時,Animate 會以影片片段的格式將它匯入「元件庫」面板。您也可以直接將「組件」面板中的組件拖曳到「元件庫」面板,然後將它的實體加入「舞台」中。無論是哪一種作法,您都必須先將組件加入元件庫,才可以存取它的類別元素。

  1. 選取「視窗 > 組件」面板。

  2. 選取「組件」面板中的組件實體,然後拖曳至「舞台」或「元件庫」面板。將組件新增到元件庫中後,您就可以將多個實體拖曳到「舞台」上。
  3. 使用「屬性」檢測器或「組件」檢測器,依需要設定組件。如需有關組件所使用的參數的詳細資訊,請參閱 Animate 文件中,與您所使用 ActionScript 版本相關的適當組件文件。

使用組件參數面板

Animate 設計人員可以將他們的外部組件匯入到 Animate,並使用外部組件建置動畫。為了讓工作流程變得更容易,Animate 提供組件參數區段做為面板。這項功能讓您可以調整或移動 Animate 配置環境中的面板。按一下面板右上角的漢堡圖示,也可將面板鎖定在畫面上的某個位置。從選單選取鎖定選項。

使用「屬性」檢測器中的「顯示參數」按鈕或使用「視窗 > 組件參數」,可開啟此面板。對話方塊中可加入參數的值。

「顯示參數」按鈕
「顯示參數」按鈕
組件參數面板
組件參數面板

此外,HTML5 自訂組件開發人員可以使用以 HTML/CSS 為基礎的使用者介面做為參數。

關於網路服務面板

(已於 Animate 中被取代) 您可以在「網路服務」面板中,檢視網路服務的清單、重新整理網路服務,以及新增或移除網路服務。請按一下「視窗 > 其他面板 > 網路服務」。在「網路服務」面板中新增網路服務後,您所建立的任何應用程式都能使用該項服務。

在「網路服務」面板中,您可以按一下「重新整理網路服務」按鈕,即可一次重新整理所有網路服務。如果您沒有使用「舞台」而是撰寫 ActionScript 程式碼,那麼您可以使用「網路服務」面板來管理網路服務。