使用元件庫

Animate 文件中的元件庫可儲存您在 Animate 編寫環境中所建立的媒體資源,或是將之匯入以便運用在文件中。您可以使用 Animate 直接建立向量圖案或文字;匯入向量圖案、點陣圖、視訊與聲音,以及建立元件。元件是建立之後便能多次重複使用的圖像、按鈕、影片片段或文字。您也可以使用 ActionScript,以動態方式將媒體內容加入文件之中。

元件庫中還包含了已經加入文件中的所有組件。組件可以是編譯後的影片片段或 MovieClip 架構組件。

在 Animate 中作業時,您可以開啟任何 Animate 文件的元件庫,以便在目前的文件中使用該檔案中的元件庫項目。您可以使用元件名稱或其 ActionScript 連結名稱,在元件庫中搜尋元件。

您可以在 Animate 應用程式中建立永久性的元件庫,每當您啟動 Animate 時就可使用這些元件庫。Animate 同時包含好幾個範例元件庫,內含按鈕、圖像、影片片段與聲音。

您可將元件庫資源以 SWF 檔的形式匯出至某個 URL 上,以建立執行階段的共享元件庫。這樣您就能利用執行階段的共享功能,連結到匯入元件的 Animate 文件中的元件庫資源。

「元件庫」面板 (視窗 > 元件庫) 能顯示元件庫中全部項目的名稱捲動清單,可供您在工作時檢視與組織這些元素。在「元件庫」面板中,項目名稱旁邊的圖示代表該項目的檔案類型。

註解:

不建議將物件從「舞台」拖曳至「元件庫」面板以轉換成元件,將無法與 Animate CC 搭配使用。

不建議將物件拖曳到兩份未固定文件之間的「舞台」,將無法與 Animate CC 搭配使用。

在另一個 Animate 檔案中開啟元件庫

  1. 在目前的文件中,選取「檔案 > 匯入 > 開啟外部元件庫」。
  2. 瀏覽至您要開啟其元件庫的 Animate 檔案,再按一下「開啟」。

    所選取的檔案的元件庫會在目前的文件中開啟,檔案的名稱會出現在「元件庫」面板的上方。若要在目前的文件中使用您選取的檔案之元件庫中的項目時,請將該項目拖曳到目前的文件的「元件庫」面板中,或是拖曳到舞台上。

調整元件庫面板大小

  1. 請執行下列其中一項:
    • 拖曳面板的右下角。

    • 按一下「擴大」按鈕將「元件庫」面板放大,使其顯示所有的欄位。

    • 按一下「縮小」按鈕,縮小「元件庫」面板的寬度。

變更直欄的寬度

  1. 將指標放在欄位標題之間,再拖曳以調整大小。

使用元件庫面板中的資料夾

您可以使用資料夾,來組織「元件庫」面板中的項目。當您建立一個新的元件時,該元件便會儲存在您選取的資料夾中。若您並未選取任何資料夾,該元件便會儲存在元件庫的根目錄中。

此外,Animate 也會將 GIF 動畫檔案放在元件庫根資料夾底下的個別資料夾,並根據順序命名所有關聯的點陣圖,藉此有條理地匯入 GIF 動畫檔案。 

建立新的資料夾

  1. 按一下「元件庫」面板底部的「新增資料夾」按鈕

開啟或關閉資料夾

  1. 連按兩下資料夾,或是選取資料夾後,從「元件庫」面板的「面板」選單中選取「展開資料夾」或「收合資料夾」。

開啟或關閉所有資料夾

  1. 從「元件庫」面板的「面板」選單中選取「展開所有資料夾」或「收合所有資料夾」。

在資料夾之間移動項目

  1. 將項目從原資料夾拖曳至另一個資料夾上。

    如果新的位置已有一個名稱相同的項目,Animate 會提示您是否要以目前移動的項目取代它。

對元件庫面板中的項目進行排序

「元件庫」面板中的欄位會列出項目的名稱及類型、項目在檔案中的使用次數、項目的連結狀態與識別名稱 (若項目與共享元件庫相關,或已匯出供 ActionScript 使用),以及項目最後修改的日期等。

您可以依據任何欄位,以字母順序排列「元件庫」面板中的項目。項目是在資料夾中完成排序的。

Animate 元件庫會組織元件庫根資料夾底下個別資料夾中匯入的 GIF 動畫檔案,並根據順序命名所有關聯的點陣圖。 

  1. 按一下欄位的標題可以依據該欄位進行排序。按一下欄標題右方的三角形按鈕,則會以反轉排序順序。

元件庫資源之間的衝突

如果將元件庫資源匯入或複製到已有其他同名資源的文件中,可以選擇是否要用新的項目取代現有項目。所有匯入或複製元件庫資源的方法都會提供這個選項。

當您試圖放置和文件中現有項目衝突的項目時,「解決元件庫項目」對話方塊便會出現。當您從來源文件複製的項目已存在於目的文件中,而且兩個項目具有不同的修改日期時,衝突便會發生。請使用文件元件庫中的資料夾來組織您的資源,以避免命名衝突。當您將元件 (或組件) 貼到文件的「舞台」上,而該元件 (或組件) 已經有不同修改日期的副本存在時,也會出現這個對話方塊。

如果您選擇不要取代現有的項目,則 Animate 會嘗試使用目前的項目,而不是您正要貼上的衝突項目。例如,如果您複製名為「元件 1」的元件,並將其副本貼到文件的「舞台」上,而該文件已經包含了一個名為「元件 1」的元件,Animate 便會建立現有的「元件 1」的實體。

如果選擇取代現有項目,則 Animate 會用同名的新項目取代現有項目 (以及所有的實體)。若您取消了「匯入」或「複製」的操作,則所有項目的操作都會被取消掉 (不只是在目的文件中發生衝突的項目)。

只有相同的元件庫項目類型才可以互相取代。也就是說,您不可以使用名為 Test 的點陣圖來取代名為 Test 的聲音。在這類情況下,新項目在被加入元件庫時,其名稱會被加上「副本」這個詞。

註解:

使用這個方法來取代元件庫項目時,將會無法還原。在執行複雜的貼上操作 (以取代衝突元件庫項目的方式來解決) 之前,請先備份 FLA 檔。

當您在將元件庫資源匯入或複製到文件中時,如果出現「解決元件庫衝突」對話方塊,請以此解決其命名衝突。

解決元件庫資源之間的命名衝突

  1. 在「解決元件庫衝突」對話方塊中,執行下列任一項作業︰

    • 若要保留目的文件中的現有資源,請按一下「不取代現有項目」。

    • 若要以同名的新項目取代現有的資源及其實體,請按一下「取代現有項目」。

使用元件庫項目

當您在「元件庫」面板中選取項目時,該項目的縮圖預覽便會出現在「元件庫」面板的上方。如果您選取的項目是動畫形式或是聲音檔時,便可以使用元件庫預覽視窗或「控制器」中的「播放」按鈕,預覽該項目。

依連結名稱搜尋元件庫項目

您可以依元件的名稱或其 ActionScript 連結名稱,在元件庫搜尋面板中搜尋元件。

  • 若要搜尋元件庫項目,請輸入元件名稱或元件庫項目 ActionScript 連結名稱前幾個字母。一邊輸入,元件庫面板就會一邊顯示相符元件的清單。

在目前文件中使用元件庫項目

  1. 將項目從「元件庫」面板拖曳到舞台上。

    此項目便會加入目前的圖層中。

將舞台上的物件轉換成元件庫中的元件

  1. 選取舞台上的物件,以滑鼠右鍵按一下並選取「轉換成元件」。

在另一份文件中使用目前文件中的元件庫項目

  1. 將項目從「元件庫」面板或舞台拖曳至另一份文件的「元件庫」面板或舞台上。

從不同文件複製元件庫項目

  1. 請選取含有元件庫項目的文件。
  2. 在「元件庫」面板中選取元件庫項目。
  3. 選取「編輯 > 複製」。
  4. 選取您想要複製元件庫項目的文件。
  5. 請選取文件的「元件庫」面板。
  6. 選取「編輯 > 貼上」。

編輯元件庫項目

  1. 在「元件庫」面板中選取項目。
  2. 從「元件庫」面板的「面板」選單中,選取下列其中一個項目:
    • 若要使用 Animate 來編輯項目,請選取「編輯」。

    • 若要使用另一種應用程式來編輯項目,選取「編輯程式」後再選取外部應用程式。

註解:

當啟動支援的外部編輯器時,Animate 會開啟原始的匯入文件。

重新命名元件庫項目

變更匯入檔案的元件庫項目名稱時,並不會變更檔名。

  1. 請執行下列其中一項:
    • 連按兩下該項目名稱。

    • 選取項目後,從「元件庫」面板的「面板」選單中選取「重新命名」。

    • 在項目上按一下右鍵 (Windows) 或 Control + 按一下 (Macintosh),然後在快顯選單中選取「重新命名」。

  2. 在方塊中輸入新的名稱。

刪除元件庫項目

當您要從元件庫中刪除項目時,文件中該項目及其所有實體也都會遭刪除。

  1. 選取項目,然後按一下「元件庫」面板底部的「垃圾筒」圖示。

尋找未使用的元件庫項目

若要組織您的文件,可以尋找未使用的元件庫項目並加以刪除。

註解:

您不需要為了減少 Animate 文件的檔案大小,而將未使用的元件庫項目刪除,因為未被採用的元件庫項目不會加入 SWF 檔案中。但是,要匯出的連結項目則會包含在 SWF 檔中。

  1. 請執行下列其中一項:
    • 從「元件庫」面板的「面板」選單中,選取「選取未使用的項目」。

    • 按照「使用次數」直欄對元件庫項目進行排序,以指出項目是否正在使用。

更新元件庫中已匯入的檔案

若您使用外部編輯器來修改您匯入 Animate 中的檔案 (如點陣圖或聲音檔),您無需將這些檔案重新匯入 Animate 中,即可完成更新動作。您也可以更新從外部 Animate 文件匯入的元件。更新匯入的檔案時,會以外部檔案的內容取代其內容。

注意:您可以在元件庫根資料夾底下的個別資料夾中,找到所匯入、根據順序命名所有關聯點陣圖的 GIF 動畫檔案。

  1. 在「元件庫」面板中選取匯入的檔案。
  2. 從「元件庫」面板的「面板」選單中選取「更新」。

在文件之間複製元件庫資源

您可以使用各種方法,將元件庫資源從來源文件複製到目的文件中:在編寫或執行階段,您也可以將元件當做共用元件庫資源,在文件之間共用。

若您嘗試複製和目的文件中現有資源同名的資源,「解決元件庫衝突」對話方塊可以讓您選擇是要覆寫現有資源,還是保存現有資源、並將新資源以修改後的名稱加入。您可以使用資料夾將元件庫資源予以組織,以降低在文件之間複製資源時發生名稱衝突的機會。

透過複製和貼上方式複製元件庫資源

  1. 在來源文件中的舞台上選取資源。

  2. 選取「編輯 > 複製」。

  3. 讓目的文件成為作用中的文件。

  4. 若要在可見的工作檯正中央貼上資源,請將指標放在舞台上,然後選取「編輯 > 在中央貼上」。若要將資源放在與來源文件相同的位置,請選取「編輯 > 在原地貼上」。

透過拖曳方式複製元件庫資源

  1. 在目的文件已開啟的情況下,選取來源文件內「元件庫」面板中的資源,然後將資源拖曳到目的文件的「元件庫」面板。

在目的文件中開啟來源文件元件庫以複製元件庫資源

  1. 先讓目的文件成為作用中的文件,然後選取「檔案 > 匯入 > 開啟外部元件庫」。

  2. 選取來源文件,再按一下「開啟」。

  3. 將資源從來源文件元件庫中,拖曳到舞台上或目的文件的元件庫中。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策