使用手冊 取消

如何在 Adobe Animate 中使用聲音

  1. Adobe Animate 使用手冊
  2. Animate 簡介
    1. Animate 的新功能
    2. 視覺詞彙
    3. Animate 系統需求
    4. Animate 鍵盤快速鍵
    5. 在 Animate 中使用多個檔案類型
  3. 動畫
    1. Animate 中的動畫基本概念
    2. 如何在 Animate 中使用影格及關鍵影格
    3. Animate 中的逐格動畫
    4. 如何在 Animate 中使用傳統補間動畫
    5. 筆刷工具
    6. 移動導引線
    7. 移動補間動畫與 ActionScript 3.0
    8. 關於移動補間動畫
    9. 移動補間動畫
    10. 建立移動補間動畫
    11. 使用屬性關鍵影格
    12. 使用補間動畫將位置製成動畫
    13. 如何使用移動編輯器編輯移動補間動畫
    14. 編輯補間動畫的移動路徑
    15. 操作移動補間動畫
    16. 新增自訂加/減速
    17. 建立和套用移動預設效果
    18. 設定動畫補間動畫範圍
    19. 使用儲存為 XML 檔案的移動補間動畫
    20. 移動補間動畫與傳統補間動畫
    21. 形狀補間動畫
    22. 在 Animate 中使用骨塊工具動畫
    23. 在 Animate 進行角色製作
    24. 如何在 Adobe Animate 中使用遮色片圖層
    25. 如何在 Animate 中使用場景
  4. 互動
    1. 如何使用 Animate 建立按鈕
    2. 將 Animate 專案轉換成其他文件類型格式
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 在 Animate 中使用程式碼片段增加互動功能
    5. 建立自訂 HTML5 組件
    6. 在 HTML5 Canvas 中使用組件
    7. 建立自訂組件:範例
    8. 自訂組件的程式碼片段
    9. 最佳作法 - 使用 Animate 做廣告
    10. 虛擬實境編寫和發佈
  5. 工作區和工作流程
    1. 建立和管理繪圖筆刷
    2. 在 HTML5 Canvas 文件中使用 Google 字體
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作區
    6. 在 HTML5 Canvas 文件中使用網頁字體
    7. 時間軸與 ActionScript
    8. 使用多重時間軸
    9. 設定偏好設定
    10. 使用 Animate 編寫面板
    11. 使用 Animate 建立時間軸圖層
    12. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    13. 移動和複製物件
    14. 範本
    15. Animate 中的尋找和取代
    16. 還原、重做和操作記錄面板
    17. 鍵盤快速鍵
    18. 如何在 Animate 中使用時間軸
    19. 建立 HTML 擴充功能
    20. 影像和 GIF 動畫的最佳化選項
    21. 匯出影像和 GIF 的設定
    22. Animate 中的資源面板
  6. 多媒體和視訊
    1. 在 Animate 中變形及結合圖像物件
    2. 在 Animate 中建立並使用元件實體
    3. 影像描圖
    4. 如何在 Adobe Animate 中使用聲音
    5. 匯出 SVG 檔案
    6. 建立要在 Animate 中使用的視訊檔案
    7. 如何在 Animate 增加視訊
    8. 使用視訊提示點
    9. 使用 Animate 繪製及建立物件
    10. 調整線條和形狀
    11. 使用 Animate CC 中的筆畫、填色和漸層
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的色彩面板
    14. 使用 Animate 開啟 Flash CS6 檔案
    15. 在 Animate 中使用傳統文字
    16. 將圖案放入 Animate 中
    17. Animate 中匯入的點陣圖
    18. 3D 圖像
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 繪製線條和形狀
    21. 使用 Animate 中的元件庫
    22. 匯出聲音
    23. 在 Animate CC 中選取物件
    24. 在 Animate 中使用 Illustrator AI 檔案
    25. 使用噴刷工具套用圖樣
    26. 套用混合模式
    27. 排列物件
    28. 使用命令選單自動執行工作
    29. 多國語言文字
    30. 使用 Animate 中的攝影機
    31. 搭配使用 Animate 與 Adobe Scout
    32. 使用 Fireworks 檔案
    33. 圖像濾鏡
    34. 聲音和 ActionScript
    35. 繪圖偏好設定
    36. 使用鋼筆工具繪圖
  7. 平台
    1. 將 Animate 專案轉換成其他文件類型格式
    2. 自訂平台支援
    3. 在 Animate 中建立及發佈 HTML5 Canvas 文件
    4. 建立並發佈 WebGL 文件
    5. 如何封裝 AIR for iOS 的應用程式
    6. 發佈 AIR for Android 應用程式
    7. Adobe AIR for Desktop 的發佈功能
    8. ActionScript 發佈設定
    9. 最佳作法 - 在應用程式中組織 ActionScript
    10. 如何搭配使用 ActionScript 與 Animate
    11. 最佳作法 - 輔助功能原則
    12. Animate 工作區中的輔助功能
    13. 撰寫和管理指令碼
    14. 啟用自訂平台的支援
    15. 自訂平台支援概觀
    16. 建立輔助功能內容
    17. 使用自訂平台支援外掛程式
    18. ActionScript 3.0 的除錯
    19. 啟用自訂平台的支援
  8. 匯出與發佈
    1. 如何從 Animate CC 匯出檔案
    2. OAM 發佈
    3. 匯出 SVG 檔案
    4. 使用 Animate 匯出圖像和視訊
    5. 發佈 AS3 文件
    6. 匯出適用於行動裝置應用程式和遊戲引擎的動畫
    7. 匯出聲音
    8. 匯出 QuickTime 視訊檔
    9. 使用 ActionScript 控制外部視訊播放
    10. 最佳作法 - 建立行動裝置內容的秘訣
    11. 最佳作法 - 視訊慣例
    12. 最佳作法 - SWF 應用程式編寫原則
    13. 最佳作法 - 建構 FLA 檔
    14. 最佳化 Animate 的 FLA 檔案的最佳作法
    15. ActionScript 發佈設定
    16. 指定 Animate 的發佈設定
    17. 匯出放映檔
    18. 匯出影像和 GIF 動畫
    19. HTML 發佈範本
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和發佈您的動畫

概觀

Adobe Animate 提供數種使用聲音的方式。您可以讓聲音持續播放、獨立於「時間軸」之外,或使用「時間軸」讓動畫與音軌同步。 您也可以在按鈕加入聲音,以提高按鈕的互動性,並讓聲音淡入和淡出,以製作更優美的音軌。

Animate 中有兩種聲音類型:事件聲音和串流聲音。事件聲音必須在開始播放前先完整下載,而且會持續播放到明確停止為止。 當前幾個影格的資料已下載足夠時,串流聲音便會開始播放;為了要在網站上播放,串流聲音會和時間軸同步。

如果您要為行動裝置建立 Animate 內容,Animate 也能讓您將裝置聲音包含在發佈的 SWF 檔中。裝置聲音是以裝置內原本支援的音效格式進行編碼,例如 MIDI、MFi 或 SMAF。

您可以使用共享元件庫,將某一聲音連結到多個文件。 您也可以使用 ActionScript 的 ® 2.0 onSoundComplete 事件或 ActionScript® 3.0 soundComplete 事件,在聲音播放完成時觸發另一事件。

您可以使用預先撰寫的行為指令或媒體組件來載入並控制播放聲音;後者也可提供控制項以執行停止、暫停、倒帶等動作。 您也可以使用 ActionScript 2.0 或 3.0 動態載入聲音。

如需詳細資訊,請參閱「ActionScript 2.0 語言參考」中的 attachSound (Sound.attachSound 方法)loadSound (Sound.loadSound 方法) 或「ActionScript 3.0 語言和組件參考」中的 Sound 類別

Animate 不支援 ActionScript 2.0 和 ActionScript 1.0。

匯入聲音

若要將聲音檔案置入 Animate 中,請將聲音檔案匯入元件庫或直接匯入舞台。

「檔案 > 匯入 > 匯入至元件庫」選單選項只會將音效置於元件庫,而不會放置在時間軸上。

當您使用「檔案 > 匯入 > 匯入至舞台」選單選項,或直接將音效檔案拖放到時間軸,以匯入音效檔案時,音效會放置在作用中圖層的作用中影格上。如果拖放多個音效檔案,則只會匯入一個音效檔案,因為一個影格只能包含一個音效。

若要匯入音效,請使用下列其中一個方法:

  • 若要將音效檔案匯入元件庫,請選取「檔案 > 匯入 > 匯入至元件庫」,然後選取您要匯入的音效檔案。
  • 若要將音效檔案匯入舞台,請選取「檔案 > 匯入 > 匯入至舞台」,然後選取您要匯入的音效檔案。
  • 將音效檔案直接拖放到舞台。

您也可以將聲音從內建元件庫拖曳到目前文件的元件庫中。

Animate 會將聲音與點陣圖及元件一起儲存在元件庫中。您只需要聲音檔的一份副本,就可以透過多種方式在文件中使用聲音。

如果您要在 Animate 文件之間共用聲音,可以將聲音納入共享元件庫中。

聲音可能會佔用相當大的磁碟空間和 RAM。 然而,經過壓縮的 mp3 聲音資料會小於 WAV 或 AIFF 聲音資料。 一般來說,在使用 WAV 或 AIFF 檔案時,最好使用 16-22 kHz 單聲道聲音 (立體聲使用的資料是單聲道的兩倍),但是 Animate 可以用 11、22 或 44 kHz 的取樣頻率匯入 8 或 16 位元的聲音。將聲音匯入 Animate 時,如果聲音的錄製格式不是 11 kHz 的倍數 (例如 8、32 或 96 kHz),則聲音將會重新取樣。Animate 可以在匯出時將聲音轉換為較低的取樣頻率。

如果您打算要在 Animate 中將特效加入聲音之中,最好匯入 16 位元的聲音。如果 RAM 大小有限,最好使用簡短的聲音片段,或使用 8 位元聲音,而不是 16 位元聲音。

若要在 Animate 中匯入或播放聲音,並不需要預先安裝 QuickTime 或 iTunes。

支援的聲音檔格式

您可以將下列聲音檔格式匯入 Animate 中:

  • Adobe Sound (.asnd)。這是 Adobe® Soundbooth™ 的原生聲音格式。

  • Wave (.wav)

  • AIFF (.aif、.aifc)

  • mp3

    您可以匯入下列其他聲音檔案格式:

  • Sound Designer® II (.sd2)

  • Sun AU (.au、.snd)

  • FLAC (.flac)

  • Ogg Vorbis (.ogg、.oga)

ASND 屬於非破壞性的音效檔格式,是 Adobe Soundbooth 的原生格式。ASND 檔案可以包含具有效果且可於日後修改的音效資料、Soundbooth 多軌工作階段,以及可讓您將 ASND 檔案還原成先前狀態的快照。WebGL 和 HTML5 Canvas 文件類型僅支援 MP3 及 WAV 格式。

在 Animate 中加入聲音

從您的電腦直接將聲音加入時間軸

您可以使用下列任一方法,直接從電腦將音效匯入到「時間軸」:

  • 選取「檔案 > 匯入 > 匯入至舞台」,然後選取您要匯入的音效檔案。
  • 將音效檔案拖放到舞台/時間軸。

請注意,一次只能加入一個音效檔案。拖放多個音效檔案只會將一個音效檔案匯入時間軸。

從元件庫新增聲音到時間軸

您可以使用元件庫將聲音加入文件中,或在執行階段使用 Sound 物件的 loadSound 方法將聲音載入 SWF。 如需詳細資訊,請參閱 ActionScript 3.0 語言參考中的 Sound Class

  1. 如果聲音尚未匯入,請先將聲音匯入元件庫。
  2. 選取「插入 > 時間軸 > 圖層」。

  3. 選取新的聲音圖層之後,請將聲音從「元件庫」面板拖曳到舞台上。 聲音會加入目前的圖層之中。

    您可以將數個聲音放在一個圖層上,也可以將數個聲音放在包含其他物件的多個圖層上。 然而,建議您將每個聲音都放在不同的圖層上。 因為每個圖層就有如分開的聲道。 在播放 SWF 檔時,所有圖層上的聲音會結合在一起。

  4. 在時間軸中選取包含聲音檔的第一個影格。
  5. 選取「視窗 > 屬性」,然後按一下右上角的箭頭展開「屬性」檢測器。

  6. 在「屬性」檢測器中,在「聲音」彈出式選單中選取聲音檔。
  7. 在「特效」彈出式選單中選擇一個特效選項:

    不會對聲音檔套用特效。 選擇這個選項,移除先前套用的特效。

    左聲道/右聲道

    僅使用左聲道或右聲道播放聲音。

    從左到右淡出/從右到左淡出

    讓聲音由某一聲道轉移到另一聲道。

    淡入

    會在播放期間逐漸增加聲音的音量。

    淡出

    會在播放期間逐漸降低聲音的音量。

    自訂

    可以讓您使用「編輯封套」來建立聲音的淡入和淡出點。

    WebGL 和 HTML5 Canvas 文件不支援特效。

  8. 在「同步」彈出式選單中選擇一個同步化選項:

    事件

    會將聲音和事件的發生同步化。 事件聲音會在開始關鍵影格第一次出現時播放,並且完整播放而不會干擾「時間軸」的播放磁頭,即使 SWF 檔停止播放也是一樣。播放已發佈的 SWF 檔時,多個事件聲音會混合在一起播放。

    如果事件聲音正在播放,而聲音再次實體化 (例如,使用者再次按下按鈕,或者播放磁頭傳遞聲音的開始關鍵影格),則聲音的第一個實體會繼續播放,而相同聲音的另一個實體會同時開始播放。在使用較長聲音時,請牢記這點,因為聲音可能會重疊,因而出現非預期的音效效果。

    起點

    和「事件」相同,差別在於如果聲音已經正在播放,就不會再播放新的聲音實體。

    停止

    停止指定的聲音。

    串流

    同步化聲音,方便在網站上播放。 Animate 會強迫動畫跟上串流聲音的速度。如果 Animate 繪製動畫影格的速度不夠快,便會略過某些影格。和事件聲音不同,串流聲音會在 SWF 檔停止播放時跟著停止。 此外,串流聲音的播放長度絕不會超過所佔影格的長度。 發佈 SWF 檔時,會將串流聲音混合在一起。

    在多重影格動畫中播放的人物語音,便是串流聲音的一個例子。

    Animate 會記住屬性檢測器中的音效同步處理選項。如果從「屬性檢測器」的「聲音」區段選取聲音,接著嘗試對「屬性檢測器」中的新關鍵影格設定其他聲音,Animate 會記住前一個聲音的「串流」或「事件」同步選項。

    如果您將 mp3 聲音當做串流聲音使用,您必須將聲音重新壓縮,以將其匯出。您可以使用和將聲音匯入時相同的壓縮設定值,將聲音匯出成 mp3 檔案。WebGL 文件不支援串流設定。

  9. 請為「重複」輸入一個數值,以指定聲音應該循環的次數,或是選取「循環」以不斷重複播放聲音。

    若要連續不斷地播放,請輸入足夠大的數字,以延長播放聲音的時間。 例如,若要將 15 秒的聲音循環 15 分鐘,請輸入 60。 我們不建議您循環播放串流聲音。 如果將串流聲音設為循環,每個循環的聲音副本都會被加入檔案之中,而且檔案大小會隨著聲音循環的次數而增加。

  10. 若要測試聲音,請將播放磁頭拖曳到包含聲音的影格上方,或使用「控制器」或「控制」選單中的命令。

從時間軸中移除聲音

  1. 在包含聲音的「時間軸」圖層中,選取同樣包含聲音的影格。
  2. 在「屬性」檢測器中,前往「聲音」區段並從「名稱」選單中選取「無」。

    Animate 隨即刪除「時間軸」圖層中的聲音。

將聲音加入至按鈕

聲音可以和不同狀態的按鈕元件建立關聯。 由於聲音是和元件一起儲存的,所以聲音可用於元件的所有實體。

  1. 在「元件庫」面板中選取按鈕。
  2. 在面板右上角的「面板」選單中選取「編輯」。
  3. 在按鈕的「時間軸」中,增加聲音的圖層 (「插入 > 時間軸 > 圖層」)。

  4. 在聲音圖層中,建立一般或空白的關鍵影格來對應您想要加入聲音的按鈕狀態。

    按一下「插入 > 時間軸 > 關鍵影格」或「插入 > 時間軸 > 空白關鍵影格」。

    例如,若要加入在按下按鈕時播放的聲音,請在影格中建立一個標籤為 Down 的關鍵影格。

  5. 按一下您建立的關鍵影格。
  6. 選取「視窗 > 屬性」。

  7. 在「屬性」檢測器的「聲音」彈出式選單中選取一個聲音檔。
  8. 在「同步」彈出式選單中選取「事件」。

    若要在不同的聲音和按鈕的每個關鍵影格之間建立關聯,請先建立空白的關鍵影格,然後為每個關鍵影格加入另一個聲音檔。 您也可以使用相同的聲音檔,然後在每個按鈕關鍵影格上套用不同的聲音特效。

將聲音與動畫同步化

若要將聲音與動畫同步化,請在關鍵影格開始及停止聲音。

  1. 將聲音加入專屬圖層中的「時間軸」(請參閱上述指示)。
  2. 若要讓這個聲音與場景中的某個事件同步化,請為聲音建立開始關鍵影格,聲音會對應到場景中您想要觸發聲音的事件關鍵影格。您可以選取上述任一同步化選項 (請參閱「將聲音加入時間軸」)。
  3. 在聲音圖層的「時間軸」中,在您要結束聲音的影格上建立關鍵影格。 時間軸中會出現聲音檔案的代號。
  4. 選取「視窗 > 屬性」,然後按一下右上角的箭頭展開「屬性」檢測器。

  5. 在「屬性」檢測器的「聲音」彈出式選單中選取相同的聲音。
  6. 依然在「屬性」檢測器中,選取「同步」彈出式選單中的「停止」。

    在播放 SWF 檔時,聲音會在到達結束關鍵影格時停止播放。

  7. 若要播放聲音,請拖曳「時間軸」中的播放磁頭。

編輯聲音

在 Animate 中編輯聲音

在 Animate 中,您可以定義聲音的開始點或控制聲音播放時的音量。也可以更改聲音開始和停止播放的點。 這麼做可移除沒有用到的區段,有效降低聲音檔的大小。

  1. 將聲音加入影格,或選取已包含聲音的影格。
  2. 選取「視窗 > 屬性」。

  3. 按一下「屬性」檢測器右側的「編輯」按鈕。
  4. 請執行下列其中一個動作:
    • 若要更改聲音的開始點和結束點,請拖曳「編輯封套」中的「開始時間」和「結束時間」控制項。

    • 若要更改聲音封套,請拖曳封套控制點,以更改聲音中不同點上的準位。 封套線會顯示播放聲音時的音量。 若要建立其他的封套控制點 (最多共八個),請按一下封套線。 若要移除封套控制點,請將它拖曳到視窗外面。

    • 若要在視窗中調整聲音的顯示範圍,請按一下「放大」或「縮小」按鈕。

    • 若要在秒數和影格之間切換時間單位,請按一下「秒數」和「影格」按鈕。

  5. 若要聆聽已完成編輯的聲音,請按一下「播放」按鈕。

在 Soundbooth 中編輯聲音

如果您已經安裝 Adobe Soundbooth,便可以使用 Soundbooth 編輯已經匯入至 Animate 檔案的聲音。在 Soundbooth 中變更內容之後,只要您存檔或覆寫原始檔案,所做的變更就會自動反映在 Animate 檔案中。

如果您在編輯聲音之後變更了聲音的檔名或格式,就必須將聲音重新匯入至 Animate。

Soundbooth 只適用於 Windows 電腦和 Intel® 架構的 Macintosh 電腦。

若要在 Soundbooth 中編輯已匯入的聲音:

  1. 在「元件庫」面板中的聲音上按一下右鍵 (Windows),或者 Control+按一下該聲音 (Macintosh)。
  2. 從 Soundbooth 的快顯選單中選擇「編輯」。檔案隨即在 Soundbooth 中開啟。
  3. 在 Soundbooth 中編輯檔案。
  4. 完成變更之後,儲存檔案。若要以非破壞性格式儲存變更,請選擇 ASND 格式。如果存檔時使用的格式與原始格式不同,您必須將聲音檔重新匯入 Animate。

  5. 返回 Animate 的「元件庫」面板,查看聲音檔編輯後的版本。

您無法使用「在 Soundbooth 中編輯」命令,編輯取自「聲音」元件庫 (「視窗 > 內建元件庫 > 聲音」) 的聲音。若要在 Soundbooth 中編輯這些聲音,請開啟 Soundbooth,再從「資源中心」面板選取聲音。編輯聲音後,將其匯入 Animate。

分割或重複時間軸上的聲音

分割時間軸上的聲音

您可以使用「分割音效」快顯選單,分割時間軸上內嵌的串流音效。「分割音效」可讓您在必要時暫停音效,之後再從時間軸上停止的時間點後面的影格恢復音效播放。您可以選擇將串流的音效分割成多個部分,以保留其效果。

若要分割時間軸上的音效剪輯並保留其效果:

  1. 選取「檔案 > 匯入 > 匯入至元件庫」。

  2. 選取音效剪輯並匯入元件庫。

  3. 在時間軸上建立新的圖層,然後將音效剪輯增加到圖層。 

  4. 在「屬性 > 聲音」下方,選取「效果」。

  5. 為「同步」類型選取「串流」。

  6. 以滑鼠右鍵按一下要分割音效的影格,然後按一下「分割音效」。

    即使移動音效或將音效變更成不同時間間隔或影格範圍,仍會保留音效效果。

在時間軸上重複播放聲音

音效重複表示在時間軸上的一些影格上持續重播某一小段的聲音。在時間軸啟用「重複」選項之後,您就可以隨著其他動畫,在某個影格範圍內重複串流音效。

若要建立循環,只要依照下列步驟,在時間軸啟用重複選項即可:

時間軸上的音效重複按鈕

在 Flash Lite 中使用聲音

Adobe® Flash® Lite 支援兩種聲音類型:標準 Animate 聲音 (例如在 Animate 桌面應用程式上使用的聲音) 以及裝置聲音。Flash Lite 1.0 只支援裝置聲音;而 Flash Lite 1.1 和 2.x 同時支援標準聲音和裝置聲音。

裝置聲音是以原生音效格式 (如 MIDI 或 MFi) 儲存於發佈的 SWF 檔中;在播放期間,Flash Lite 會將聲音資料傳送給裝置,而由裝置對聲音進行解碼與播放。 由於大多數的裝置音效格式均無法匯入 Animate 中,因此您必須改以支援的格式 (如 mp3 或 AIFF) 匯入 Proxy 聲音,再以指定的外部裝置聲音來取代匯入的聲音。

裝置聲音只能當成事件聲音使用;您無法同步處理裝置聲音和時間軸,而標準聲音則可以。

Flash Lite 1.0 和 Flash Lite 1.1 不支援使用 Flash® Player 桌上型電腦版本中的下列功能:

  • ActionScript Sound 物件

  • 載入外部 mp3 檔案

  • 語音音效壓縮選項

如需詳細資訊,請參閱「開發 Flash Lite 2.x 應用程式」中的「處理聲音、視訊和影像」或是「開發 Flash Lite 1.x 應用程式」中的「處理聲音」。

Adobe 標誌

登入您的帳戶