建立實體

建立元件之後,您便可以在整份文件中 (包括在其他元件中) 建立該元件的實體。當您修改元件時,Animate CC (先前稱為 Flash Professional CC) 便會更新元件的所有實體。

您可以從「屬性」檢測器中為實體指定名稱。請使用該實體的名稱,在 ActionScript 中參照實體。若要使用 ActionScript® 來控制實體,請為單一時間軸內的每個實體指定唯一名稱。 

若要指定顏色效果、指派動作、設定圖像顯示模式,或變更新實體的行為指令,請使用「屬性」檢測器。除非另外指定,否則該實體的行為指令會與元件的行為指令相同。所作的任何變更都只會影響實體,而不會影響元件。

建立元件的實體

  1. 在時間軸中選取圖層。Animate 只能將實體置於關鍵影格中,而且一定是在目前的圖層上。如果您選取的並非關鍵影格,則 Animate 會將實體加入目前影格左方的第一個關鍵影格中。

    註解:

    關鍵影格是可在其中定義動畫內所做變更的影格。如需詳細資訊,請參閱將影格插入時間軸

  2. 選取「視窗 > 元件庫」。

  3. 將元件從元件庫中拖曳至舞台上。

  4. 若要在建立了圖像元件的實體之後,增加含有圖像元件的影格數目,請選取「插入 > 時間軸 > 影格」。

將自訂名稱套用至實體

  1. 在舞台上選取實體。

  2. 選取「視窗 > 屬性」,然後在「實體名稱」方塊中輸入名稱。

編輯實體屬性

每個元件實體都具有獨立於元件,自己的屬性。您可以更改實體的色調、透明度和亮度;重新定義實體的行為指令 (例如,將圖像更改成影片片段);並指定動畫在圖像實體中播放的方式。也可以傾斜、旋轉或縮放實體,而不會影響到元件。

此外,您也可以命名影片片段或按鈕實體,如此便能使用 ActionScript 來更改其屬性。如需詳細資訊,請參閱學習 ActionScript 3.0 中的物件和類別。若要編輯實體屬性,請使用「屬性」檢測器 (「視窗 > 屬性」)。

實體會連同其屬性一併儲存。如果您對元件進行編輯,或是將實體重新連結到不同的元件上,已經變更的實體屬性仍會套用至實體。

設定實體的可見度

您可以透過關閉「可見」屬性,在舞台上隱藏某個元件實體。使用「可見」屬性所達到的顯示效能,比將元件的 Alpha 屬性設為 0 更快。

「可見」屬性不僅要求「播放程式」必須設定為 Flash Player 10.2 或更新版本,而且只與影片片段、按鈕及組件實體相容。

  1. 在舞台上選取實體。

  2. 在「屬性」面板的「顯示」區段中,取消選取「可見」屬性。

變更實體的顏色和透明度

元件的每個實體都可以有自己的顏色特效。若要設定實體的顏色和透明度選項,請使用「屬性」檢測器。「屬性」檢測器中的設定也會對置於元件中的點陣圖造成影響。

變更特定影格中實體的顏色和透明度時,Animate 會在顯示該影格時立即做出變更。若要製作出漸進式的顏色變化效果,請套用移動補間動畫。對顏色進行補間處理時,請於實體的開始和結束關鍵影格中輸入不同的特效設定,然後對這些設定進行補間處理,讓實體的顏色可以隨著時間而改變。

sy_tint_tween
sy_alpha_tween
補間動畫會讓實體的顏色或透明度發生漸進式的變化。

註解:

如果您將顏色特效套用至具有多個影格的影片片段元件上,則 Animate 會將該特效套用至該影片片段元件中的每個影格上。

  1. 請在「舞台」上選取該實體,然後選取「視窗 > 屬性」。
  2. 在「屬性」檢測器的「樣式」選單中,從「顏色效果」區域選取下列其中一個選項:

    亮度

    會對影像的相對亮度或暗度進行調整,測量等級是從黑色 (-100%) 到白色 (100%)。若要調整亮度,請按一下三角形,然後拖曳滑桿,或是在方塊中輸入數值。

    色調

    會用相同的色相將實體著色。若要將色調百分比從透明 (0%) 設定為完全飽和 (100%),請使用「屬性」檢測器中的「色調」滑桿。若要調整色調,請按一下三角形,然後拖曳滑桿,或是在方塊中輸入數值。若要選取顏色,請將紅、綠、藍值輸入各自的方塊中,或是按一下「顏色」控制項,在「顏色挑選器」中選取顏色。

    Alpha

    會對實體的透明度進行調整,從透明 (0%) 到完全飽和 (100%)。若要調整 Alpha 值,請按一下三角形,然後拖曳滑桿,或是在方塊中輸入數值。

    進階

    會分別對實體的紅、綠、藍值及透明度進行調整。若要在物件 (如點陣圖) 上建立細膩的動態顏色效果,使用這個選項將可發揮最大的功用。您可以使用左邊的控制項,將顏色或透明度值減少指定的百分比。您可以使用右邊的控制項,將顏色或透明度值減少或增加某個常數值。

    目前的紅、綠、藍值及 Alpha 值會乘以一個百分比值,再加上右欄中的常數值,產生新的顏色值。例如,如果目前的紅色值是 100,而左滑桿和右滑桿又分別設為 50% 及 100%,則會產生新的紅色值 150 ([100 x .5] + 100 = 150)。

    注意:「特效」面板中的「進階」設定會實作 (a * y + b)= x 函數,其中 a 是在左邊的方塊組中指定的百分比,y 是原始點陣圖的顏色,b 是在右邊的方塊組中指定的數值,而 x 則是最終的特效 (RGB 介於 0 至 255 之間,Alpha 透明度介於 0 至 100 之間)。

    您也可以使用 ActionScript 的 ColorTransform 物件,變更實體的顏色。如需顏色物件的詳細資訊,請參閱「ActionScript 2.0 語言參考」或「ActionScript 3.0 語言和組件參考」中的 ColorTransform。

以某個實體替換另一個實體

為了在「舞台」上顯示不同的實體,並保留所有原始的實體屬性 (如顏色效果或按鈕動作),請將不同的元件指定給實體。

例如,假設您正在建立卡通,裡面的角色是「老鼠」元件,但您決定將角色變更為「貓」。您可以用「貓」元件將「老鼠」元件替換掉,並讓更新之後的角色在所有影格中出現在大致相同的位置。

指定不同的元件給實體

  1. 請在「舞台」上選取該實體,然後選取「視窗 > 屬性」。

  2. 在「屬性」檢測器中按一下「替換」按鈕。

  3. 選取元件以取代目前指定給實體的元件。若要重製選取的元件,請按一下「重製元件」,再按一下「確定」。

    如果您正要製作幾個差異不大的元件,透過重製的動作可讓您使用元件庫中的現有元件做為新元件的基礎,並能減少複製的次數。

取代元件的所有實體

  1. 將與您要取代之元件同名的元件從「元件庫」面板拖曳到您要編輯之 FLA 檔的「元件庫」面板中,然後按一下「取代」。如果元件庫中有多個資料夾,您必須將新元件拖曳到與所要取代之元件相同的資料夾。

變更實體的類型

若要在 Animate 應用程式中重新定義實體的行為指令,請變更其類型。例如,如果某個圖像實體包含了一段動畫,而您希望該段動畫在播放時能獨立於「主時間軸」之外,則可以將該圖像實體重新定義為影片片段實體。

  1. 請在「舞台」上選取該實體,然後選取「視窗 > 屬性」。
  2. 從「屬性」檢測器中的選單選取「圖像」、「按鈕」或「影片片段」。

設定圖像實體的循環

您可以在「屬性」檢測器中設定選項,以決定圖像實體的連續動畫在 Animate 應用程式中播放的方式。

將動畫圖像元件置入文件之後,元件便會和文件的時間軸結合。相較之下,影片片段元件有自己的獨立時間軸。因為動畫圖像元件和主文件使用相同的時間軸,所以動畫圖像元件會在文件編輯模式中顯示其動畫。影片片段元件則是以靜態物件的形式出現在「舞台」上,在 Animate 編輯環境中並不會以動畫的形式出現。

  1. 在「舞台」上選取圖像實體,然後選取「視窗 > 屬性」。
  2. 在「屬性」檢測器的「選項」選單中,從「循環」區域選取動畫選項:

    循環

    可重複播放目前實體中包含的所有連續動畫,重複次數等於該實體所佔據的影格數目。

    播放一次

    會從您指定的影格開始播放連續動畫,直到動畫結束,然後便會停止。

    單一影格

    顯示連續動畫的其中一個影格。請指定您要播放的影格。

  3. 若要指定循環時要顯示之圖像元件的第一個影格,請在「第一個」文字方塊中輸入影格編號。「單一影格」選項也會使用您在此指定的影格編號。

影格選取器

「影格選取器」可協助您以視覺方式預覽及選擇圖像元件的第一個影格。在先前的版本中,您必須以「編輯」模式進到元件內才能預覽影格。這個功能強化了如「對嘴」等動畫工作流程的使用者體驗。

註解:

「影格選取器」面板僅適用於圖像元件,對於影片片段或按鈕元件類型,則會停用。在使用這個功能之前,請先確認您已經將資源轉換為元件

  1. 選取「圖像元件 > 屬性面板 > 重複 > 使用影格選取器按鈕」,以顯示「影格選取器」面板,或者選取「視窗 > 影格選取器」。

    Frame Picker_ PI
    影格選取器

  2. 在「影格選取器」面板中,選取「清單」或「縮圖」檢視畫面,以顯示所選圖像元件的所有影格預覽。您也可以檢視影格編號及其標籤。 

    清單:以垂直清單檢視顯示影格。

    縮圖:以格點檢視顯示影格,並且會在調整面板大小時重新調整。

    建立關鍵影格:這個選項可讓您從「影格選取器」面板選取位置時,自動建立關鍵影格。

    重複:顯示圖像的各種重複選項,例如「重複」、「播放一次」和「單一影格」。

    滑桿箭頭:調整預覽大小。

    滑桿左鍵:讓視圖顯示較多影格。

    滑桿右鍵:讓視圖顯示較少影格。

    篩選影格選項下拉式清單:顯示各種篩選影格選項。

    list
    清單檢視

    thumnail
    縮圖檢視


  3. 使用「滑桿」或「縮放」按鈕,調整預覽或縮圖大小。 將「滑桿」移至面板左上角,可以檢視更多影格。如果將「滑桿」移到右下角,則可以檢視較大的預覽。

  4. 按一下任何影格,將該影格設為所選元件的第一個影格。

建立關鍵影格

「影格選取器」面板提供「建立關鍵影格」核取方塊,可在選取「影格選取器」面板中的影格時自動建立關鍵影格。此外,您還可以從「影格選取器」面板中設定圖像元件的重複選項。

您可以選取「圖像元件 > 屬性面板 > 重複 > 使用影格選取器按鈕」來顯示「影格選取器」,或選取「視窗 > 影格選取器」來叫用「影格選取器」面板。

CreateKeyframe

影格的篩選選項

Animate 可為面板中所列的影格提供篩選選項。您可以選擇依下列項目進行篩選:

  • 所有影格 – 顯示所有影格。
  • 關鍵影格 – 只顯示您所選擇的關鍵影格。
  • 標籤 – 只顯示具有標籤的影格。
filterOptions

自動對嘴

自動對嘴可讓您根據所選的音效圖層,更輕鬆、更快速地將適當的嘴型放在時間軸上。只要使用在圖像元件內繪製的現有嘴型清單,就能辦到。當您在圖像元件上套用自動對嘴時,系統會在分析指定的音效圖層之後,自動在不同位置建立與音效發音嘴型相符的關鍵影格。完成後,您就能視需要,使用一般工作流程和「影格選取器」進行進一步調整。

發音嘴型是一般臉部影像,可用來指示聲音。 

建立對嘴

請依照下列步驟,開始建立對嘴。:

  1. 建立圖像元件 (嘴型)。

    在圖像元件內,您可以繪製所有嘴型/發音嘴型。

  2. 在主要時間軸中,在新圖層匯入音效。

    註解:

    自動對嘴與設定為「串流」的音效同步設定,搭配效果最佳。

    具有音效圖層的樣本元件
    具有音效圖層的樣本元件
  3. 選取嘴巴圖像元件。在「屬性」檢測器中,按一下「對嘴」

    「屬性」檢測器中的「對嘴」
    「屬性」檢測器中的「對嘴」

    「建立對嘴」對話方塊隨即出現。根據預設,發音嘴型的 12 個基本類型顯示如下:

    建立對嘴
    建立對嘴
  4. 按一下任何發音嘴型,以修改嘴型對應。隨即出現彈出式視窗,其中包含圖像元件內的所有嘴型。從彈出式視窗中選取適當的影格,以設定用於目前的發音嘴型。

    修改每個發音嘴型的嘴型
    修改每個發音嘴型的嘴型
  5. 選取要同步之對嘴的音效圖層。按一下「同步」按鈕。

    套用對嘴後的時間軸螢幕擷取畫面
    套用對嘴後的時間軸螢幕擷取畫面

    註解:

    自動對嘴會套用到出現所選圖像元件的影格範圍上。此外,您也可以先選取多個關鍵影格,以便在選取的影格範圍間套用對嘴。

  6. 按下 Ctrl+Enter 執行檔案並預覽輸出。

    您可以檢視動畫檔案,其中包含也與聲音檔案同步的自動產生嘴巴動作。

打散元件實體

若要中斷實體和元件之間的連結,並將該實體放入尚未組成群組的形狀和線條之集合中,請打散實體。當您需要大幅變更實體而不影響到其他實體時,這個功能非常有用。

在實體打散後,對實體來源元件所做的變更將不會影響實體。

  1. 在舞台上選取實體。
  2. 選取「修改 > 打散」。這動作會將該實體打散成組件圖像元素。
  3. 若要修改這些元素,請使用上色與繪圖工具。

取得舞台上實體的相關資訊

「屬性」檢測器和「資訊」面板會顯示下列有關「舞台」上所選取實體的資訊:

  • 在「屬性」檢測器中,可以檢視實體的行為指令及設定值,亦即:所有的實體類型-顏色效果設定、位置及大小;圖像-循環模式以及包含該圖像的第一個影格;按鈕-實體名稱 (若已指定) 及字距選項;影片片段-實體名稱 (若已指定)。對於位置,「屬性」檢測器會顯示元件註冊點的 xy 座標。

  • 在「資訊」面板中,可以檢視實體的大小及位置、實體的註冊點位置、實體的紅 (R)、綠 (G)、藍 (B) 及 Alpha (A) 值 (若該實體具有實心填色),以及游標的位置。「屬性」檢測器上的「位置及大小」區段會顯示元件註冊點或變形點的 xy 座標。您可以切換檢視註冊點或變形點的座標。

  • 在「影片結構檢視器」中,您可以檢視目前文件的內容,包括實體和元件。

    在「動作」面板中,您可以檢視指定給按鈕或影片片段的任何動作。

取得實體的相關資訊

  1. 在舞台上選取實體。

  2. 顯示「屬性」檢測器 (「視窗 > 屬性」) 或要使用的面板:

    • 若要顯示「資訊」面板,請選取「視窗 > 資訊」。

    • 若要顯示「影片結構檢視器」,請選取「視窗 > 影片結構檢視器」。

    • 若要顯示「動作」面板,請選取「視窗 > 動作」。

在影片結構檢視器中檢視所選取元件的元件定義:

  1. 按一下「影片結構檢視器」頂端的「顯示按鈕、影片片段及圖像」按鈕。

  2. 按一下右鍵 (Windows) 或 Control+按一下 (Macintosh),然後選取「顯示元件實體」和「前往元件定義」;或是在「影片結構檢視器」右上角的選單中選取這些選項。

跳到包含所選取元件之實體的場景

  1. 顯示元件定義。

  2. 按一下右鍵 (Windows) 或 Control+按一下 (Macintosh),然後選取「顯示影片元素」和「前往元件定義」;或是在「影片結構檢視器」右上角的選單中選取這些選項。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策