Guide d'utilisation Annuler

Fusion des données à l’aide du panneau Variables

  1. Guide de l’utilisateur d’Illustrator
  2. Découverte d’Illustrator
    1. Présentation d’Illustrator
      1. Nouveautés d’Illustrator
      2. Questions fréquentes
      3. Configuration requise pour Illustrator
      4. Illustrator pour Apple Silicon
    2. Espace de travail
      1. Principes de base sur les espaces de travail
      2. Création de documents
      3. Outils
      4. Raccourcis clavier par défaut
      5. Personnalisation des raccourcis clavier
      6. Introduction aux plans de travail
      7. Gestion des plans de travail
      8. Personnalisation de l’espace de travail
      9. Panneau Propriétés
      10. Définition des préférences de la mémoire
      11. Espace de travail Tactile
      12. Prise en charge de Microsoft Surface Dial dans Illustrator
      13. Récupération, annulation et automatisation
      14. Faire pivoter l’affichage
      15. Règles, grilles et repères
      16. Accessibilité dans Illustrator
      17. Mode sans échec
      18. Affichage des illustrations
      19. Utilisation de la Touch Bar avec Illustrator
      20. Fichiers et modèles
    3. Outils dans Illustrator
      1. Sélection
        1. Présentation
        2. Sélection
        3. Sélection directe
        4. Lasso
        5. Plan de travail
      2. Navigation
        1. Présentation
        2. Zoom
        3. Pivotement de l’affichage
      3. Peinture
        1. Présentation
        2. Dégradé
        3. Concepteur de forme
      4. Texte
        1. Présentation
        2. Texte
        3. Texte curviligne
  3. Illustrator sur iPad
    1. Introduction à Illustrator sur iPad
      1. Présentation d’Illustrator sur iPad
      2. FAQ sur Illustrator sur iPad
      3. Configuration requise | Illustrator sur iPad
      4. Ce que vous pouvez ou ne pouvez pas faire dans Illustrator sur iPad
    2. Espace de travail
      1. Espace de travail Illustrator sur iPad
      2. Raccourcis et mouvements tactiles
      3. Raccourcis clavier pour Illustrator sur iPad
      4. Gestion des paramètres de votre application
    3. Documents
      1. Utilisation des documents dans Illustrator sur iPad
      2. Importation de documents Photoshop et Fresco
    4. Sélection et organisation des objets
      1. Création des objets répétés
      2. Fusion d’objets
    5. Dessin
      1. Dessin et modification des tracés
      2. Dessin et modification de formes
    6. Texte
      1. Utilisation du texte et des polices
      2. Création de compositions de texte sur un tracé
      3. Ajout de vos propres polices
    7. Utilisation d’images
      1. Vectorisation d’images pixellisées
    8. Couleur
      1. Application des couleurs et des dégradés
  4. Documents en ligne
    1. Fonctionnalités de base
      1. Utilisation des documents en ligne Illustrator
      2. Partage et collaboration sur des documents en ligne Illustrator
      3. Mise à niveau de l’espace de stockage pour Adobe Illustrator
      4. Documents en ligne Illustrator | Questions fréquentes
    2. Résolution des problèmes
      1. Résolution des problèmes de création ou d’enregistrement de documents en ligne Illustrator
      2. Résolution des problèmes sur les documents en ligne Illustrator
  5. Ajout et modification de contenu
    1. Dessin
      1. Concepts de base sur le dessin
      2. Modification des tracés
      3. Dessin ultraprécis d’illustrations
      4. Dessin avec l’outil Stylo, Courbure ou Crayon
      5. Dessin de lignes et formes simples
      6. Vectorisation d’images
      7. Simplification des tracés
      8. Définition de grilles de perspective
      9. Outils de symbolisme et jeux de symboles
      10. Modification des segments de tracé
      11. Création d’une fleur en 5 étapes faciles
      12. Dessin en perspective
      13. Symboles
      14. Dessin de tracés alignés sur les pixels dans des workflows web
    2. Effets 3D et matières Adobe Substance
      1. À propos des effets 3D dans Illustrator
      2. Création de graphismes 3D
      3. Placage d’illustrations sur des objets 3D
      4. Création d’objets 3D
      5. Création de texte 3D
    3. Couleur
      1. À propos de la couleur
      2. Sélection de couleurs
      3. Utilisation et création de nuanciers
      4. Correction des couleurs
      5. Utilisation du panneau Thèmes Adobe Color
      6. Groupes de couleurs (harmonies)
      7. Panneau Thèmes de couleur
      8. Redéfinition des couleurs d’une illustration
    4. Peinture
      1. À propos de la peinture
      2. Peinture avec les fonds et les contours
      3. Groupes de peinture dynamique
      4. Dégradés
      5. Formes
      6. Transparence et modes de fusion
      7. Application d’un contour sur un objet
      8. Création et modification de motifs
      9. Filets
      10. Motifs
    5. Sélection et organisation des objets
      1. Sélection d’objets
      2. Calques
      3. Association et développement des objets
      4. Déplacement, alignement et répartition d’objets
      5. Superposition d’objets    
      6. Verrouillage, masquage et suppression d’objets
      7. Duplication d’objets
      8. Application de rotations et de symétries aux objets
    6. Remodelage d’objets
      1. Recadrage des images
      2. Transformation d’objets
      3. Combinaison d’objets
      4. Découpage, division et rognage d’objets
      5. Déformation de la marionnette
      6. Mise à l’échelle, déformation et distorsion des objets
      7. Fusion d’objets
      8. Modelage à l’aide d’enveloppes
      9. Remodelage des objets à l’aide d’effets
      10. Création de formes avec les outils Mise en forme et Concepteur de forme
      11. Utilisation des angles dynamiques
      12. Amélioration des flux de modelage avec prise en charge des commandes tactiles
      13. Modification des masques d’écrêtage
      14. Formes dynamiques
      15. Création de formes à l’aide de l’outil Concepteur de forme
      16. Modifications globales
    7. Texte
      1. Ajout de texte et utilisation d’objets texte
      2. Gestion de la zone de texte
      3. Polices et typographie
      4. Mise en forme de texte
      5. Importation et exportation de texte
      6. Mise en forme des paragraphes
      7. Caractères spéciaux
      8. Création de texte curviligne
      9. Styles de caractère et de paragraphe
      10. Onglets
      11. Texte et typographie
      12. Recherche de polices manquantes (flux de travaux Typekit)
      13. Mise à jour de textes provenant d’Illustrator 10
      14. Texte en arabe et en hébreu
      15. Polices | FAQ et conseils de dépannage
      16. Création d’effets de texte 3D
      17. Designs typographiques créatifs
      18. Mise à l’échelle et rotation du texte
      19. Espacement des lignes et interlettrage
      20. Césure et sauts de ligne
      21. Améliorations relatives au texte
      22. Orthographe et dictionnaires de langue
      23. Mise en forme des caractères asiatiques
      24. Compositeurs de scripts asiatiques
      25. Création de designs de texte avec des dégradés d’objets
      26. Création d’une affiche de texte à l’aide du tracé d’image
    8. Création d’effets spéciaux
      1. Utilisation des effets
      2. Styles graphiques
      3. Création d’une ombre portée
      4. Attributs d’aspect
      5. Création d’esquisses et de mosaïques
      6. Ombres portées, lueurs et contour progressif
      7. Résumé des effets
    9. Images Web
      1. Méthodes recommandées pour la création d’images destinées au Web
      2. Graphismes
      3. SVG
      4. Création d’animations
      5. Tranches et cartes-images
  6. Importation, exportation et enregistrement
    1. Importation
      1. Importation de fichiers d’illustration
      2. Importation d’images bitmap
      3. Importation d’une illustration à partir de Photoshop
      4. Importation de plusieurs fichiers
      5. Annulation de l’incorporation des images
      6. Importation de fichiers Adobe PDF
      7. Importation de fichiers EPS, DCS et AutoCAD
      8. Informations sur les liens
    2. Bibliothèques Creative Cloud dans Illustrator 
      1. Bibliothèques Creative Cloud dans Illustrator
    3. Enregistrement
      1. Enregistrement d’une illustration
    4. Exportation
      1. Utilisation d’illustrations Illustrator dans Photoshop
      2. Exportation d’une illustration
      3. Collecte et exportation de ressources par lots
      4. Assemblage de fichiers
      5. Création de fichiers Adobe PDF
      6. Extraction de code CSS | Illustrator CC
      7. Options Adobe PDF
      8. Informations sur les fichiers et métadonnées
  7. Impression
    1. Préparation pour l’impression
      1. Configuration des documents pour l’impression
      2. Modification du format et de l’orientation de la page
      3. Définition des traits de coupe pour le rognage ou l’alignement
      4. Premiers pas avec les zones de travail de grande taille
    2. Impression
      1. Surimpression
      2. Impression avec gestion des couleurs
      3. Impression PostScript
      4. Paramètres prédéfinis d’impression
      5. Repères d’impression et fonds perdus
      6. Impression et enregistrement d’illustrations transparentes
      7. Recouvrement
      8. Impression des séparations des couleurs
      9. Impression de dégradés, de filets et de dégradés de formes
      10. Surimpression en blanc
  8. Automatisation des tâches
    1. Fusion des données à l’aide du panneau Variables
    2. Automatisation avec les scripts
    3. Automatisation avec des scripts d’action
  9. Résolution des problèmes 
    1. Problèmes de plantage
    2. Récupération de fichiers après un plantage
    3. Problèmes liés aux fichiers
    4. Formats de fichier pris en charge
    5. Problèmes avec un pilote de matériel GPU
    6. Problèmes liés à un appareil Wacom
    7. Problèmes liés aux fichiers DLL
    8. Problèmes de mémoire
    9. Problèmes liés au fichier de préférences
    10. Problèmes de police
    11. Problèmes d’imprimante
    12. Partage des rapports d’incident avec Adobe

Dans Illustrator, à l’aide du panneau Variables, vous pouvez facilement créer plusieurs variantes de votre illustration en fusionnant une source de données (fichier CSV ou XML) avec un document Illustrator. Par exemple, au lieu d’effectuer manuellement la modification des objets dans un modèle, vous pouvez utiliser la fonctionnalité de fusion de données pour produire des centaines de variantes du modèle, pour différentes surfaces d’impression, et ce rapidement et avec précision. De même, vous pouvez modifier les noms des participants sur les badges d’événements ou varier les images des bannières web et des cartes postales, sans avoir à refaire vos illustrations. Il vous suffit de créer une conception, puis vous pouvez rapidement produire des variantes en important les noms ou les images depuis un fichier source de données.

Créez des variations personnalisées de votre modèle de conception pour différents projets, telles que des affiches imprimables, des bannières web et des badges d’événement, le tout à l’aide du panneau Variables.

Conditions préalables

Pour fusionner des données, il vous suffit de disposer d’un fichier source de données et d’un document cible. 

  • Le fichier source de données contient des informations qui varient à chaque réédition du document cible, par exemple les noms, les photos et les adresses des destinataires d’une lettre type. Un fichier source de données peut être un fichier .csv (délimité par des virgules) ou un fichier .xml (extensible markup language).
  • Le document cible est un document Illustrator qui contient l’illustration de base à utiliser comme modèle. Ce document peut contenir les espaces réservés des champs de données et les éléments qui ne seront pas modifiés dans chaque itération du document fusionné.

Accès à la fonctionnalité de fusion de données

La fusion de données est accessible depuis le panneau Variables dans Illustrator (Fenêtre > Variables). Le type et le nom de chaque variable du document sont répertoriés dans le panneau. Lorsque la variable est liée à un objet, la colonne Objets affiche le nom de l’objet lié tel qu’il apparaît dans le panneau Calques. Vous pouvez trier les variables par nom, objet ou type en cliquant sur les éléments de la barre d’en-tête.

Panneau Variables

A. Ensemble de données B. Menu du panneau C. Permutation des ensembles de données D. Nom de l’objet lié E. Nom de la variable F. Type de variable G. Verrouiller les variables H. Rendre l’objet dynamique I. Rendre la visibilité dynamique J. Annuler la liaison des variables K. Créer des variables L. Supprimer des variables 

Procédure rapide de fusion des données

  1. Créez un document Illustrator à utiliser comme modèle.

  2. Configurez votre fichier de données source au format CSV ou XML. Pour plus d’informations, reportez-vous à la section Préparation d’un fichier source de données.

  3. Importez un fichier source de données dans Illustrator à l’aide du panneau Variables. Pour plus d’informations, reportez-vous à la section Importation d’un fichier source de données.

  4. Liez une variable à un objet dans votre modèle. Pour plus d’informations, reportez-vous à la section Liaison de variables à des objets.

  5. Affichez l’aperçu du document avec chaque ensemble de données avant d’exporter tous les fichiers. Pour plus d’informations, reportez-vous à la section Affichage de l’aperçu du document avec chaque ensemble de données.

  6. Exportez un lot de fichiers à partir des données à l’aide du panneau Actions dans Illustrator. Pour plus d’informations, reportez-vous à la section Exportation de fichiers à l’aide du panneau Actions.

Préparation d’un fichier source de données

Les fichiers source de données doivent être enregistrés au format .csv (séparé par des virgules) ou .xml (Extensible Markup Language).

Configuration de vos fichiers source CSV

Dans un fichier .csv (séparé par des virgules), les enregistrements sont séparés par des sauts de paragraphe et les champs par des virgules ou tabulations. Le fichier de source de données peut aussi contenir du texte ou des chemins faisant référence à des images sur votre disque dur. Avant d’importer un fichier CSV, procédez comme suit pour permettre à Illustrator d’identifier le type de variable.

  1. Ouvrez votre feuille de calcul.

  2. Précisez le nom de votre champ de données dans la première ligne de la feuille de calcul. Ensuite, procédez comme suit :

    • Entrez le symbole « arobase » (@) avant le nom du champ de données pour insérer du texte ou des chemins d’accès aux fichiers image. Seule la première ligne requiert le symbole @. Les lignes suivantes doivent inclure les chemins d’accès aux images.
    • De même, au début du nom du champ de données, saisissez un symbole « pourcentage » (%) pour les graphiques et un symbole « hashtag » (#) pour la visibilité.
    Remarque :
    • Dans votre feuille de calcul, les noms des champs de données ne doivent pas contenir d’espaces. Par exemple, vous pouvez intituler un champ de données Nom_société et non Nom de la société.
    • De même, les chemins se référant aux fichiers image et aux fichiers de graphiques ne doivent pas contenir d’espaces. Par exemple, le chemin d’accès d’un fichier image doit être C:\Photos\BenoitTournier et non C:\Photos\Benoit Tournier.
    • Tous les fichiers de graphiques liés à votre fichier de source de données doivent être enregistrés au format .csv (valeurs séparées par des virgules).
    • Si un message d’erreur s’affiche lorsque vous insérez le symbole @ au début du champ, insérez une apostrophe (’) avant le symbole @ (exemple : ’@Photos) pour valider la fonction. Certaines applications telles que Microsoft Excel réservent le symbole @ à des fonctions précises.

    (Windows) Exemples de références d’image ou de graphique dans un fichier de source de données

    Nom

    Age

    @Photos

    %Graphes

    Benoît Tournier

    36

    C:\Photos\BenoitTournier.jpg

    C:\Photos\BenoitTournier.csv

    Daniel Petit

    53

    C:\Mesdocuments\daniel.jpg

    C:\Mesdocuments\daniel.csv

    Marielle Lefaure

    26

    C:\Photos\Lefaure.jpg

    C:\Photos\Lefaure.csv

    (macOs) Exemples de références d’image ou de graphique dans un fichier de source de données

    Nom

    Age

    @Photos

    %Graphes

    Benoît Tournier

    36

    /Utilisateurs/photos/BenoitTournier.jpg

    /Utilisateurs/photos/BenoitTournier.csv

    Daniel Petit

    53

    /Utilisateurs/famille/photos/daniel.jpg

    /Utilisateurs/famille/photos/daniel.csv

    Marielle Lefaure

    26

    /Utilisateurs/alpha/photos/Lefaure.jpg

    /Utilisateurs/alpha/photos/Lefaure.csv

  3. Saisissez vos données dans la feuille de calcul.

  4. Utilisez l’une des méthodes suivantes :

    • Enregistrez les feuilles de calcul créées à l’aide de la dernière version de Microsoft Excel (version 2016) aux formats de fichier suivants :
      • CSV (séparé par des virgules) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • Sauvegardez les feuilles de calcul créées à l’aide d’Apple Numbers au format CSV avec le code Unicode (UTF-8).
    Remarque :

    Actuellement, les fichiers CSV exportés dans les formats mentionnés ci-dessus sont pris en charge dans Illustrator. Les autres formats de fichier CSV, tels que les fichiers Macintosh à valeurs séparées par des virgules (.csv), ne sont pas pris en charge pour la fusion de données.

Préparez un fichier XML

  1. Définissez une variable dans votre document. Pour plus d’informations, reportez-vous à la section Liaison de variables à des objets.

  2. Cliquez sur le bouton Capturer l’ensemble de données () dans le panneau Variables. Vous pouvez également sélectionner l’option Capturer l’ensemble de données dans le menu du panneau Variables.

  3. Après la création du nombre désiré d’ensembles de données, sélectionnez Enregistrer la bibliothèque de variables dans le menu du panneau Variables, afin d’enregistrer les ensembles de données dans un fichier XML. Précisez le nom de fichier et un emplacement, puis cliquez sur le bouton Enregistrer.

    Exportation de variables que vous avez créées dans Illustrator en tant que fichier XML

  4. A présent, éditez le fichier XML dans un éditeur de texte tel que Notepad++ (Windows) ou TextWrangler (macOS) pour inclure vos ensembles de données dans ce fichier.

    Exemple : modification d’un fichier XML à l’aide d’un éditeur de texte

    A. Remplacez le chemin de l’image B. Remplacez la chaîne de texte 

  5. Pour importer votre fichier XML dans Illustrator, sélectionnez Charger la bibliothèque de variables dans le menu du panneau Variables. Sélectionnez le fichier XML et cliquez sur Ouvrir.

    Importation de variables dans Illustrator

Importation d’un fichier source de données

Pour lier les variables aux données souhaitées, importez une source de données dans le panneau Variables. Vous ne pouvez sélectionner qu’un seul fichier de source de données par document.

  1. Choisissez Fenêtre > Variables.

  2. Dans le panneau Variables, cliquez sur Importer.

    Importation d’un fichier de source de données à l’aide du panneau Variables

  3. Dans la boîte de dialogue Charger la bibliothèque de variables, sélectionnez un fichier de source de données au format CSV ou XML et cliquez sur Ouvrir.

    Sélection d’un fichier de source de données CSV ou XML

  4. (Facultatif) Vous pouvez modifier, renommer ou supprimer l’ensemble de données ultérieurement, en le sélectionnant d’abord dans le menu déroulant de l’ensemble de données , puis en modifiant ses options.

    • Pour passer d’un ensemble de données à un autre, sélectionnez un ensemble de données dans la liste Ensemble de données du panneau Variables. Vous pouvez également cliquer sur le bouton Ensemble de données précédent () ou Ensemble de données suivant ().
    • Pour appliquer les données du plan de travail à l’ensemble de données actuel, sélectionnez Mettre à jour  l’ensemble de données  dans le menu du panneau Variables.
    • Pour renommer un ensemble de données, modifiez le texte directement dans la zone de texte de l’ensemble de données . Vous pouvez également double-cliquer sur les mots Ensemble de données (à gauche de la zone de l’ensemble de données , puis saisir un nouveau nom et cliquer sur OK.
    • Pour supprimer un ensemble de données, cliquez sur l’icône Supprimer. Vous pouvez également sélectionner Supprimer l’ensemble de données dans le menu du panneau Variables.

Liaison de variables avec des objets

Les variables servent à identifier les éléments d’un modèle que vous souhaitez modifier. Vous pouvez définir quatre types de variables : les variables Visibilité, les variables Chaîne de caractères, les variables Fichier lié et les variables Données de graphe. Le type d’une variable indique les attributs d’objet modifiables (dynamiques). Le type et le nom de chaque variable du document sont répertoriés dans le panneau. Lorsque la variable est liée à un objet, la colonne Objets affiche le nom de l’objet lié tel qu’il apparaît dans le panneau Calques.

Type de variable

Icône indiquant le type de variable

Définition

Variables Visibilité

Permettent d’afficher ou de masquer des illustrations.

Variables Chaîne de caractères

Remplacent une chaîne de texte.

Variables Fichier lié

Remplacent l’objet d’un plan de travail par un objet d’un autre fichier.

Variables Données de graphe

Permettent de remplacer les valeurs dans un graphe.

Variable d’aucun type (non liée)

Liée à aucun objet.

Pour définir des variables dans Illustrator, procédez comme suit :

  1. Sélectionnez un objet.

  2. Dans le panneau Variables (Fenêtre > Variables), sélectionnez la variable avec laquelle vous voulez lier l’objet.

  3.  Pour lier l’objet avec la variable, utilisez l’une des méthodes suivantes :

    • Cliquez sur le bouton Rendre l’objet dynamique ().
    • Choisissez Rendre l’objet dynamique dans le menu du panneau.

Pour créer une variable sans liaison à un objet, procédez comme suit :

  1. Cliquez sur le bouton Nouvelle variable () dans le panneau Variables ou sélectionnez Nouvelle variable dans le menu du panneau.

  2. Pour ensuite lier un objet à la variable, sélectionnez l’objet et la variable, puis cliquez sur le bouton Rendre la visibilité dynamique () ou Rendre l’objet dynamique (). Vous pouvez également sélectionner l’une de ces options dans le menu du panneau.

Utilisation des variables

Vous pouvez modifier le nom ou le type d’une variable, annuler la liaison d’une variable et verrouiller une variable dans le panneau Variables.

L’annulation de la liaison d’une variable rompt le lien existant entre une variable et son objet. Le verrouillage des variables empêche la création et la suppression de variables, ainsi que la modification des options de variable. Vous pouvez toutefois lier des objets à des variables verrouillées et annuler ces liaisons.

Modification du nom et du type d’une variable

  1. Cliquez deux fois sur la variable dans le panneau Variables. Vous pouvez également sélectionner la variable dans le panneau Variables, puis choisir l’option Options de variable dans le menu du panneau.

Annulation de la liaison d’une variable

  1. Cliquez sur le bouton Annuler la liaison de la variable () dans le panneau Variables ou choisissez l’option Annuler la liaison de la variable dans le menu du panneau Variables.

Verrouillage ou déverrouillage de toutes les variables d’un document

  1. Cliquez sur le bouton Verrouiller les variables/Déverrouiller les variables  ou  dans le panneau Variables.

Suppression des variables

La suppression d’une variable efface cette dernière du panneau Variables. Si vous supprimez une variable liée à un objet, cet objet devient statique (sauf s’il est également lié à une variable d’un autre type).

  1. Sélectionnez la variable à supprimer.

  2. Utilisez l’une des méthodes suivantes :

    • Cliquez sur le bouton Supprimer la variable () dans le panneau Variables ou choisissez l’option Supprimer la variable dans le menu du panneau.

    • Pour supprimer la variable sans confirmation, faites glisser la variable vers le bouton Supprimer la variable ().

Modification des objets dynamiques

Vous pouvez modifier les données associées à une variable en modifiant l’objet auquel elle est liée. Par exemple, si vous utilisez une variable Visibilité, vous pouvez modifier l’état de visibilité de l’objet dans le panneau Calques. La modification d’objets dynamiques vous permet de créer plusieurs ensembles de données à utiliser dans le modèle.

  1. Pour sélectionner automatiquement un objet dynamique, sélectionnez un objet dynamique sur le plan de travail ou utilisez l’une des méthodes suivantes :

    • Cliquez sur une variable dans le panneau Variables tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée.

    • Sélectionnez une variable dans le panneau Variables et choisissez l’option Sélectionner l’objet lié dans le menu du panneau.

    • Pour sélectionner tous les objets dynamiques, choisissez l’option Sélectionner tous les objets liés dans le menu du panneau Variables.

  2. Modifiez les données associées à l’objet de la manière suivante :

    • Dans le cas d’un texte, modifiez la chaîne de caractères sur le plan de travail.

    • Dans le cas de fichiers liés, remplacez les images à partir du panneau Liens ou à l’aide de la commande Fichier > Importer.

    • Dans le cas des graphes, modifiez les données dans la boîte de dialogue Données de graphe.

    • Dans le cas des objets avec visibilité dynamique, modifiez l’état de visibilité de l’objet dans le panneau Calques.

Identification des objets dynamiques à l’aide des ID XML

Le panneau Variables affiche le nom des objets dynamiques tels qu’ils sont répertoriés dans le panneau Calques. Si vous enregistrez le modèle au format SVG pour l’utiliser avec d’autres produits Adobe, ces noms d’objets doivent être conformes aux conventions d’attribution de nom XML. Par exemple, les noms XML doivent commencer par une lettre, un trait de soulignement ou deux-points et ne peuvent contenir aucun espace.

Illustrator affecte automatiquement un ID XML valide à tout objet dynamique créé. Pour afficher, modifier et exporter des noms d’objet à l’aide d’ID XML, choisissez la commande Edition > Préférences > Unités (Windows) ou Illustrator > Préférences > Unités (Mac OS), puis sélectionnez l’option ID XML.

Affichez l’aperçu du document avec chaque ensemble de données

Pour découvrir l’aspect final des graphiques, vous pouvez les prévisualiser avant d’exporter tous les fichiers. Utilisez les flèches en regard de l’ensemble de données dans le panneau Variables pour parcourir les ensembles de données et afficher un aperçu de celui de votre choix dans votre document.

Exportation de fichiers à l’aide du panneau Actions

Une fois que vous avez défini les variables et un ou plusieurs ensembles de données, vous pouvez produire les illustrations en mode de traitement par lots, en utilisant les valeurs des ensembles de données. Procédez comme suit :

  1. A l’aide du panneau Actions (Fenêtre > Actions), enregistrez une action pour enregistrer votre document au format désiré. Pour plus d’informations, reportez-vous à la section Automatisation avec actions.

  2. Sélectionnez Traitement par lots dans le menu du panneau Actions et sélectionnez l’action que vous avez créée à l’étape précédente.

  3. Dans la zone Source, sélectionnez Ensembles de données afin d’appliquer l’action sur chaque ensemble de données dans le fichier ouvert.

  4. Dans la zone Destination, spécifiez ce que vous souhaitez faire des fichiers traités. Vous pouvez les laisser ouverts sans enregistrer les modifications (Sans), les enregistrer et les fermer à leur emplacement actuel (Enregistrer et fermer) ou les enregistrer dans un emplacement différent (Dossier).

    Selon l’option choisie, vous pouvez définir d’autres options pour l’enregistrement des fichiers. Pour plus d’informations, reportez-vous à la section Exécution d’un script d’action sur un lot de fichiers.

  5. Cliquez sur OK.

Enregistrement d’un modèle pour la fusion de données

Lorsque vous définissez des variables dans un document Illustrator, vous créez en fait un modèle pour la fusion de données. Vous pouvez enregistrer le modèle au format SVG pour l’utiliser avec d’autres produits Adobe, tels qu’Adobe® Graphics Server. Par exemple, un développeur utilisant Adobe Graphics Server peut lier les variables du fichier SVG directement à une base de données ou une autre source de données.

  1. Choisissez la commande Fichier > Enregistrer sous, saisissez un nom de fichier, sélectionnez le format de fichier SVG et cliquez sur le bouton Enregistrer.

  2. Cliquez sur le bouton Plus d’options et sélectionnez l’option Inclure les données d’Adobe Graphics Server. Cette option inclut toutes les informations requises pour la substitution de variables dans le fichier SVG.

  3. Cliquez sur OK.

Vous rencontrez des problèmes lors de l’importation de votre fichier CSV ?

Si le message d’erreur La bibliothèque de variables entrante n’est pas valide s’affiche lors du chargement d’un fichier de source de données CSV, vérifiez les éléments suivants :

  • Votre fichier CSV n’est pas vide.
  • Les feuilles de calcul que vous avez créées à l’aide de la dernière version de Microsoft Excel sont enregistrées au format CSV (valeurs séparées par des virgules) (*.csv) ou CSV (MS-DOS) (*.csv) et celles que vous avez créées à l’aide d’Apple Numbers sont enregistrées au format CSV avec le code Unicode (UTF-8). Les fichiers de source de données enregistrés dans les autres formats de fichier, tels que les fichiers Macintosh à valeurs séparées par des virgules (*.csv), ne sont pas pris en charge pour la fusion de données.
  • Toutes les colonnes disposent d’un nom de champ de données. Par exemple, Illustrator affiche ce message d’erreur lorsqu’une colonne dans votre fichier de source de données contient des données, mais ne dispose pas d’un nom de champ de données.
  • Le fichier de source de données ne contient pas une colonne vide située entre des colonnes remplies. Par exemple, Illustrator affiche ce message d’erreur lorsque les colonnes B et D de votre fichier de source de données contiennent des données, mais que la colonne C est vide.
Exemple : erreurs lors de la configuration d’un fichier source CSV pour la fusion de données

A. Nom du champ de données manquant pour une colonne B. Une colonne vide se trouve entre des colonnes remplies 

  • Dans votre feuille de calcul, les noms des champs de données ne contiennent pas d’espace.
  • Les chemins d’accès aux images et aux graphiques dans votre fichier source ne contiennent pas d’espace.
  • Les fichiers de graphiques liés à votre fichier de source de données sont enregistrés au format .csv (valeurs séparées par des virgules).
Logo Adobe

Accéder à votre compte

[Feedback V2 Badge]