Dans Illustrator, à l’aide du panneau Variables, vous pouvez facilement créer plusieurs variantes de votre illustration en fusionnant une source de données (fichier CSV ou XML) avec un document Illustrator. Par exemple, au lieu d’effectuer manuellement la modification des objets dans un modèle, vous pouvez utiliser la fonctionnalité de fusion de données pour produire des centaines de variantes du modèle, pour différentes surfaces d’impression, et ce rapidement et avec précision. De même, vous pouvez modifier les noms des participants sur les badges d’événements ou varier les images des bannières web et des cartes postales, sans avoir à refaire vos illustrations. Il vous suffit de créer une conception, puis vous pouvez rapidement produire des variantes en important les noms ou les images depuis un fichier source de données.

variable-panel
Créez des variations personnalisées de votre modèle de conception pour différents projets, telles que des affiches imprimables, des bannières web et des badges d’événement, le tout à l’aide du panneau Variables.

Conditions préalables

Pour fusionner des données, il vous suffit de disposer d’un fichier source de données et d’un document cible. 

  • Le fichier source de données contient des informations qui varient à chaque réédition du document cible, par exemple les noms, les photos et les adresses des destinataires d’une lettre type. Un fichier source de données peut être un fichier .csv (délimité par des virgules) ou un fichier .xml (extensible markup language).
  • Le document cible est un document Illustrator qui contient l’illustration de base à utiliser comme modèle. Ce document peut contenir les espaces réservés des champs de données et les éléments qui ne seront pas modifiés dans chaque itération du document fusionné.

Accès à la fonctionnalité de fusion de données

La fusion de données est accessible depuis le panneau Variables dans Illustrator (Fenêtre > Variables). Le type et le nom de chaque variable du document sont répertoriés dans le panneau. Lorsque la variable est liée à un objet, la colonne Objets affiche le nom de l’objet lié tel qu’il apparaît dans le panneau Calques. Vous pouvez trier les variables par nom, objet ou type en cliquant sur les éléments de la barre d’en-tête.

Panneau Variables
Panneau Variables

A. Ensemble de données B. Menu du panneau C. Permutation des ensembles de données D. Nom de l’objet lié E. Nom de la variable F. Type de variable G. Verrouiller les variables H. Rendre l’objet dynamique I. Rendre la visibilité dynamique J. Annuler la liaison des variables K. Créer des variables L. Supprimer des variables 

Procédure rapide de fusion des données

  1. Créez un document Illustrator à utiliser comme modèle.

  2. Configurez votre fichier de données source au format CSV ou XML. Pour plus d’informations, reportez-vous à la section Préparation d’un fichier source de données.

  3. Importez un fichier source de données dans Illustrator à l’aide du panneau Variables. Pour plus d’informations, reportez-vous à la section Importation d’un fichier source de données.

  4. Liez une variable à un objet dans votre modèle. Pour plus d’informations, reportez-vous à la section Liaison de variables à des objets.

  5. Affichez l’aperçu du document avec chaque ensemble de données avant d’exporter tous les fichiers. Pour plus d’informations, reportez-vous à la section Affichage de l’aperçu du document avec chaque ensemble de données.

  6. Exportez un lot de fichiers à partir des données à l’aide du panneau Actions dans Illustrator. Pour plus d’informations, reportez-vous à la section Exportation de fichiers à l’aide du panneau Actions.

Préparation d’un fichier source de données

Les fichiers source de données doivent être enregistrés au format .csv (séparé par des virgules) ou .xml (Extensible Markup Language).

Configuration de vos fichiers source CSV

Dans un fichier .csv (séparé par des virgules), les enregistrements sont séparés par des sauts de paragraphe et les champs par des virgules ou tabulations. Le fichier de source de données peut aussi contenir du texte ou des chemins faisant référence à des images sur votre disque dur. Avant d’importer un fichier CSV, procédez comme suit pour permettre à Illustrator d’identifier le type de variable.

  1. Ouvrez votre feuille de calcul.

  2. Précisez le nom de votre champ de données dans la première ligne de la feuille de calcul. Ensuite, procédez comme suit :

    • Entrez le symbole « arobase » (@) avant le nom du champ de données pour insérer du texte ou des chemins d’accès aux fichiers image. Seule la première ligne requiert le symbole @. Les lignes suivantes doivent inclure les chemins d’accès aux images.
    • De même, au début du nom du champ de données, saisissez un symbole « pourcentage » (%) pour les graphiques et un symbole « hashtag » (#) pour la visibilité.

    Remarque :

    • Dans votre feuille de calcul, les noms des champs de données ne doivent pas contenir d’espaces. Par exemple, vous pouvez intituler un champ de données Nom_société et non Nom de la société.
    • De même, les chemins se référant aux fichiers image et aux fichiers de graphiques ne doivent pas contenir d’espaces. Par exemple, le chemin d’accès d’un fichier image doit être C:\Photos\BenoitTournier et non C:\Photos\Benoit Tournier.
    • Tous les fichiers de graphiques liés à votre fichier de source de données doivent être enregistrés au format .csv (valeurs séparées par des virgules).
    • Si un message d’erreur s’affiche lorsque vous insérez le symbole @ au début du champ, insérez une apostrophe (’) avant le symbole @ (exemple : ’@Photos) pour valider la fonction. Certaines applications telles que Microsoft Excel réservent le symbole @ à des fonctions précises.

    (Windows) Exemples de références d’image ou de graphique dans un fichier de source de données

    Nom Age @Photos %Graphes
    Benoît Tournier 36 C:\Photos\BenoitTournier.jpg C:\Photos\BenoitTournier.csv
    Daniel Petit 53 C:\Mesdocuments\daniel.jpg C:\Mesdocuments\daniel.csv
    Marielle Lefaure 26 C:\Photos\Lefaure.jpg C:\Photos\Lefaure.csv

    (macOs) Exemples de références d’image ou de graphique dans un fichier de source de données

    Nom Age @Photos %Graphes
    Benoît Tournier 36 /Utilisateurs/photos/BenoitTournier.jpg
    /Utilisateurs/photos/BenoitTournier.csv
    Daniel Petit 53 /Utilisateurs/famille/photos/daniel.jpg
    /Utilisateurs/famille/photos/daniel.csv
    Marielle Lefaure 26 /Utilisateurs/alpha/photos/Lefaure.jpg /Utilisateurs/alpha/photos/Lefaure.csv
  3. Saisissez vos données dans la feuille de calcul.

  4. Utilisez l’une des méthodes suivantes :

    • Enregistrez les feuilles de calcul créées à l’aide de la dernière version de Microsoft Excel (version 2016) aux formats de fichier suivants :
      • CSV (séparé par des virgules) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • Sauvegardez les feuilles de calcul créées à l’aide d’Apple Numbers au format CSV avec le code Unicode (UTF-8).

    Remarque :

    Actuellement, les fichiers CSV exportés dans les formats mentionnés ci-dessus sont pris en charge dans Illustrator. Les autres formats de fichier CSV, tels que les fichiers Macintosh à valeurs séparées par des virgules (.csv), ne sont pas pris en charge pour la fusion de données.

Préparez un fichier XML

  1. Définissez une variable dans votre document. Pour plus d’informations, reportez-vous à la section Liaison de variables à des objets.

  2. Cliquez sur le bouton Capturer l’ensemble de données () dans le panneau Variables. Vous pouvez également sélectionner l’option Capturer l’ensemble de données dans le menu du panneau Variables.

  3. Après la création du nombre désiré d’ensembles de données, sélectionnez Enregistrer la bibliothèque de variables dans le menu du panneau Variables, afin d’enregistrer les ensembles de données dans un fichier XML. Précisez le nom de fichier et un emplacement, puis cliquez sur le bouton Enregistrer.

    save-variable-as-xml-file
    Exportation de variables que vous avez créées dans Illustrator en tant que fichier XML
  4. A présent, éditez le fichier XML dans un éditeur de texte tel que Notepad++ (Windows) ou TextWrangler (macOS) pour inclure vos ensembles de données dans ce fichier.

    example-XML-file
    Exemple : modification d’un fichier XML à l’aide d’un éditeur de texte

    A. Remplacez le chemin de l’image B. Remplacez la chaîne de texte 
  5. Pour importer votre fichier XML dans Illustrator, sélectionnez Charger la bibliothèque de variables dans le menu du panneau Variables. Sélectionnez le fichier XML et cliquez sur Ouvrir.

    load-variable-to-data-set
    Importation de variables dans Illustrator

Importation d’un fichier source de données

Pour lier les variables aux données souhaitées, importez une source de données dans le panneau Variables. Vous ne pouvez sélectionner qu’un seul fichier de source de données par document.

  1. Choisissez Fenêtre > Variables.

  2. Dans le panneau Variables, cliquez sur Importer.

    import-data-set_1
    Importation d’un fichier de source de données à l’aide du panneau Variables
  3. Dans la boîte de dialogue Charger la bibliothèque de variables, sélectionnez un fichier de source de données au format CSV ou XML et cliquez sur Ouvrir.

    select-a-data-source-file_1
    Sélection d’un fichier de source de données CSV ou XML
  4. (Facultatif) Vous pouvez modifier, renommer ou supprimer l’ensemble de données ultérieurement, en le sélectionnant d’abord dans le menu déroulant del’ensemble de données, puis en modifiant ses options.

    • Pour passer d’un ensemble de données à un autre, sélectionnez un ensemble de données dans laliste Ensemble de donnéesdu panneau Variables. Vous pouvez également cliquer sur le bouton Ensemble de données précédent () ou Ensemble de données suivant ().
    • Pour appliquer les données du plan de travail à l’ensemble de données actuel, sélectionnez Mettre à jour l’ensemble de données dans le menu du panneau Variables.
    • Pour renommer un ensemble de données, modifiez le texte directement dans la zone de texte del’ensemble de données. Vous pouvez également double-cliquer sur les mots Ensemble de données (à gauche de la zone del’ensemble de données, puis saisir un nouveaunomet cliquer sur OK.
    • Pour supprimer un ensemble de données, cliquez sur l’icône Supprimer. Vous pouvez également sélectionner Supprimer l’ensemble de données dans le menu du panneau Variables.

Liaison de variables avec des objets

Les variables servent à identifier les éléments d’un modèle que vous souhaitez modifier. Vous pouvez définir quatre types de variables : les variables Visibilité, les variables Chaîne de caractères, les variables Fichier lié et les variables Données de graphe. Le type d’une variable indique les attributs d’objet modifiables (dynamiques). Le type et le nom de chaque variable du document sont répertoriés dans le panneau. Lorsque la variable est liée à un objet, la colonne Objets affiche le nom de l’objet lié tel qu’il apparaît dans le panneau Calques.

Type de variable Icône indiquant le type de variable
Définition
Variables Visibilité Permettent d’afficher ou de masquer des illustrations.
Variables Chaîne de caractères Remplacent une chaîne de texte.
Variables Fichier lié Remplacent l’objet d’un plan de travail par un objet d’un autre fichier.
Variables Données de graphe Permettent de remplacer les valeurs dans un graphe.
Variable d’aucun type (non liée) Liée à aucun objet.

Pour définir des variables dans Illustrator, procédez comme suit :

  1. Sélectionnez un objet.

  2. Dans le panneau Variables (Fenêtre > Variables), sélectionnez la variable avec laquelle vous voulez lier l’objet.

  3.  Pour lier l’objet avec la variable, utilisez l’une des méthodes suivantes :

    • Cliquez sur le bouton Rendre l’objet dynamique ().
    • Choisissez Rendre l’objet dynamique dans le menu du panneau.

Pour créer une variable sans liaison à un objet, procédez comme suit :

  1. Cliquez sur le bouton Nouvelle variable () dans le panneau Variables ou sélectionnez Nouvelle variable dans le menu du panneau.

  2. Pour ensuite lier un objet à la variable, sélectionnez l’objet et la variable, puis cliquez sur le bouton Rendre la visibilité dynamique () ou Rendre l’objet dynamique (). Vous pouvez également sélectionner l’une de ces options dans le menu du panneau.

Utilisation des variables

Vous pouvez modifier le nom ou le type d’une variable, annuler la liaison d’une variable et verrouiller une variable dans le panneau Variables.

L’annulation de la liaison d’une variable rompt le lien existant entre une variable et son objet. Le verrouillage des variables empêche la création et la suppression de variables, ainsi que la modification des options de variable. Vous pouvez toutefois lier des objets à des variables verrouillées et annuler ces liaisons.

Modification du nom et du type d’une variable

  1. Cliquez deux fois sur la variable dans le panneau Variables. Vous pouvez également sélectionner la variable dans le panneau Variables, puis choisir l’option Options de variable dans le menu du panneau.

Annulation de la liaison d’une variable

  1. Cliquez sur le bouton Annuler la liaison de la variable () dans le panneau Variables ou choisissez l’option Annuler la liaison de la variable dans le menu du panneau Variables.

Verrouillage ou déverrouillage de toutes les variables d’un document

  1. Cliquez sur le bouton Verrouiller les variables/Déverrouiller les variables  ou  dans le panneau Variables.

Suppression des variables

La suppression d’une variable efface cette dernière du panneau Variables. Si vous supprimez une variable liée à un objet, cet objet devient statique (sauf s’il est également lié à une variable d’un autre type).

  1. Sélectionnez la variable à supprimer.

  2. Utilisez l’une des méthodes suivantes :

    • Cliquez sur le bouton Supprimer la variable () dans le panneau Variables ou choisissez l’option Supprimer la variable dans le menu du panneau.

    • Pour supprimer la variable sans confirmation, faites glisser la variable vers le bouton Supprimer la variable ().

Modification des objets dynamiques

Vous pouvez modifier les données associées à une variable en modifiant l’objet auquel elle est liée. Par exemple, si vous utilisez une variable Visibilité, vous pouvez modifier l’état de visibilité de l’objet dans le panneau Calques. La modification d’objets dynamiquesvous permet decréer plusieurs ensembles de données à utiliser dans le modèle.

  1. Pour sélectionner automatiquement un objet dynamique, sélectionnez un objet dynamique sur le plan de travail ou utilisez l’une des méthodes suivantes :

    • Cliquez sur une variable dans le panneau Variables tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée.

    • Sélectionnez une variable dans le panneau Variables et choisissez l’option Sélectionner l’objet lié dans le menu du panneau.

    • Pour sélectionner tous les objets dynamiques, choisissez l’option Sélectionner tous les objets liés dans le menu du panneau Variables.

  2. Modifiez les données associées à l’objet de la manière suivante :

    • Dans le cas d’un texte, modifiez la chaîne de caractères sur le plan de travail.

    • Dans le cas de fichiers liés, remplacez les images à partir du panneau Liens ou à l’aide de la commande Fichier > Importer.

    • Dans le cas des graphes, modifiez les données dans la boîte de dialogue Données de graphe.

    • Dans le cas des objets avec visibilité dynamique, modifiez l’état de visibilité de l’objet dans le panneau Calques.

Identification des objets dynamiques à l’aide des ID XML

Le panneau Variables affiche le nom des objets dynamiques tels qu’ils sont répertoriés dans le panneau Calques. Si vous enregistrez le modèle au format SVG pour l’utiliser avec d’autres produits Adobe, ces noms d’objets doivent être conformes aux conventions d’attribution de nom XML. Par exemple, les noms XML doivent commencer par une lettre, un trait de soulignement ou deux-points et ne peuvent contenir aucun espace.

Illustrator affecte automatiquement un ID XML valide à tout objet dynamique créé. Pour afficher, modifier et exporter des noms d’objet à l’aide d’ID XML, choisissez la commande Edition > Préférences > Unités (Windows) ou Illustrator > Préférences > Unités (Mac OS), puis sélectionnez l’option ID XML.

Affichez l’aperçu du document avec chaque ensemble de données

Pour découvrir l’aspect final des graphiques, vous pouvez les prévisualiser avant d’exporter tous les fichiers. Utilisez les flèches en regard de l’ensemble de données dans le panneau Variables pour parcourir les ensembles de données et afficher un aperçu de celui de votre choix dans votre document.

Exportation de fichiers à l’aide du panneau Actions

Une fois que vous avez défini les variables et un ou plusieurs ensembles de données, vous pouvez produire les illustrations en mode de traitement par lots, en utilisant les valeurs des ensembles de données. Procédez comme suit :

  1. A l’aide du panneau Actions (Fenêtre > Actions), enregistrez une action pour enregistrer votre document au format désiré. Pour plus d’informations, reportez-vous à la section Automatisation avec actions.

  2. Sélectionnez Traitement par lots dans le menu du panneau Actions et sélectionnez l’action que vous avez créée à l’étape précédente.

  3. Dans la zone Source, sélectionnez Ensembles de données afin d’appliquer l’action sur chaque ensemble de données dans le fichier ouvert.

  4. Dans la zone Destination, spécifiez ce que vous souhaitez faire des fichiers traités. Vous pouvez les laisser ouverts sans enregistrer les modifications (Sans), les enregistrer et les fermer à leur emplacement actuel (Enregistrer et fermer) ou les enregistrer dans un emplacement différent (Dossier).

    Selon l’option choisie, vous pouvez définir d’autres options pour l’enregistrement des fichiers. Pour plus d’informations, reportez-vous à la section Exécution d’un script d’action sur un lot de fichiers.

  5. Cliquez sur OK.

Enregistrement d’un modèle pour la fusion de données

Lorsque vous définissez des variables dans un document Illustrator, vous créez en fait un modèle pour la fusion de données. Vous pouvez enregistrer le modèle au format SVG pour l’utiliser avec d’autres produits Adobe, tels qu’Adobe® Graphics Server. Par exemple, un développeur utilisant Adobe Graphics Server peut lier les variables du fichier SVG directement à une base de données ou une autre source de données.

  1. Choisissez la commande Fichier > Enregistrer sous, saisissez un nom de fichier, sélectionnez le format de fichier SVG et cliquez sur le bouton Enregistrer.

  2. Cliquez sur le bouton Plus d’options et sélectionnez l’option Inclure les données d’Adobe Graphics Server. Cette option inclut toutes les informations requises pour la substitution de variables dans le fichier SVG.

  3. Cliquez sur OK.

Vous rencontrez des problèmes lors de l’importation de votre fichier CSV ?

Si le message d’erreur La bibliothèque de variables entrante n’est pas valide s’affiche lors du chargement d’un fichier de source de données CSV, vérifiez les éléments suivants :

  • Votre fichier CSV n’est pas vide.
  • Les feuilles de calcul que vous avez créées à l’aide de la dernière version de Microsoft Excel sont enregistrées au format CSV (valeurs séparées par des virgules) (*.csv) ou CSV (MS-DOS) (*.csv) et celles que vous avez créées à l’aide d’Apple Numbers sont enregistrées au format CSV avec le code Unicode (UTF-8). Les fichiers de source de données enregistrés dans les autres formats de fichier, tels que les fichiers Macintosh à valeurs séparées par des virgules (*.csv), ne sont pas pris en charge pour la fusion de données.
  • Toutes les colonnes disposent d’un nom de champ de données. Par exemple, Illustrator affiche ce message d’erreur lorsqu’une colonne dans votre fichier de source de données contient des données, mais ne dispose pas d’un nom de champ de données.
  • Le fichier de source de données ne contient pas une colonne vide située entre des colonnes remplies. Par exemple, Illustrator affiche ce message d’erreur lorsque les colonnes B et D de votre fichier de source de données contiennent des données, mais que la colonne C est vide.
Example-errors-while-importing-CSV-files
Exemple : erreurs lors de la configuration d’un fichier source CSV pour la fusion de données

A. Nom du champ de données manquant pour une colonne B. Une colonne vide se trouve entre des colonnes remplies 
  • Dans votre feuille de calcul, les noms des champs de données ne contiennent pas d’espace.
  • Les chemins d’accès aux images et aux graphiques dans votre fichier source ne contiennent pas d’espace.
  • Les fichiers de graphiques liés à votre fichier de source de données sont enregistrés au format .csv (valeurs séparées par des virgules).

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne