If your page load rule is not firing incorrectly, you may end up facing one or more of the following problems:

  • Rule not getting triggered at the desired condition (issues  with your rule conditions)
  • Multiple server calls or alternatively, no server calls
  • Data elements values not being called.

 

In order to troubleshoot your page load rules, you can try following the steps listed below:

  1. Load your page and in console window and type “_satellite.setDebug(true);” to turn on the debugger.
  2. Reload the page and check for the rules fired on that particular page.
  3. Check for your specific page load rule applied on that page.
  4. If your page load rule has a condition defined but is still it is not firing in that case you need to check the condition of that page load rule.
  5. Sometimes, with regards to rule conditions, data may not be passed if the rule is fired at the top of the page as it requires some time. In that case, change your condition to make the rule fire at the bottom of the page.
  6. Problems related to Page Load Rule can be caused due to incorrect Regex usage in which case would need to check for these conditions.
  7. If your rule condition has a Data Element to match the value, the data element may not be being captured correctly in which case it is first a good idea to check if the value is being captured in the first place
    (data elements can be called using the %<data_element_name%).

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea