To create slideshow-type content that can be played in Flash Player, you can export to either SWF or FLA. The main difference is that SWF files are ready to be viewed and cannot be edited, whereas FLA files must be edited in Adobe Flash Professional to be viewed in Adobe Flash Player.

SWF

An exported SWF file is ready for viewing in Adobe Flash Player and may include interactive elements such as page transitions, hyperlinks, movies, sound clips, animation, and navigation buttons.

FLA

An exported FLA file includes only some interactive elements. The FLA file can be opened in Flash Pro, where you or a Flash developer can add advanced effects before exporting to SWF.

Export to Flash
Export to Flash

A. Export directly to SWF B. Export to FLA for editing in Flash Professional 

Create interactive SWF (Flash) files for the web

When you export to SWF, you create an interactive file that’s ready for viewing in Adobe Flash Player or in a web browser. The SWF file can include buttons, page transitions, movies and audio files, animation, and hyperlinks added in InDesign. Exporting to SWF is a good way to create an interactive slideshow, or a flip book, based on an InDesign document.

If you want to edit the document in Flash Pro before creating the SWF file, export to FLA instead of SWF. See Create FLA files for the web.

SWF export
SWF export

A. Document in InDesign before SWF export B. Interactive SWF file in web browser 
  1. Create or edit the InDesign document to prepare it for Flash export. For more detailed information on setting up the document for export, see Flash export issues.

    • Add navigation buttons that allow users to move from page to page in the exported SWF file. You can create a buttons by drawing an object and converting it to a button using the Buttons panel (choose Window > Interactive > Buttons). You can also use the Sample Buttons panel to drag predefined navigation buttons into your document. See Create buttons.

    • Use the Page Transitions panel (choose Window > Interactive > Page Transitions) to add page transitions such as wipes or dissolves. When you export to SWF, you can also select the Include Interactive Page Curl option, which lets viewers drag a page corner to turn the page.

    • Use the Animation panel (choose Window > Interactive > Animation) to add motion presets. See Animation.

  2. To export the document to SWF format, choose File > Export. Choose Flash Player (SWF) from the Save As Type (Windows) or Format (Mac OS) menu, and click Save.

  3. In the Export SWF dialog box, specify the options, and then click OK. See SWF export options.

When you export a SWF file, separate HTML and SWF files are created. If the SWF file includes movies or sound clips, a Resources folder is also created. To hand off or upload the files to the web, make sure you send all the assets.

SWF export options

The following options appear on the General and Advanced tabs of the Export SWF dialog box.

Export

Indicate whether the current selection, all pages in the document, or a page range is included. Choosing Selection is especially useful if you want to save the exported SWF file for use in an exported PDF file. If you select Range, specify a page range, such as 1-7, 9 to print pages 1 through 7 and 9. See Specifying pages to print.

Generate HTML File

Select this option to generate an HTML page that plays back the SWF file. This option is especially useful for quickly previewing the SWF file in your web browser.

View SWF After Exporting

Select this option to play back the SWF file in your default web browser. This option is available only if you generate an HTML file.

Size (pixels)

Specify whether the SWF file is scaled by a percentage, fit to a monitor size you specify, or sized according to the width and height you specify.

Background

Specify whether the background of your SWF is transparent or if it uses the current Paper color from the Swatches panel. Selecting Transparent disables the Page Transitions and Interactive Page Curl options.

Interactivity And Media

Select Include All to allow movies, sounds, buttons, and animations to be interactive in the exported SWF file. Select Appearance Only to include the normal state of buttons and the video posters as static elements. If Appearance Only is selected, animations export as they appear in the layout at the time of export. Appearance Only is selected if you choose Flatten Transparency in the Advanced panel.

Page Transitions

Specify one page transition to apply to all pages during export. If you use the Page Transitions panel to specify transitions, choose the From Document option to use those settings.

Include Interactive Page Curl

If this option is selected, users playing the SWF file can drag a corner of the page to turn it, giving the appearance of turning the page in a real book.

Frame Rate

Higher frame rates create smoother animations but may increase the file size. Changing the frame rate does not affect playback duration.

Text

Specify how InDesign text is output. Choose Flash Classic Text to output searchable text that results in the smallest file size. Choose Convert To Outlines to output the text as a series of smooth straight lines, like converting text to outlines. Choose Convert To Pixels to output the text in a bitmap image. Text converted to pixels may appear jagged when zoomed in on.

Rasterize Pages

This option converts all InDesign page items to bitmap. Selecting this option results in a larger SWF file, and page items may appear jagged when zoomed in on.

Flatten Transparency

This option removes live transparency from the SWF and preserves the transparency appearance. However, all interactivity is removed from the exported SWF file if this option is selected.

Compression

Choose Automatic to let InDesign determine the best quality for color and grayscale images. For most files, this option produces satisfactory results. Choosing JPEG (Lossy) is suitable for grayscale or color images. JPEG compression is lossy, which means that it removes image data and possibly reduces image quality. However, it attempts to reduce file size with a minimal loss of information. Because JPEG compression eliminates data, it can achieve much smaller files sizes. Choosing PNG (Lossless) exports the file without lossy compression.

Note:

If you notice a loss of image quality in transparent images when you export to SWF, choose PNG (Lossless) to improve the quality.

JPEG Quality

Specifies the amount of detail in the exported image. The higher the quality, the larger the file size. This option is dimmed if you choose PNG (Lossless) for Compression.

Resolution

Specify the resolution of bitmap images in the exported SWF. Choosing a high resolution is especially important to allow viewers to zoom in on pixel-based content within your exported SWF. Choosing a high resolution can significantly increase the file size.

Create FLA files for the web

When you export your InDesign document to FLA file format, you can open the file in Adobe Flash® CS5 Professional to edit the contents. Exporting to FLA in InDesign CS5 format replaces XFL export in InDesign CS4. Use the Flash authoring environment to edit or add video, audio, animation, and complex interactivity.

If you want to export the InDesign document directly to a format that can be opened directly in a web browser, use the SWF format instead of FLA. See Create interactive SWF (Flash) files for the web.

FLA export
FLA export

A. Document in InDesign before FLA export B. FLA file opened in Flash Pro 
  1. Create or edit the InDesign document to prepare it for Flash export. For more detailed information on setting up the document for export, see Flash export issues.

  2. To export the document to FLA format, choose File > Export. Choose Flash CS5 Professional (FLA) from the Save As Type (Windows) or Format (Mac OS) menu, and click Save.

  3. In the Export Flash CS5 Professional (FLA) dialog box, specify the options, and then click OK. For information on export options, see FLA export options.

  4. Open the exported FLA file in Flash Professional.

FLA export options

The following options appear in the Export Flash CS5 Professional (FLA) dialog box.

Export

Indicate whether the current selection, all pages in the document, or a page range is included. If you select Range, specify a page range, such as 1-7, 9 to print pages 1 through 7 and 9. See Specifying pages to print.

Rasterize Pages

This option converts all InDesign page items to bitmap. Selecting this option results in a larger FLA file, and page items become jagged when zoomed in on.

Flatten Transparency

Selecting this option flattens all objects with transparency. Flattened objects may be difficult to animate in Adobe Flash Pro.

Size (Pixels)

Specify whether the FLA file is scaled by a percentage, fit to a monitor size you specify, or sized according to a width and height you specify.

Interactivity And Media

Select Include All to allow movies, sounds, buttons, and animations to be included in the exported FLA file. If the document includes a multi-state object, it is converted into a movie clip symbol in which each state appears on its own frame in the timeline.

Select Appearance Only to include the normal state of buttons and the video posters as static elements. If Appearance Only is selected, animations export as they appear in the layout at the time of export. Appearance Only is selected if you choose Flatten Transparency.

Text

Specify how InDesign text is output. Choose Flash TLF Text to take advantage of the rich set of Text Layout Framework attributes in Flash Professional. If this option is selected, select Insert Dictionary Hyphenation Points to allow hyphenation. Choose Flash Classic Text to output searchable text that results in a small file size. Choose Convert To Outlines to output the text as a series of smooth straight lines, like converting text to outlines. Choose Convert To Pixels to output the text in a bitmap image. Text converted to pixels may appear jagged when zoomed in on.

Compression

Choose Automatic to let InDesign determine the best quality for color and grayscale images. For most files, this option produces satisfactory results. Choosing JPEG (Lossy) is suitable for grayscale or color images. JPEG compression is lossy, which means that it removes image data and possibly reduces image quality. However, it attempts to reduce file size with a minimal loss of information. Because JPEG compression eliminates data, it can achieve much smaller files sizes. Choosing PNG (Lossless) exports the file without lossy compression.

JPEG Quality

Specifies the amount of detail in the exported image. The higher the quality, the larger the file size. This option is dimmed if you choose PNG (Lossless) for Compression.

Resolution

Specify the resolution of bitmap images in the exported FLA file. Choosing a high resolution is especially important to allow viewers to zoom in on pixel-based content. Choosing a high resolution can significantly increase the file size.

Flash export issues

Consider the following factors when designing your InDesign document for SWF or FLA output.

Document setup issues

How InDesign pages are converted

When you export to SWF or FLA, InDesign spreads become separate clips in a timeline, like slides in a slideshow. Each spread is mapped to a new keyframe. In Flash Player, you advance through the spreads of the exported document by pressing arrow keys or clicking interactive buttons.

Note:

When creating a document intended for the web, choose Web from the Intent menu in the New Document dialog box.

Page size

When you create a document, you can choose a specific resolution, such as 800 x 600, from the Page Size menu in the New Document dialog box. During export, you can also adjust the scale or resolution of the exported SWF or FLA file.

Interactivity features

Buttons, page transitions, hyperlinks, animation, and media files can be included in exported SWF and FLA files.

Buttons

For buttons in an exported SWF or FLA file, the Next Page and Previous Page actions are especially useful controls for playback in Flash Player. However, some actions that work in interactive PDF files have no effect in Flash Player. When you choose an action in the Buttons panel, do not select an option from the PDF Only section.

Note:

You can add navigation buttons that are preformatted with Go To Next Page and Go To Previous Page actions. Choose Sample Buttons from the Buttons panel menu. See Add a button from the Sample Buttons panel.

Page Transitions

All page transitions work well in Flash Player. In addition to page transitions that appear when you turn the page, you can add include an interactive page curl during export that lets you drag corners of pages to turn them.

Hyperlinks

Create links to websites or to other pages in the document. Hyperlinks are broken in FLA files.

Movies and sound clips

Movies and sound clips are included in an exported SWF file if they’re in a supported format, such as SWF, FLV, F4V, and MP4 for movies and MP3 for sound clips.

When you export to FLA, only the poster image is included in the FLA file. Supported media files appear in a resources folder saved in the same location as the exported FLA file.

Conversion issues

Color

SWF and FLA files use RGB color. When a document is exported to SWF or FLA, InDesign converts all color spaces (such as CMYK and LAB) to sRGB. InDesign converts spot colors to equivalent RGB process colors.

To avoid unwanted color changes in artwork with text with transparency, choose Edit > Transparency Blend Space > Document RGB. To avoid unwanted color changes in images with transparency, avoid using a lossy compression during export.

Text

When exporting to SWF or FLA, you can determine whether text is output as Flash text or converted to outlines or pixels. Text exported as Flash Classic Text remains fully editable when the FLA file is opened in Adobe Flash CS5 Professional and can be searched in web browsers when saved as SWF files.

Images

When you export images to SWF or FLA, you can change image compression, JPEG quality, and resolution settings during export.

When you export images to FLA, an image placed multiple times in your InDesign document is saved as a single image asset with a shared location. Note that a large number of vector images in the InDesign document may cause performance problems in the exported file.

To reduce file size, place repeating images on master pages, and avoid copying and pasting images. If the same image is placed multiple times in the document and not transformed or cropped, only one copy of the file is exported in the FLA file. Images that are copied and pasted are treated as separate objects.

By default, a placed Illustrator file is treated as a single image in the FLA file, whereas an Illustrator file that’s copied and pasted generates many individual objects. For best results, place the Illustrator image as a PDF file instead of copying and pasting from Illustrator. Copying and pasting results in multiple editable paths.

Note:

You can change preference options to make sure that Illustrator objects are pasted as one object instead of a collection of small vectors. In Illustrator File Handling & Clipboard preferences, select PDF and deselect AICB (No Transparency Support). In InDesign Clipboard Handling preferences, select both Prefer PDF When Pasting and Copy PDF To Clipboard.

Transparency

Before exporting to SWF, make sure that transparent objects do not overlap any interactive element, such as a button or hyperlink. If an object with transparency overlaps an interactive element, the interactivity may be lost during export. You may want to flatten transparency before exporting to FLA.

In some instances, choosing a lossy compression reduces the quality of images with transparency. When exporting, choose PNG (Lossless) to improve the quality.

3D attributes

3D attributes are not supported in the exported SWF and FLA files.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy