InDesign과 macOS Catalina(10.15)

ExtendScript 도구 키트가 열리지 않음

문제

macOS 10.14 또는 이전 버전에서는 InDesign의 스크립트 패널을 사용하여 JavaScript를 편집할 때(> 유틸리티 > 스크립트) ExtendScript 도구 키트가 표시됩니다. 이 도구 키트는 32비트 애플리케이션입니다. 그러나 64비트 애플리케이션만 지원하는 macOS 10.15(Catalina)에서는 ExtendScript Toolkit가 열리지 않습니다.

해결 방법

ExtendScript Toolkit이 ExtendScript Debugger 1.1.0으로 대체되었습니다.

macOS 10.15 이상 버전에서 JavaScript를 편집하고 디버깅하려면 다음을 수행합니다.

  • /Applications 폴더에 Visual Studio 코드를 다운로드하여 설치합니다.
  • Visual Studio 코드 애플리케이션에서 확장 프로그램 아래에 사용 가능한 ESTK(ExtendScript Extension)를 설치합니다.

플러그인을 찾을 수 없거나 확인할 수 없음

macOS 10.15에서 격리된 플러그인은 다음 오류 중 하나를 반환합니다.

  • InDesign: 파일을 찾을 수 없음 오류 
  • OS: 개발자가 확인할 수 없기 때문에 플러그인을 열 수 없습니다.

이 오류는 웹에서 다운로드하거나 끌어서 놓기와 같은 다른 방법으로 설치했다는 공증을 받지 않은 플러그인에서 발생합니다.

  • 플러그인이 이미 설치되어 있는 고객은 macOS 10.15으로 업데이트하면 이 문제가 표시되지 않습니다.
  • macOS 10.15으로 업그레이드하는 고객은 플러그인을 다운로드하여 설치하려고 하면 오류가 표시될 수 있습니다.

해결 방법

macOS 10.15에 대해 공증된 타사 개발자로부터 업데이트된 플러그인을 받습니다. InDesign은 Apple에서 공증한 플러그인을 로드합니다.

 

해결 방법

공증되지 않은 이전 플러그인의 경우 관리자 권한이 있는 고객은 플러그인이 InDesign 애플리케이션 플러그인 폴더에 설치되어 있는 경우 다음 명령을 사용하여 격리 플래그를 제거할 수 있습니다.

sudo xattr -r -d com.apple.quarantine /Applications/Adobe\ Indesign\ 2019/Plug-ins/<플러그인 이름>

 

플러그인이 격리되어 있는지 여부 확인

고객은 터미널을 사용하여 플러그인이 격리되었는지 여부를 판별할 수 있습니다.

플러그인이 Indesign 애플리케이션 플러그인 폴더에 있는 경우의 예:

% ls -l@ /Applications/Adobe\ Indesign\ 2019/Plug-ins/<플러그인 이름>/

 참고: <플러그인 이름>을(를) 수정해야 하는 플러그인의 실제 이름으로 대체합니다.

다음 결과를 반환하는 것은 무엇입니까?

total 0 drwxr-xr-x@ 6 <username> wheel 192 Sep 26 15:11 Contents com.apple.quarantine 22

"com.apple.quarantine 22"는 플러그인이 격리되었음을 의미합니다.

타사 플러그인 개발자의 경우

타사 플러그인 개발 및 디버깅은 macOS 10.15(Catalina)에서 지원되지 않습니다. macOS로 플러그인을 개발하려면 다음 시스템 요구 사항을 충족해야 합니다.

  • Xcode 9.2
  • macOS 10.13 또는 10.14

 Adobe

쉽고 빠르게 지원 받기

신규 사용자이신가요?

Adobe MAX 2024

Adobe MAX
크리에이티비티 컨퍼런스

10월 14~16일 마이애미 비치 및 온라인

Adobe MAX

크리에이티비티 컨퍼런스

10월 14~16일 마이애미 비치 및 온라인

Adobe MAX 2024

Adobe MAX
크리에이티비티 컨퍼런스

10월 14~16일 마이애미 비치 및 온라인

Adobe MAX

크리에이티비티 컨퍼런스

10월 14~16일 마이애미 비치 및 온라인