Publicação no Adobe AIR para desktop

  1. Guia do Usuário do Adobe Animate
  2. Introdução ao Animate
    1. Novidades no Animate
    2. Glossário visual
    3. Requisitos de sistema do Animate
    4. Atalhos de teclado do Animate
    5. Trabalhar com vários tipos de arquivo no Animate
  3. Animação
    1. Noções básicas de animação no Animate
    2. Como usar quadros e quadros-chave no Animate
    3. Animação quadro a quadro no Animate
    4. Como trabalhar com animação de interpolação clássica no Animate
    5. Ferramenta Pincel
    6. Guia de movimento
    7. Interpolação de movimento e ActionScript 3.0
    8. Sobre a animação com interpolação de movimento
    9. Animações de interpolação de movimento
    10. Criação de uma animação de interpolação de movimento
    11. Utilização dos quadros-chave de propriedade
    12. Animação de posição com uma interpolação
    13. Editar interpolações de movimento usando o Motion Editor
    14. Edição do caminho de movimento de uma animação de interpolação
    15. Manipulação de interpolações de movimento
    16. Adição de atenuações personalizadas
    17. Criação e aplicação das predefinições de movimento
    18. Configuração de extensões de interpolação de animação
    19. Trabalhar com interpolações de movimento salvas como arquivos XML
    20. Interpolações de movimento e interpolações clássicas
    21. Interpolação de formas
    22. Uso da animação da ferramenta Bone no Animate
    23. Trabalhar com manipulação de caracteres no Animate
    24. Como usar camadas de máscara no Adobe Animate
    25. Como trabalhar com cenas no Animate
  4. Interatividade
    1. Como criar botões com o Animate
    2. Converter projetos do Animate em outros formatos de tipo de documento
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Adicionar interatividade com snippets de código no Animate
    5. Criar componentes HTML5 personalizados
    6. Uso de componentes do HTML5 Canvas
    7. Criação de componentes personalizados: exemplos
    8. Snippets de código para componentes personalizados
    9. Práticas recomendadas - Publicidade com o Animate
    10. Criação e publicação de Realidade virtual
  5. Fluxo de trabalho e espaço de trabalho
    1. Criação e gerenciamento de pincéis
    2. Uso de Google Fonts em documentos HTML5 Canvas
    3. Uso das Bibliotecas da Creative Cloud e do Adobe Animate
    4. Uso dos painéis Palco e Ferramentas do Animate
    5. Fluxo e espaço de trabalho do Animate
    6. Uso de fontes da Web em documentos HTML5 Canvas
    7. Linhas de tempo e ActionScript
    8. Trabalhar com múltiplas linhas de tempo
    9. Definir preferências
    10. Uso de painéis de criação do Animate
    11. Criar camadas na linha do tempo com o Animate
    12. Exportar animações para aplicativos móveis e mecanismos de jogo
    13. Mover e copiar objetos
    14. Modelos
    15. Localização e substituição no Animate
    16. Desfazer, refazer e o painel de Histórico
    17. Atalhos de teclado
    18. Como usar a linha do tempo no Animate
    19. Criação de extensões HTML
    20. Opções de otimização para imagens e GIFs animados
    21. Configurações de exportação para imagens e GIFs
    22. Painel Ativos no Animate
  6. Multimídia e vídeo
    1. Transformação e combinação de objetos gráficos no Animate
    2. Criar e trabalhar com instâncias do símbolo no Animate
    3. Traçado de imagem
    4. Como usar som no Adobe Animate
    5. Exportação de arquivos SVG
    6. Criação de arquivos de vídeo para uso no Animate
    7. Como adicionar vídeos no Animate
    8. Trabalhar com pontos de sinalização de vídeo
    9. Desenhar e criar objetos com o Animate
    10. Remodelação de linhas e formas
    11. Traçados, preenchimentos e gradientes com o Animate CC
    12. Trabalhar com o Adobe Premiere Pro e o After Effects
    13. Painéis de cor no Animate CC
    14. Abrir arquivos do Flash CS6 com o Animate
    15. Trabalho com texto clássico no Animate
    16. Aplicação de ilustração final no Animate
    17. Bitmaps importados no Animate
    18. Gráficos em 3D
    19. Trabalhar com símbolos no Animate
    20. Desenhar linhas e formas com o Adobe Animate
    21. Trabalho com bibliotecas no Animate
    22. Exportação de sons
    23. Seleção de objetos no Animate CC
    24. Trabalho com arquivos AI do Illustrator no Animate
    25. Aplicação de padrões com a ferramenta Pincel de borrifar
    26. Aplicação de modos de mesclagem
    27. Organização de objetos
    28. Automação de tarefas com o menu Comandos
    29. Texto multilíngue
    30. Uso de câmera no Animate
    31. Uso do Animate com o Adobe Scout
    32. Trabalhar com arquivos Fireworks
    33. Filtros gráficos
    34. Som e ActionScript
    35. Preferências de desenho
    36. Desenho com a ferramenta Caneta
  7. Plataformas
    1. Converter projetos do Animate em outros formatos de tipo de documento
    2. Suporte da plataforma personalizada
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Criação e publicação de um documento WebGL
    5. Compactação de aplicativos no AIR para iOS
    6. Publicação de AIR em aplicativos Android
    7. Publicação no Adobe AIR para desktop
    8. Configurações de publicação do ActionScript
    9. Práticas recomendadas - Organização do ActionScript em um aplicativo
    10. Como usar ActionScript com o Animate
    11. Práticas recomendadas - Diretrizes de acessibilidade
    12. Acessibilidade no espaço de trabalho do Animate
    13. Programação e gerenciamento de scripts
    14. Ativação do suporte para plataformas personalizadas
    15. Visão geral do suporte da plataforma personalizada
    16. Criação de conteúdo acessível
    17. Trabalhar com plug-ins personalizados de suporte da plataforma
    18. Depuração do ActionScript 3.0
    19. Ativação do suporte para plataformas personalizadas
  8. Publicação e exportação
    1. Exportação de arquivos do Animate CC
    2. Publicação OAM
    3. Exportação de arquivos SVG
    4. Exportar gráficos e vídeos com o Animate
    5. Publicação de documentos AS3
    6. Exportar animações para aplicativos móveis e mecanismos de jogo
    7. Exportação de sons
    8. Exportação de arquivos de vídeo QuickTime
    9. Controle de reprodução de vídeo externo com o ActionScript
    10. Práticas recomendadas - Dicas para a criação de conteúdo em dispositivos móveis
    11. Práticas recomendadas - Convenções de vídeo
    12. Práticas recomendadas - Diretrizes de criação de aplicativos SWF
    13. Práticas recomendadas - Estruturação de arquivos FLA
    14. Práticas recomendadas para otimizar arquivos FLA para o Animate
    15. Configurações de publicação do ActionScript
    16. Especificar configurações de publicação para o Animate
    17. Exportação de arquivos projetores
    18. Exportar imagens e GIFs animados
    19. Modelos de publicação HTML
    20. Trabalhar com o Adobe Premiere Pro e o After Effects
    21. Compartilhar e publicar animações rapidamente

Sobre o Adobe AIR

O Adobe® AIR™ é um tempo de execução entre vários sistemas operacionais que permite potencializar suas habilidades de desenvolvimento para Web existentes (Adobe® Animate®, Adobe® Flex™, Adobe®Flash Builder™, HTML, JavaScript® e Ajax) para criar e implantar Aplicações avançadas para internet (RIAs) na área de trabalho. O AIR permite trabalhar em ambientes familiares, potencializar as ferramentas e abordagens que você considera mais confortáveis. A compatibilidade com Animate, Flex, HTML, JavaScript e Ajax ajuda a criar a melhor experiência possível que atenda a suas necessidades.

Usuários interagem com aplicativos do AIR da mesma forma que interagem com aplicativos nativos da área de trabalho. O tempo de execução é instalado uma vez no computador do usuário e, em seguida, os aplicativos AIR são instalados e executados exatamente como qualquer outro aplicativo da área de trabalho. O tempo de execução oferece uma plataforma cruzada de sistema operacional e estrutura para implantação de aplicativos e, portanto, elimina os testes entre navegadores, assegurando funcionalidade e interações consistentes entre áreas de trabalho. Em vez de desenvolver para um sistema operacional específico, você direciona o tempo de execução.

O AIR altera significativamente o modo como os aplicativos podem ser criados, implantados e experimentados. Você obtém mais controle criativo e pode estender os aplicativos baseados em Animate, Flex, HTML e Ajax para a área de trabalho, sem ter que aprender as tecnologias tradicionais de desenvolvimento para área de trabalho.

Para obter informações sobre requisitos de software e hardware para aplicativos AIR móveis e para desktops, consulte Requisitos do sistema AIR.

Para obter informações completas sobre o desenvolvimento de aplicativos do Adobe AIR™, consulte Criação de aplicativos do Adobe AIR.

Criar um arquivo Adobe AIR

Você pode criar documentos do Adobe AIR Animate usando a tela de boas-vindas do Animate ou o comando Arquivo > Novo, ou criar um Arquivo Animate do ActionScript® 3.0 e convertê-lo em um arquivo Adobe AIR por meio da caixa de diálogo Configurações de publicação.

Para criar um arquivo do Adobe AIR, execute um dos procedimentos a seguir:

  • Inicie o Animate. A tela de boas-vindas é exibida. Se já tiver iniciado o Animate, feche quaisquer documentos abertos e volte para a tela de boas-vindas. Na tela Bem-vindo, selecione Adobe AIR 2 (CS5) ou AIR (CS5.5).

    Observação: se você desabilitou a tela de boas-vindas do Animate, poderá exibi-la novamente selecionando Editar > Preferências e marcando Tela de boas-vindas na categoria Geral do menu pop-up Ao iniciar.

  • Escolha Arquivo > Novo > Avançado nas guias na parte superior da tela e selecione Adobe AIR 2 (CS5) ou AIR (CS5.5) e clique em OK.

Template_air
Modelo do Air

  • Abra um arquivo do Animate e converta-o em arquivo AIR selecionando Adobe AIR no menu Player da guia Animate, na caixa de diálogo Configurações de publicação (Arquivo > Configurações de publicação).
Observação:

(Somente Flash CS5) Se você salvou um arquivo AIR do Flash CS5 em formato Flash CS4, defina a versão do Player como AIR 1.5 manualmente na caixa de diálogo Configurações de Publicação quando abrir o arquivo no Flash CS4. O Flash CS4 oferece suporte à publicação somente para AIR 1.5.

Visualizar ou publicar um aplicativo do Adobe AIR

Você pode visualizar um arquivo SWF do AIR quando ele for exibido na janela do aplicativo do AIR. A visualização é útil quando você quiser ver quais são os aspectos visíveis da aparência do aplicativo sem compactá-lo e instalá-lo.

  1. Verifique se você definiu a configuração de Target para Adobe AIR na guia Animate da caixa de diálogo Configurações de publicação.

  2. Selecione Controlar > Testar filme > Testar ou pressione Ctrl + Enter.

Se você ainda não definiu as configurações do aplicativo na caixa de diálogo AIR - Configurações do aplicativo e do instalador, o Animate gera um arquivo de descrição do aplicativo padrão (swfname-app.xml) para você na mesma pasta em que o arquivo SWF está gravado. Se você definir as configurações de aplicativo utilizando a caixa de diálogo Configurações do aplicativo e do instalador do AIR, o arquivo de descrição do aplicativo irá refleti-las.

Para publicar um arquivo AIR, execute um dos procedimentos a seguir:

  • Clique no botão Publicar na caixa de diálogo Configurações de publicação.

  • Clique no botão Publicar na caixa de diálogo Configurações do aplicativo e do instalador do AIR.

  • Selecione Arquivo > Publicar.

  • Selecione Arquivo > Publicar visualização.

Ao publicar um arquivo AIR, o Animate cria um arquivo SWF e um arquivo de descrição do aplicativo XML, e compacta cópias de ambos, juntamente com qualquer outro arquivo que você adicionou ao seu aplicativo, em um arquivo do instalador do AIR (swfname.air).

Observação:

(Apenas para o Windows) A publicação de um aplicativo do AIR falha, se o nome do arquivo contém caracteres que não pertençam ao inglês.

Criação de arquivos do aplicativo do AIR e do instalador

Após concluir o desenvolvimento de seu aplicativo, especifique as configurações dos arquivos de descrição e do instalador do aplicativo do AIR necessários para implantá-lo. O Animate cria os arquivos de descrição e do instalador juntamente com o arquivo SWF quando um arquivo AIR é publicado.

Especifique as configurações desses arquivos na caixa de diálogo AIR - Configurações do aplicativo e do instalador. Após criar um arquivo AIR, é possível abrir essa caixa de diálogo a partir do Inspetor de propriedades ou do botão Configurações do menu Player, na guia Animate da caixa de diálogo Configurações de publicação.

Criar arquivos do aplicativo do Adobe AIR e do instalador

  1. No Animate, abra o arquivo FLA ou o conjunto de arquivos que compõe seu aplicativo do Adobe AIR.

  2. Salve o arquivo FLA do Adobe AIR antes de abrir a caixa de diálogo Configurações do AIR.

  3. Selecione Arquivo > Configurações do AIR 2.

  4. Preencha a caixa de diálogo Configurações do AIR e, em seguida, clique em Publicar.

    Quando você clica no botão Publicar, os seguintes arquivos são compactados: o arquivo SWF, o arquivo de descrição do aplicativo, os arquivos de ícone do aplicativo e os arquivos listados na caixa de texto Arquivos incluídos. Se você ainda não criou um certificado digital, o Animate exibe a caixa de diálogo Assinatura digital quando você clica no botão Publicar.

A caixa de diálogo Configurações do aplicativo e do instalador do AIR é dividida em quatro abas: Geral, Assinatura, Ícones e Avançado. Para obter mais informações sobre as configurações, consulte as seções a seguir.

Configurações gerais

A aba Geral da caixa de diálogo Configurações do aplicativo e do instalador do AIR contém as seguintes opções:

Arquivo de saída

O nome e o local do arquivo .air a ser criado quando se usa o comando Publicar.

Saída como

O tipo de pacote a ser criado.

  • Pacote do AIR - Cria um arquivo de instalação padrão do AIR que presume que o tempo de execução do AIR pode ser baixado separadamente durante a instalação ou já está instalado no dispositivo alvo.
  • Instalador Mac - Cria um arquivo de instalador para Macintosh completo.installer file.
  • Aplicativo com tempo de execução incorporado - Cria um arquivo de instalação do AIR que contém o tempo de execução, para que outro download não seja necessário.

Instalador do Windows

Selecione esta opção para compilar um instalador nativo específico à plataforma Windows (.exe) em vez de um instalador AIR independente da plataforma (.air).

Nome

O nome do arquivo principal do aplicativo. O padrão é o nome do arquivo FLA.

Versão

Opcional. Especifica o número da versão do aplicativo. O padrão é 1.0.

ID do aplicativo

Identifica o aplicativo com uma ID exclusiva. Você pode alterar a ID padrão se preferir. Não use espaços nem caracteres especiais na ID. Os únicos caracteres válidos são 0-9, a-z, A-Z, . (ponto) e - (traço), extensão 1 a 212 caracteres. O padrão é com.adobe.example.applicationName.

Descrição

Opcional. Permite digitar uma descrição do aplicativo para ser exibida na janela do instalador quando o usuário o instala. O padrão é em branco.

Copyright

Opcional. Permite digitar um aviso de copyright. O padrão é em branco.

Estilo da janela

Especifica o estilo da janela (ou cromo) que será utilizado na interface de usuário quando o usuário executa o aplicativo no computador. Você pode especificar Cromo do sistema (padrão), que se refere ao estilo visual de janela padrão que o sistema operacional usa. Também é possível especificar Cromo personalizado (opaco) ou Cromo personalizado (transparente). Para exibir seu aplicativo sem o cromo do sistema, selecione Nenhum. O Cromo do sistema rodeia o aplicativo com o controle de janelas padrão do sistema operacional. O Cromo personalizado (opaco) elimina o cromo padrão do sistema e permite a você criar um cromo do seu próprio aplicativo. (Você cria o cromo personalizado diretamente no arquivo FLA.) O Cromo personalizado (transparente) é igual ao Cromo personalizado (opaco), mas ele adiciona recursos transparentes às margens da página. Esses recursos servem para janelas de aplicativos que não são quadradas ou retangulares.

Modo de renderização

Permite que você especifique qual método o tempo de execução do AIR usa para renderizar o conteúdo gráfico. As opções incluem:

  • Automático - detecta automaticamente e usa o método de renderização mais rápido disponível no dispositivo.
  • CPU - Usa o CPU.
  • Direto - Renderiza utilizando Stage3D. Este é o método de renderização mais rápido disponível.

Para uma lista de processadores que não suportam o modo Direto, acesse chipsets e drivers que não suportam Stage3D | Flash Player 11, AIR 3.


Perfis

Quais perfis incluir durante a criação do arquivo AIR. Para limitar o aplicativo AIR a um perfil específico, desmarque os perfis desnecessários. 

Arquivos inclusos

Especifica os arquivos e as pastas adicionais a incluir no pacote do seu aplicativo. Clique no botão de adição (+) para adicionar arquivos e no botão de pasta para adicionar pastas. Para excluir um arquivo ou pasta da lista, selecione o arquivo ou a pasta e clique no botão de subtração (-).

Por padrão, o arquivo de descrição do aplicativo e o arquivo SWF principal são adicionados automaticamente à lista de pacotes. A lista de pacotes mostra esses arquivos mesmo se você ainda não tiver publicado o arquivo FLA do Adobe AIR. A lista de pacotes exibe os arquivos e pastas em uma estrutura simples. Os arquivos em uma pasta não são listados, e o caminho completo para os arquivos é mostrado, mas truncado se necessário.

Se você adicionou qualquer arquivo de extensão nativa do AIR ao caminhos a biblioteca ActionScript, estes arquivos também aparecem nessa lista.

Os arquivos de ícone não são incluídos na lista. Quando o Animate compacta os arquivos, ele copia os arquivos de ícone para uma pasta temporária que é relativa ao local do arquivo SWF. O Animate exclui a pasta depois que a compactação for concluída.

Configurações de assinatura

A aba Assinatura da caixa de diálogo Configurações do aplicativo e do instalador do AIR permite especificar um certificado de assinatura de código para o aplicativo.

Para obter mais informações sobre assinaturas digitais, consulte Assinatura do aplicativo e Assinatura digital de um arquivo AIR.

Configurações de ícones

A aba Ícones da caixa de diálogo Configurações do aplicativo e do instalador do AIR permite especificar um ícone para o aplicativo. O ícone é mostrado depois que você instala o aplicativo e o executa no tempo de execução do Adobe AIR. Você pode especificar quatro tamanhos diferentes de ícones (128, 48, 32 e 16 pixels) para permitir diferentes exibições nas quais os ícones são exibidos. Por exemplo, o ícone pode ser exibido no navegador do arquivo nas exibições em miniatura, detalhes e lado a lado. Ele também pode ser exibido como um ícone de área de trabalho e no título da janela do aplicativo do AIR, bem como em outros lugares.

O padrão da imagem do ícone será o ícone da amostra do aplicativo do AIR, se nenhum outro arquivo de ícone for especificado (somente no Flash CS5).

Para especificar um ícone, clique no tamanho do ícone na parte superior da aba Ícones e, em seguida, navegue até o arquivo a ser usado para o tamanho. Os arquivos devem estar no formato PNG (Portable Network Graphics).

Se você especificar uma imagem, ela deve estar no tamanho exato (128x128, 48x48, 32x32 ou 16x16). Se você não fornecer uma imagem para um tamanho de ícone específico, o Adobe AIR escala uma das imagens fornecidas para criar a imagem do ícone que está faltando.

Configurações avançadas

A aba Avançado permite especificar configurações adicionais para o arquivo de descrição do aplicativo.

É possível especificar quaisquer tipos de arquivo associados com que seu aplicativo AIR deve lidar. Por exemplo, se você definiu seu aplicativo para ser o aplicativo principal para suportar arquivos HTML, você deverá especificar isso na caixa de texto Tipos de arquivos associados.

Também é possível especificar configurações para os seguintes aspectos do aplicativo:

  • O tamanho e a posição da janela inicial.

  • A pasta na qual o aplicativo está instalado.

  • A pasta de menu do programa na qual o aplicativo ficará.

A caixa de diálogo tem as seguintes opções:

Tipos de arquivos associados

Permite especificar os tipos de arquivos associados para os quais o aplicativo do AIR fornece suporte. Clique no botão de adição (+) para adicionar um novo tipo de arquivo à caixa de texto. Clicar no botão de adição (+) exibe a caixa de diálogo Configurações de tipo de arquivo. Clicar no botão de subtração (-) remove um item que está selecionado na caixa de texto. Clicar no botão Lápis exibe a caixa de diálogo Configurações de tipo de arquivo e permite editar um item selecionado na caixa de texto. Por padrão, os botões de subtração (-) e Lápis estão desativados. A seleção de um item na caixa de texto ativa os botões de subtração (-) e Lápis, permitindo remover ou editar o item. O valor padrão na caixa de texto é Nenhum.

Configurações da janela inicial

Permite especificar as configurações de tamanho e posição para a janela inicial do aplicativo.

  • Largura: Especifica a largura inicial da janela em pixels. O valor padrão é em branco.

  • Altura: Especifica a altura inicial da janela em pixels. O valor padrão é em branco.

  • X: Especifica a posição inicial horizontal da janela em pixels. O valor padrão é em branco.

  • Y: Especifica a posição inicial vertical da janela em pixels. O valor padrão é em branco.

  • Largura máxima e altura máxima: Especifica o tamanho máximo da janela em pixels. Os valores padrão são em branco.

  • Largura mínima e altura mínima: Especifica o tamanho mínimo da janela em pixels. Os valores padrão são em branco.

  • Maximizável: Permite especificar se o usuário poderá maximizar a janela. Essa opção é selecionada (ou true) por padrão.

  • Minimizável: Permite especificar se o usuário poderá minimizar a janela. Essa opção é selecionada (ou true) por padrão.

  • Redimensionável: Permite especificar se o usuário poderá redimensionar a janela. Se essa opção não estiver selecionada, Largura máxima, Altura máxima, Largura mínima e Altura mínima serão desativadas. Essa opção é selecionada (ou true) por padrão.

  • Visível: Permite especificar se a janela do aplicativo será visível inicialmente. A opção é selecionada (ou true) por padrão.

Outras configurações

Permite especificar as seguintes informações adicionais sobre a instalação:

  • Pasta de instalação: especifica a pasta na qual o aplicativo está instalado.

  • Pasta de menu do programa (somente Windows): especifica o nome da pasta de menu do programa para o aplicativo.

  • Usar UI personalizada para atualizações: especifica o que acontece quando um usuário abre um arquivo do instalador AIR de um aplicativo que já está instalado. Por padrão, o AIR exibe uma caixa de diálogo que permite ao usuário atualizar a versão instalada com a versão no arquivo AIR. Se você não quiser que o usuário tome essa decisão e que o aplicativo tenha o controle sobre as atualizações, selecione esta opção. A seleção desta opção substitui o comportamento padrão e fornece ao aplicativo o controle sobre suas atualizações.

Configurações de idiomas

O painel de Idiomas permite que você selecione os idiomas que você gostaria que sejam associados ao armazenamento do aplicativo ou ao marketplace. Ao selecionar um idioma, você permite que usuários de sistemas operacionais neste idioma façam download de seu aplicativo. Estas configurações de idioma não fazem mais nada para localizar a interface de usuário do aplicativo.

Se nenhum idioma for selecionado, o aplicativo é publicado com suporte para todos os idiomas. Isso evita que você precise selecionar todos os idiomas. Os idiomas listados são aqueles suportados pelo Adobe AIR. Android pode suportar outros idiomas.

Configurações de tipo de arquivo

O Animate exibirá a caixa de diálogo Configurações de tipo de arquivo se você clicar no botão de adição (+) ou Lápis na seção Tipos de arquivos associados da guia Avançado para adicionar ou editar tipos de arquivo associados ao aplicativo AIR.

Os únicos dois campos obrigatórios nessa caixa de diálogo são Nome e Extensão. Se você clicar em OK e esses campos estiverem em branco, o Animate exibirá uma caixa de diálogo de erro.

Você pode especificar as seguintes configurações para um tipo de arquivo associado:

Nome

O nome do tipo de arquivo (por exemplo, linguagem de markup de hipertexto, arquivo de texto ou de exemplo).

Extensão

A extensão do nome do arquivo (por exemplo, html, txt ou xmpl), até 39 caracteres alfanuméricos básicos (A-Za-z0-9) e sem ponto à esquerda.

Descrição

Opcional. A descrição de um tipo de arquivo (por exemplo, Arquivo de vídeo da Adobe).

Tipo de conteúdo

Opcional. Especifica o tipo MIME do arquivo.

Configurações do ícone de tipo de arquivo

Opcional. Permite especificar um ícone associado ao tipo de arquivo. Você pode especificar quatro tamanhos diferentes de ícone (128x128, 48x48, 32x32 e 16x16 pixels) para permitir diferentes exibições nas quais os ícones são exibidos. Por exemplo, o ícone pode ser exibido no navegador do arquivo nas exibições em miniatura, detalhes e lado a lado. Se você especificar uma imagem, ela deverá ser do tamanho especificado. Se você não especificar um arquivo para um determinado tamanho, o AIR usará a imagem de um tamanho aproximado e a dimensionará para que se ajuste àquela ocorrência. Para especificar um ícone, clique na pasta para o tamanho de ícone e selecione um arquivo de ícone para ser utilizado ou digite o caminho e o nome do arquivo para o arquivo de ícone na caixa de texto próxima ao prompt. O arquivo de ícone deve estar no formato PNG. Após a criação de um novo tipo de arquivo, ele é exibido na caixa de listagem Tipo de arquivo na caixa de diálogo Configurações avançadas.

Falha na criação de arquivos do aplicativo e do instalador

Ocorre falha na criação dos arquivos do aplicativo e do instalador nas seguintes situações:

  • A string de ID do aplicativo tem um tamanho incorreto ou contém caracteres inválidos. A string de ID do aplicativo pode conter de 1 a 212 caracteres e incluir os seguintes caracteres: 0-9, a-z, A-Z, . (ponto), - (hífen).

  • Os arquivos da lista Arquivos incluídos não existem.

  • Os tamanhos dos arquivos personalizados de ícone estão incorretos.

  • A pasta de destino do AIR não tem acesso de gravação.

  • Você não assinou o aplicativo ou não especificou que ele é um aplicativo do Adobe AIRI que pode ser assinado posteriormente.

Assinatura do aplicativo

Todos os aplicativos do Adobe AIR devem estar assinados para serem instalados em outro sistema. No entanto, o Animate permite que você crie arquivos do instalador do Adobe AIR não assinados. Dessa forma o aplicativo pode ser assinado posteriormente. Esses arquivos do instalador do Adobe AIR não assinados são chamados de pacote AIRI (AIR Intermediate). Esse recurso é útil para os casos em que o certificado está em uma máquina diferente ou a assinatura é tratada separadamente do desenvolvimento do aplicativo.

Assinar um aplicativo do Adobe AIR com um certificado digital pré-adquirido de uma autoridade de certificação raiz

  1. Escolha Arquivo > Configurações do AIR 2 e, em seguida, clique na aba Assinatura.

    Essa aba tem dois botões de opção que permitem assinar o aplicativo do Adobe AIR com um certificado digital ou preparar um pacote AIRI. Se você assinar o aplicativo do AIR, poderá utilizar um certificado digital concedido por uma autoridade de certificação raiz ou criar um certificado autoassinado. Um certificado autoassinado é fácil de criar, mas não é tão confiável quanto um certificado concedido por uma autoridade de certificação raiz.

  2. Selecione um arquivo de certificado no menu pop-up ou clique no botão Procurar para localizar um arquivo de certificado.

  3. Selecione o certificado.

  4. Digite a senha.

  5. Clique em OK.

Para obter mais informações sobre a assinatura do aplicativo AIR, consulte Assinatura digital de um arquivo AIR.

Criar um certificado digital autoassinado

  1. Clique no botão Criar. A caixa de diálogo Certificado digital autoassinado é aberta.

  2. Preencha as entradas para Nome do editor, Unidade organizacional, Nome da organização, País, Senha e Confirmar senha. Em País, é possível selecionar uma opção do menu ou digitar o código de duas letras do país que não aparece no menu. Consulte a lista de códigos de país válidos em http://www.iso.org/iso/country_codes.

  3. Especifique o tipo de certificado.

    A opção Tipo refere-se ao nível de segurança que o certificado possui. 1024-RSA usa uma chave de 1024 bits (menos segura) e 2048-RSA usa uma chave de 2048 bits (mais segura). O padrão é 2048-RSA. 

    Observação:

    No Animate, os certificados 1024 RSA oferecem suporte apenas até a versão 2017.2. Para obter mais informações sobre a solução, clique aqui

  4. Salve as informações em um arquivo de certificado preenchendo a entrada Salvar como ou clicando no botão Procurar para procurar o local da pasta.

  5. Clique em OK.

  6. Na caixa de diálogo Assinatura digital, digite a senha atribuída na segunda etapa deste procedimento e clique em OK.

Para que o Animate lembre a senha usada nesta sessão, clique em Lembrar senha dessa sessão.

Se a opção Carimbo de data e hora não estiver marcada quando clicar em OK, uma caixa de diálogo avisará que a instalação do aplicativo falhará quando o certificado digital expirar. Se você clicar em Sim na resposta desse aviso, o carimbo de data e hora será desabilitado. Se você clicar em Não, a opção Carimbo de data e hora será automaticamente selecionada e habilitada.

Para obter mais informações sobre a criação de um certificado digital autoassinado, consulte Assinatura digital de um arquivo AIR.

Você também pode criar um aplicativo do AIRI (AIR Intermediate) sem uma assinatura digital. Entretanto, um usuário não pode instalar o aplicativo em uma área de trabalho até que você adicione uma assinatura digital.

Preparar um pacote AIRI que será assinado posteriormente

  1. Na aba Assinatura, selecione Prepare um arquivo intermediário AIR (AIRI) que será assinado depois e clique em OK.

    O status da assinatura digital é alterado para indicar que você optou por preparar um pacote AIRI que será assinado posteriormente. O botão Definir muda para um botão Alterar.

Se você optar por assinar o aplicativo posteriormente, deverá usar a linha de comando da ferramenta para desenvolvedores do AIR fornecida com o Animate e com o SKD do AIR. Para obter mais informações, consulte Construindo aplicativos no Adobe AIR.

URL do servidor do carimbo de data e hora

O Animate suporta o servidor do carimbo de data e hora mais recente junto com uma opção para adicionar o URL para o servidor do carimbo de data e hora personalizado. 

Adicionar ou remover uma versão do AIR SDK

Você pode adicionar novos lançamentos e versões personalizadas do SDK do AIR SDK para o Animate. Uma vez adicionado, o novo SDK aparece na lista de destino do player nas Configurações de publicação.

Para adicionar uma nova versão do SDK:

  1. Baixe a nova pasta do AIR SDK.
  2. No Animate, escolha Ajuda > Gerenciar SDK do AIR.
  3. Na caixa de diálogo Gerenciar AIR SDK, clique no botão de adição “+” e navegue na nova pasta AIR SDK. Clique em OK.
  4. Clique em OK na Caixa de diálogo Gerenciar AIR SDK.

O novo SDK aparece na lista de destino do Player nas Configurações de publicação. A menor versão aceitável do SDK deve ser maior que a versão incluída no Animate.

Para remover a versão do SDK:

  1. No Animate, escolha Ajuda > Gerenciar SDK do AIR.
  2. Na caixa de diálogo Gerenciar AIR SDK, selecione o SDK que deseja remover.
  3. Clique no botão de subtração “-”. Clique em OK.
Logotipo da Adobe

Fazer logon em sua conta