Interpolação de formas

  1. Guia do Usuário do Adobe Animate
  2. Introdução ao Animate
    1. Novidades no Animate
    2. Glossário visual
    3. Requisitos de sistema do Animate
    4. Atalhos de teclado do Animate
    5. Trabalhar com vários tipos de arquivo no Animate
  3. Animação
    1. Noções básicas de animação no Animate
    2. Como usar quadros e quadros-chave no Animate
    3. Animação quadro a quadro no Animate
    4. Como trabalhar com animação de interpolação clássica no Animate
    5. Ferramenta Pincel
    6. Guia de movimento
    7. Interpolação de movimento e ActionScript 3.0
    8. Sobre a animação com interpolação de movimento
    9. Animações de interpolação de movimento
    10. Criação de uma animação de interpolação de movimento
    11. Utilização dos quadros-chave de propriedade
    12. Animação de posição com uma interpolação
    13. Editar interpolações de movimento usando o Motion Editor
    14. Edição do caminho de movimento de uma animação de interpolação
    15. Manipulação de interpolações de movimento
    16. Adição de atenuações personalizadas
    17. Criação e aplicação das predefinições de movimento
    18. Configuração de extensões de interpolação de animação
    19. Trabalhar com interpolações de movimento salvas como arquivos XML
    20. Interpolações de movimento e interpolações clássicas
    21. Interpolação de formas
    22. Uso da animação da ferramenta Bone no Animate
    23. Trabalhar com manipulação de caracteres no Animate
    24. Como usar camadas de máscara no Adobe Animate
    25. Como trabalhar com cenas no Animate
  4. Interatividade
    1. Como criar botões com o Animate
    2. Converter projetos do Animate em outros formatos de tipo de documento
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Adicionar interatividade com snippets de código no Animate
    5. Criar componentes HTML5 personalizados
    6. Uso de componentes do HTML5 Canvas
    7. Criação de componentes personalizados: exemplos
    8. Snippets de código para componentes personalizados
    9. Práticas recomendadas - Publicidade com o Animate
    10. Criação e publicação de Realidade virtual
  5. Fluxo de trabalho e espaço de trabalho
    1. Criação e gerenciamento de pincéis
    2. Uso de Google Fonts em documentos HTML5 Canvas
    3. Uso das Bibliotecas da Creative Cloud e do Adobe Animate
    4. Uso dos painéis Palco e Ferramentas do Animate
    5. Fluxo e espaço de trabalho do Animate
    6. Uso de fontes da Web em documentos HTML5 Canvas
    7. Linhas de tempo e ActionScript
    8. Trabalhar com múltiplas linhas de tempo
    9. Definir preferências
    10. Uso de painéis de criação do Animate
    11. Criar camadas na linha do tempo com o Animate
    12. Exportar animações para aplicativos móveis e mecanismos de jogo
    13. Mover e copiar objetos
    14. Modelos
    15. Localização e substituição no Animate
    16. Desfazer, refazer e o painel de Histórico
    17. Atalhos de teclado
    18. Como usar a linha do tempo no Animate
    19. Criação de extensões HTML
    20. Opções de otimização para imagens e GIFs animados
    21. Configurações de exportação para imagens e GIFs
    22. Painel Ativos no Animate
  6. Multimídia e vídeo
    1. Transformação e combinação de objetos gráficos no Animate
    2. Criar e trabalhar com instâncias do símbolo no Animate
    3. Traçado de imagem
    4. Como usar som no Adobe Animate
    5. Exportação de arquivos SVG
    6. Criação de arquivos de vídeo para uso no Animate
    7. Como adicionar vídeos no Animate
    8. Trabalhar com pontos de sinalização de vídeo
    9. Desenhar e criar objetos com o Animate
    10. Remodelação de linhas e formas
    11. Traçados, preenchimentos e gradientes com o Animate CC
    12. Trabalhar com o Adobe Premiere Pro e o After Effects
    13. Painéis de cor no Animate CC
    14. Abrir arquivos do Flash CS6 com o Animate
    15. Trabalho com texto clássico no Animate
    16. Aplicação de ilustração final no Animate
    17. Bitmaps importados no Animate
    18. Gráficos em 3D
    19. Trabalhar com símbolos no Animate
    20. Desenhar linhas e formas com o Adobe Animate
    21. Trabalho com bibliotecas no Animate
    22. Exportação de sons
    23. Seleção de objetos no Animate CC
    24. Trabalho com arquivos AI do Illustrator no Animate
    25. Aplicação de padrões com a ferramenta Pincel de borrifar
    26. Aplicação de modos de mesclagem
    27. Organização de objetos
    28. Automação de tarefas com o menu Comandos
    29. Texto multilíngue
    30. Uso de câmera no Animate
    31. Uso do Animate com o Adobe Scout
    32. Trabalhar com arquivos Fireworks
    33. Filtros gráficos
    34. Som e ActionScript
    35. Preferências de desenho
    36. Desenho com a ferramenta Caneta
  7. Plataformas
    1. Converter projetos do Animate em outros formatos de tipo de documento
    2. Suporte da plataforma personalizada
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Criação e publicação de um documento WebGL
    5. Compactação de aplicativos no AIR para iOS
    6. Publicação de AIR em aplicativos Android
    7. Publicação no Adobe AIR para desktop
    8. Configurações de publicação do ActionScript
    9. Práticas recomendadas - Organização do ActionScript em um aplicativo
    10. Como usar ActionScript com o Animate
    11. Práticas recomendadas - Diretrizes de acessibilidade
    12. Acessibilidade no espaço de trabalho do Animate
    13. Programação e gerenciamento de scripts
    14. Ativação do suporte para plataformas personalizadas
    15. Visão geral do suporte da plataforma personalizada
    16. Criação de conteúdo acessível
    17. Trabalhar com plug-ins personalizados de suporte da plataforma
    18. Depuração do ActionScript 3.0
    19. Ativação do suporte para plataformas personalizadas
  8. Publicação e exportação
    1. Exportação de arquivos do Animate CC
    2. Publicação OAM
    3. Exportação de arquivos SVG
    4. Exportar gráficos e vídeos com o Animate
    5. Publicação de documentos AS3
    6. Exportar animações para aplicativos móveis e mecanismos de jogo
    7. Exportação de sons
    8. Exportação de arquivos de vídeo QuickTime
    9. Controle de reprodução de vídeo externo com o ActionScript
    10. Práticas recomendadas - Dicas para a criação de conteúdo em dispositivos móveis
    11. Práticas recomendadas - Convenções de vídeo
    12. Práticas recomendadas - Diretrizes de criação de aplicativos SWF
    13. Práticas recomendadas - Estruturação de arquivos FLA
    14. Práticas recomendadas para otimizar arquivos FLA para o Animate
    15. Configurações de publicação do ActionScript
    16. Especificar configurações de publicação para o Animate
    17. Exportação de arquivos projetores
    18. Exportar imagens e GIFs animados
    19. Modelos de publicação HTML
    20. Trabalhar com o Adobe Premiere Pro e o After Effects
    21. Compartilhar e publicar animações rapidamente

Na interpolação de formas, você desenha uma forma vetorial em um quadro específico na Linha do tempo e altera essa forma, ou desenha outra forma em outro quadro específico. Em seguida, o Animate interpola as formas intermediárias para os quadros intermediários, o que cria a animação de uma forma se transformando em outra.

O Animate permite adicionar interpolações de forma para uniformizar traçados sólidos e não uniformizar traçados elaborados. Também é possível adicionar interpolações de formas a traçados aprimorados usando a ferramenta de largura variável. Teste as formas que deseja usar para determinar os resultados. É possível usar referências de forma para informar ao Animate que pontos da forma inicial correspondem a pontos específicos na forma final.

Você também pode interpolar a posição e a cor das formas em uma interpolação de formas.

Para aplicar a interpolação de forma a grupos, ocorrências ou imagens de bitmap, separe esses elementos. Para aplicar a interpolação de forma ao texto, separe o texto duas vezes para convertê-lo em objetos. Consulte Separar uma ocorrência do seu símbolo.

Criar uma interpolação de formas

As etapas a seguir mostram como criar uma interpolação de formas do quadro 1 ao quadro 30 da linha do tempo. No entanto, você pode criar interpolações em qualquer parte da linha do tempo que escolher.

  1. No quadro 1, desenhe um quadrado com a ferramenta Retângulo.
  2. Selecione o quadro 30 da mesma camada e adicione um quadro-chave em branco, escolhendo Inserir > Linha do tempo > Quadro-chave em branco, ou pressionando F7.

  3. No palco, desenhe um círculo com a ferramenta oval no quadro 30.

    Agora você possui um quadro-chave no quadro 1 com um quadrado e um quadro-chave no quadro 30 com um círculo.

  4. Na Linha do tempo, selecione um dos quadros entre os dois quadros-chave na camada que contém as duas formas.

  5. Escolha Inserir > Interpolação de formas.

    O Animate interpola as formas de todos os quadros entre os dois quadros-chave.

  6. Para visualizar a interpolação, movimente o indicador de reprodução nos quadros na Linha do tempo ou pressione a tecla Enter.

  7. Para interpolar movimento além da forma, mova a forma no quadro 30 para um local diferente a partir do quadro 1.

    Visualize a animação pressionando a teclaEnter.

  8. Para interpolar a cor da forma, crie uma cor para a forma no quadro 1 diferente da cor da forma no quadro 30.
  9. Para adicionar atenuação à interpolação, selecione um dos quadros e digite um valor no campo Atenuação, no Inspetor de propriedades.

    Para atenuar o início da interpolação, digite um valor negativo. Para atenuar o final da interpolação, digite um valor positivo.

Criação de predefinições de atenuação ou atenuações personalizadas

As predefinições de atenuação são atenuações pré-configuradas que podem ser aplicadas a um objeto no palco.

Um conjunto de predefinições de atenuação geralmente utilizadas está disponível para a interpolação de Forma. É possível selecionar a predefinição de uma lista de predefinições de atenuação e aplicá-la à propriedade selecionada. Além disso, é possível aplicar uma atenuação personalizada a uma interpolação de forma.

  1. Clique na camada que contém uma interpolação de formas na linha do tempo do Animate.

  2. Para abrir as propriedades de Interpolação, clique na categoria de Interpolação no painel de propriedades.

    Propriedades de interpolação
    Propriedades de interpolação

  3. Selecione a predefinição de atenuação de sua escolha na caixa de diálogo pop-up de tipos de atenuação. Clique duas vezes no tipo de predefinição a ser aplicado. 

    Se escolher aplicar a atenuação clássica, também é possível aumentar ou diminuir a intensidade da atenuação ao mover o controle deslizante. 

    Tipos de atenuação de predefinições
    Tipos de atenuação de predefinições

  4. Clique no ícone Editar ao lado do campo Atenuação para aplicar uma atenuação personalizada. 

    A caixa de diálogo Atenuação personalizada exibe um gráfico que representa a variação do movimento ao longo do tempo. O eixo horizontal representa os quadros, e o eixo vertical representa a percentagem da mudança. O primeiro quadro-chave é representado como 0%, e o último é representado como 100%.

    A inclinação da curva do gráfico representa a taxa de mudança do objeto. Quando a curva for horizontal (sem inclinação), a velocidade é zero; quando a curva for vertical, ocorre uma taxa instantânea de mudança.

    Gráfico personalizado de atenuação mostrando a constante de velocidade
    Gráfico personalizado de atenuação mostrando a constante de velocidade. Abra esta caixa de diálogo selecionando um quadro em uma interpolação de forma e clicando no botão Editar na seção Atenuação do Inspetor de propriedades.

    Você pode salvar uma atenuação personalizada e a reutilizar escolhendo a atenuação personalizada na lista Personalizada. Clique no botão Salvar e aplicar no modo de edição após fazer as alterações. Na captura de tela abaixo, é possível encontrar a predefinição de uma atenuação personalizada com o nome MyEase1

    Predefinição de atenuação personalizada
    Predefinição de atenuação personalizada

    É possível usar atenuações predefinidas em vários conjuntos da linha do tempo ao selecionar os conjuntos correspondentes e aplicar a atenuação.

    Aplicar predefinição de atenuação para várias extensões
    Aplicar predefinição de atenuação para várias extensões

Controlar alterações de forma com as referências de forma

Para controlar alterações de forma mais complexas ou improváveis, você pode usar as referências de forma. As referências de forma identificam os pontos que correspondem às formas de início e fim. Por exemplo, se você estiver interpolando o desenho de um rosto à medida que ele muda de expressão, é possível usar uma referência de forma para marcar cada olho. Então, em vez do rosto se tornar uma massa amorfa enquanto ocorre a mudança de forma, os dois olhos permanecem reconhecíveis e mudam separadamente durante a alteração.

Referências de forma como letras
Referências de forma como letras

As referências de forma contêm letras (de “a” a “z”) para identificar quais pontos correspondem nas formas inicial e final. Você pode usar até 26 referências de forma.

As referências de forma são amarelas em um quadro-chave inicial, verde em um quadro-chave final e vermelho quando não estão em uma curva.

Para obter melhores resultados ao interpolar as formas, siga estas orientações:

  • Na interpolação de forma complexa, crie formas intermediárias e interpole-as, em vez de simplesmente definir uma forma inicial e final.

  • Certifique-se de que as referências de forma sejam idênticas. Por exemplo, se você estiver usando três referências de forma para um triângulo, elas devem estar na mesma ordem no triângulo original e no triângulo da interpolação. A ordem não pode ser a, b, c no primeiro quadro-chave e a, c, b no segundo.

  • As referências de forma funcionam melhor se você as colocar em sentido anti-horário, começando no canto superior esquerdo da forma.

Usar referências de forma

  1. Selecione o primeiro quadro-chave em uma sequência interpolada de forma.
  2. Selecione Modificar > Forma > Adicionar referência de forma. A referência de forma inicial aparece como um círculo vermelho, com a letra a em algum lugar na forma.

  3. Mova a referência de forma para um ponto a ser marcado.
  4. Selecione o último quadro-chave em uma sequência de interpolação. A referência de forma final aparece como um círculo verde, com a letra a em algum lugar na forma.

  5. Mova a referência para o ponto na forma final que corresponde ao primeiro ponto marcado.

  6. Para ver como as referências de forma mudam a interpolação de forma, reproduza novamente a animação. Para refinar a interpolação, mova as referências de forma.
  7. Para adicionar mais referências de forma, repita esse processo. Aparecem novas referências com as próximas letras (b, c etc).

Ver todas as referências de forma

  1. Selecione Exibir > Mostrar referências de forma. A camada e o quadro-chave que contêm as referências de forma devem estar ativos para que a opção Mostrar referências de forma esteja disponível.

Remover uma referência de forma

  1. Arraste a referência para fora do palco.

Remover todas as referências de forma

  1. Selecione Modificar > Forma > Remover todas as referências.

Adicionar interpolação de forma a traçados com largura variável

O Animate permite adicionar interpolação de forma a traçados com largura variável. Antes, o Animate permitia apenas a criação de interpolações de forma para traçados e formas uniformes e sólidos. Isso limitou os designers na criação de interpolações de forma para traçados não uniformes, como traçados aprimorados com a ferramenta de largura variável. Interpolar traçados com largura variável amplia muito as possibilidades de design no Animate.

Adicionar Interpolações de forma a traçados mais sofisticados não é diferente de interpolar a uma forma ou a um traçado uniforme e sólido. O fluxo de trabalho exige que você defina a forma inicial e final da interpolação, e o Animate cria os quadros transitórios da interpolação.

Sobre a ferramenta de largura variável

A ferramenta de Largura da variável permite aprimorar os traçados sólidos uniformes para criar traçados bonitos e elaborados. Para obter informações sobre como aprimorar traçados usando a ferramenta Largura variável, consulte Melhoria de traçados e formas usando a ferramenta Largura variável.

Adição da interpolação de forma aos traçados de largura variável

  1. No Animate CC, trace uma linha com a ferramenta Linha.

    Traçado de linha com valor de traçado definido como dois pixels
    Um traçado de linha desenhado usando a ferramenta Linha no Palco com valor de traçado definido como dois pixels.

  2. Use a ferramenta de Largura variável para adicionar a largura no meio do traçado (veja a figura abaixo). Para obter informações sobre como usar a ferramenta Largura variável, consulte Melhoria de traçados usando a ferramenta Largura variável.

    Traçado de largura variável com valor de 68,0 pixels
    O Traçado de largura variável criado por meio da Ferramenta de largura variável com valor de traçado definido como 68.0 pixels.

  3. Selecione outro quadro na linha do tempo, como o quadro 30, e crie a forma final do traçado para sua interpolação.

    Forma final adicionada ao último quadro-chave da interpolação de forma
    Forma final adicionada ao último quadro-chave da interpolação de forma.

  4. Clique com o botão direito do mouse em qualquer quadro entre 1 e 30 e selecione Criar interpolação de forma.

Adição de interpolações de forma a perfis de largura variável

O Animate também permite adicionar interpolações de forma a traçados mais sofisticados salvos como Perfis de largura variável. É possível aplicar perfis de largura às formas iniciais e finais de uma interpolação e permitir que o Animate crie uma suave interpolação de forma.

Os perfis de largura são apenas traçados mais sofisticados criados e salvos usando a ferramenta de largura variável para facilitar a reutilização. Para obter mais informações sobre perfis de largura, consulte Salvar perfis de largura.

Para adicionar interpolações de forma a perfis de largura variável, faça o seguinte:

  1. No Animate, trace uma linha no Palco usando a Ferramenta Linha.

    Traçado de linha com valor de dois pixels
    Um traçado de linha desenhado usando a ferramenta Linha no Palco com valor de traçado definido como dois pixels.

  2. No Inspetor de propriedades, selecione e aplique um Perfil de largura no menu suspenso de Largura.

    Traçado de largura variável com valor de traçado de 68,0 pixels
    O Traçado de largura variável criado por meio da Ferramenta de largura variável com valor de traçado definido como 68.0 pixels.

  3. Selecione outro quadro na linha do tempo, como o quadro 30, e selecione um perfil de largura desejado no menu suspenso de largura no Inspetor de propriedades.

  4. Para adicionar a interpolação de formas nos Perfis de largura selecionados, clique com o botão direito do mouse em qualquer quadro entre 1 e 30 e selecione Criar interpolação de forma.

Logotipo da Adobe

Fazer logon em sua conta