Otimização de documentos do Animate

Na medida em que aumenta o tamanho do arquivo de documentos, também aumenta o tempo de download e a velocidade da reprodução. Você pode tomar diversas medidas para preparar seu documento para reprodução ótima. Como parte do processo de publicação, o Animate executa automaticamente alguma otimização nos documentos. Antes de exportar um documento, você pode otimizá-lo ainda mais. usando diversas estratégias para reduzir o tamanho do arquivo. Você pode também comprimir o arquivo SWF na publicação. Enquanto você faz as mudanças, teste o documento executando-o em diversos computadores, sistemas operacionais e conexões da internet.

Otimização de documentos

  • Use símbolos, animados ou não, para todos os elementos que aparecem mais de uma vez.

  • Use animações interpoladas sempre que possível na criação de sequências animadas. As animações interpoladas usam menos espaço de arquivo do que uma série de quadros-chave.

  • Use clipes de filme em vez de símbolos gráficos para sequências de animação.

  • Limite a área de mudança em cada quadro-chave; faça a ação acontecer na menor área possível.

  • Evite elementos de bitmap animados; use imagens de bitmaps como elementos estáticos ou de fundo.

  • Use mp3, o menor formato de som, sempre que possível.

Otimização de elementos e de linhas

  • Agrupar elementos.

  • Use camadas, para separar os elementos que mudam durante a animação, dos elementos que não mudam.

  • Use Modificar > Forma > Otimizar para minimizar o número de linhas separadas, usadas para descrever formas.

  • Limite o número de tipos de linhas especiais, como tracejadas, pontilhadas, irregulares e assim por diante. As linhas sólidas exigem menos memória. As linhas criadas com a ferramenta Lápis exigem menos memória que os traçados com pincel.

Otimização de texto e de fontes

  • Limite o número de fontes e de estilos de fonte. Use fontes incorporados com moderação, pois elas aumentam o tamanho do arquivo.

  • Para as opções Incorporação de fontes, selecione apenas os caracteres necessários, em vez de incluir toda a fonte.

Otimização de cores

  • Use o menu Cores no inspetor de Propriedades Símbolo, para criar muitas ocorrências de um único símbolo em cores diferentes.

  • Use o painel Cores (Janela > Cor) para combinar a paleta de cores do documento com a paleta específica do navegador.

  • Use gradientes com moderação. O preenchimento de uma área com cor gradiente exige cerca de 50 bytes a mais do que preenchê-la com cor sólida.

  • Use transparência alfa com moderação, pois ela retarda a reprodução.

Acelerar exibição de documento

Para acelerar a exibição do documento, use os comandos do menu Visualizar para desativar os recursos de definição de qualidade que exigem computação extra e retardam a exibição do documento.

Nenhum desses comandos tem qualquer efeito sobre como o Animate exporta um documento. Para especificar a qualidade de exibição dos documentos do Animate em um navegador da web, use os parâmetros objeto e incorporado. O comando Publicar pode fazer isso para você automaticamente.

  1. Selecione Visualizar > Modo de visualização e selecione uma das seguintes opções:

    Contornos

    Exibe apenas os contornos das formas no palco e faz com todas as linhas apareçam como linhas finas. Isso facilita a remodelagem dos elementos gráficos e a exibição rápida de cenas complexas.

    Rápida

    Desativa a suavização de bordas e exibe todas as cores e os estilos de linha de seu desenho.

    Suavização de bordas

    Ativa a suavização de bordas para linhas, formas e bitmaps e exibe formas e linhas de modo que as suas bordas pareçam mais suaves na tela. Desenha mais lentamente do que a opção Rápido A suavização de bordas funciona melhor em cartões de vídeo que oferecem milhares (16 bits) ou milhões (24 bits) de cores. No modo 16 ou 256 cores, as linhas pretas ficam mais suaves, mas as cores têm melhor aparência no modo Rápido.

    Texto de suavização de bordas

    Suaviza as bordas de todos os textos. Funciona melhor com tamanhos grandes de fontes e pode ser lento com grandes quantidades de texto. Este é o modo mais comum no qual trabalhar.

    Total

    Apresenta todo o conteúdo totalmente no Palco. Pode desacelerar a exibição.

Otimização de gráficos e de animação

Antes de criar animações ou gráficos otimizados e simplificados, esquematize e planeje seu projeto. Estabelece um alvo para o tamanho e o comprimento do arquivo de animação e testa durante todo o processo de desenvolvimento.

Siga essas diretrizes para otimizar gráficos e animação:

  • Evite usar gradientes, pois eles necessitam de muitas cores e cálculos para serem processados, o que é mais difícil para um computador criar.

  • Pelo mesmo motivo, mantenha em um mínimo a quantidade de alfa ou de transparência usada em um arquivo SWF.

    Os objetos animados que incluem transparências exigem muito do processador e devem ser mantidos em um mínimo. Gráficos transparentes animados sobre bitmaps são tipos de animação especialmente exigentes do processador e devem ser mantidos em um mínimo ou totalmente evitados.

    Observação: o melhor formato de bitmap a ser importado para o Animate é o PNG, o formato nativo do Macromedia Fireworks da Adobe. Os arquivos PNG têm informações RGB e alfa para cada pixel. Se você importar um arquivo Fireworks PNG para o Animate, é possível reter alguma capacidade para editar os objetos gráficos no arquivo FLA.

  • Otimize os bitmaps sem comprimi-los exageradamente. Uma resolução de 72 dpi é ótima para a web. A compressão de uma imagem de bitmap reduz o tamanho do arquivo, mas comprimir em exagero compromete a qualidade do gráfico. Verifique se as configurações para qualidade do JPEG na caixa de diálogos Configurações de Publicação não comprimem demais a imagem. A representação de uma imagem como gráfico vetorial é preferível na maioria dos casos. O uso de imagens vetoriais reduz o tamanho do arquivo, pois as imagens são feitas de cálculos em vez de muitos pixels. Limite o número de cores em sua imagem enquanto ela ainda retém a qualidade.

    Observação: evite redimensionar os bitmaps para tamanhos maiores que suas dimensões originais, pois isso reduz a qualidade da imagem e exige muito do processador.

  • Defina a propriedade _visível para falsa em vez de mudar o nível _alfa para 0 ou 1 em um arquivo SWF. O cálculo do nível _alfa para uma ocorrência no Palco exige muito do processador. Se você desativar a visibilidade da ocorrência, isso economiza ciclos e memória para a CPU, o que pode dar animações mais suaves para os arquivos SWF. Em vez de descarregar e possivelmente recarregar os ativos, defina a propriedade _visível para falso, o que torna menos intensivo o uso do processador.

  • Reduza o número de linhas e pontos que você usa em um arquivo SWF. Use a caixa de diálogo Otimizar curvas (Modificar > Forma > Otimizar) para reduzir o número de vetores em um desenho. Selecione a opção Use diversas etapas para maior otimização. A otimização de um gráfico reduz o tamanho do arquivo, mas comprimi-lo demais compromete sua qualidade. Entretanto, a otimização das curvas reduz o tamanho do arquivo e melhora o desempenho do arquivo SWF. Há opções de terceiros disponíveis para a otimização especializada de curvas e de pontos que produzem resultados diferentes.

 

Para obter os melhores resultados, tente formas diferentes de produzir conteúdos animados e teste cada uma das opções.

A taxa mais alta de quadros (medida em quadros por segundo, ou fps) produz uma animação suave em um arquivo SWF mas pode exigir muito do processador, principalmente em computadores mais antigos. Teste as animações em taxas de quadros diferentes, para encontrar a menor taxa de quadros possível.

Para uma amostra de animação com script, consulte a página Amostras do Animate em www.adobe.com/go/learn_fl_samples. Faça o download e descomprima o arquivo zipado Amostras e navegue até a pasta ActionScript2.0/Animação para acessar a amostra.

Desempenho e taxa de quadros da animação

Quando você junta animação a um aplicativo, considere a taxa de quadro definida para o arquivo FLA. A taxa de quadros pode afetar o desempenho do arquivo SWF e do computador em que é executado. A definição de uma taxa de quadros muito alta pode levar a problemas com o processador, especialmente se forem usados muitos ativos ou o ActionScript para criar a animação.

No entanto, você precisa considerar também a configuração da taxa de quadros, pois ela afeta a uniformidade da execução da animação. Por exemplo, uma animação definida para 12 quadros por segundo (fps) no inspetor de Propriedades será executada 12 quadros a cada segundo. Se a taxa de quadros do documento é definida para 24 fps, a animação é mais suave do que se fosse executada em 12 fps. Entretanto, essa animação a 24 fps também será executada de forma mais rápida do que a 12 fps, de modo que a duração total (em segundos) é mais curta. Assim, para fazer uma animação de 5 segundos usando uma taxa de quadros maior, é preciso acrescentar mais quadros para preencher esses cinco segundos do que em uma taxa mais baixa de quadros (e assim eleva o tamanho total do arquivo da animação). Em geral, uma animação de 5 segundos a 24 fps tem tamanho de arquivo maior do que uma animação de 5 segundos a 12 fps.

Observação:

Quando você usa um manipulador de eventos onEnterFrame para criar animações com script, a animação é executada na taxa de quadros do documento, como se você tivesse criado uma interpolação de movimento em uma linha do tempo. Uma alternativa ao manipulador de eventos onEnterFrame é o setInterval (Consulte Referência de linguagem ActionScript 2.0). Em vez de depender da taxa de quadros, você chama as funções em intervalos especificados. Como no onEnterFrame, quanto maior a frequência de uso do setInterval para chamar uma função, mais intensivo é o uso da animação no processador.

Use a taxa de quadro mais baixa possível que faça sua animação ser executada suavemente no tempo de execução, o que ajuda a reduzir o esforço do processador do usuário final. Taxas de quadros altas (mais de 30 a 40 fps) colocam muita carga nos processadores e não mudam muito a aparência da animação no tempo de execução ou até nada mudam.

Selecione a taxa de quadros da animação o mais cedo possível no processo de desenvolvimento. Quando você testar o arquivo SWF, verifique a duração e o tamanho do arquivo de sua animação. A taxa de quadros afeta muito a velocidade da animação.

Filtros e desempenho do arquivo SWF

Se você usar muitos filtros no aplicativo, pode usar grandes quantidades de memória e prejudicar o desempenho do Flash Player. Como um clipe de filme com filtros anexados tem dois bitmaps de 32 bit, esses bitmaps podem forçar o aplicativo a usar uma quantidade significativa de memória, se forem usados muitos bitmaps. O sistema operacional do computador pode gerar um erro de falta de memória. Em um computador moderno, os erros de falta de memória devem ser raros, a menos que você esteja usando extensivamente efeitos de filtro em um aplicativo (por exemplo, se houver milhares de bitmaps no Palco).

No entanto, se você encontrar um erro de falta de memória, pode ocorrer o seguinte:

  • A matriz de filtros é ignorada.

  • O clipe de filme é desenhado usando o criador comum de vetores.

  • Não há bitmaps em cache para o clipe de filme.

    Depois que ocorrer um erro de falta de memória, o clipe de filme não tenta mais usar a matriz de filtros ou o cache de bitmaps. Um outro fator que afeta o desempenho do player é o valor usado para o parâmetro de qualidade para cada filtro aplicado. Valores mais altos exigem mais CPU e memória para o efeito ser criado, enquanto a definição do parâmetro de qualidade em um valor mais baixo exige menos recursos do computador. Evite usar um número excessivo de filtros e use uma configuração de qualidade mais baixa, sempre que possível.

    Observação: se um objeto de 100 por 100 pixels é dobrado, ele usará quatro vezes a memória, uma vez que as dimensões do conteúdo agora serão de 200 por 200 pixels. Se você dobrar novamente, a forma será desenhada como um objeto de 800 por 800 pixels que usa 64 vezes a memória que era usada pelo objeto original de 100 por 100 pixels. Sempre que usar filtros no arquivo SWF, desabilite as opções do menu zoom do menu de contexto do arquivo SWF.

    Você pode encontrar erros se usar tipos de parâmetros inválidos. Alguns filtros de parâmetros têm também uma faixa válida particular. Se você definir um valor fora da faixa válida, ele muda para um valor válido dentro da faixa. Por exemplo, a qualidade deveria ser um valor de 1 a 3 para a operação padrão e só pode ser definida em 0 a 15. Qualquer coisa superior a 15 fica definida como 15.

    Alguns construtores têm restrições sobre o comprimento das matrizes exigidas como parâmetros de entrada. Se um filtro de convolução ou de matriz de cor for criado com uma matriz inválida (não do tamanho correto), o construtor falha e o filtro não é criado com sucesso. Se o objeto do filtro for usado em seguida como entrada em uma matriz de filtros de um clipe de filme, ele é ignorado.

    Dica: quando se usa um filtro de desfoque, o uso de valores de desfoqueX e desfoqueY que são potências de 2 (como 2, 4, 8, 16 e 32) podem ser computados mais rapidamente e dão uma melhora de desempenho de 20% a 30%.

Bitmap em cache e desempenho do arquivo SWF

O bitmap em cache ajuda a melhorar o desempenho de clipes de filmes de conteúdo estático nos aplicativos. Quando você define as propriedades MovieClip.cacheAsBitmap ou Button.cacheAsBitmap para verdadeiro, o Flash Player coloca em cache a representação interna do bitmap do clipe de filme ou da ocorrência do botão. Isso pode melhorar o desempenho dos clipes de filme com conteúdo vetorial complexo. Todos os dados vetoriais de um clipe de filme que têm bitmaps em cache são desenhados no bitmap, em vez de no Palco principal.

Observação:

O bitmap é copiado no Palco principal como pixels não expandidos e não girados, encaixados nos limites dos pixels mais próximos. Os pixels são mapeados um a um com o objeto pai. Se os limites do bitmap mudarem, este é recriado em vez de ser expandido.

Para obter informações detalhadas sobre ocorrências de clipes de filme ou de botões em cache, consulte os seguintes tópicos:

  • Sobre armazenamento em cache e rolagem de clipes de filme com o ActionScript em Aprendizado sobre o ActionScript 2.0

  • Armazenamento em cache de um clipe de filme Aprendizado sobre o ActionScript 2.0

    Use a propriedade cacheAsBitmap com clipes de filmes com grande quantidade de conteúdo estático e que não são dimensionados e girados frequentemente. Com esses clipes de filme, o uso da propriedade cacheAsBitmap pode levar a melhorias de desempenho quando o clipe de filme é convertido (quando suas posições x e y são mudadas).

    A ativação do cache para um clipe de filme cria uma superfície, o que tem diversas vantagens, como ajudar na criação rápida de animações vetoriais complexas. Em algumas situações, a ativação do cache não melhora o desempenho, pode mesmo piorar.

    O desempenho global de dados em cache depende da complexidade dos dados vetoriais das ocorrências, quanto foram mudados os dados e se foi ou não definida a propriedade opaqueBackground. Se você estiver mudando regiões pequenas, a diferença entre o uso de superfície e o uso de dados vetoriais pode ser desprezível. Teste o seu trabalho das duas formas, antes de implantar o aplicativo.

Quando usar bitmap em cache

A seguir, alguns casos comuns nos quais podem ser vistos benefícios significativos quando se ativa bitmap em cache com a otimização de gráficos vetoriais.

Imagem de fundo complexa

Um aplicativo que contenha imagens de fundo detalhadas e complexas de dados vetoriais Para melhorar o desempenho, selecione o conteúdo, armazene em um clipe de filme e defina a propriedade opaqueBackground como verdadeira. O fundo é criado como um bitmap e pode se redesenhado rapidamente, de modo que a execução da animação seja mais rápida.

Rolagem de campo de texto

Um aplicativo que exibe uma grande quantidade de texto na rolagem do campo de texto. Coloque o campo de texto em um clipe de filme definido como rolável, com limites de rolagem (a propriedade scrollRect), o que habilita a rolagem rápida de pixels para a ocorrência especificada. Quando o usuário rola a ocorrência de clipe de filme, os pixels rolados movem-se para cima e geram a região recém-exposta, em vez de gerar novamente todo o campo de texto.

Sistema de janelas

Um aplicativo com um sistema complexo de janelas sobrepostas. Cada janela pode ser aberta ou fechada (por exemplo, as janelas de navegador da web). Se você marcar cada janela como uma superfície (defina a propriedade cacheAsBitmap como verdadeira), cada janela é isolada e colocada em cache. Os usuários podem arrastar as janelas de modo que se superponham, e as janelas não precisam gerar novamente o conteúdo vetorial.

Quando evitar o uso de bitmap em cache

O mau uso do bitmap em cache pode afetar negativamente o arquivo SWF. Quando desenvolver um arquivo FLA que usa superfícies, lembre-se das diretrizes a seguir:

  • Não use em exagero superfícies (clipes de filmes com o cache ativado). Cada superfície usa mais memória do que um clipe normal de filme; ative as superfícies apenas para melhorar o desempenho apresentado.

  • Um bitmap em cache pode usar significativamente mais memória do que uma ocorrência comum de clipe de filme. Por exemplo, se o clipe de filme no Palco tem 250 por 250 pixels, pode usar 250 kB em cache; ao invés disso, poderia utilizar apenas 1 kB se fosse uma ocorrência comum de clipe de filme (não em cache).

  • Evite o zoom em superfícies em cache. Se usar exageradamente bitmap em cache, é consumida uma grande quantidade de memória (veja observação anterior) se você ampliar o conteúdo.

  • Use superfícies para ocorrências de clipe de filme em grande parte estáticas (sem animação). Você pode arrastar ou mover a ocorrência, mas os conteúdos da ocorrência não devem ser animados ou mudados muito. Por exemplo, se você girar ou transformar uma ocorrência, ela muda entre a superfície e os dados vetoriais, o que é difícil de processar e afeta negativamente o arquivo SWF.

  • Se misturar superfícies com dados vetoriais, aumenta a quantidade de processamento a ser feita pelo Flash Player (e algumas vezes o computador). Agrupe as superfícies, por exemplo, quando criar aplicativos em janelas.

Trabalho com componentes no Flash Player

O componente estrutura permite que você aumente a funcionalidade dos componentes, mas pode, possivelmente, aumentar de forma considerável o tamanho do arquivo para um aplicativo. Os componentes herdam uns dos outros. Um componente acrescenta tamanho ao documento do Animate, mas os componentes subsequentes, que usam a mesma estrutura, necessariamente não acrescentarão mais tamanho. Na medida em que se colocam mais componentes no Palco, aumenta o tamanho do arquivo, mas em algum momento ele entra em equilíbrio, pois os componentes compartilham classes e não carregam novas cópias dessas classes.

Se usar múltiplos componentes que não compartilham da mesma estrutura, eles podem acrescentar tamanho substancial ao arquivo SWF. Por exemplo, o componente XMLConnector soma 17 kB ao arquivo SWF e os componentes TextInput 24 kB ao seu documento. Se acrescentar o componente ComboBox serão 28 kB, pois ele não faz parte da estrutura de nenhum dos componentes anteriores. Como o componente XMLConnector usa vínculo de dados, as classes somam 6 kB ao arquivo SWF. Um documento que use todos esses componentes tem 77 kB antes que seja acrescentada qualquer coisa ao arquivo. Considere com cuidado o tamanho do arquivo SWF quando juntar novos componentes ao documento.

Os componentes precisam existir na biblioteca do arquivo SWF pai. Por exemplo, um aplicativo precisa ter na biblioteca a cópia dos componentes que usa, mesmo se esses componentes forem necessários para arquivos SWF filhos carregados no tempo de execução. Isso é necessário para garantir que os componentes funcionem adequadamente e aumenta ligeiramente o tempo de download do arquivo SWF pai. Entretanto, a biblioteca pai não é herdada ou compartilhada nos arquivos SWF carregados no pai. Precisa ser feito o download de cada arquivo SWF filho para o aplicativo, com sua própria cópia dos mesmos componentes.

Se você estiver planejando publicar um arquivo SWF com compatibilidade para trás, precisa ter um bom conhecimento dos componentes que têm essa capacidade. A tabela a seguir fornece informações sobre a disponibilidade dos componentes nas diferentes versões do Flash Player:

Componentes

Flash Player 6 (6.0.65.0) e anterior

Flash Player 6 (6.0.65.0)

Flash Player 7 e 8

Flash Player 9

ActionScript 3.0

Não suportado

Não suportado

Não suportado

Suportado

ActionScript 2.0

Suportado

Suportado

Suportado

Suportado

Conjunto de componentes V2 UI

Não suportado

Suportado

Suportado

Suportado

Componentes de mídia

Não suportado

Não suportado

Suportado

Suportado

Componentes de dados

Não suportado

Não suportado

Suportado

Suportado

Para funcionar, cancele a seleção da opção Otimizar para Flash Player 6r65 nas configurações de Publicação para os componentes V2 UI.

Otimização de desempenho e estilos dos componentes

Se usar o ActionScript 2.0, uma das chamadas que provocam uso mais intensivo do processador em uma estrutura de componente é a chamada setStyle. A chamada setStyle tem execução eficiente, mas exige muito do processador pela forma como é implementada. A chamada setStyle nem sempre é necessária em todos os aplicativos, mas se você a utilizar, considere seu efeito no desempenho.

Para melhorar o desempenho, você pode mudar os estilos antes que sejam carregados, calculados e aplicados aos objetos no arquivo SWF. Se puder mudar os estilos antes que sejam carregados e calculados, não precisa chamar o setStyle.

Para melhorar o desempenho quando se usa estilos, defina as propriedades de cada objeto assim que são exemplificados Se você anexar dinamicamente ocorrências no Palco, defina as propriedades no initObj na chamada feita para o createClassObject(), como mostra o ActionScript a seguir:

createClassObject(ComponentClass, "myInstance", 0, {styleName:"myStyle", color:0x99CCFF});

Para as ocorrências colocadas diretamente no Palco, você pode usar o onClipEvent() para cada ocorrência ou usar subclasses (recomendado). Para obter mais informações sobre subclasses, consulte Sobre programar uma subclasse em Aprendizado sobre o ActionScript 2.0.

Se precisar dar novo estilo aos componentes, pode melhorar a eficiência de seu aplicativo usando o componente Loader. Para implementar diversos estilos em componentes diferentes, coloque cada componente em seu próprio arquivo SWF. Se você mudar os estilos no componente Carregador e recarregar o arquivo SWF, os componentes do arquivo SWF serão recriados. Quando o componente é recriado, o cache de estilos fica esvaziado e o estilo do componente é redefinido e referenciado novamente.

Observação:

Para aplicar um único estilo a todas as ocorrências de um componente no arquivo SWF, mude globalmente o estilo usando o _global.styles.ComponentName.

Uso de bibliotecas compartilhadas no tempo de execução

Algumas vezes você pode melhorar o tempo de download usando bibliotecas compartilhadas no tempo de execução. Essas bibliotecas são, em geral, necessárias para aplicativos maiores ou quando numerosos aplicativos de um site usam os mesmos componentes ou símbolos. Com a externalização dos ativos comuns dos arquivos SWF, não é preciso fazer download das classes repetidamente. O primeiro arquivo SWF a usar a biblioteca compartilhada tem tempo de download mais longo, porque o arquivo SWF e a biblioteca são carregados. A biblioteca faz cache no computador do usuário e depois todos os arquivos SWF subsequentes usam a biblioteca. Esse processo pode melhorar muito o tempo de download para alguns arquivos maiores.

Exibição de caracteres especiais

Os sistemas operacionais de computador têm uma página específica de códigos que é regional. Por exemplo, um computador no Japão tem página de código diferente de um na Inglaterra. O Flash Player 5 e as versões anteriores se apoiavam na página de código para exibir o texto; o Flash Player 6 e versões posteriores usam Unicode para exibir texto. O Unicode é mais confiável e padronizado para a exibição de texto, porque é um conjunto universal de caracteres para todas as linguagens. Os aplicativos mais atuais usam o Unicode.

Você pode usar as sequências de escape do Unicode para exibir caracteres especiais no Flash Player 6 e posterior. Entretanto, nem todos os caracteres são exibidos corretamente, se não for carregado texto codificado UTF‑8 ou UTF‑16 (Unicode) ou se você não usar a sequência de escape Unicode para exibir o caractere especial. Para um conjunto de gráficos de código, consulte o site da web do Unicode em Unicode.org. Para uma lista de sequências de escape mais comumente usadas, consulte a tabela que se segue nesta seção.

Um aplicativo não Unicode usa a página do código do sistema operacional para criar caracteres em uma página. Nesse caso, a página de código especifica os caracteres que você visualiza, de modo que os caracteres aparecem corretamente apenas quando a página de código no sistema operacional do usuário está compatível com a página de código do aplicativo. A página de código que foi usada para criar o arquivo SWF precisa combinar com a página de código do computador do usuário final. O uso de páginas de código não é uma boa ideia para aplicativos que um público-alvo internacional possa usar; nesse caso, use Unicode no lugar.

O uso de System.useCodepage no seu código força o arquivo SWF a usar a página de código do sistema em vez do Unicode.

Use esse processo apenas se estiver carregando texto codificado não Unicode de um local externo e quando esse texto está codificado com a mesma página de código que o computador do usuário. Se as duas condições forem verdadeiras, o texto aparece sem problemas. Se as duas condições não forem verdadeiras, use Unicode e a sequência de escape do Unicode para formatar o texto. Para usar uma sequência de escape, acrescente o seguinte ActionScript 2.0 no Quadro 1 na Linha do tempo:

this.createTextField("myText_txt", 99, 10, 10, 200, 25); 
myText_txt.text = "this is my text, \u00A9 2004";

Este ActionScript cria um campo de texto e introduz texto que inclui o símbolo de copyright (©) no campo de texto.

Você pode fazer o arquivo SWF usar a página de código do sistema operacional, controlada pela propriedade useCodepage. Quando o Animate exporta um arquivo SWF, ele assume o padrão de exportação de texto Unicode e o System.useCodepage é definido como false. Você pode encontrar problemas para exibir textos especiais, ou textos em sistemas internacionais, caso em que o uso da página de código do sistema pode parecer solucionar o problema da exibição incorreta do texto. Entretanto, o uso do System.useCodePage é sempre o último recurso.

Para usar a página de código do sistema, coloque a seguinte linha do código ActionScript 2.0 no Quadro 1 da Linha do tempo:

System.useCodepage = true;
<< need an AS3 example here as well. See
dev/qa. >>

Observação:

Pode aparecer um caractere especial se o computador do usuário tiver o caractere incluído na fonte que está sendo usada. Se não tiver certeza, incorpore o caractere ou a fonte no arquivo SWF.

A tabela seguinte contém algumas das sequências de escape do Unicode mais usadas comumente.

Descrição do caractere

Sequência de escape do Unicode

em-dash ()

\u2014

sinal de registrado (®)

\u00AE

sinal de copyright (©)

\u00A9

sinal de marca registrada (™)

\u2122

sinal de Euro ()

\u20AC

barra invertida (\)

\u005C

barra (/)

\u002F

chave aberta ({)

\u007B

chave fechada (})

\u007D

maior do que (<)

\u003C

menor do que (>)

\u003E

asterisco (*)

\u002A

Testar o desempenho do download de documentos

O Flash Player procura cumprir a taxa de quadros que você definiu; a taxa de quadros real durante a reprodução pode variar em diferentes computadores. Se está sendo feito o download de um documento e ele atinge um quadro particular, antes que os dados necessários do quadro já tenham baixado, o documento entra em pausa até que o dado chegue.

Para visualizar graficamente o desempenho de download, use o Gerador de perfil de banda larga que mostra quanto dado é enviado para cada quadro, de acordo com a velocidade do modem especificada.

Observação: (somente para Animate CC) o Criador de perfil de largura de banda não está disponível no Animate CC. Em vez disso, você pode optar por usar o Adobe Scout com o Animate. Para obter mais informações, consulte Uso do Adobe Scout com o Animate.

Na simulação da velocidade de download, o Animate usa estimativas de desempenho comum da Internet, não a velocidade exata do modem. Por exemplo, se você optar por simular uma velocidade de modem de 28,8 Kbps, o Animate define a taxa real como 2,3 Kbps para refletir o desempenho comum da Internet. O gerador de perfil compensa pelo suporte de compressão adicionado para os arquivos SWF, que reduz o tamanho do arquivo e melhora o desempenho do fluxo.

Quando arquivos SWF externos, GIF e arquivos XML além de variáveis são transmitidos para o player com o uso de chamadas do ActionScript como loadMovie e getUrl, os dados fluem na taxa definida para a transmissão contínua de dados. A taxa de fluxo para o arquivo SWF principal é reduzida com base na redução da banda larga que os pedidos de mais dados provocam. Teste seu documento em cada velocidade e em cada computador que você planeja suportar, para garantir que o documento não sobrecarregue a conexão mais lenta e o computador para o qual foi destinado.

Você pode gerar também um relatório dos quadros que estão atrasando a reprodução e depois otimizar ou eliminar parte do conteúdo nesses quadros.

Para mudar as configurações do arquivo SWF criado usando os comandos Testar filme e Testar cena, use Arquivo > Configurações de publicação.

Teste do desempenho de download

  1. Siga um destes procedimentos:
    • Selecione Controle > Testar cena, ou Controle > Testar.

      Se você testar uma cena ou um documento, o Animate publica a seleção atual como arquivo SWF com o uso da caixa de diálogo Configurações de publicação. O arquivo SWF abre em uma nova janela e começa a reprodução imediatamente.

    • Selecione Arquivo > Abrir e selecione um arquivo SWF.

  2. Selecione Visualizar > Configurações de download e selecione a velocidade de download para determinar a taxa de fluxo que o Animate simula. Para introduzir uma configuração de usuário personalizada, selecione Personalizar.

  3. Quando visualizar o arquivo SWF, selecione Visualizar > Gerador de perfil de banda larga para mostrar o gráfico do desempenho de download.

    O lado esquerdo do gerador de perfis exibe as informações sobre o documento, configurações, estado e fluxos, se qualquer deles estiver incluído no documento.

    A seção da direita do gerador de perfis mostra o cabeçalho e o gráfico da Linha do tempo. No gráfico, cada barra representa um quadro individual do documento. O tamanho da barra corresponde ao tamanho desse quadro em bytes. A linha vermelha abaixo do cabeçalho da Linha do tempo indica se um dado quadro flui em tempo real com a velocidade do modem atual definida no menu Controlar. Se uma barra se estender acima da linha vermelha, o documento deve esperar que o quadro carregue.

    Observação: (somente para Animate CC) o Criador de perfil de largura de banda não está disponível no Animate CC. Em vez disso, você pode optar por usar o Adobe Scout com o Animate. Para obter mais informações, consulte Uso do Adobe Scout com o Animate.

     

  4. Selecione Visualizar > Simular Download para ativar e desativar o fluxo.

    Se você desativar o fluxo, o documento inicia sem simular uma conexão com a web.

    Observação: (somente para Animate CC) a opção Simular download não está disponível no Animate CC.

     

  5. Clique em uma barra do gráfico para mostrar as configurações para o quadro correspondente na janela esquerda e parar o documento.
  6. Se necessário, ajuste a visualização do gráfico, com uma das ações a seguir:
    • Selecione Visualização > Gráfico de fluxo para mostrar os quadros que causam pausas.

      Esta visualização padrão exibe alternadamente blocos cinza claros e escuros que representam cada quadro. O lado de cada bloco indica seu tamanho relativo em byte. O primeiro quadro armazena os conteúdos do símbolo, assim, frequentemente será maior que os outros quadros.

    • Selecione Visualizar > Gráfico Quadro a Quadro para exibir o tamanho de cada quadro.

      Esta visualização ajuda a visualizar os quadros que contribuem para atrasos no fluxo. Se qualquer bloco de quadros se estende acima da linha vermelha do gráfico, o Flash Player para a reprodução até que conclua o download de todo o quadro.

  7. Feche a janela de teste para voltar ao ambiente de criação.

    Depois de configurar o ambiente de teste com o uso do Gerador de perfil de banda larga, você pode abrir qualquer arquivo SWF diretamente no ambiente de teste. O arquivo se abre em uma janela Flash Player, usando o Gerador de perfil de banda larga e outras opções de visualização selecionadas.

    Observação: (somente para Animate CC) o Criador de perfil de largura de banda não está disponível no Animate CC. Em vez disso, você pode optar por usar o Adobe Scout com o Animate. Para obter mais informações, consulte Uso do Adobe Scout com o Animate.

     

Geração de relatório final

  1. Selecione Arquivo > Configurações de publicação, em seguida, clique na guia Animate tab.

  2. Selecione Gerar relatório de tamanho.
  3. Clique em Publicar.

    O Animate gera um arquivo de texto com a extensão .txt. (se o arquivo de documentos for myMovie.fla, o arquivo de texto será myMovie Report.txt). O relatório lista o tamanho de cada quadro, forma, texto, som, vídeo e o script ActionScript por quadro.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online