Trabalho com bitmaps importados

Ao importar um bitmap para o Animate, é possível modificá-lo e usá-lo em seu documento do Animate de várias maneiras.

Se um documento do Animate exibir um bitmap importado com um tamanho maior do que o original, a imagem pode ficar distorcida. Para ter certeza de que as imagens serão exibidas adequadamente, visualize os bitmaps importados.

Ao selecionar um bitmap no Palco, o Inspetor de propriedades exibe o nome do símbolo do bitmap e suas dimensões em pixel e sua posição no Palco. Usando o Inspetor de propriedades, você pode alternar uma ocorrência de um bitmap, ou seja, substituir a ocorrência por uma ocorrência de outro bitmap no documento atual.

 

Exibir o Inspetor de propriedades com as propriedades do bitmap

  1. Selecione uma ocorrência de um bitmap no Palco.

  2. Selecione Janela > Propriedades.

Substituir uma ocorrência de um bitmap por uma ocorrência de outro bitmap

  1. Selecione a ocorrência de um bitmap no Palco.

  2. Selecione Janela > Propriedades e clique em Alternar.

  3. Selecione um bitmap para substituir aquele atualmente atribuído à ocorrência.

Definir propriedades de bitmap

É possível aplicar suavização de borda em um bitmap importado para suavizar as bordas na imagem. Você pode também selecionar uma opção de compactação para reduzir o tamanho do arquivo de bitmap e formatar o arquivo para ser exibido na Web.

  1. Selecione um bitmap no painel Biblioteca e clique no botão Propriedades na parte inferior do painel Biblioteca.
  2. Selecione Permitir suavização. Suavizar melhora a qualidade das imagens bitmap quando são dimensionadas.
  3. Em Compactação, selecione uma das opções a seguir:

    Foto (JPEG)

    Compacta a imagem no formato JPEG. Para usar a qualidade de compactação padrão especificada para a imagem importada, selecione Usar qualidade padrão de documento. Para especificar uma nova configuração de compactação de qualidade, cancele a seleção da opção Usar qualidade padrão do documento e digite um valor entre 1 e 100 no campo de texto Qualidade. (Uma configuração mais alta apresenta maior preservação da integridade da imagem, mas gera um tamanho de arquivo maior).

    Sem perdas (PNG/GIF)

    Compacta a imagem com compactação sem perdas, na qual nenhum dado é descartado da imagem.

    Observação: use a compactação de Foto para imagens com variações complexas de tons ou cores, como fotografias ou imagens com preenchimentos de gradiente. Use a compactação sem perdas para imagens com formas simples e relativamente poucas cores.

  4. Para determinar os resultados da compactação do arquivo, clique em Testar. Para determinar se a configuração de compactação selecionada é aceitável, compare o tamanho do arquivo original com o tamanho do arquivo compactado.
  5. Clique em OK.

Observação:

As configurações de qualidade do JPEG selecionadas na caixa de diálogo Configurações de publicação não especificam uma configuração de qualidade para os arquivos JPEG importados. Especifique uma configuração de qualidade para cada arquivo JPEG importado na caixa de diálogo Propriedades do bitmap.

(Apenas para Animate CC) Troca de vários bitmaps

A opção Trocar bitmap permite que você troque símbolos e bitmaps por símbolos ou bitmaps selecionados.

  1. No Animate Pro CC, selecione vários bitmaps no palco.

  2. No painel Propriedades, clique em TROCAR.
  3. Na caixa de diálogo Trocar símbolo, selecione o bitmap pelo qual você deseja substituir todos os símbolos/bitmap selecionados.
  4. Clique em OK.

Importar bitmaps no tempo de execução

Para adicionar bitmaps em um documento no tempo de execução, use o comando BitmapData do ActionScript® 2.0 ou do ActionScript 3.0. Para isso, especifique um identificador de ligação para o bitmap. Para obter mais informações, consulte Atribuição de ligações a ativos na biblioteca em Uso do ActionScript 2.0 ou Exportação de símbolos da biblioteca para ActionScript, no Guia do desenvolvedor do ActionScript 3.0.

  1. Selecione o bitmap no painel Biblioteca.
  2. Siga um destes procedimentos:
    • Selecione Ligação no menu Painel no canto superior direito do painel.

    • Clique com o botão direito (Windows) ou clique com a tecla Control pressionada (Macintosh) no nome do bitmap no painel Biblioteca e selecione Propriedades no menu de contexto.

      Se as propriedades de Ligação não estiverem visíveis na caixa de diálogo Propriedades, clique em Avançado.

  3. Em Ligação, selecione Exportar para ActionScript.
  4. Digite uma string do identificador no campo de texto e clique em OK.

Aplicar um bitmap como um preenchimento

Para aplicar um bitmap como um preenchimento em um objeto gráfico, use o painel Cor. A aplicação de um bitmap como preenchimento ladrilha o bitmap para preencher o objeto. A ferramenta Transformação de gradiente permite que você dimensione, gire ou incline uma imagem e seu preenchimento de bitmap.

  1. Para aplicar o preenchimento à arte final existente, selecione o(s) objeto(s) gráfico(s) no Palco.
  2. Selecione Janela > Cor.
  3. Selecione Bitmap no menu pop-up da parte superior direita do painel.
  4. Para usar uma janela de visualização maior para exibir mais bitmaps no documento atual, clique na seta no canto inferior direito para expandir o painel Cor.
  5. Clique em um bitmap para selecioná-lo.

    O bitmap torna-se a cor de preenchimento atual. Se você tiver selecionado a arte final na etapa 1, o bitmap será aplicado como um preenchimento à arte final.

Edição de um bitmap em um editor externo

Se você estiver editando um arquivo PNG do Fireworks como uma imagem nivelada, edite o arquivo de origem PNG do bitmap, quando disponível.

Observação:

Não é possível editar bitmaps dos arquivos PNG do Fireworks importados como objetos editáveis em um editor de imagem externo.

Se você tiver o Fireworks 3 ou posterior ou outro aplicativo de edição de imagem instalado em seu sistema, é possível iniciar o aplicativo a partir do Animate para editar um bitmap importado.

Editar um bitmap com o Photoshop CS5 ou posterior

Observação:

Se você estiver usando o CS5.5, precisará usar o Photoshop CS5.1 para acessar esse recurso.

  1. No painel Biblioteca, clique com o botão direito (Windows) ou clique com a tecla Control pressionada (Macintosh) no ícone do bitmap e selecione Editar com Photoshop CS5.

  2. Faça as modificações desejadas no arquivo no Photoshop.

  3. No Photoshop, selecione Arquivo > Salvar. (Não altere o nome ou o formato do arquivo.)

  4. Retorne ao Animate.

    O arquivo é automaticamente atualizado no Animate.

Editar um bitmap com o Fireworks 3 ou posterior

  1. No painel Biblioteca, clique com o botão direito (Windows) ou clique com a tecla Control pressionada (Macintosh) no ícone do bitmap e selecione Editar com Fireworks 3.

  2. Especifique se deseja abrir o arquivo de origem PNG ou o arquivo bitmap.

  3. Faça as modificações desejadas no arquivo no Fireworks.

  4. No Fireworks, selecione Arquivo > Atualizar.

  5. Retorne ao Animate.

    O arquivo é automaticamente atualizado no Animate.

Editar um bitmap com outro aplicativo de edição de imagem

  1. No painel Biblioteca, clique com o botão direito (Windows) ou clique com a tecla Control pressionada (Macintosh) no ícone do bitmap e selecione Editar com.

  2. Selecione um aplicativo de edição de imagem para abrir o arquivo bitmap e clique em OK.

  3. Faça as modificações desejadas no arquivo no aplicativo de edição de imagem.

  4. Salve o arquivo no aplicativo de edição de imagem.

    O arquivo é automaticamente atualizado no Animate.

  5. Retorne ao Animate para continuar a edição do documento.

Separe um bitmap e crie um bitmap de preenchimento

A separação de um bitmap no Palco separa a imagem no palco de seu item de biblioteca e o converte em uma forma a partir de uma instância de bitmap. Ao separar um bitmap, você pode modificá-lo com as ferramentas de desenho e pintura do Animate. Com o uso da ferramenta Varinha mágica, é possível selecionar áreas de um bitmap que contém as mesmas cores ou similares.

Para pintar com um bitmap separado, selecione o bitmap com a ferramenta Conta-gotas e aplique o bitmap como um preenchimento com a ferramenta Balde de tinta ou outra ferramenta de desenho.

Separar um bitmap

  1. Selecione um bitmap na cena atual.

  2. Selecionar Modificar > Separar.

Alteração do preenchimento das áreas de um bitmap separado

  1. No painel Ferramentas, selecione a ferramenta Varinha mágica. Se a ferramenta Varinha mágica não estiver visível, clique na ferramenta Lasso e selecione a ferramenta Varinha mágica no menu pop-up. Defina as seguintes opções no Inspetor de propriedade:

    • Em Limiar, digite um valor entre 1 e 200 para definir o quanto a cor dos pixels adjacentes deve combinar para ser incluída na seleção. Um valor mais alto inclui uma gama de cores maior. Se você digitar 0, só os pixels de cor exatamente igual a do primeiro pixel clicado serão selecionados.

    • Em Suavização, selecione uma opção para definir quantas bordas da seleção serão suavizadas.

  2. Para selecionar uma área, clique no bitmap. Para adicionar à seleção, continue clicando.

  3. Para preencher as áreas selecionadas no bitmap, selecione o preenchimento a ser usado no controle Cor de preenchimento.

  4. Para aplicar o novo preenchimento, selecione a ferramenta Balde de tinta e clique em qualquer lugar na área selecionada.

Conversão de um bitmap em um gráfico vetorial

O comando Traçar bitmap converte um bitmap em um gráfico vetorial com áreas de cor distintas e editáveis. Você pode manipular a imagem como um gráfico vetorial e pode reduzir o tamanho do arquivo.

Ao converter um bitmap em um gráfico vetorial, este gráfico vetorial não fica mais vinculado ao símbolo do bitmap no painel Biblioteca.

Observação:

Se o bitmap importado contiver formas complexas e muitas cores, o gráfico de vetor convertido pode ter um tamanho de arquivo maior do que o bitmap original. Para encontrar um equilíbrio entre o tamanho do arquivo e a qualidade da imagem, tente uma série de configurações na caixa de diálogo Traçar bitmap.

É possível também separar um bitmap para modificar a imagem com as ferramentas de desenho e pintura do Animate.

  1. Selecione um bitmap na cena atual.

  2. Selecione Modificar > Bitmap > Traçar bitmap.

  3. Digite um valor do Limiar de cor.

    Quando dois pixels são comparados, se a diferença nos valores de cor RGB for menor do que o limiar de cor, os dois pixels serão considerados da mesma cor. À medida que o valor do limiar é aumentado, o número de cores diminui.

  4. Em Área mínima, digite um valor para definir o número de pixels circundantes para considerar quando atribuir uma cor a um pixel.

  5. Em Ajuste da curva, selecione uma opção para determinar o quão suaves os contornos serão desenhados.

  6. Em Limiar do canto, selecione uma opção para determinar se as bordas nítidas serão retidas ou suavizadas.

    Para criar um gráfico vetorial que pareça ao máximo com o bitmap original, digite os seguintes valores:

    • Limiar de cor: 10

    • Área mínima: 1 pixel

    • Ajuste da curva: Pixels

    • Limiar do canto: Muitos cantos

Uso da ferramenta Conta-gotas para aplicar um preenchimento de bitmap

  1. Selecione a ferramenta Conta-gotas e clique no bitmap separado no Palco. A ferramenta Conta-gotas define o bitmap a ser o preenchimento atual e muda a ferramenta ativa para o Balde de tinta.

  2. Siga um destes procedimentos:

    • Para aplicar o bitmap como um preenchimento, clique no objeto gráfico existente com a ferramenta Balde de tinta.

    • Selecione a ferramenta Oval, Retângulo ou Caneta e desenhe um novo objeto. O objeto é preenchido com o bitmap separado.

      Para dimensionar, girar ou inclinar o preenchimento do bitmap, use a ferramenta Transformação livre.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online