Formatar código

Seu código pode ser formatado e recuado automaticamente quando digitado. Com o uso do mapeamento dinâmico de fontes, você garante que as fontes corretas sejam usadas em textos multilíngues.

Definir as opções de Formato automático

  1. Siga um destes procedimentos:
    • No menu do painel  (no canto superior direito do painel Ações), selecione Preferências.

    • Na janela Script, selecione Editar > Preferências (Windows) ou Animate > Preferências (Macintosh).

  2. Na caixa de diálogo Preferências, selecione Formato automático.
  3. Selecione uma das opções de Formato automático.

    Depois de definir as opções de Formato automático, suas configurações serão aplicadas automaticamente ao código que você escrever, mas não ao código existente. Para o código existente, você deve aplicar as configurações manualmente.

Formatar código de acordo com as configurações do Formato automático

  • Clique em Formato automático  na barra de ferramentas do painel Ações ou da janela Script.
  • No menu do painel (no canto superior direito do painel Ações), selecione Formato automático.
  • Pressione Control+Shift+F (Windows) ou Command+Shift+F (Macintosh).
  • Na janela Script, selecione Ferramentas > Formato automático.

Usar mapeamento de fontes dinâmicas

  1. Para ativar ou desativar o mapeamento dinâmico de fontes, marque ou desmarque Mapeamento dinâmico de fontes na caixa de diálogo Preferências.

    O mapeamento dinâmico de fontes é desativado por padrão, pois esse recurso aumenta o tempo de desempenho quando você está trabalhando com scripts. Se você está trabalhando com texto multilíngue, ative o mapeamento dinâmico de fontes, pois este recurso ajuda a garantir que sejam usadas as fontes corretas.

Usar recuo automático

  1. Para ativar ou desativar o recuo automático, marque ou desmarque o Recuo automático na caixa de diálogo Preferências.

    Quando o recuo automático está ativado, o texto digitado após um parêntese de abertura "(" ou uma chave de abertura "{" é automaticamente recuado de acordo com a configuração do Tamanho da tabulação nas preferências do ActionScript.

    Em seus scripts, você pode recuar uma linha selecionando-a e pressionando Tab. Para remover o recuo, selecione a linha e pressione Shift+Tab.

Comentar seções do código

Os comentários de código são partes do código que o compilador do ActionScript ignora. Uma linha de comentário explica o que seu código está fazendo, ou desativa temporariamente algum código que você não quer excluir. Comente uma linha de código iniciando-o com barras duplas (//). O compilador ignora todo o texto nessa linha após as barras duplas. Você também pode comentar blocos maiores de código colocando uma barra e um asterisco (/*) no início do bloco e um asterisco e uma barra (*/) no final do bloco.

Você pode digitar estes marcadores de comentário manualmente, ou pode usar botões na parte superior do painel Ações ou da janela Script para adicioná-los.

Comentar uma linha de código

  1. Posicione o ponto de inserção no início da linha ou no caractere onde você quer que o comentário inicie.
  2. Clique com o botão direito do mouse e escolha Comentário. Você também pode usar os atalhos de teclado Ctrl + M (Windows) ou Comando + M ou vá para Editar > Comentar seleção.

Barras duplas (//) são colocadas no ponto de inserção.

Comentar várias linhas de código

  1. Selecione as linhas a serem comentadas. (A primeira e a última linha da seleção podem ser linhas parciais.)
  2. Clique com o botão direito do mouse e escolha Comentário. Você também pode usar os atalhos de teclado Ctrl + M (Windows) ou Comando + M ou vá para Editar > Comentar seleção.

Os caracteres de comentário de bloco são colocados no início (/*) e no final (*/) da seleção.

Observação:

Se houver comentários entre as linhas de texto selecionadas, uma linha de comentário será aplicada em todas as linhas selecionadas.

Remover um comentário

  1. Posicione o ponto de inserção na linha que contém o comentário, ou selecione o bloco de código que está comentado.
  2. Clique com o botão direito do mouse e selecione Retirar comentário. Você também pode usar os atalhos de teclado Ctrl + Shift + M (Windows) ou Comando + Shift + M ou vá para Editar > Retirar comentário da seleção.

Usar atribuição de cores à sintaxe

No ActionScript, como em qualquer linguagem, a sintaxe é o modo como os elementos são agrupados para criar um significado. Se você usar a sintaxe incorreta do ActionScript, seus scripts não funcionarão.

Para destacar erros de sintaxe, defina um código de cor para as partes de seus scripts. Por exemplo, suponha que você configurou a preferência da atribuição de cores à sintaxe para que as palavras-chave apareçam em azul. Quando você digita var, a palavra var aparece em azul. No entanto, se você digita por engano vae, a palavra vae permanece em preto, o que mostra que você cometeu um erro de digitação.

Siga um destes procedimentos:

  • Selecione Editar > Preferências (Windows) ou Animate > Preferências (Macintosh), clique em Editor de código na lista Categoria e especifique as configurações da Atribuição de cores à sintaxe.

  • Com o ponto de inserção no painel Script, pressione Control-U (Windows) ou Command-U (Macintosh).

Observação:

Quando você grava scripts no painel Ações, os comandos que não são suportados pela versão do player que você está objetivando aparecem em amarelo na caixa de ferramentas de ações. Por exemplo, se a versão do arquivo SWF do Flash Player está configurada para Flash 7, o código ActionScript que só seja suportado pelo Flash Player 8 aparece em amarelo na caixa de ferramentas de ações.

Uso do identificador e a lista de palavra-chave no tempo de execução

Ao iniciar o Animate, o identificador e as listas de palavra-chave são lidos do arquivo de recurso e em cache. Além de ler as listas de padrão do recurso, também faz a verificação de palavras-chave adicionais e lista de identificador na pasta Preferência. É possível adicionar palavras-chave e identificadores adicionais, acrescentando "arquivos .txt" nas seguintes pastas:

  • C:\Users\<Username>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptKeywords]\

  • C:\Users\<UserName>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptIdentifiers]\

  • C:\Users\<UserName>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptKeywords]\

  • C:\Users\<UserName>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptIdentifiers]\

Usar números de linha e quebra de texto

Quando você edita ou modifica um código, os números de linha tornam o código mais fácil de ser rolado e analisado. A quebra de texto ajuda a evitar a rolagem horizontal de longas linhas de código (especialmente quando você trabalha no ambiente de autoria, ou em resoluções baixas de tela).

Ativar ou desativar números de linha

  • Na janela Script, selecione Exibir > Números de linha.
  • Pressione Control+Shift+L (Windows) ou Command+Shift+L (Macintosh).

Destacar uma linha específica

  • Na janela Script, selecione Editar > Ir para linha.

Ativar ou desativar a quebra de texto

  • Na janela Script, selecione Exibir > Quebra de texto.
  • Pressione Control+Shift+W (Windows) ou Command+Shift+W (Macintosh).

Exibir caracteres ocultos

Caracteres como espaços, tabulações e quebras de linha são ocultos no código ActionScript. Você pode precisar exibir esses caracteres. Por exemplo, você tem de localizar e remover espaços duplos que não fazem parte do valor de uma string, pois esses espaços causam erros no compilador.

  • Pressione Control+Shift+8 (Windows) ou Command+Shift+8 (Macintosh).

Os símbolos a seguir são usados para exibir caracteres ocultos.

Caractere oculto

Símbolo

Espaço único

.

Espaço duplo

l

Tab

>>

quebra de linha


Como localizar texto em um script

A ferramenta Localizar permite que você localize e substitua strings de texto em seus scripts.

Observação:

Para pesquisar o texto em cada script em um documento do Animate, use o Explorador de filmes.

Localizar texto

  1. No painel Ações ou na janela Script, clique em Localizar  ou pressione Control+F (Windows) ou Command+F (Macintosh).
  2. Informe a string de pesquisa.
  3. Clique em Localizar próxima.

Localizar e substituir texto em um script

  1. No painel Ações ou na janela Script, clique em Localizar  ou pressione Control+F (Windows) ou Command+F (Macintosh).
  2. Informe a string de pesquisa.
  3. Na caixa Substituir, informe a nova string.
  4. Clique em Localizar próxima.
  5. Para substituir a string, clique em Substituir; para substituir todas as ocorrências da string, clique em Substituir tudo.

(Descontinuado com o Animate) Repetir uma pesquisa no painel Ações

  1. No menu do painel  (no canto superior direito do painel Ações), selecione Localizar novamente.

(Descontinuado com o Animate) Repetir uma pesquisa no painel Script

  1. Selecione Editar > Localizar novamente.

(Descontinuado com o Animate ) Verificar sintaxe e pontuação

Você pode fazer uma rápida verificação de seu código ActionScript sem publicar o arquivo FLA.

Quando você verifica a sintaxe, o script atual é verificado. Se o script atual chamar as classes ActionScript, elas também serão selecionadas. Outros scripts que possam estar no arquivo FLA não serão verificados.

Para os arquivos ActionScript 2.0, Verificar Syntax executa o código por meio do compilador, gerando erros de sintaxe e compilador.

Para os arquivos do ActionScript 3.0, o Verificar Syntax gera apenas os erros de sintaxe. Para gerar os erros do compilador, tais como incompatibilidade de tipos, valores de retorno inadequados e erros ortográficos de nome de método ou variável, você deverá usar o comando Controlar > Testar.

Verificar sintaxe

Para verificar a sintaxe, execute um dos seguintes procedimentos:

  • No painel Ações ou na janela Script, clique em Verificar sintaxe .
  • Clique no painel Script e, depois, pressione Control+T (Windows) ou Command+T (Macintosh). Clicar ou digitar no painel Script traz o foco para ele. Se o foco estiver em um objeto no Palco, o painel Transformar se abre em vez dele.

Os erros de sintaxe são listados no painel Erros do compilador.

Observação:

Em um arquivo externo de classe do ActionScript na janela Script, o caminho da classe global (AS2) ou de origem (AS3) afeta a verificação da sintaxe. Mesmo que o caminho da classe global ou o caminho de origem esteja definido corretamente, erros poderão ser gerados, pois o compilador não tem conhecimento de que essa classe esteja sendo compilada.

Verificar equilíbrio da pontuação

  1. Clique entre chaves {}, colchetes [] ou parênteses () em seu script.
  2. No Windows, pressione Control+' (aspa simples); no Macintosh, pressione Command+' (aspa simples). O texto entre chaves, colchetes ou parênteses é destacado, e você pode verificar se a pontuação de abertura tem uma pontuação de fechamento correspondente.

(Descontinuado com o Animate) Importar e exportar scripts

Você pode importar um script para o painel Ações ou a janela Script. Você também pode exportar seus scripts do painel Ações para os arquivos externos do ActionScript. (Quando você usa a janela Script, a exportação é desnecessária pois, em vez disso, você pode salvar o arquivo AS.)

Se o texto em seus scripts não tiver a aparência esperada quando você abrir ou importar um arquivo, altere a preferência de codificação de importação.

Importar um arquivo AS externo

  1. No painel Script, posicione o ponto de inserção onde você deseja que fique localizada a primeira linha do script externo.
  2. Siga um destes procedimentos:
    • No menu do painel Ações, selecione Importar script, ou pressione Control+Shift+I (Windows) ou Command+Shift+I (Macintosh).

    • Na janela Script, selecione Arquivo > Importar script ou pressione Control+Shift+I (Windows) ou Command+Shift+I (Macintosh).

Exportar um script do painel Ações

  1. Selecione o script a ser exportado. Depois, no menu do painel Ações, selecione Exportar script, ou pressione Control+Shift+X (Windows) ou Command+Shift+X (Macintosh).
  2. Salve o arquivo do ActionScript (AS).

Configurar opções de codificação de texto

  1. Selecione Editar > Preferências (Windows) ou Animate> Preferências (Macintosh) e, depois, selecione ActionScript na lista Categoria.

  2. Defina as opções desejadas:

    Abrir/importar

    Selecione Codificação UTF-8 para abrir ou importar usando a codificação Unicode, ou selecione Codificação padrão para abrir ou importar usando a forma de codificação do idioma atualmente em uso pelo seu sistema.

    Salvar/exportar

    Selecione Codificação UTF-8 para salvar ou exportar usando a codificação Unicode, ou selecione Codificação padrão para salvar ou exportar usando a forma de codificação do idioma atualmente em uso pelo seu sistema.

Ativar ou desativar o aviso de codificação de exportação

  1. Selecione Editar > Preferências (Windows) ou Animate> Preferências (Macintosh) e, depois, selecione Avisos na lista Categoria.

  2. Marque ou desmarque Avisar sobre conflitos de codificação ao exportar arquivos ActionScript.

(Descontinuado com o Animate) Codificação de scripts importados e exportados

Você pode configurar as preferências do ActionScript para especificar o tipo de codificação a ser usado com arquivos do ActionScript importados e exportados. A Codificação UTF-8 é o formato Unicode de 8 bits, que permite incluir texto em vários idiomas em seu arquivo. A Codificação padrão é a codificação suportada pelo idioma que seu sistema está usando no momento, também chamada de página de código tradicional.

Observação:

Quando você usa um aplicativo que não está no idioma inglês em um sistema em inglês, ocorre uma falha no comando Testar filme se qualquer parte do caminho do arquivo SWF tiver caracteres que não possam ser representados por meio do uso do esquema de codificação Multibyte Character Sets (MBCS, conjuntos de caracteres de multibytes). Por exemplo, caminhos em japonês, que funcionam em um sistema em japonês, não funcionam em um sistema em inglês. Certifique-se de usar nomes de caminhos somente em inglês nos sistemas em inglês. Todas as áreas do aplicativo que usam o player Testar filme estão sujeitas a essa limitação.

Fixar scripts no painel Ações

Use o recurso Fixar script para fixar guias dos scripts individuais no painel Script e movê-los como quiser. Esse recurso é útil se você ainda não organizou o código em seu arquivo FLA em um local central ou se você está usando vários scripts.

Você pode fixar um script para manter o local do código no painel Ações e alternar entre vários scripts abertos. Isso pode ser especialmente útil em depurações. 

Você também pode desafixar um script ou todos para desafixar um script selecionado ou todos os scripts do painel Ações.

Na figura a seguir, o script associado ao local atual na linha do tempo está no Quadro 1 da camada denominada Limpar. (A guia na extremidade esquerda sempre segue o seu local ao longo da linha do tempo.) O script também está fixado conforme exemplificado na guia à extrema direita. Estes dois scripts estão fixados:

  • No quadro 1 
  • No quadro 15 da camada Introdução

Use atalhos do teclado ou clique nas guias para alternar entre os scripts fixados. Mover pelos scripts fixados não altera sua posição atual na linha do tempo. Se um novo script é selecionado no navegador do Action Script, o foco se move para o primeiro quadro, ou seja: o Quadro 1.

Observação:

Se o conteúdo no painel Script não for alterado para refletir o local selecionado na linha do tempo então ele estará exibindo um script fixado. Clique na guia do quadro atual no canto superior esquerdo do painel Script para mostrar o script associado ao seu local ao longo da linha de tempo.

as_pin_scripts
Um script fixado

Fixar um script

  1. Clique na Linha do tempopara que o script seja exibido na guia do quadro atual no canto superior esquerdo do painel Script no painel Ações .

  2. Siga um destes procedimentos:
    • Clique no ícone de tachinha à direita da guia.
    • Selecione Exibir> Fixar script para fixar o script.

     

Desafixar todos os scripts

  1. Selecione o script fixado no painel Ações.

  2. Selecione Exibir> Desafixar script para desafixar o script selecionado no painel Ações.

  3. Selecione Exibir> Desafixar todos os scripts para desafixar todos os scripts do painel Ações.

pinscript4
Opções de desafixar

Atalhos de teclado para scripts fixados

Quando o ponto de inserção está no painel Script, use os seguintes atalhos de teclado para trabalhar com scripts fixados.

Ação

Windows 

Macintosh

Fixar script

Control+Shift+= (sinal de igual)

Command+Shift+=

Desafixar script

Control+Shift+- (sinal de menos)

Command+Shift+-

Inserir caminhos de destino

Muitas ações de scripts se destinam a afetar clipes de filme, botões e outras ocorrências de símbolos. Em seu código, você pode fazer referência a ocorrências de símbolos em uma linha do tempo inserindo um caminho de destino — o endereço da ocorrência que você deseja atingir. Você pode configurar um caminho de destino absoluto ou relativo. Um caminho absoluto contém o endereço completo da ocorrência. Um caminho relativo contém somente a parte do endereço que é diferente do endereço do próprio script no arquivo FLA e não funcionará mais se o script for movido para outro local.

  1. No painel Ações, clique em uma ação em seu script.
  2. Clique em Caminho de destino .
  3. Informe o caminho para a ocorrência de destino, ou selecione o destino na lista.
  4. Selecione a opção de caminho Absoluto ou Relativo.

Usar referências de código

Quando você trabalha no painel Ações ou na janela Script, o software pode detectar que ação você está informando e exibe uma referência de código. Há dois tipos de referências de código: uma dica de ferramenta que contém a sintaxe completa para essa ação, e um menu pop-up que lista os elementos possíveis do ActionScript, tais como nomes de métodos ou de propriedades, às vezes referidos como uma forma de conclusão de código.

As referências de código são ativadas por padrão. Ao definir as preferências, você pode desativar as referências de código para determinar a rapidez com que aparecem. Quando as referências de código estão desativadas nas preferências, você ainda pode exibir manualmente uma referência de código para um comando específico.

Observação:

Se você não puder exibir referências de código para uma variável ou um objeto criado no ActionScript 2.0, mas as referências de código estiverem ativadas nas preferências do ActionScript, certifique-se de que nomeou a variável ou o objeto com o sufixo apropriado ou que usou uma digitação estrita para a variável ou o objeto.

Ativação das referências de código

Você pode disparar referências de código de várias formas.

Digitação estrita para objetos

Quando você usa o ActionScript 2.0 e usa a digitação estrita para uma variável que está baseada em uma classe incorporada (como Button, Array etc.), o painel Script exibe as referências de código para a variável. Por exemplo, suponha que você informe as duas linhas de código a seguir:

var foo:Array = new Array(); 
foo.

Assim que você digita o ponto (.), o Animate exibe em um menu pop-up uma lista dos métodos e propriedades disponíveis para os objetos Array (Matriz), pois você digitou a variável como Array (Matriz).

Sufixos e referências de código

Se você usa o ActionScript 1.0 ou deseja exibir as referências de código para objetos sem digitá-las estritamente, adicione um sufixo ao nome de cada objeto quando você criá-lo. Por exemplo, o sufixo que dispara a referência de código para a classe Camera é _cam. Suponha que você digita o seguinte código: var my_array = new Array(); var my_cam = Camera.get();

Se você informa, então, my_cam seguido de um ponto, as referências de código para o objeto Camera aparecem.

Para os objetos que aparecem no Palco, use o sufixo na caixa Nome da ocorrência no Inspetor de propriedades. Por exemplo, para exibir referências de código para objetos MovieClip, use o Inspetor de propriedades para atribuir nomes de ocorrências ao sufixo _mc a todos os objetos MovieClip. Depois disso, sempre que você digitar o nome da ocorrência seguido de um ponto, a referência de código aparecerá.

var my_array = new Array(); 
var my_cam = Camera.get();

Observação:

Embora os sufixos não sejam obrigatórios para o disparo de referências de código quando você usa a digitação estrita para um objeto, o uso de sufixos ajuda consistentemente a tornar seu código compreensível.

A tabela a seguir lista os sufixos que disparam referências de código no ActionScript 2.0:

Tipo de objeto

Sufixo da variável

Array

_array

Botão

_btn

Câmera

_cam

Cor

_cor

ContextMenu

_cm

ContextMenuItem

_cmi

Data

_date

Erro

_err

LoadVars

_lv

LocalConnection

_lc

Microphone

_mic

MovieClip

_mc

MovieClipLoader

_mcl

PrintJob

_pj

NetConnection

_nc

NetStream

_ns

SharedObject

_so

Sound

_som

String

_str

TextField

_txt

TextFormat

_fmt

Vídeo

_vídeo

XML

_xml

XMLNode

_xmlnode

XMLSocket

_xmlsocket

Comentários e referências de código

Você também pode usar os comentários do ActionScript para especificar uma classe de objeto para as referências de código. No exemplo a seguir, um comentário informa ao ActionScript que a classe da ocorrência theObject é Object, e assim em diante.

// Object theObject;// Array theArray;// MovieClip theMC;

Se você informar subsequentemente theMC seguido de um ponto, serão exibidas as referências de código para métodos e propriedades de MovieClip. Se você informar theArray seguido de um ponto, serão exibidas as referências de código para métodos e propriedades de Array, e assim por diante.

No entanto, em vez dessa técnica, a Adobe recomenda que você use a digitação de dados estritos ou os sufixos, pois essas técnicas ativam automaticamente as referências de código e tornam seu código mais compreensível.

Especificar as configurações de preferências para as referências de código

  • No painel Ações ou na janela Script, selecione Editar > Preferências (Windows) ou Animate > Preferências (Macintosh), clique em Editor de código na lista Categoria e, depois, ative ou desative as Referências de código.

(Descontinuado com o Animate) Especificar um atraso para referências de código

  1. No painel Ações ou na janela Script, selecione Editar > Preferências (Windows) ou Animate > Preferências (Macintosh).

  2. Clique em ActionScript na lista Categoria.
  3. Use o controle deslizante para selecionar um valor para o atraso, em segundos.

Usar referências de código no estilo de dica de ferramenta

  1. Exiba a referência de código digitando um parêntese de abertura “(“ depois de um elemento que requer parênteses (por exemplo, após o nome de um método, um comando como if ou do..while etc.).
    as_code_hint_paren1
    Os parênteses de abertura chamam as referências de códigos

  2. Informe um valor para o parâmetro.

    Para vários parâmetros, separe os valores com vírgulas. Para funções ou instruções, como o loop for, separe os parâmetros com ponto-e-vírgulas.

    Os comandos sobrecarregados (funções ou métodos que podem ser chamados com diferentes conjuntos de parâmetros) como gotoAndPlay() ou for exibem um indicador que permite selecionar o parâmetro que você deseja definir. Para selecionar o parâmetro, clique nas setas menores ou pressione Control+seta à esquerda e Control+seta à direita.

    as_code_hint_paren3
    Uma referência de código com vários conjuntos de parâmetros

  3. Para descartar a referência de código, execute um dos seguintes procedimentos:
    • Digite um parêntese de fechamento “)”.

    • Clique fora da instrução.

    • Pressione Escape.

Usar referências de código no estilo de dica de ferramenta:

  1. Exiba a referência de código digitando um ponto após o nome de uma variável ou de um objeto.
    as_code_hint_dot1
    Referências de código no estilo de dica de ferramenta:

  2. Para navegar pelas referências de código, use as teclas de seta para cima e seta para baixo.
  3. Para selecionar um item no menu, pressione Enter ou Tab, ou clique duas vezes no item.
  4. Para descartar a referência de código, execute um dos seguintes procedimentos:
    • Selecione um dos itens de menu.

    • Clique acima ou abaixo da janela do menu.

    • Digite um parêntese de fechamento “)” se você já tiver digitado um parêntese de abertura “(“.

    • Pressione Escape.

Exibir manualmente uma referência de código

  1. Clique no local de um código onde possam aparecer referências de código, como nos seguintes locais:
    • Após o ponto (.) que se segue a uma instrução ou um comando, onde uma propriedade ou um método deve ser informado

    • Entre parênteses [()] no nome de um método

  2. Siga um destes procedimentos:
    • Para habilitar manualmente Referências de código, selecione Exibir > Mostrar referência de código.

    • Pressione Control+barra de espaço (Windows) ou Command+barra de espaço (Macintosh).

Preenchimento de código de classes personalizadas

Ao criar classes personalizadas do ActionScript 3.0, o Animate analisa as classes e determina os objetos, as propriedades e os métodos incluídos. O Animate pode, então, fornecer preenchimento de código ao programar código que faça referência às classes personalizadas. O preenchimento do código de classes personalizadas é automático para qualquer classe que você vincule a qualquer outro código com o comando import.

O preenchimento de código permite que os desenvolvedores trabalhem mais rapidamente, já que não precisam se lembrar de todos os objetos, métodos e propriedades usados pela classe. Os Designers podem trabalhar com classes que não tenham programado eles mesmos, porque não têm conhecimento em primeira mão de como trabalhar com a classe.

O preenchimento de código inclui o seguinte:

  • Preenchimento de código para referências de classes aninhadas

    A assistência continuada do preenchimento de código é útil quando você grava referências aninhadas.

  • Preenchimento de código para “this”

    Quando você digita “this” no arquivo de classe, obtém o preenchimento de código para essa mesma classe.

  • Preenchimento de código para “new+<space>”

    Ao digitar “new+<space>”, o Animate exibe uma lista de classes e pacotes disponíveis.

  • Preenchimento de código para “import”

    Ao digitar “import + <space>”, o Animate exibe uma lista de todos os pacotes incorporados e personalizados.

  • Preenchimento de código para bibliotecas SWC

    Ao adicionar uma biblioteca SWC ao caminho de biblioteca ou ao caminho de biblioteca externa, o Animate ativa o preenchimento de código para todas as classes incluídas no arquivo SWC.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online