Guia do Usuário Cancelar

Trabalhar com manipulação de caracteres no Animate

  1. Guia do Usuário do Adobe Animate
  2. Introdução ao Animate
    1. Novidades no Animate
    2. Glossário visual
    3. Requisitos de sistema do Animate
    4. Atalhos de teclado do Animate
    5. Trabalhar com vários tipos de arquivo no Animate
  3. Animação
    1. Noções básicas de animação no Animate
    2. Como usar quadros e quadros-chave no Animate
    3. Animação quadro a quadro no Animate
    4. Como trabalhar com animação de interpolação clássica no Animate
    5. Ferramenta Pincel
    6. Guia de movimento
    7. Interpolação de movimento e ActionScript 3.0
    8. Sobre a animação com interpolação de movimento
    9. Animações de interpolação de movimento
    10. Criação de uma animação de interpolação de movimento
    11. Utilização dos quadros-chave de propriedade
    12. Animação de posição com uma interpolação
    13. Editar interpolações de movimento usando o Motion Editor
    14. Edição do caminho de movimento de uma animação de interpolação
    15. Manipulação de interpolações de movimento
    16. Adição de atenuações personalizadas
    17. Criação e aplicação das predefinições de movimento
    18. Configuração de extensões de interpolação de animação
    19. Trabalhar com interpolações de movimento salvas como arquivos XML
    20. Interpolações de movimento e interpolações clássicas
    21. Interpolação de formas
    22. Uso da animação da ferramenta Bone no Animate
    23. Trabalhar com manipulação de caracteres no Animate
    24. Como usar camadas de máscara no Adobe Animate
    25. Como trabalhar com cenas no Animate
  4. Interatividade
    1. Como criar botões com o Animate
    2. Converter projetos do Animate em outros formatos de tipo de documento
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Adicionar interatividade com snippets de código no Animate
    5. Criar componentes HTML5 personalizados
    6. Uso de componentes do HTML5 Canvas
    7. Criação de componentes personalizados: exemplos
    8. Snippets de código para componentes personalizados
    9. Práticas recomendadas - Publicidade com o Animate
    10. Criação e publicação de Realidade virtual
  5. Fluxo de trabalho e espaço de trabalho
    1. Criação e gerenciamento de pincéis
    2. Uso de Google Fonts em documentos HTML5 Canvas
    3. Uso das Bibliotecas da Creative Cloud e do Adobe Animate
    4. Uso dos painéis Palco e Ferramentas do Animate
    5. Fluxo e espaço de trabalho do Animate
    6. Uso de fontes da Web em documentos HTML5 Canvas
    7. Linhas de tempo e ActionScript
    8. Trabalhar com múltiplas linhas de tempo
    9. Definir preferências
    10. Uso de painéis de criação do Animate
    11. Criar camadas na linha do tempo com o Animate
    12. Exportar animações para aplicativos móveis e mecanismos de jogo
    13. Mover e copiar objetos
    14. Modelos
    15. Localização e substituição no Animate
    16. Desfazer, refazer e o painel de Histórico
    17. Atalhos de teclado
    18. Como usar a linha do tempo no Animate
    19. Criação de extensões HTML
    20. Opções de otimização para imagens e GIFs animados
    21. Configurações de exportação para imagens e GIFs
    22. Painel Ativos no Animate
  6. Multimídia e vídeo
    1. Transformação e combinação de objetos gráficos no Animate
    2. Criar e trabalhar com instâncias do símbolo no Animate
    3. Traçado de imagem
    4. Como usar som no Adobe Animate
    5. Exportação de arquivos SVG
    6. Criação de arquivos de vídeo para uso no Animate
    7. Como adicionar vídeos no Animate
    8. Trabalhar com pontos de sinalização de vídeo
    9. Desenhar e criar objetos com o Animate
    10. Remodelação de linhas e formas
    11. Traçados, preenchimentos e gradientes com o Animate CC
    12. Trabalhar com o Adobe Premiere Pro e o After Effects
    13. Painéis de cor no Animate CC
    14. Abrir arquivos do Flash CS6 com o Animate
    15. Trabalho com texto clássico no Animate
    16. Aplicação de ilustração final no Animate
    17. Bitmaps importados no Animate
    18. Gráficos em 3D
    19. Trabalhar com símbolos no Animate
    20. Desenhar linhas e formas com o Adobe Animate
    21. Trabalho com bibliotecas no Animate
    22. Exportação de sons
    23. Seleção de objetos no Animate CC
    24. Trabalho com arquivos AI do Illustrator no Animate
    25. Aplicação de padrões com a ferramenta Pincel de borrifar
    26. Aplicação de modos de mesclagem
    27. Organização de objetos
    28. Automação de tarefas com o menu Comandos
    29. Texto multilíngue
    30. Uso de câmera no Animate
    31. Uso do Animate com o Adobe Scout
    32. Trabalhar com arquivos Fireworks
    33. Filtros gráficos
    34. Som e ActionScript
    35. Preferências de desenho
    36. Desenho com a ferramenta Caneta
  7. Plataformas
    1. Converter projetos do Animate em outros formatos de tipo de documento
    2. Suporte da plataforma personalizada
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Criação e publicação de um documento WebGL
    5. Compactação de aplicativos no AIR para iOS
    6. Publicação de AIR em aplicativos Android
    7. Publicação no Adobe AIR para desktop
    8. Configurações de publicação do ActionScript
    9. Práticas recomendadas - Organização do ActionScript em um aplicativo
    10. Como usar ActionScript com o Animate
    11. Práticas recomendadas - Diretrizes de acessibilidade
    12. Acessibilidade no espaço de trabalho do Animate
    13. Programação e gerenciamento de scripts
    14. Ativação do suporte para plataformas personalizadas
    15. Visão geral do suporte da plataforma personalizada
    16. Criação de conteúdo acessível
    17. Trabalhar com plug-ins personalizados de suporte da plataforma
    18. Depuração do ActionScript 3.0
    19. Ativação do suporte para plataformas personalizadas
  8. Publicação e exportação
    1. Exportação de arquivos do Animate CC
    2. Publicação OAM
    3. Exportação de arquivos SVG
    4. Exportar gráficos e vídeos com o Animate
    5. Publicação de documentos AS3
    6. Exportar animações para aplicativos móveis e mecanismos de jogo
    7. Exportação de sons
    8. Exportação de arquivos de vídeo QuickTime
    9. Controle de reprodução de vídeo externo com o ActionScript
    10. Práticas recomendadas - Dicas para a criação de conteúdo em dispositivos móveis
    11. Práticas recomendadas - Convenções de vídeo
    12. Práticas recomendadas - Diretrizes de criação de aplicativos SWF
    13. Práticas recomendadas - Estruturação de arquivos FLA
    14. Práticas recomendadas para otimizar arquivos FLA para o Animate
    15. Configurações de publicação do ActionScript
    16. Especificar configurações de publicação para o Animate
    17. Exportação de arquivos projetores
    18. Exportar imagens e GIFs animados
    19. Modelos de publicação HTML
    20. Trabalhar com o Adobe Premiere Pro e o After Effects
    21. Compartilhar e publicar animações rapidamente

Saiba como editar caracteres usando equipamentos no Animate.

Manipulação moderna

A manipulação moderna é a nova maneira de configurar rapidamente um equipamento usando a ferramenta Distorção de ativo, girar os bones ou deformar as junções para criar poses e aplicar uma interpolação clássica para criar automaticamente os intermediários e formar uma animação suave.

Veja a seguir alguns dos recursos ativados no fluxo de trabalho Manipulação moderna:

  • Capacidade de criar bones rígidos e macios usando a ferramenta Distorção de ativo
  • Capacidade de alterar o tipo de bone de rígido para macio e vice-versa
  • Capacidade de alterar a densidade da malha para ter equilíbrio entre a qualidade e o desempenho de distorção
  • Capacidade de adicionar/remover o pino sem quebrar a interpolação
  • Capacidade de congelar junções
  • Capacidade de girar o bone ou especificar o ângulo desejado para o bone selecionado no painel Propriedades
  • Guia Ferramenta dedicada no painel Propriedades da ferramenta Distorção de ativo
  • Opção para ativar/desativar a propagação de pinos em quadros-chave e muito mais

Criação de equipamento

Etapas para criar um equipamento:

  • Você deve selecionar uma forma ou bitmap no palco para manipulação.
  • A Ferramenta distorção de ativo no painel de ferramentas como destacado na imagem pode ser usada para manipulação.
rig_creation_1

  • Com a Ferramenta distorção de ativo, clique na parte da forma ou do bitmap para adicionar a primeira junção. Observe que ela cria uma malha triangulada e adiciona uma junção ao local onde você clicou
rig_creation_2

  • Clicar para adicionar uma junção também adiciona o bone da junção previamente selecionada à junção adicionada recentemente. Conforme mostrado na imagem, consulte a seção “Opções de distorção” na guia “Ferramenta” do Inspetor de propriedades quando a ferramenta de distorção de ativo é selecionada. Aqui, a opção “criar bones” está ativada por padrão e garante que um bone seja adicionado à nova junção a partir da junção selecionada anteriormente. Se a opção “criar bones” estiver desativada ou nenhuma das junções for selecionada, a junção adicionada recentemente não adicionará nenhum bone.
rig_creation_3

  • Antes de adicionar qualquer nova junção, verifique se uma junção apropriada está selecionada a partir da qual o bone deve ser adicionado à nova junção.
rig_creation_4

  • Conclua o equipamento adicionando todos os bones necessários
modify_rig_1


Modificar o equipamento e a interpolação

Deformação

Com a Ferramenta distorção de ativo, a função arrastar a junção pode ser usada para deformar a malha. 

modify_rig_1

Além disso, você pode clicar e arrastar o bone para girá-lo. Ao arrastar, o tamanho do bone não é alterado como acontece ao arrastar uma junção.

modify_rig_2

Trabalhar com quadros-chave

Os quadros-chave na linha do tempo podem ser usados para criar poses diferentes. Adicione um novo quadro-chave e deformação usando uma junção/bone. Cada quadro-chave terá sua própria pose definida. Quando a pose é criada, as transformações também podem ser aplicadas, como mover o objeto, dimensionar, girar etc. A imagem a seguir mostra 3 poses diferentes em 3 quadros-chave exibidos usando o modo “Editar vários quadros”.

Interpolação clássica para interpolação

Após a criação de poses, a interpolação clássica pode ser criada em intervalos de quadros para criar uma animação suave com base nas poses criadas em quadros-chave. A imagem a seguir captura “transparências” entre poses para mostrar como a animação suave pode ser feita usando a interpolação clássica.

modify_rig_4

Adicionar/remover junções

Após a configuração de pose entre quadros-chave, se for necessário fazer alterações no equipamento adicionando/removendo junções ou bones, o Animate aplica automaticamente a alteração correspondente em todos os quadros-chave. Portanto, não é necessário alternar manualmente para cada quadro-chave para alterar um equipamento.

Uma junção pode ser removida ao selecionar primeiro uma junção clicando nela e pressionando a tecla Delete. Todos os bones que se conectam a essa junção também são removidos automaticamente. Caso queira excluir somente o bone, mas não a junção conectada a ele, selecione o bone e pressione a tecla Delete.

modify_rig_5

modify_rig_6

modify_rig_7


Recursos aprimorados

Bones suaves

Os bones suaves são úteis para obter um curvatura mais suave para a malha subjacente durante a deformação. Por padrão, todos os bones são rígidos. Para usar o bone suave, selecione o bone e altere a propriedade “Tipo de bone” na seção “Opções de distorção” na guia “Objeto” do Inspetor de propriedades para transformá-lo em um bone suave.

soft_bones

Congelar junções

A funcionalidade “Congelar junção” é muito útil na manipulação. As junções congeladas não se movem quando outra parte do equipamento é movida. Para converter qualquer junção em uma junção congelada, selecione a junção e altere a propriedade “Congelar junção” na seção “Opções de distorção” na guia “Objeto” do Inspetor de propriedades.

fixed_j0ints

A imagem a seguir mostra o exemplo de deformação obtida apenas movendo a junção raiz para baixo. As outras junções não se movem porque estão congeladas juntas.

fixed_joints_1


Fluxos de trabalho adicionais e atalhos

Veja a seguir alguns dos fluxos de trabalho adicionais e atalhos que são úteis ao criar equipamentos.

Girar bone

Há duas maneiras de girar o bone sem alterar seu tamanho. Conforme descrito anteriormente, selecione o bone e arraste-o para girá-lo. Outro fluxo de trabalho é selecionar o bone (ou a junção na extremidade do bone) e alterar precisamente o valor de rotação usando a propriedade de texto ativo “Ângulo de rotação” na seção “Opções de distorção” na guia “Objeto” no Inspetor de propriedades

rotte_bones

Densidade da malha

Há uma caixa de seleção na seção “Opções de distorção” na guia Ferramentas e Objeto do Inspetor de propriedades para ativar/desativar a exibição no palco da malha triangulada. Além disso, a densidade da malha pode ser modificada usando o controle deslizante mostrado na imagem abaixo. A densidade de malha mais alta fornece deformações mais suaves, mas resulta em mais eficiência ao trabalhar com vários quadros-chave. Por outro lado, a densidade de malha mais baixa resulta em melhor desempenho em detrimento da qualidade da deformação. O Animate calcula automaticamente a densidade da malha para o caractere distorcido para obter o equilíbrio entre qualidade e desempenho. No entanto, é possível alterá-la usando o controle deslizante.

mesh_density

Controle da propagação de alterações

Sempre que as propriedades de junções ou bones forem alteradas (congelar junção, bone suave/rígido, junção aberta/fixa), o Animate garante automaticamente a propagação dessa alteração em todos os quadros-chave. Em alguns casos, você pode não querer que a alteração seja feita em todos os quadros. Por exemplo, você precisa de um bone suave somente em quadros-chave específicos e de um bone rígido em outros quadros-chave. A propriedade “Propagar alterações” na seção “Opções de distorção” na guia “Ferramenta” do Inspetor de propriedades pode ser usada para controlar se você precisa propagar ou não

propagação

Conectar bone entre pontos existentes

Para criar um bone entre as junções existentes, primeiro selecione a junção que deve ser a principal do bone. Agora segure a tecla Alt/Option para modificar e clique em outra junção que deveria estar na extremidade do bone.

Mover a junção sem alterar a deformação

Mover qualquer junção resulta em deformação. Às vezes, depois de criar uma pose deformada, é necessário alterar a posição da junção sem alterar a deformação. Isso pode ser feito mantendo o modificador da tecla Alt/Option ao mover a junção.

Mover somente a junção selecionada (não mover a junção secundária)

Selecione a junção que será movida clicando duas vezes nela. Agora, se você mover essa junção, as outras conectadas a ela usando bones não serão afetadas. Isso serve para desativar temporariamente a cinemática direta.

Novidades?

Nós explicamos como manipular seu caractere. Agora você pode aprender como compartilhar sua animação em redes sociais no Animate .

Logotipo da Adobe

Fazer logon em sua conta