Benutzerhandbuch Abbrechen

Erstellen und Veröffentlichen eines WebGL-Dokuments

  1. Adobe Animate-Benutzerhandbuch
  2. Einführung in Animate
    1. Neue Funktionen in Animate
    2. Visuelles Glossar
    3. Systemanforderungen für Animate
    4. Tastaturbefehle für Animate
    5. Mit verschiedenen Dateitypen in Animate arbeiten
  3. Animation
    1. Grundlagen von Animationen in Animate
    2. So verwenden Sie Bilder und Schlüsselbilder in Animate
    3. Einzelbildanimation in Animate
    4. So arbeiten Sie in Animate mit klassischen Tween-Animationen
    5. Pinselwerkzeug
    6. Bewegungsführung
    7. Bewegungs-Tweens und ActionScript 3.0
    8. Bewegungs-Tween-Animationen
    9. Bewegungs-Tween-Animationen
    10. Erstellen von Bewegungs-Tween-Animationen
    11. Verwenden von Eigenschaftenschlüsselbildern
    12. Animieren der Position mithilfe eines Tweens
    13. So bearbeiten Sie Bewegungs-Tweens mit dem Bewegungs-Editor
    14. Bearbeiten des Bewegungspfades einer Tween-Animation
    15. Manipulieren von Bewegungs-Tweens
    16. Hinzufügen von benutzerdefinierten Beschleunigungen
    17. Erstellen und Anwenden von Bewegungsvoreinstellungen
    18. Einrichten von Animations-Tween-Bereichen
    19. Arbeiten mit als XML-Dateien gespeicherten Bewegungs-Tweens
    20. Vergleich von Bewegungs-Tweens und klassischen Tweens
    21. Form-Tweening
    22. Verwenden von Animation mit dem Bone-Werkzeug in Animate
    23. Arbeiten mit Figuren-Rigging in Animate
    24. So verwenden Sie Maskenebenen in Adobe Animate
    25. So arbeiten Sie in Animate mit Szenen
  4. Interaktivität
    1. So erstellen Sie in Animate Schaltflächen
    2. Konvertieren von Animate-Projekten in andere Dokumenttypen
    3. HTML5 Canvas-Dokumente in Animate erstellen und veröffentlichen
    4. Interaktivität mit Codefragmenten in Animate hinzufügen
    5. Erstellen benutzerdefinierter HTML5-Komponenten
    6. Verwenden von Komponenten in HTML5 Canvas
    7. Erstellen von benutzerdefinierten Komponenten: Beispiele
    8. Codefragmente für benutzerdefinierte Komponenten
    9. Empfohlene Verfahren – Anzeigen mit Animate
    10. Authoring und Veröffentlichen für VR
  5. Arbeitsbereich und Arbeitsablauf
    1. Erstellen und Verwalten von Pinseln
    2. Verwenden von Google Fonts in HTML5 Canvas-Dokumenten
    3. Verwenden von Creative Cloud Libraries in Adobe Animate
    4. Bühne und Bedienfeld „Werkzeuge“ in Animate verwenden
    5. Arbeitsablauf und Arbeitsbereich in Animate
    6. Verwenden von Webschriftarten in HTML5 Canvas-Dokumenten
    7. Zeitleisten und ActionScript
    8. Arbeiten mit mehreren Zeitleisten
    9. Festlegen von Voreinstellungen
    10. Verwenden der Animate-Authoring-Bedienfelder
    11. Zeitleisten-Ebenen in Animate erstellen
    12. Exportieren von Animationen für Apps und Game-Engines
    13. Verschieben und Kopieren von Objekten
    14. Vorlagen
    15. Suchen und Ersetzen in Animate
    16. Rückgängigmachen, Wiederholen und das Bedienfeld „Protokoll“
    17. Tastaturbefehle
    18. So verwenden Sie die Zeitleiste in Animate
    19. Erstellen von HTML-Erweiterungen
    20. Optimierungsoptionen für Bilder und animierte GIF-Dateien
    21. Exporteinstellungen für Bilder und GIF-Dateien
    22. Bedienfeld „Elemente“ in Animate
  6. Multimedia und Video
    1. Transformieren und Kombinieren von Grafikobjekten in Animate
    2. Erstellen von und Arbeiten mit Symbolinstanzen in Animate
    3. Bildnachzeichner
    4. So verwenden Sie Sound in Adobe Animate
    5. Exportieren von SVG-Dateien
    6. Erstellen von Videodateien zur Verwendung in Animate
    7. So fügen Sie in Animate ein Video hinzu
    8. Arbeiten mit Video-Cue-Points
    9. Objekte in Animate zeichnen und erstellen
    10. Umformen von Linien und Formen
    11. Striche, Füllungen und Farbverläufe in Animate CC
    12. Adobe Premiere Pro und After Effects
    13. Farb-Bedienfelder in Animate CC
    14. Öffnen von Flash CS6-Dateien mit Animate
    15. In Animate mit klassischem Text arbeiten
    16. Platzieren von Bildern in Animate
    17. Importierte Bitmaps in Animate
    18. 3D-Grafiken
    19. Arbeiten mit Symbolen in Animate
    20. Zeichnen von Linien und Formen mit Adobe Animate
    21. Mit Bibliotheken in Animate arbeiten
    22. Exportieren von Sounds
    23. Auswählen von Objekten in Animate CC
    24. Arbeiten mit Adobe Illustrator AI-Dateien in Animate
    25. Anwenden von Mustern mit dem Sprühen-Werkzeug
    26. Anwenden von Mischmodi
    27. Anordnen von Objekten
    28. Automatisieren von Aufgaben mit dem Menü „Befehle“
    29. Mehrsprachiger Text
    30. Verwenden der Kamera in Animate
    31. Verwenden von Animate mit Adobe Scout
    32. Arbeiten mit Fireworks-Dateien
    33. Grafikfilter
    34. Sounds und ActionScript
    35. Zeichnungsvoreinstellungen
    36. Zeichnen mit dem Stiftwerkzeug
  7. Plattformen
    1. Konvertieren von Animate-Projekten in andere Dokumenttypen
    2. Unterstützung benutzerdefinierter Plattformen
    3. HTML5 Canvas-Dokumente in Animate erstellen und veröffentlichen
    4. Erstellen und Veröffentlichen eines WebGL-Dokuments
    5. So packen Sie Apps für AIR for iOS:
    6. Veröffentlichen von Apps für AIR for Android
    7. Veröffentlichen für Adobe AIR für den Desktop
    8. ActionScript-Veröffentlichungseinstellungen
    9. Empfohlene Verfahren – Organisieren von ActionScript in einer Anwendung
    10. So verwenden Sie ActionScript mit Animate
    11. Empfohlene Verfahren – Richtlinien für Eingabehilfen
    12. Eingabehilfen für den Animate-Arbeitsbereich
    13. Schreiben und Verwalten von Skripts
    14. Aktivieren der Unterstützung für benutzerdefinierte Plattformen
    15. Unterstützung benutzerdefinierter Plattformen – Übersicht
    16. Erstellen barrierefreier Inhalte
    17. Arbeiten mit Plug-ins zur Unterstützung benutzerdefinierter Plattformen
    18. Debuggen von ActionScript 3.0
    19. Aktivieren der Unterstützung für benutzerdefinierte Plattformen
  8. Exportieren und Veröffentlichen
    1. So exportieren Sie Dateien aus Animate CC
    2. OAM-Veröffentlichung
    3. Exportieren von SVG-Dateien
    4. Exportieren von Grafiken und Videos mit Animate
    5. Veröffentlichen von AS3-Dokumenten
    6. Exportieren von Animationen für Apps und Game-Engines
    7. Exportieren von Sounds
    8. Exportieren von QuickTime-Videodateien
    9. Steuern der Wiedergabe von externen Videos mithilfe von ActionScript
    10. Empfohlene Verfahren – Tipps zum Erstellen von Inhalten für mobile Geräte
    11. Empfohlene Verfahren – Videokonventionen
    12. Empfohlene Verfahren – Authoring-Richtlinien für SWF-Anwendungen
    13. Empfohlene Verfahren – Strukturierung von FLA-Dateien
    14. Empfohlene Verfahren für die Optimierung von FLA-Dateien für Animate
    15. ActionScript-Veröffentlichungseinstellungen
    16. Veröffentlichungseinstellungen für Animate festlegen
    17. Exportieren von Projektor-Dateien
    18. Exportieren von Bildern und animierten GIF-Dateien
    19. HTML-Veröffentlichungsvorlagen
    20. Adobe Premiere Pro und After Effects
    21. Schnelles Teilen und Veröffentlichen Ihrer Animationen

Was ist WebGL?

WebGL ist ein Open-Web-Standard für das Rendern von Grafiken in jedem kompatiblen Browser ohne zusätzliche Plugins. WebGL ist vollständig in alle Webstandards des Browsers integriert, wodurch die GPU-beschleunigte Nutzung von Bildverarbeitung und Effekten im Webseiten-Canvas möglich wird. WebGL-Elemente können in andere HTML-Elemente eingebettet und mit anderen Teilen der Seite zusammengefügt werden.

Die meisten modernen Browser unterstützen WebGL. Unter diesem Link finden Sie weitere Informationen zu den exakten Versionen, die unterstützt werden.

In einigen Browsern ist WebGL nicht standardmäßig aktiviert. Wie Sie WebGL in Ihrem Browser aktivieren, erfahren Sie in diesem Artikel.

 Stellen Sie sicher, dass WebGL in Ihrem Browser aktiviert ist. In einigen Browsern ist es standardmäßig deaktiviert.

Verwenden des Dokumenttyps WebGL-glTF

Animate verfügt nun über zwei WebGL-glTF-Dokumenttypen. Der Dokumenttyp „WebGL-glTF Standard“ ermöglicht eine Integration in alle standardmäßigen WebGL-glTF-Pakete. Er ist vollkommen standardkonform.

  1. Um ein WebGL-glTF-basiertes Dokument zu erstellen, wählen Sie auf der Registerkarte Erweitert des Startbildschirms den Dokumenttyp „WebGL-glTF Standard“ oder „WebGL-glTF Extended“ aus. 

    WebGL-glTF-Dokumenttyp
    WebGL-glTF-Dokumenttyp

  2. Legen Sie Breite, Höhe und Einheiten nach Bedarf fest und klicken Sie auf Erstellen.

Veröffentlichen von WebGL-glTF-Dateien

  1. Klicken Sie im Eigenschafteninspektor auf Veröffentlichungseinstellungen.

    WebGL-glTF-Datei veröffentlichen
    WebGL-glTF-Datei veröffentlichen

  2. Geben Sie einen Namen in das Textfeld Ausgabename ein.

  3. Wählen Sie unter „Format“ die Option GLB oder GLTF.

  4. Legen Sie im Textfeld „Bildauflösung“ eine Dezimalzahl mit einem Bereich von 1 bis 3 fest.

  5. Aktivieren Sie Leerräume in JSON-Datei entfernen, um die Dateigröße zu verringern.

  6. Standardmäßig sind die Optionen Zeitleistenschleife und Ausgeblendete Ebenen einschließen aktiviert. Sie können sie deaktivieren, um kleine Fehler zu finden.

  7. Klicken Sie auf die Schaltfläche Veröffentlichen, um die Datei zu veröffentlichen.

Konvertieren von Animationen ins GLTF- und GLB-Format

Die Formate WebGL-glTF und GLBreduzieren die Dateigröße und die Laufzeit der Verarbeitung. Mit Animate können Sie die Dokumente in beiden Formaten verwenden. Möchten Sie Ihre Videos in beiden Formaten verwenden? Sehen Sie sich einfach das Tutorial am Ende dieses Beispiels an und befolgen Sie die Schritte.

  1. Klicken Sie unter Eigenschaften auf Veröffentlichungseinstellungen.

  2. Geben Sie einen Namen in das Textfeld Ausgabename ein.

  3. Wählen Sie unter „Format“ die Option GLB oder GLTF.

  4. Legen Sie im Textfeld Bildauflösung eine Dezimalzahl mit einem Bereich von bis 3 fest.

  5. Aktivieren Sie Leerräume in JSON-Datei entfernen, um die Dateigröße zu verringern.

Erstellen erweiterter Animationen mit WebGL GLTF-Export in Animate

Sehen Sie sich das Video an, um zu erfahren, wie eine Animation im WebGL GLTF-Format oder im GLB-Format aussieht.

Animate 18.0 und frühere Versionen

Wenn Sie Animate 18.0 oder frühere Animate-Versionen verwenden, finden Sie nachstehend weitere Informationen.

Der Dokumenttyp WebGL

Animate bietet Ihnen die Möglichkeit, attraktive interaktive Inhalte im Web Graphics Library-Format (WebGL) zu erstellen und zu veröffentlichen. Da WebGL voll in Browser integriert ist, kann Animate die GPU-beschleunigte Nutzung von Grafikverarbeitung und -Rendering für das Webseiten-Canvas nutzen.

Mit diesem neuen Dokumenttyp können Sie Inhalte erstellen und schnell als WebGL-Ausgabe veröffentlichen. Sie können leistungsstarke Werkzeuge in Animate nutzen, um attraktive Inhalte zu erstellen und dann WebGL-Ausgaben rendern, die in jedem kompatiblen Browser ausgeführt werden können. Dies bedeutet, dass Sie Zeitleiste, Arbeitsbereich und Zeichenwerkzeuge in Animate wie gewohnt verwenden können, um native WebGL-Inhalte zu erstellen. Die meisten gängigen Browser unterstützen WebGL, weswegen Animate Inhalte in den meisten Web-Plattformen rendern kann.

 Die Unterstützung für WebGL ist nur als Vorschau verfügbar. Dieses Update von Animate bietet Unterstützung für grundlegende Animationen und Skripterstellung sowie eine Reihe von Interaktivitätsfunktionen. Zukünftige Versionen von Animate werden weitere Funktionen für den Dokumenttyp WebGL enthalten. Eine vollständige Liste der Animate-Funktionen, die für WebGL unterstützt werden, finden Sie in diesem KB-Artikel.

Erstellen eines WebGL-Dokuments

In Animate können Sie mit dem WebGL-Dokument schnell Inhalte für das WebGL-Format erstellen und veröffentlichen. So erstellen Sie ein WebGL-Dokument:

  1. Starten Sie Animate.
  2. Klicken Sie auf dem Begrüßungsbildschirm auf die Option WebGL (Vorschau). Wählen Sie alternativ Datei > Neu, um das Dialogfeld Neues Dokument anzuzeigen. Klicken Sie auf die Option WebGL(Vorschau).

Anzeigen einer Vorschau von WebGL-Inhalten in Browsern

Sie können die Funktion „Film testen“ in Animate nutzen, um Ihren Inhalt zu testen bzw. eine Vorschau anzuzeigen. Um eine Vorschau anzuzeigen, gehen Sie wie folgt vor:

  1. Drücken Sie in Animate die Strg- + Eingabetaste (Windows) bzw. die Befehls- + Eingabetaste (Mac). Dadurch wird der Standardbrowser gestartet und der WebGL-Inhalt wird gerendert.
Animate benötigt für das Ausführen von WebGL-Inhalten einen Webserver. Animate verfügt über einen integrierten Webserver, der so konfiguriert ist, dass WebGL-Inhalt an Port 8090 ausgeführt wird. Wenn bereits ein anderer Server diesen Port verwendet, erkennt und löst Animate automatisch den Konflikt.

Veröffentlichen von Inhalten im WebGL-Format

Animate bietet Ihnen die Möglichkeit, native WebGL-Inhalte zu erstellen und zu veröffentlichen.

Um ein WebGL-Dokument zu veröffentlichen, gehen Sie wie folgt vor:

  1. Wählen Sie Datei > Einstellungen für Veröffentlichungen, um das Dialogfeld „Einstellungen für Veröffentlichungen“ anzuzeigen. Alternativ können Sie Datei > Veröffentlichen wählen, wenn Sie bereits Einstellungen für die Veröffentlichung von WebGL ausgewählt haben.
  2. Wählen Sie im Dialogfeld „Einstellungen für Veröffentlichungen“ Werte für folgende Optionen:

Ausgabedatei

Geben Sie einen aussagekräftigen Namen für die Ausgabe an. Wählen Sie außerdem das Verzeichnis, in dem die WebGL-Ausgabe veröffentlicht werden soll.

Überschreiben von HTML

Hier können Sie angeben, ob der HTML-Wrapper bei jeder Veröffentlichung des WebGL-Projekts überschrieben werden soll oder nicht. Sie können diese Option deaktivieren, wenn Sie externe Änderungen an der veröffentlichten HTML-Datei vorgenommen haben und diese beibehalten möchten, während Sie in Animate an der Animation oder an Elementen vorgenommene Änderungen aktualisieren.

Ausgeblendete Ebenen einschließen

Schließt alle ausgeblendeten Ebenen in die WebGL-Ausgabe ein. Wenn Sie die Option „Ausgeblendete Ebenen einschließen“ deaktivieren, wird keine der ausgeblendeten Ebenen (einschließlich der in Filmclips verschachtelten Ebenen), die als ausgeblendet markiert ist, in die WebGL-Datei exportiert. Auf diese Weise können Sie problemlos Versionen von WebGL-Dokumenten testen, indem Sie Ebenen ausblenden.

Zeitleistenschleife

Wiederholt den Inhalt nach Wiedergabe des letzten Bildes. Deaktivieren Sie diese Option, um den Inhalt beim letzten Bild anzuhalten

  1. Klicken Sie auf „Veröffentlichen“, um Ihren WebGL-Inhalt an der gewünschten Position zu veröffentlichen.

 Der maximale BpS-Wert, der für in Browsern ausgeführten WebGL-Inhalt angegeben werden kann, ist 60 BpS.

Die WebGL-Ausgabe

Die veröffentlichte WebGL-Ausgabe enthält die folgenden Dateien:

HTML-Wrapper-Datei

Sie enthält die Laufzeit, ruft Elemente ab und initialisiert den WebGL-Renderer. Die Datei hat standardmäßig den Namen „<FLA_name>.html“. Sie können im Dialogfeld „Einstellungen für Veröffentlichungen“ (Datei > Einstellungen für Veröffentlichungen) einen anderen Namen für die HTML-Datei angeben.

Die HTML-Datei wird standardmäßig im selben Verzeichnis abgelegt wie die FLA-Datei. Sie können im Dialogfeld „Einstellungen für Veröffentlichungen“ ein anderes Verzeichnis angeben.

JavaScript-Datei (WebGL-Laufzeit)

Rendert veröffentlichte Inhalte in WebGL. Wird in der Bibliothek/dem Ordner des WebGL-Dokuments veröffentlicht. Die Datei trägt den Namen: flwebgl-<version>.min.js

Der HTML-Wrapper nutzt diese JS-Datei, um WebGL-Inhalte zu rendern.

Texturatlas

Speichert sämtliche Farbwerte (der Formen) einschließlich der Bitmap-Instanzen auf der Bühne.

Hinzufügen von Audio zu einem WebGL-Dokument

Sie können Audio in ein WebGL-Dokument importieren und es darin einbetten, die Soundwiedergabe mithilfe der Synchronisierungseinstellungen (Ereignis, Start und Stopp) steuern und Audio zur Laufzeit über die Zeitleiste wiedergeben. WebGL unterstützt derzeit nur die Formate .wav und .mp3.

Weitere Informationen zum Arbeiten mit Audio finden Sie unter Verwenden von Sounds in Animate.

Migrieren vorhandener Inhalte in ein WebGL-Dokument

Sie können auch vorhandene Inhalte in Animate in ein WebGL-Dokument migrieren. In Animate können Sie migrieren, indem Sie Inhalt manuell kopieren oder importieren. Wenn Sie in Animate mit mehreren Dokumenten arbeiten, ist es auch üblich, Inhalte zwischen Dokumenten als Ebenen oder Elemente in der Bibliothek zu kopieren. Obwohl die meisten Funktionen von Animate unterstützt werden, werden einige Inhaltstypen angepasst, sodass sie besser für das WebGL-Format geeignet sind.

Animate enthält diverse leistungsstarke Funktionen, mit denen optisch ansprechende Inhalte erstellt werden können. Da es sich bei einigen dieser Funktionen jedoch um native Animate-Funktionen handelt, werden sie in einem WebGL-Dokument nicht unterstützt. Animate wandelt solche Inhalte in ein unterstütztes Format um. Außerdem wird visuell angezeigt, wenn ein Werkzeug oder eine Funktion nicht unterstützt wird.

Kopieren

Inhalt (Ebenen oder Bibliothekssymbole) aus einem herkömmlichen Animate-Dokumenttyp (z. B. ActionScript 3.0, AIR for Android, AIR for Desktop usw.) in ein WebGL-Dokument. In diesem Fall wird ein nicht unterstützter Inhaltstyp entweder entfernt oder so konvertiert, dass er den Standard unterstützt.

Beim Kopieren einer 3D-Animation werden z. B. alle 3D-Transformationen gelöscht, die auf Objekte auf der Bühne angewendet wurden.

Importieren

einer PSD- oder AI-Datei mit nicht unterstütztem Inhalt. In diesem Fall wird der Inhalt entweder entfernt oder so konvertiert, dass er den Standard unterstützt.

Importieren Sie z. B. eine PSD-Datei, auf die Weichzeichnungseffekte angewendet sind. Animate entfernt den Effekt.

Arbeiten

mit mehreren Dokumenttypen (z. B. ActionScript 3.0 und WebGL) gleichzeitig, Sie wechseln zwischen Dokumenten, während ein nicht unterstütztes Werkzeug bzw. eine nicht unterstützte Option ausgewählt ist. In diesem Fall wird in Animate angezeigt, dass die Funktion nicht unterstützt wird.

Sie haben z. B. in einem ActionScript 3.0-Dokument eine gepunktete Linie erstellt und wechseln zu WebGL, während das Linienwerkzeug nach wie vor ausgewählt ist. Beobachten Sie den Mauszeiger und den Eigenschafteninspektor. Dort wird angezeigt, dass die gepunktete Linie in Canvas nicht unterstützt wird.

Skripts

Sie können JavaScript-Code in das Bedienfeld „Aktionen“ schreiben; er wird ausgeführt, nachdem der Player das Bild erreicht hat. Die Variable „this“ im Zusammenhang mit Bildskripts bezieht sich auf die Instanz des MovieClips, zu der sie gehört. Darüber hinaus können die Bildskripts auf JavaScript-Funktionen und Variablen zugreifen, die in der HTML-Containerdatei deklariert wurden. Wenn Sie ein Bild oder eine Ebene aus einem ActionScript-Dokument kopieren und in ein WebGL-Dokument einfügen, werden etwaige vorhandene Skripts kommentiert.

Änderungen, die nach der Migration auf den Inhalt angewendet werden

Im Folgenden finden Sie die Änderungstypen, die angewendet werden, wenn Sie alte Inhalte in ein WebGL-Dokument migrieren.

Inhalt wird entfernt

Inhaltstypen, die in HTML5 Canvas nicht unterstützt werden, werden entfernt. Beispiel:

Filter

werden nicht unterstützt. Der Filter wird entfernt und die Form wird durch eine einfarbige Füllung ersetzt.

Der Effekt „Weichzeichnen“ wird entfernt und durch eine Füllung des Typs „Einfarbig“ ersetzt.

Inhalt wird auf einen unterstützten Standardwert angepasst

Inhaltstyp oder Funktion wird unterstützt, eine Eigenschaft der Funktion jedoch nicht. Beispiel:

 

Radialverlauf

wird in eine einfarbige Füllung in der Primärfarbe angepasst.

„Radialverlauf“ wird in eine einfarbige Füllung in der Primärfarbe angepasst.

Verbessern der Renderleistung mithilfe der Bitmap-Zwischenspeicherung

Mit Bitmap-Zwischenspeicherung zur Laufzeit lässt sich die Renderleistung verbessern, und zwar indem ein statischer MovieClip (z. B. ein Hintergrundbild) oder ein Schaltflächensymbol zur Laufzeit als Bitmap im Cache gespeichert wird. Vektorelemente werden standardmäßig in jedem Bild neu gezeichnet, Durch das Zwischenspeichern eines MovieClips oder eines Schaltflächensymbols als Bitmap wird verhindert, dass der Browser das Element ständig neu zeichnen muss, da das Bild eine Bitmap ist, deren Position sich nicht ändert. Dies ermöglicht eine deutliche Leistungssteigerung beim Rendern von WebGL-Inhalten.

Beispielsweise können Sie bei der Erstellung einer Animation mit einem komplexen Hintergrund einen Movieclip erstellen, der alle Hintergrundelemente enthält. Wählen Sie dann im Eigenschafteninspektor die Option zur Zwischenspeicherung als Bitmap für den Hintergrund-Movieclip aus. Während der Wiedergabe wird der Hintergrund als Bitmap gerendert, die mit der aktuellen Bildschirmtiefe gespeichert ist. Der Browser zeichnet die Bitmap auf der Bühne nur einmal und sehr schnell, wodurch die Animation schneller und reibungsloser abgespielt werden kann.

Mithilfe der Bitmap-Zwischenspeicherung können Sie das aktuelle Erscheinungsbild eines Movieclips festhalten. Wenn sich ein Bereich ändert, wird die Bitmap-Zwischenspeicherung mit Vektordaten aktualisiert. Die Anzahl der Neuzeichnungen, die vom Browser vorgenommen werden müssen, wird dadurch auf ein Minimum reduziert, und das Rendering erfolgt schneller und flüssiger.

Zum Aktivieren der Eigenschaft Als Bitmap zwischenspeichern zu einem MovieClip-Symbol wählen Sie die MovieClip-Instanz und anschließend „Als Bitmap zwischenspeichern“ im Dropdown-Menü „Rendern“ im Eigenschafteninspektor (Fenster > Eigenschaften).

Überlegungen zur Verwendung von „Als Bitmap zwischenspeichern“

Wenn Sie die Eigenschaft „Als Bitmap zwischenspeichern“ auf WebGL-Inhalt anwenden, beachten Sie Folgendes:

  • Die maximale Größe des MovieClip-Symbols ist auf 2048 x 2048 beschränkt. Die tatsächlichen Grenzen der MovieClip-Instanz, die zwischengespeichert werden kann, sind kleiner als 2048 x 2048, da WebGL einige Pixel reserviert.
  • Wenn es mehrere Instanzen desselben MovieClips gibt, generiert Animate den Cache mit der Größe der ersten Instanz. Der Cache wird jedoch nicht neu generiert, und die Eigenschaft „Als Bitmap zwischenspeichern“ wird nicht ignoriert, selbst wenn sich die Transformation des MovieClips stark ändert. Wenn das MovieClip-Symbol nun während der Animation groß skaliert wird, wird die Animation möglicherweise verpixelt angezeigt.

 Adobe

Schneller und einfacher Hilfe erhalten

Neuer Benutzer?