Rückgängigmachen, Wiederholen und das Bedienfeld „Protokoll“

  1. Adobe Animate-Benutzerhandbuch
  2. Einführung in Animate
    1. Neue Funktionen in Animate
    2. Visuelles Glossar
    3. Systemanforderungen für Animate
    4. Tastaturbefehle für Animate
    5. Mit verschiedenen Dateitypen in Animate arbeiten
  3. Animation
    1. Grundlagen von Animationen in Animate
    2. So verwenden Sie Bilder und Schlüsselbilder in Animate
    3. Einzelbildanimation in Animate
    4. So arbeiten Sie in Animate mit klassischen Tween-Animationen
    5. Pinselwerkzeug
    6. Bewegungsführung
    7. Bewegungs-Tweens und ActionScript 3.0
    8. Bewegungs-Tween-Animationen
    9. Bewegungs-Tween-Animationen
    10. Erstellen von Bewegungs-Tween-Animationen
    11. Verwenden von Eigenschaftenschlüsselbildern
    12. Animieren der Position mithilfe eines Tweens
    13. So bearbeiten Sie Bewegungs-Tweens mit dem Bewegungs-Editor
    14. Bearbeiten des Bewegungspfades einer Tween-Animation
    15. Manipulieren von Bewegungs-Tweens
    16. Hinzufügen von benutzerdefinierten Beschleunigungen
    17. Erstellen und Anwenden von Bewegungsvoreinstellungen
    18. Einrichten von Animations-Tween-Bereichen
    19. Arbeiten mit als XML-Dateien gespeicherten Bewegungs-Tweens
    20. Vergleich von Bewegungs-Tweens und klassischen Tweens
    21. Form-Tweening
    22. Verwenden von Animation mit dem Bone-Werkzeug in Animate
    23. Arbeiten mit Figuren-Rigging in Animate
    24. So verwenden Sie Maskenebenen in Adobe Animate
    25. So arbeiten Sie in Animate mit Szenen
  4. Interaktivität
    1. So erstellen Sie in Animate Schaltflächen
    2. Konvertieren von Animate-Projekten in andere Dokumenttypen
    3. HTML5 Canvas-Dokumente in Animate erstellen und veröffentlichen
    4. Interaktivität mit Codefragmenten in Animate hinzufügen
    5. Erstellen benutzerdefinierter HTML5-Komponenten
    6. Verwenden von Komponenten in HTML5 Canvas
    7. Erstellen von benutzerdefinierten Komponenten: Beispiele
    8. Codefragmente für benutzerdefinierte Komponenten
    9. Empfohlene Verfahren – Anzeigen mit Animate
    10. Authoring und Veröffentlichen für VR
  5. Arbeitsbereich und Arbeitsablauf
    1. Erstellen und Verwalten von Pinseln
    2. Verwenden von Google Fonts in HTML5 Canvas-Dokumenten
    3. Verwenden von Creative Cloud Libraries in Adobe Animate
    4. Bühne und Bedienfeld „Werkzeuge“ in Animate verwenden
    5. Arbeitsablauf und Arbeitsbereich in Animate
    6. Verwenden von Webschriftarten in HTML5 Canvas-Dokumenten
    7. Zeitleisten und ActionScript
    8. Arbeiten mit mehreren Zeitleisten
    9. Festlegen von Voreinstellungen
    10. Verwenden der Animate-Authoring-Bedienfelder
    11. Zeitleisten-Ebenen in Animate erstellen
    12. Exportieren von Animationen für Apps und Game-Engines
    13. Verschieben und Kopieren von Objekten
    14. Vorlagen
    15. Suchen und Ersetzen in Animate
    16. Rückgängigmachen, Wiederholen und das Bedienfeld „Protokoll“
    17. Tastaturbefehle
    18. So verwenden Sie die Zeitleiste in Animate
    19. Erstellen von HTML-Erweiterungen
    20. Optimierungsoptionen für Bilder und animierte GIF-Dateien
    21. Exporteinstellungen für Bilder und GIF-Dateien
    22. Bedienfeld „Elemente“ in Animate
  6. Multimedia und Video
    1. Transformieren und Kombinieren von Grafikobjekten in Animate
    2. Erstellen von und Arbeiten mit Symbolinstanzen in Animate
    3. Bildnachzeichner
    4. So verwenden Sie Sound in Adobe Animate
    5. Exportieren von SVG-Dateien
    6. Erstellen von Videodateien zur Verwendung in Animate
    7. So fügen Sie in Animate ein Video hinzu
    8. Arbeiten mit Video-Cue-Points
    9. Objekte in Animate zeichnen und erstellen
    10. Umformen von Linien und Formen
    11. Striche, Füllungen und Farbverläufe in Animate CC
    12. Adobe Premiere Pro und After Effects
    13. Farb-Bedienfelder in Animate CC
    14. Öffnen von Flash CS6-Dateien mit Animate
    15. In Animate mit klassischem Text arbeiten
    16. Platzieren von Bildern in Animate
    17. Importierte Bitmaps in Animate
    18. 3D-Grafiken
    19. Arbeiten mit Symbolen in Animate
    20. Zeichnen von Linien und Formen mit Adobe Animate
    21. Mit Bibliotheken in Animate arbeiten
    22. Exportieren von Sounds
    23. Auswählen von Objekten in Animate CC
    24. Arbeiten mit Adobe Illustrator AI-Dateien in Animate
    25. Anwenden von Mustern mit dem Sprühen-Werkzeug
    26. Anwenden von Mischmodi
    27. Anordnen von Objekten
    28. Automatisieren von Aufgaben mit dem Menü „Befehle“
    29. Mehrsprachiger Text
    30. Verwenden der Kamera in Animate
    31. Verwenden von Animate mit Adobe Scout
    32. Arbeiten mit Fireworks-Dateien
    33. Grafikfilter
    34. Sounds und ActionScript
    35. Zeichnungsvoreinstellungen
    36. Zeichnen mit dem Stiftwerkzeug
  7. Plattformen
    1. Konvertieren von Animate-Projekten in andere Dokumenttypen
    2. Unterstützung benutzerdefinierter Plattformen
    3. HTML5 Canvas-Dokumente in Animate erstellen und veröffentlichen
    4. Erstellen und Veröffentlichen eines WebGL-Dokuments
    5. So packen Sie Apps für AIR for iOS:
    6. Veröffentlichen von Apps für AIR for Android
    7. Veröffentlichen für Adobe AIR für den Desktop
    8. ActionScript-Veröffentlichungseinstellungen
    9. Empfohlene Verfahren – Organisieren von ActionScript in einer Anwendung
    10. So verwenden Sie ActionScript mit Animate
    11. Empfohlene Verfahren – Richtlinien für Eingabehilfen
    12. Eingabehilfen für den Animate-Arbeitsbereich
    13. Schreiben und Verwalten von Skripts
    14. Aktivieren der Unterstützung für benutzerdefinierte Plattformen
    15. Unterstützung benutzerdefinierter Plattformen – Übersicht
    16. Erstellen barrierefreier Inhalte
    17. Arbeiten mit Plug-ins zur Unterstützung benutzerdefinierter Plattformen
    18. Debuggen von ActionScript 3.0
    19. Aktivieren der Unterstützung für benutzerdefinierte Plattformen
  8. Exportieren und Veröffentlichen
    1. So exportieren Sie Dateien aus Animate CC
    2. OAM-Veröffentlichung
    3. Exportieren von SVG-Dateien
    4. Exportieren von Grafiken und Videos mit Animate
    5. Veröffentlichen von AS3-Dokumenten
    6. Exportieren von Animationen für Apps und Game-Engines
    7. Exportieren von Sounds
    8. Exportieren von QuickTime-Videodateien
    9. Steuern der Wiedergabe von externen Videos mithilfe von ActionScript
    10. Empfohlene Verfahren – Tipps zum Erstellen von Inhalten für mobile Geräte
    11. Empfohlene Verfahren – Videokonventionen
    12. Empfohlene Verfahren – Authoring-Richtlinien für SWF-Anwendungen
    13. Empfohlene Verfahren – Strukturierung von FLA-Dateien
    14. Empfohlene Verfahren für die Optimierung von FLA-Dateien für Animate
    15. ActionScript-Veröffentlichungseinstellungen
    16. Veröffentlichungseinstellungen für Animate festlegen
    17. Exportieren von Projektor-Dateien
    18. Exportieren von Bildern und animierten GIF-Dateien
    19. HTML-Veröffentlichungsvorlagen
    20. Adobe Premiere Pro und After Effects
    21. Schnelles Teilen und Veröffentlichen Ihrer Animationen

Befehle „Rückgängig“, „Wiederherstellen“ und „Wiederholen“

Sie können Aktionen an einzelnen Objekten oder an allen Objekten im aktuellen Dokument rückgängig machen oder wiederherstellen, in dem Sie die Befehle „Rückgängig“ bzw. „Wiederherstellen“ für Objekte oder Dokumente angeben („Bearbeiten“ > „Rückgängig“ oder „Bearbeiten“ > „Wiederherstellen“). Das Standardverhalten ist Rückgängig- und Wiederherstellen-Schritte für Dokumente.

Um die Optionen für das Rückgängigmachen auf Objekt- bzw. auf Dokumentebene zu wählen, gehen Sie wie folgt vor:

  1. Wählen Sie in Animate CC „Bearbeiten“ > „Voreinstellungen“.
  2. Wählen Sie auf der Registerkarte „Allgemein“ im Dropdownfeld „Rückgängig“ die Option „Rückgängig-Schritte für Objekte“.

Hinweis: Manche Aktionen können mit der Option „Rückgängig-Schritte für Objekte“ nicht rückgängig gemacht werden. Dazu gehören Bearbeitungsmodus aufrufen und beenden; Bibliothekselemente auswählen, bearbeiten und verschieben; Szenen erstellen, löschen und verschieben.

Mit dem Befehl „Wiederholen“ können Sie einen Schritt auf das gleiche oder ein anderes Objekt erneut anwenden. Wenn Sie beispielsweise eine Form namens „Form_A“ verschieben, können Sie „Bearbeiten“ > „Wiederholen“ wählen, um die Form erneut zu verschieben, oder eine andere Form, z. B. „Form_B“, auswählen und dann „Bearbeiten“ > „Wiederholen“ wählen, um die zweite Form um den gleichen Wert zu verschieben.

Standardmäßig unterstützt Animate 100 Schritte für den Menübefehl „Rückgängig“. Die Anzahl der Schritte für „Rückgängig“ und „Wiederherstellen“ können Sie in den Animate-Voreinstellungen auswählen. Möglich sind hier Angaben von 2 bis 300.

Wenn Sie einen Schritt mit „Bearbeiten“ > „Rückgängig“ oder im Bedienfeld „Protokoll“ rückgängig machen, ändert sich die Dateigröße des Dokuments standardmäßig nicht, auch dann nicht, wenn Sie ein Element im Dokument löschen. Wenn Sie beispielsweise eine Videodatei in ein Dokument importieren und den Import dann rückgängig machen, sind die Videodaten in der Dateigröße des Dokuments nach wie vor enthalten. Alle Elemente, die Sie durch den Befehl „Rückgängig“ aus einem Dokument löschen, müssen beihalten werden, falls Sie die Elemente später mit dem Befehl „Wiederherstellen“ aufrufen möchten.

Verwenden des Bedienfelds „Protokoll“

Im Bedienfeld „Protokoll“ (Fenster > Protokoll) ist eine Liste mit einer festgelegten Höchstzahl von Schritten enthalten, die Sie im aktiven Dokument seit dem Erstellen oder Öffnen des Dokuments ausgeführt haben. (Das Bedienfeld „Protokoll“ enthält keine Schritte, die Sie in anderen Dokumenten durchgeführt haben.) Der Schieberegler im Bedienfeld „Protokoll“ zeigt zunächst auf den Schritt, den Sie zuletzt durchgeführt haben.

  • Mit dem Bedienfeld „Protokoll“ können Sie einzelne Schritte oder mehrere Schritte auf einmal rückgängig machen oder wiederherstellen. Im Bedienfeld „Protokoll“ können Sie Schritte auf das gleiche oder ein anderes Objekt im Dokument anwenden. Die Reihenfolge der Schritte lässt sich im Bedienfeld „Protokoll“ jedoch nicht ändern. Das Bedienfeld „Protokoll“ ist ein Protokoll der Schritte in der Reihenfolge, in der sie durchgeführt wurden.

    Hinweis: Wenn Sie einen Schritt oder eine Reihe von Schritten rückgängig machen und anschließend einen neuen Schritt im Dokument vornehmen, können Sie die Schritte im Bedienfeld „Protokoll“ nicht mehr wiederherstellen; sie werden aus dem Bedienfeld ausgeblendet.

  • Standardmäßig unterstützt Animate 100 Schritte für „Rückgängig“ im Bedienfeld „Protokoll“. Die Anzahl der Schritte für „Rückgängig“ und „Wiederherstellen“ können Sie in den Animate-Voreinstellungen auswählen. Möglich sind hier Angaben von 2 bis 300.

  • Sie können das Bedienfeld „Protokoll“ leeren, um die Protokoll-Liste für das aktuelle Dokument zu löschen. Nachdem Sie die Protokoll-Liste gelöscht haben, können Sie die gelöschten Schritte nicht mehr rückgängig machen. Durch Löschen der Protokoll-Liste werden die Schritte nicht rückgängig gemacht; es wird lediglich das Protokoll dieser Schritte aus dem Arbeitsspeicher des aktuellen Dokuments gelöscht.

Wenn Sie ein Dokument schließen, wird die Protokoll-Liste ebenfalls geleert. Um Schritte aus einem Dokument zu verwenden, nachdem es geschlossen wurde, kopieren Sie die Schritte mit dem Befehl „Schritte kopieren“ oder speichern Sie die Schritte als Befehl.

Rückgängigmachen der Schritte im Bedienfeld „Protokoll“

Wenn Sie einen Schritt rückgängig machen, wird der Schritt im Bedienfeld „Protokoll“ abgeblendet.

  • Sie können den zuletzt durchgeführten Schritt rückgängig machen, indem Sie den Schieberegler im Bedienfeld „Protokoll“ in der Liste einen Schritt nach oben ziehen.

  • Sie können mehrere Schritte auf einmal rückgängig machen, indem Sie den Schieberegler zu einem Schritt ziehen oder entlang der Schiebereglerspur links neben einen Schritt klicken. Der Schieberegler bewegt sich automatisch zu diesem Schritt, und die dazwischen liegenden Schritte werden rückgängig gemacht.

Hinweis: Die Scrollmethode (bei der die nachfolgenden Schritte ausgewählt werden) unterscheidet sich von der Auswahl eines einzelnen Schritts. Um zu einem Schritt zu scrollen, müssen Sie links neben den Schritt klicken.

Wiedergeben der Schritte im Bedienfeld „Protokoll“

Wenn Sie Schritte mit dem Bedienfeld „Protokoll“ wiedergeben, werden diejenigen Schritte wiedergegeben, die im Bedienfeld „Protokoll“ ausgewählt (markiert) sind. Das ist nicht unbedingt der Schritt, auf den der Schieberegler zurzeit zeigt.

Sie können Schritte im Bedienfeld „Protokoll“ auf jedes im Dokument ausgewählte Objekt anwenden.

Wiedergeben eines Schritts

  1. Wählen Sie im Bedienfeld „Protokoll“ einen Schritt aus, und klicken Sie auf die Schaltfläche „Wiedergabe“.

Wiedergeben einer Reihe aufeinander folgender Schritte

  1. Wählen Sie Schritte im Bedienfeld „Protokoll“ mit einer der folgenden Methoden aus:
    • Ziehen Sie von einem Schritt zu einem anderen. (Ziehen Sie nicht den Schieberegler, sondern ziehen Sie den Mauszeiger bei gedrückter Maustaste von der Beschriftung eines Schrittes zu der eines anderen.)

    • Wählen Sie den ersten Schritt aus, und klicken Sie dann bei gedrückter Umschalttaste auf den letzten Schritt. Oder: Wählen Sie den letzten Schritt aus, und klicken Sie dann bei gedrückter Umschalttaste auf den ersten Schritt.

  2. Klicken Sie auf „Wiedergabe“. Die Schritte werden in der vorgegebenen Reihenfolge wiedergegeben und ein neuer Schritt mit der Beschriftung „Schritte wiedergeben“ wird im Bedienfeld „Protokoll“ angezeigt.

Wiedergeben von nicht aufeinander folgenden Schritten

  1. Wählen Sie einen Schritt im Bedienfeld „Protokoll“ aus und klicken Sie dann bei gedrückter Strg-Taste (Windows) bzw. Ctrl-Taste (Macintosh) auf andere Schritte. Wenn Sie bei gedrückter Strg-Taste bzw. Ctrl-Taste auf einen ausgewählten Schritt klicken, wird seine Auswahl wieder aufgehoben.
  2. Klicken Sie auf „Wiedergabe“.

Kopieren und Einfügen von Schritten zwischen Dokumenten

Jedes offene Dokument verfügt über ein eigenes Schrittprotokoll. Mit dem Befehl „Schritte kopieren“ im Optionsmenü des Bedienfelds „Protokoll“ können Sie Schritte aus einem Dokument kopieren und in einem anderen Dokument einfügen. Wenn Sie Schritte in einen Texteditor kopieren, werden sie als JavaScript™-Code eingefügt.

  1. Wählen Sie die gewünschten Schritte im Bedienfeld „Protokoll“ des Dokuments aus, das die Schritte enthält.
  2. Wählen Sie im Optionsmenü des Bedienfelds „Protokoll“ den Befehl „Schritte kopieren“.
  3. Öffnen Sie das Dokument, in das Sie die Schritte einfügen möchten.
  4. Wählen Sie ein Objekt aus, auf das Sie die Schritte anwenden möchten.
  5. Wählen Sie „Bearbeiten“ > „Einfügen“ aus, um die Schritte einzufügen. Beim Einfügen in das Bedienfeld „Protokoll“ des Dokuments werden die Schritte abgespielt. Im Bedienfeld „Protokoll“ werden die Schritte nur als ein Schritt mit der Bezeichnung „Schritte einfügen“ angezeigt.
Adobe-Logo

Bei Ihrem Konto anmelden