Flash Player alkalmazásban lejátszható, diavetítésszerű tartalom SWF és FLA formátum exportálásával egyaránt készíthető. A legfőbb különbség az, hogy míg az SWF fájlok azonnal lejátszhatók, de nem szerkeszthetők; addig az FLA fájlokat még az Adobe Flash Professional alkalmazásban szerkeszteni kell, hogy az Adobe Flash Player le tudja majd játszani.

SWF

Az exportált SWF fájl azonnal megtekinthető Adobe Flash Player alkalmazásban, és tartalmazhat interaktív elemeket, például oldalátmeneteket, hiperhivatkozásokat, mozgóképet, hangklipet, animációt és navigációs gombokat.

FLA

Az exportált FLA fájl csak néhány interaktív elemet tartalmaz. Az FLA fájl Flash Pro alkalmazásban nyitható meg, ahol Ön, illetve egy Flash-fejlesztő elhelyezhet speciális hatásokat, mielőtt SWF fájlba exportálná.

Exportálás a Flash számára
Exportálás a Flash számára

A. Exportálás közvetlenül SWF fájlba B. Exportálás a Flash Professional alkalmazásban szerkeszthető FLA fájlba 

Interaktív SWF (Flash) internetes fájlok készítése

SWF fájl exportálásával olyan interaktív fájl hozható létre, amelyet az Adobe Flash Player vagy egy internetböngésző azonnal képes lejátszani. Az SWF fájl tartalmazhat az InDesign alkalmazás használatával elhelyezett gombokat, oldalátmeneteket, mozgóképet, hangfájlt, animációt és hiperhivatkozásokat. SWF fájl exportálásával kitűnően készíthető InDesign dokumentumból interaktív diavetítés vagy lapozható anyag.

Ha a dokumentumot még Flash Pro alkalmazásban szerkeszteni kívánja, mielőtt az SWF fájlt elkészítené belőle, akkor SWF helyett FLA fájlba exportálja. Lásd: Internetes célú FLA fájl létrehozása.

SWF formátumba való exportálás
SWF formátumba való exportálás

A. A dokumentum az InDesign programban, az SWF formátumba való exportálás előtt B. Interaktív SWF fájl a internetböngészőben 
  1. Hozza létre az InDesign dokumentumot, illetve szerkessze, mielőtt exportálná a Flash számára. A dokumentum exportálás előtti beállításának részletesebb ismertetése: Flash programban való lejátszáshoz exportált fájlokkal kapcsolatos problémák.

    • Navigációs gombok elhelyezése, amelyekkel a felhasználók majd lapozhatják az exportált SWF fájlt. Gomb létrehozható úgy, hogy megrajzol egy objektumot, majd átalakítja azt gombbá a Gombok panel használatával (Ablak > Interaktív > Gombok). A Mintagombok panel is használható, ahonnan előre definiált navigációs gombok húzhatók át a dokumentumba. Lásd: Gombok létrehozása.

    • Az Oldalátmenetek panellel (Ablak > Interaktív > Oldalátmenetek) lehet beállítani oldalátmeneteket, például letörlést és szórt áttűnést. SWF fájlba exportáláskor bejelölhető az Interaktív oldalcsavarodással együtt beállítás, amelynek segítségével a néző az oldal sarkának elhúzásával lapozhat.

    • Az Animáció panel (Ablak > Interaktív > Animáció) használatával adható meg mozgáskészlet. Lásd: Animáció.

  2. A dokumentum SWF fájlba exportálásához válassza a Fájl > Exportálás műveletet. 

  3. Válassza Az InDesign-dokumentum nevének használata fájlnévként lehetőséget, ha szeretné, hogy az exportált fájl neve megegyezzen a következő exportált dokumentum nevével.

  4. Válassza a Flash Player (SWF) elemet a Fájl típusa (Windows), illetve a Formátum (Mac OS) menüből, majd kattintson a Mentés gombra.

  5. Adja meg a beállításokat az SWF exportálása párbeszédpanelen, majd kattintson az OK gombra. Lásd: SWF exportálás beállításai.

SWF exportálásakor külön HTML és SWF fájl keletkezik. Ha az SWF tartalmaz mozgóképet vagy hangot, akkor egy „Resources” nevű mappa is létrejön. Mikor leadja vagy feltölti a fájlokat internetes felhasználásra, mindenképpen küldje az összes tartozékot.

SWF exportálás beállításai

A következő beállítások jelennek meg az Általános és a Speciális fülön, az SWF exportálási beállításai párbeszédpanelen.

Exportálás

Jelölje meg, hogy az aktuális kijelölés, a dokumentum minden oldala vagy az oldalaknak egy tartománya exportálódjon. A Kijelölés kiválasztása különösen akkor hasznos, ha exportálandó SWF fájlt egy exportált PDF fájlban történő felhasználásra kívánja menteni. Ha a Tartományt választja, adjon meg egy tartományt, például 1-7, 9 az 1-től a 7-ig terjedő, valamint a 9. oldalt nyomtatja. Lásd: Nyomtatandó oldalak megadása.

HTML fájl generálása

Ezt a négyzetet akkor jelölje be, ha szeretne egy olyan HTML oldalt generálni, amely lejátssza az SWF fájlt. Ennek a beállításnak különösen akkor veheti hasznát, ha előzetesen szeretné gyorsan megtekinteni az SWF fájlt a internetböngészőben.

SWF megtekintése exportálás után

Ezt a négyzetet akkor jelölje be, ha szeretné lejátszani az SWF fájlt az alapértelmezett internetböngészőben. Ez a beállítás csak akkor választható, ha HTML fájlt is generál.

Méret (képpontokban)

Adja meg, hogy adott százalékkal, egy megadott monitorméretnek vagy egy megadott szélességnek és magasságnak megfelelően legyen-e méretezve az SWF fájl.

Háttér

Adja meg, hogy az SWF fájl háttere átlátszó legyen-e, vagy az aktuális Papírszínt használja-e a Színtárak panelről. Az Átlátszó kiválasztása mellett nem állnak rendelkezésre az Oldalátmenetek és Interaktív oldalcsavarodás beállítások.

Interaktivitás és média

A „Tartalmazzon mindent” beállítás esetén minden mozgókép, hang, gomb és animáció interaktivitása engedélyezve lesz az exportált SWF fájlban. A „Csak megjelenés” beállítása esetén a gomboknak csak a normál állapota és a videóknak csak az előnézeti képe exportálódik statikus elemként. A „Csak megjelenés” beállítása esetén az animációk csak az exportáláskori pillanatnyi megjelenési formájukban kerülnek be. „Csak megjelenés” van beállítva, ha a Speciális panelen az „Átlátszóság simítása” beállítást választotta ki.

Oldalátmenetek

Megadható egyetlen oldalátmenet, amely exportáláskor az összes oldalra vonatkozni fog. Ha az oldalátmeneteket az Oldalátmenetek panel használatával adja meg, és a dokumentum beállításait kívánja használni, akkor válassza a „Dokumentum szerint” lehetőséget.

Interaktív lapozással együtt

Ha ez van beállítva, akkor az SWF fájt lejátszó felhasználók az oldalak sarkának húzásával tudnak lapozni, ami egy valódi könyv lapozásának érzetét kelni.

Képsebesség

Ahogy a képsebesség nő, úgy lesz az animáció egyre simább, de ezzel növekedhet a fájlméret. A képsebesség módosítása nem érinti a lejátszás időtartamát.

Szöveg

Itt adhatja meg az InDesign dokumentum szövegének kimeneti módját. A „Klasszikus Flash-szöveg” beállítással a kimeneti szöveg kereshető és a legkisebb fájlméretű lesz. Az „Átalakítás körvonallá” beállítással a kimeneti szöveg simított egyenes vonalak sorozata lesz, mintha a szöveget körvonallá alakították volna. Az „Átalakítás képpontokká” beállítással a kimeneti szöveg bittérképes kép lesz. A képpontokká átalakított szöveg körvonala ránagyításkor egyenetlennek tűnhet.

Oldalak raszterizálása

A beállítás hatására a program az összes InDesign-oldalelemet bittérképpé alakítja. A beállítás hatására nagyobb lesz az SWF fájl, a felnagyított oldalelemek szegélye pedig egyenetlenné válhat.

Átlátszóság simítása

Ez a beállítás megszünteti az SWF élő átlátszóságát és megőrizi az átlátszóság megjelenését. Viszont ha ez a beállítás van kiválasztva, az exportált SWF fájl minden interaktivitása megszűnik.

Tömörítés

Az Automatikus beállítással az InDesign alkalmazásra bízhatja a színes és szürkeárnyalatos képek legjobb minőségének megtalálását. A legtöbb fájl esetén ez a beállítás megfelelő eredményt ad. A JPEG (veszteséges) beállítás szürkeárnyalatos és színes képekhez felel meg. A JPEG tömörítés veszteséges, tehát csökken a képadat mennyisége és bizonyára romlik a képminőség. Ugyanakkor lehetőség szerint minimális információveszteséggel csökkenti a fájlméretet. Mivel a JPEG-tömörítés adatokat távolít el a képekből, használatával jóval kisebbé tehetők a fájlok. A PNG (veszteségmentes) beállítás veszteséges tömörítés nélkül exportálja a fájlt.

Megjegyzés:

Ha SWF exportálásakor, áttetszőséget tartalmazó képeknél minőségromlást lát, akkor javítsa a minőséget PNG (veszteségmentes) beállítás kiválasztásával.

JPEG minőség

Meghatározza az exportált kép részletgazdagságát. Minél jobb a minőség, annál nagyobb a fájl mérete. Ez a beállítás nem él, ha PNG (veszteségmentes) tömörítést választ ki.

Felbontás

Adja meg az SWF fájlba exportálandó bittérképes képek felbontását. A nagy felbontás főként azért fontos, hogy a nézők majd bele tudjanak nagyítani az exportált SWF bittérképes részébe. Nagy felbontás kiválasztása jelentősen megnövelheti a fájlméretet.

Internetes célú FLA fájl létrehozása

Ha az InDesign dokumentumot FLA fájlba exportálja, akkor azt az Adobe Flash® CS5 Professional alkalmazással megnyithatja, hogy tartalmát szerkessze. Az InDesign CS5 „Exportálás FLA fájlba” művelete váltja fel az InDesign CS4 „XFL exportálása” műveletét. A Flash tervezői környezetének használatával szerkeszthető és elhelyezhető videó, hang, animáció és összetett interaktivitás.

Ha az InDesign dokumentumot egyenesen internetböngészőben közvetlenül megnyitható formátumba kívánja exportálni, FLA helyett alkalmazza az SWF formátumot. Lásd: Interaktív SWF (Flash) internetes fájlok készítése.

FLA exportálása
FLA exportálása

A. Dokumentum az InDesign alkalmazásban FLA exportálása előtt B. FLA fájl a Flash Pro alkalmazásban megnyitva 
  1. Hozza létre az InDesign dokumentumot, illetve szerkessze, mielőtt exportálná a Flash számára. A dokumentum exportálás előtti beállításának részletesebb ismertetése: Flash programban való lejátszáshoz exportált fájlokkal kapcsolatos problémák.

  2. A dokumentum FLA fájlba exportálásához válassza a Fájl > Exportálás műveletet. Válassza a „Flash CS5 Professional (FLA)” elemet a Fájl típusa (Windows), illetve a Formátum (Mac OS) menüből, majd kattintson a Mentés gombra.

  3. A „Flash CS5 Professional (FLA) exportálása” párbeszédpanelben adja meg a beállításokat, majd kattintson az OK gombra. További tudnivalók az exportálási beállításokról: FLA-exportálás beállításai.

  4. Az exportált FLA fájlt Flash Professional alkalmazásban nyissa meg.

FLA exportálás beállításai

A következő beállítások jelennek meg a „Flash CS5 Professional (FLA) exportálása” párbeszédpanelben.

Exportálás

Jelölje meg, hogy az aktuális kijelölés, a dokumentum minden oldala vagy az oldalaknak egy tartománya exportálódjon. Ha a Tartományt választja, adjon meg egy tartományt, például 1-7, 9 az 1-től a 7-ig terjedő, valamint a 9. oldalt nyomtatja. Lásd: Nyomtatandó oldalak megadása.

Oldalak raszterizálása

A beállítás hatására a program az összes InDesign-oldalelemet bittérképpé alakítja. A beállítás hatására nagyobb lesz az FLA fájl, a felnagyított oldalelemek szegélye pedig egyenetlenné válik.

Átlátszóság simítása

A beállítás hatására a program átlátszósággal együtt simítja az összes objektumot. A simított objektumokat nehezen lehet animálni az Adobe Flash Pro programban.

Méret (képpontokban)

Adja meg, hogy adott százalékkal, egy megadott monitorméretnek vagy egy megadott szélességnek és magasságnak megfelelően legyen-e méretezve az FLA fájl.

Interaktivitás és média

A „Tartalmazzon mindent” beállítás esetén minden mozgókép, hang, gomb és animáció exportálásra kerül az FLA fájlba. Ha a dokumentumban többállapotú objektum található, akkor az olyan klip szimbólummá alakul át, amelyben az egyes állapotok az idővonalon külön képkockákon jelennek meg.

A „Csak megjelenés” beállítása esetén a gomboknak csak a normál állapota és a videóknak csak az előnézeti képe exportálódik statikus elemként. A „Csak megjelenés” beállítása esetén az animációk csak az exportáláskori pillanatnyi megjelenési formájukban kerülnek be. „Csak megjelenés” van beállítva, ha az „Átlátszóság simítása” beállítást választotta ki.

Szöveg

Itt adhatja meg az InDesign dokumentum szövegének kimeneti módját. Válassza ki a Flash TLF szöveg beállítást, így kihasználhatja a Flash Professional alkalmazásban a Szövegelrendezés keretrendszer sok különféle jellemzőjét. Ha ez a beállítás ki van választva, az „Elválasztójelek szótár szerint beillesztése” művelettel lehetővé teheti az elválasztást. A „Klasszikus Flash-szöveg” beállítással a kimeneti szöveg kereshető és kis fájlméretű lesz. Az „Átalakítás körvonallá” beállítással a kimeneti szöveg simított egyenes vonalak sorozata lesz, mintha a szöveget körvonallá alakították volna. Az „Átalakítás képpontokká” beállítással a kimeneti szöveg bittérképes kép lesz. A képpontokká átalakított szöveg körvonala ránagyításkor egyenetlennek tűnhet.

Tömörítés

Az Automatikus beállítással az InDesign alkalmazásra bízhatja a színes és szürkeárnyalatos képek legjobb minőségének megtalálását. A legtöbb fájl esetén ez a beállítás megfelelő eredményt ad. A JPEG (veszteséges) beállítás szürkeárnyalatos és színes képekhez felel meg. A JPEG tömörítés veszteséges, tehát csökken a képadat mennyisége és bizonyára romlik a képminőség. Ugyanakkor lehetőség szerint minimális információveszteséggel csökkenti a fájlméretet. Mivel a JPEG-tömörítés adatokat távolít el a képekből, használatával jóval kisebbé tehetők a fájlok. A PNG (veszteségmentes) beállítás veszteséges tömörítés nélkül exportálja a fájlt.

JPEG minőség

Meghatározza az exportált kép részletgazdagságát. Minél jobb a minőség, annál nagyobb a fájl mérete. Ez a beállítás nem él, ha PNG (veszteségmentes) tömörítést választ ki.

Felbontás

Adja meg az FLA fájlba exportálandó bittérképes képek felbontását. A nagy felbontás főként azért fontos, hogy a nézők majd bele tudjanak nagyítani a bittérképes részébe. Nagy felbontás kiválasztása jelentősen megnövelheti a fájlméretet.

Flash formátumú exportálási problémák

SWF vagy FLA kimenetre szánt InDesign dokumentum összeállításakor vegye figyelembe az alábbi tényezőket.

Dokumentumbeállítási problémák

Az InDesign oldalak átalakításának módja

Az SWF és az FLA formátumba exportált InDesign oldalpárokból külön klip lesz az idővonalon, mintha csak egy diavetítés diái lennének. A program mindegyik oldalpárt egy új kulcsképnek felelteti meg. A Flash Player programban nyílbillentyűk lenyomásával, illetve interaktív gombokra való kattintással léptetheti az exportált dokumentumban található oldalpárokat.

Megjegyzés:

Ha az internetre szánja a létrehozott dokumentumot, akkor válassza a Web menüelemet az „Új dokumentum” párbeszédpanel Rendeltetés menüjéből.

Oldalméret

Dokumentum létrehozásakor adott (pl. 800 x 600 méretű) felbontást választhat az Új dokumentum párbeszédpanel Oldalméret listájában. Exportáláskor módosíthatja a készítendő SWF vagy FLA fájl méretezését és felbontását is.

Interaktivitási funkciók

A készítendő SWF vagy FLA fájlt exportálhat úgy is, hogy az tartalmazza a gombokat, oldalátmeneteket, hiperhivatkozásokat, animációkat és médiafájlokat is.

Gombok

Exportált SWF vagy FLA fájl gombjainak szempontjából a „Következő oldal” és „Előző oldal” műveletek különösen hasznos vezérlési lehetőségek, amikor a Flash Player a lejátszást végzi. Olyan műveletek is vannak, amelyek az interaktív PDF fájlokban működnek, a Flash Player programban azonban nem. Mikor a Gombok panelről kiválaszt egy műveletet, nehogy a „Csak PDF” szakaszból válasszon.

Megjegyzés:

Elhelyezhetők „Ugrás a következő oldalra” és „Ugrás az előző oldalra” műveletekhez előre konfigurált navigációs gombok. Válassza a Mintagombok menüelemet a Gombok panelmenüből. Lásd: Gomb hozzáadása a Mintagombok panelről.

Oldalátmenetek

A oldaláttűnések mindegyike működik a Flash Player programban. Exportáláskor választhatja, hogy interaktív oldalcsavarodás is legyen az exportált fájlban, így annak lejátszásakor a lapok váltásakor megjelenő oldaláttűnéseken kívül a lap sarkának arrébb húzásával is lehet majd „lapozni” a fájlban.

Hivatkozások

Webhelyekre, illetve a dokumentum más oldalaira mutató hivatkozásokat hozhat létre. A hiperhivatkozások meg vannak szakadva az FLA fájlban.

Mozgóképek és hangklipek

Az exportált SWF fájlba akkor kerülnek bele a mozgóképek és hangklipek, ha formátumok támogatott: például a mozgókép SWF, FLV, F4V vagy MP4, a hangklip MP3 formátumú.

FLA exportálása esetén csak az videó előnézeti képe kerül bele a létrejövő FLA fájlba. A támogatott formátumú médiafájlok egy olyan forrásmappában jelennek meg, amely az exportált FLA fájllal megegyező helyen jön létre.

Átalakítási problémák

Szín

Az SWF és az FLA formátum RGB színeket használ. SWF vagy FLA exportálásakor az InDesign minden színteret (pl. CMYK és LAB) átalakít sRGB színtérbe. Az InDesign RGB megfelelőjére alakítja az összes direktszínt.

Az átlátszó szöveggel ellátott grafikák nemkívánatos színkonverziójának elkerülése érdekében válassza a Szerkesztés menü Áttetszőség-keverési tér elemének Dokumentum RGB parancsát. Az áttetszőséget tartalmazó képek nemkívánatos színtorzulását elkerülendő, exportálásnál ne használjon veszteséges tömörítést.

Szöveg

SWF vagy FLA exportálásakor megadható, hogy szöveg Flash-szövegként kerüljön a létrejövő fájlba, vagy körvonalakká, illetve bittérképpé átalakítva. A klasszikus Flash-szövegként exportált szöveg teljesen szerkeszthető marad, amikor az FLA fájlt az Adobe Flash CS5 Professional megnyitja; illetve SWF fájlként mentve az internetböngészők keresni tudnak benne.

Képek

Képek SWF vagy FLA fájlba exportálásakor beállítható a képtömörítés, a JPEG minősége és az exportálási felbontás.

Képek FLA fájlba exportálásakor, az InDesign dokumentumban több példányban elhelyezett képek csak egy képforrásként lesznek elmentve egy megosztott helyre. Ha sok vektorkép van az InDesign dokumentumban, akkor az teljesítménybeli problémákat okozhat az exportált fájl lejátszásakor.

A fájlméret csökkentése érdekében a képek másolása és beillesztése helyett célszerű mesteroldalakon elhelyezni az ismétlődő képeket. Ha egyazon kép több példányban van elhelyezve a dokumentumban, és átalakítva vagy vágva nincsenek, akkor csak egy példány exportálódik az FLA fájlba. A másolt és beillesztett képeket külön objektumokként kezeli a program.

Alapértelmezés szerint a program az elhelyezett Illustrator fájlt egyetlen képként kezeli az FLA fájlban, míg a másolt és beillesztett Illustrator fájlokat különálló objektumokként. A legjobb végeredmény érdekében ne az Illustrator alkalmazásból való másolás-beillesztés útján helyezze el az Illustrator-képet, hanem PDF fájlként. Ha másolás-beillesztés útján helyezi el, akkor abból több szerkeszthető görbe keletkezik.

Megjegyzés:

A beállítások közül választható lehetőségekkel gondoskodhat arról, hogy a program kis vektorokból álló gyűjtemények helyett egyetlen objektumként illessze be az Illustrator-objektumokat. Az Illustrator Fájlkezelés és vágólap beállításai között jelölje be a PDF lehetőség mellett látható négyzetet, az AICB (az átlátszóságot nem támogatja) lehetőség mellett látható négyzet jelölését pedig szüntesse meg. Az InDesign Vágólap beállításai között jelölje be mind a PDF előnyben részesítése beillesztéskor, mind a PDF másolása a vágólapra lehetőség mellett látható négyzetet.

Áttetszőség

SWF fájlba való exportálás előtt győződjön meg arról, hogy egyetlen interaktív elemet (pl. gombot vagy hiperhivatkozást) sem fednek az áttetsző objektumok. Ha valamelyik áttetsző objektum fedi valamelyik interaktív elemet, akkor exportálás során megszűnhet az elem interaktív jellege. FLA exportálása előtt érdemes lehet az átlátszóságot simítani.

Egyes esetekben a veszteséges tömörítés alkalmazása rontja az áttetszőséget tartalmazó képek minőségét. Exportálásnál a PNG (veszteségmentes) tömörítés alkalmazásával javítható a minőség.

3D jellemzők

A 3D jellemzőket az exportált SWF és FLA fájlok nem támogatják.

Ez a munka a Creative Commons Nevezd meg!-Ne add el!-Így add tovább! 3.0 Unported licenc alatt lett közzétéve.  A Twitter™ és Facebook közzétételeket a Creative Commons jogi feltételei nem szabályozzák.

Jogi közlemények   |   Online adatvédelmi nyilatkozat