Táblázatcellák, sorok és oszlopok kijelölése

A cellában lévő szöveg egészének vagy egy részének kijelölésekor a kijelölt rész ugyanúgy jelenik meg, mintha egy táblázaton kívüli szövegrészt jelölt volna ki. Ha a kijelölés azonban több cellára is kiterjed, a program a cellákat és azok tartalmát is kijelöli.

Több keretet is felölelő táblázat esetén a fejlécsorokra vagy a láblécsorokra mutatva (kivéve az első fejléc- és láblécsort) egy lakatikon jelenik meg, jelezve, hogy abban a sorban nem jelölhető ki szöveg vagy cella. Ha a szóban forgó fejléc- vagy láblécsorban cellákat szeretne kijelölni, ugorjon a táblázat elejére.

Cellák kijelölése

  1. A Szöveg eszközzel  tegye a következők egyikét:
    • Egyetlen cella kijelöléséhez kattintson bele a cellába, vagy jelöljön ki egy szövegrészt, és válassza a Táblázat menü Kijelölés almenüjének Cella parancsát.

    • Több cella kijelöléséhez húzza az egérmutatót a cella valamelyik szegélyén kívülre. Legyen óvatos: ne az oszlop vagy a sor szélét jelző vonalat húzza, mert úgy csak átméretezi a táblázatot.

Megjegyzés:

Ha váltani szeretne a cellában lévő teljes szövegmennyiség és maga a cella kijelölése között, nyomja meg az ESC billentyűt.

Teljes oszlopok vagy sorok kijelölése

  1. A Szöveg eszközzel  tegye a következők egyikét:
    • Kattintson bele egy cellába, vagy jelöljön ki egy szöveget, majd válassza a Táblázat menü Kijelölés almenüjének Oszlop vagy Sor parancsát.

    • Vigye az egérmutatót az egyik oszlop felső szegélye vagy az egyik sor bal oldali szegélye fölé. A mutató nyíllá változik ( vagy ), ezután kattintással jelölheti ki a teljes oszlopot vagy sort.

Sor kijelölés előtt és után
Sor kijelölés előtt és után

  1. Kattintson a táblázatba, vagy jelöljön ki szöveget a táblázatban.
  2. Kattintson a Táblázat menü Kijelölés almenüjének Fejlécsorok, Törzssorok vagy Láblécsorok parancsára.

A teljes táblázat kijelölése

  1. A Szöveg eszközzel  tegye a következők egyikét:
    • Kattintson a kérdéses táblázaton belülre vagy jelöljön ki szöveget abban, és válassza a Táblázat menü Kijelölés almenüjének Táblázat parancsát.

    • Vigye az egérmutatót a táblázat bal felső sarka fölé. A mutató nyíllá változik () – kattintással kijelölheti az egész táblázatot.

    Táblázat kijelölés előtt és után
    Táblázat kijelölés előtt és után

    • Váltson a Szöveg eszközre, és húzza az egérmutatót a teljes táblázaton keresztül.

Megjegyzés:

A táblázatok a rögzített grafikák kijelölésének módjával megegyező módszerrel is kijelölhetők: helyezze a kurzort közvetlenül a táblázat elé vagy mögé, és a SHIFT+JOBBRA vagy a SHIFT+BALRA billentyűkombinációval kijelölheti a táblázatot.

Sorok és oszlopok beszúrása

Sorokat és oszlopokat több különböző módszerrel is be lehet szúrni.

Sor beszúrása

  1. Vigye a kurzort az új sor megjelenési helye alatti vagy fölötti sorba.
  2. Kattintson a Táblázat menü Beszúrás almenüjének Sor parancsára.
  3. Adja meg a sorok számát a Szám mezőben.
  4. Az új sor(ok) elhelyezésének függvényében jelölje be a Fölé vagy az Alá választógombot, majd kattintson az OK gombra.

Az új cellák ugyanolyan formátumúak, mint az a szöveg, amely a beszúrási pontot magában foglaló sorban található.

Megjegyzés:

Ha a beszúrási pont az utolsó cellában áll, akkor a tabulátorbillentyű megnyomásával is létrehozható új sor.

Oszlop beszúrása

  1. Vigye a kurzort az új oszlop megjelenési helye melletti valamelyik oszlopba.
  2. Kattintson a Táblázat menü Beszúrás almenüjének Oszlop parancsára.
  3. Adja meg az oszlopok számát a Szám mezőben.
  4. Az új oszlop(ok) elhelyezésének függvényében jelölje be a Balra vagy a Jobbra választógombot, majd kattintson az OK gombra.

Az új cellák ugyanolyan formátumúak, mint az a szöveg, amely a beszúrási pontot magában foglaló oszlopban található.

Több sor és oszlop beszúrása

  1. Legyen a beszúrási pont az egyik cellában, és így kattintson a Táblázat menü Táblázat beállításai almenüjének Táblázat beállítása parancsára.
  2. Változtassa meg a sorok és az oszlopok számát, majd kattintson az OK gombra.

Az új sorokat a táblázat aljához, az új oszlopokat pedig a táblázat jobb oldalához adja hozzá a rendszer.

Megjegyzés:

A sorok és az oszlopok száma a Táblázat panelen is módosítható. A Táblázat panel megjelenítéséhez válassza az Ablak menü Szöveg és táblázatok almenüjének Táblázat elemét.

Sor vagy oszlop beszúrása húzással

Ha oszlopok hozzáadásakor a húzott oszlop szélességének egy-másfélszeresénél nagyobb távolságra húzza az oszlopszegélyt, akkor a program az eredeti oszlop szélességével megegyező szélességű új oszlopokat ad hozzá a táblázathoz. Ha a húzás célja csupán egyetlen oszlop beszúrása, az eredményül kapott oszlop keskenyebb vagy szélesebb is lehet a húzás kiinduló oszlopánál. Ugyanez igaz a sorokra is, kivéve, ha a húzott sorhoz tartozó Sormagasság mezőben a Legalább érték szerepel. Ha ilyen esetben a húzással csak egy sort szeretne létrehozni, az InDesign szükség esetén átméretezi az új sort, hogy abban rendben elférjen a szöveg.

  1. Váltson a Szöveg eszközre , és vigye az egérmutatót az egyik oszlop vagy sor szegélye fölé. Ekkor a mutató kétágú nyíllá ( vagy ) változik.
  2. Tartsa lenyomva a bal egérgombot, majd az ALT (Windows) vagy az OPTION (Macintosh) billentyűt is lenyomva tartva húzza lefelé az egeret új sor, vagy jobbra új oszlop létrehozásához. (Ha az egérgomb megnyomása előtt nyomja meg az ALT vagy az OPTION billentyűt, akkor a Kéz eszközt aktiválja. Igyekezzen még a húzás előtt megnyomni az ALT vagy az OPTION billentyűt.)

Megjegyzés:

A táblázat felső vagy bal oldali szegélye mentén nem szúrhatók be húzással sorok és oszlopok. Ezek a mezők a sorok és az oszlopok kijelöléséhez használatosak.

Sorok, oszlopok vagy táblázatok törlése

  • Sor, oszlop vagy táblázat törléséhez helyezze a kurzort a táblázaton belülre (vagy jelöljön ki szöveget a táblázatban), majd kattintson a Táblázat > Törlés > Sor, Oszlop vagy Táblázat lehetőségre.
  • Ha a Táblázat beállításai párbeszédpanel használatával szeretne sorokat és oszlopokat törölni, kattintson a Táblázat > Táblázat beállításai > Táblázat beállítása lehetőségre. Változtassa meg a sorok és az oszlopok számát, majd kattintson az OK gombra. A sorokat a táblázat aljáról, az oszlopokat pedig a táblázat jobb oldaláról törli a rendszer.
  • Ha az egérrel szeretne sort vagy oszlopot törölni, vigye az egérmutatót a táblázat alsó sorának vagy jobb oldali oszlopának alsó (külső) szegélye fölé: a mutató kétágú nyíllá ( vagy ) változik. Tartsa lenyomva a bal egérgombot, majd az ALT (Windows) vagy az OPTION (Macintosh) billentyűt is lenyomva tartva húzza felfelé az egeret a sor(ok), vagy balra az oszlop(ok) törléséhez.

Megjegyzés:

Ha az egérgomb megnyomása előtt nyomja meg az ALT vagy az OPTION billentyűt, akkor a Kéz eszközt aktiválja. Igyekezzen még a húzás előtt megnyomni az ALT vagy az OPTION billentyűt.

  • Ha a cellák törlése nélkül szeretné törölni bizonyos cellák tartalmát, jelölje ki a törlendő szöveget tartalmazó cellákat, vagy a Szöveg eszközzel jelölje ki a cellákban lévő szöveget. Nyomja meg a Backspace vagy a Delete billentyűt, vagy kattintson a Szerkesztés > Törlés lehetőségre.

Kereten belüli táblázat igazításának megváltoztatása

A táblázatok alapértelmezés szerint olyan szélesek, mint az azokat befoglaló bekezdés vagy táblázatcella. A szövegkeret vagy a táblázat mérete természetesen módosítható is, hogy a táblázat szélesebb vagy keskenyebb lehessen a keretnél. Ilyen esetben eldönthető, hogy a kereten belül hogyan szeretné igazítani a táblázatot.

  1. Helyezze a kurzort a táblázattól jobbra vagy balra. Győződjön meg arról, hogy a szövegbeviteli pont a táblázatot tartalmazó bekezdésben, nem pedig a táblázaton belül található. A kurzor felveszi a keretben lévő táblázat magasságát.
  2. Kattintson a Bekezdés vagy a vezérlőpult igazítást végző gombjainak egyikére (például a Középre igazítás gombra).

A táblázaton belül a tabulátorbillentyűvel vagy a nyílbillentyűkkel navigálhat. Lehetősége van arra is, hogy a megadott sorra ugorjon: ez különösen hasznos a hosszú táblázatokban.

Navigálás a táblázatban a tabulátorbillentyűvel

  • A következő cellára a tabulátorbillentyű megnyomásával ugorhat. Ha a táblázat utolsó cellájában nyomja meg a tabulátorbillentyűt, a program új sort hoz létre. A Táblázatbeli szöveg formázása című témakörből megtudhatja, hogy miként szúrhat be tabulátorokat és beszúrásokat a táblázatba.
  • A SHIFT+TAB billentyűkombinációval az előző cellára ugorhat. Ha a táblázat első cellájában nyomja le ezt a billentyűkombinációt, a kurzor az utolsó táblázatcellába ugrik.

Navigálás a táblázatban a nyílbillentyűkkel

A nyílbillentyűk a táblázatcellákon belül és az azok közötti navigáláshoz egyaránt használhatók. Ha a kurzor a sor utolsó cellájának végén van, a JOBBRA billentyűvel ugyanazon sor első cellájának elejére viheti. Hasonlóképpen, ha a kurzor az oszlop utolsó cellájának végén van, a LE billentyűvel ugyanazon oszlop első cellájának elejére viheti.

Ugrás a táblázat adott sorára

  1. Kattintson a Táblázat menü Ugrás sorra parancsára.
  2. Végezze el a következő műveletek valamelyikét:
    • Adja meg a léptetőmezőben a sor számát, és kattintson az OK gombra.

    • Ha az aktuális táblázatban van fejléc- vagy láblécsor, válassza a legördülő lista Fejléc vagy Lábléc elemét, és kattintson az OK gombra.

Táblázattartalom kivágása, másolása és beillesztése

Cellában található kijelölt szöveg esetén a kivágási, a másolási és a beillesztési műveletek megegyeznek a táblázaton kívüli kijelölt szöveggel végezhető műveletekkel. Ezenkívül arra is lehetősége van, hogy a cellákat és azok tartalmát vágja ki, másolja és illessze be. Ha beillesztéskor táblázatban van a beszúrási pont, az egyszerre beillesztett több cella a táblázaton belüli különálló táblázatként jelenik meg. Az InDesign a teljes táblázat áthelyezését és másolását is támogatja.

  1. Jelölje ki a kivágandó vagy másolandó cellákat, és kattintson a Szerkesztés menü Kivágás vagy Másolat parancsára.
  2. Végezze el a következő műveletek valamelyikét:
    • Táblázat táblázatba ágyazásához vigye a kurzort abba a cellába, amelyben meg szeretné jeleníteni a táblázatot, és kattintson a Szerkesztés menü Beillesztés parancsára.

    • Már meglévő cellák felülírásához jelöljön ki a táblázatban legalább egy cellát (ne felejtsen el elegendő számú cellát hagyni a kijelölt cella alatt és attól jobbra), és válassza a Szerkesztés menü Beillesztés parancsát.

Táblázat áthelyezése vagy másolása

  1. A teljes táblázat kijelöléséhez vigye a beszúrási pontot a táblázatba, és kattintson a Táblázat menü Kijelölés almenüjének Táblázat parancsára.
  2. Válassza a Szerkesztés menü Kivágás vagy Másolás parancsát, vigye a beszúrási pontot a táblázat leendő helyére, és kattintson a Szerkesztés menü Beillesztés parancsára.

Táblázatok szöveggé alakítása

  1. Vigye a kurzort a Szöveg eszközzel  a táblázaton belülre, vagy jelöljön ki szöveget a táblázatban.
  2. Kattintson a Táblázat menü Táblázat szöveggé alakítása parancsára.
  3. Adja meg az Oszlopelválasztó és a Sorelválasztó mezőben a használandó elválasztó karaktereket.

    A legjobb eredményt úgy érheti el, hogy más-más elválasztót ad meg az oszlopokhoz és a sorokhoz (például tabulátort az oszlopokhoz, bekezdést pedig a sorokhoz).

  4. Kattintson az OK gombra.

Táblázat szöveggé alakításakor a program eltávolítja a táblázat vonalait, majd minden egyes sor és oszlop végére beszúrja a megadott elválasztó karaktert.

Táblázatok egyesítése

A Beillesztés paranccsal egyesíthet két vagy több táblázatot.

  1. A céltáblázatba szúrjon be legalább annyi üres sort, amennyi a többi táblázathoz szükséges. (Ha a másolt mennyiségnél kevesebb sort szúr be, a beillesztés nem hajtható végre.)
  2. A forrástáblázatban jelölje ki a másolni kívánt cellákat. (Ha több oszlopcellát másol, mint amennyi a céltáblázatban rendelkezésre áll, a beillesztés nem hajtható végre.)
  3. Jelöljön ki legalább egy cellát a beillesztés helyének megadásához, és kattintson a Szerkesztés menü Beillesztés parancsára.

Megjegyzés:

Ha a beillesztett sorok formázása eltér a táblázat többi részétől, definiáljon egy vagy több cellastílust, és alkalmazza őket a beillesztett cellákra. A létező formázás felülbírálásához az Alt (Windows) vagy Option (Mac OS) billentyűt lenyomva tartva kattintson a cellastílusra.

Anne-Marie Concepcion cikke táblázatok összefűzéséről (angol nyelven): Joining Tables.

Táblázatok használata a Szövegegység-szerkesztőben

A Szerkesztés menü Szerkesztés a Szövegegység-szerkesztőben parancsának hatására a táblázatok, valamint azok tartalma megjelenik a Szövegegység-szerkesztőben. A Szövegegység-szerkesztőben szerkesztheti a táblázatokat.

Táblázatok szerkesztése a Szövegegység-szerkesztőben
Táblázatok szerkesztése a Szövegegység-szerkesztőben

A. Táblázat ikon B. Túlszedett grafika 
  • A Szövegegység-szerkesztőben látható táblázat kibontásához, illetve összecsukásához kattintson a táblázat tetején, a táblázat ikonjától balra látható háromszögre.

  • A táblázat sorok, illetve oszlopok szerint való rendezéséhez a jobb gombbal (Windows), illetve a Ctrl billentyűt nyomva tartva (Mac OS) kattintson a táblázat ikonra, majd válassza a Rendezés sorok szerint, illetve a Rendezés oszlopok szerint parancsot.

  • Az Elrendezés nézetben módosíthatja és formázhatja a táblázatot. A Szövegegység-szerkesztőben nem lehet külön kijelölni a sorokat és az oszlopokat.

Ez a munka a Creative Commons Nevezd meg!-Ne add el!-Így add tovább! 3.0 Unported licenc alatt lett közzétéve.  A Twitter™ és Facebook közzétételeket a Creative Commons jogi feltételei nem szabályozzák.

Jogi közlemények   |   Online adatvédelmi nyilatkozat