Sobre botões

Geralmente, os botões são associados a formulários, mas podem ser adicionados a qualquer documento. Eles podem abrir um arquivo, reproduzir um clipe de filme ou de som, enviar dados a um servidor da Web e muito mais. Ao decidir a maneira de iniciar uma ação, lembre-se de que os botões oferecem os seguintes recursos não disponíveis nos links e nos marcadores:

  • Os botões podem ativar uma única ação ou uma série de ações.

  • Eles podem alterar a aparência em resposta às ações do mouse.

  • Podem ser facilmente copiados em muitas páginas.

  • As ações do mouse podem ativar diferentes ações de botão. Por exemplo, Mouse para baixo (um clique), Mouse para cima (soltar após um clique), Mouse para dentro (mover o ponteiro sobre o botão) e Mouse para fora (mover o ponteiro para fora do botão) podem iniciar uma ação diferente para o mesmo botão.

    Os botões são um modo fácil e intuitivo pelo qual os usuários podem iniciar uma ação nos documentos PDF. Os botões podem ter uma combinação de rótulos e ícones para conduzir os usuários por uma série de ações ou eventos, que se alteram conforme o movimento do mouse. Por exemplo, crie botões com os rótulos “Reproduzir,” “Pausar,” e “Parar” e os ícones adequados. Em seguida, defina ações para que esses botões reproduzam, pausem e interrompam um clipe de filme. É possível selecionar para um botão qualquer combinação de comportamentos do mouse e especificar qualquer combinação de ações para determinado comportamento.

Adicionar um botão a um formulário Acrobat DC PDF

  1. Verifique se você está no modo de edição, selecionando Ferramentas > Preparar formulário e, em seguida, selecionando o Botão na barra de ferramentas. O cursor muda para um fio de retículo.

  2. Na página, clique onde deseja adicionar o botão para criar um botão com o tamanho padrão. Para um botão de tamanho personalizado, arraste um retângulo para definir o tamanho do botão.
  3. Clique duas vezes no campo do botão e especifique um nome, o texto da dica de ferramenta e outras propriedades comuns.
  4. Clique na guia Aparência e especifique as opções para determinar a aparência do botão na página. Se for selecionada uma cor para o plano de fundo, não será possível ver nenhuma imagem que esteja atrás do botão. As opções de texto afetam o rótulo especificado na guia Opções, não o nome do botão na guia Geral.

    Observação:

    Se o item Ativar opções de idioma da direita para a esquerda estiver selecionado no painel Internacional da caixa de diálogo Preferências, a guia Aparência incluirá opções para alterar o estilo dos dígitos, e a direção do texto para os botões.

  5. Clique na guia Opções e selecione opções para determinar como os rótulos e os ícones serão exibidos no botão.
  6. Clique na guia Ações. Especifique opções para determinar o que acontecerá quando o botão for clicado, como a ação de pular para uma página diferente ou reproduzir um clipe de mídia.
  7. Clique em Fechar.

    Observação:

    Se estiver criando um conjunto de botões, poderá ajustar o objeto às guias ou linhas da grade.

  8. Para visualizar e testar o botão, clique em Visualizar na extremidade direita da barra de ferramentas. Depois de terminar, clique em Editar para retornar à ferramenta Preparar formulário, ou clique no ícone de cruz na extremidade direita da barra de ferramentas para fechar a ferramenta.

Adição do botão Enviar

Quando você distribui um formulário, o Acrobat DC verifica o formulário automaticamente. Caso não encontre um botão de envio, ele adiciona um botão Enviar formulário à barra de mensagens do documento. Os usuários podem clicar no botão Enviar formulário para enviar formulários preenchidos de volta para você. Caso não pretenda usar o botão Enviar formulário criado pelo Acrobat DC, é possível adicionar um botão de envio personalizado ao formulário.

  1. Caso não esteja no modo de edição, selecione Ferramentas > Preparar formulário.

  2. Usando a ferramenta Botão , arraste pela área na qual você deseja exibir o botão. Clique duas vezes no botão e defina opções nas guias Geral e Opções.

  3. Na guia Opções, escolha uma opção no menu Layout para o rótulo do botão, a imagem do ícone ou para ambos. Siga um destes procedimentos (ou ambos):

    • Digite o texto na caixa Rótulo para identificar o botão como um botão de envio.

    • Clique em Escolher ícone e digite o caminho para um arquivo de imagens ou clique em Procurar para localizar o arquivo de imagens que deseja utilizar.

  4. Na guia Ações, selecione Enviar um formulário no menu Selecionar ação e, em seguida, clique em Adicionar.

  5. Na caixa de diálogo Enviar seleções de formulário, siga um destes procedimentos:
    • Para coletar os dados do formulário em um servidor, digite o local na caixa Digite um URL para este link. Por exemplo: http://www.[domínio]/[pasta]/[subpasta]/ para um endereço de Internet ou \\[servidor]\[pasta]\[subpasta]\ para uma localização em uma rede local.

    • Para coletar dados de formulário como anexos de email, digite mailto: seguindo pelo endereço de email. Por exemplo, mailto:ninguem@adobe.com.

  6. Selecione as opções do Formato de exportação, Seleção de campos e Opções de data e clique em OK.

  7. Clique em Fechar.

  8. Para visualizar e testar o botão, clique em Visualizar na extremidade direita da barra de ferramentas. Depois de terminar, clique em Editar para retornar à ferramenta Preparar formulário, ou clique no ícone de cruz na extremidade direita da barra de ferramentas para fechar a ferramenta.

Observação:

Se os dados retornarem no formato FDF ou XFDF, o URL do servidor deverá terminar com o sufixo #FDF; por exemplo, http://meuservidor/cgi-bin/meuscript#FDF.

Opções para envio de seleções de formulários

As seguintes opções estão disponíveis na caixa de diálogo Enviar seleções de formulários:

Digite um URL para este link

Especifica o URL para reunir os dados de formulário.

FDF

Retorna a entrada do usuário sem enviar de volta o arquivo PDF subjacente. É possível selecionar opções para incluir Dados da área, Comentários e Alterações incrementais ao PDF.

Observação:

A seleção da opção para fazer alterações incrementais é útil para receber assinaturas digitais de uma maneira que simplifique sua leitura e reconstrução por um servidor.

HTML

Retorna o formulário em Hypertext Markup Language (HTML).

XFDF

Retorna a entrada do usuário como um arquivo XML. É possível incluir comentários aos dados de campo ou apenas incluir dados de campo.

PDF

Retorna o arquivo PDF com a entrada de usuário.

Seleção de campo

Especifica quais campos são retornados. Para receber apenas alguns dados de campo concluídos, selecione Somente estes, clique em Selecionar campos e selecione os campos a serem incluídos ou excluídos na caixa de diálogo Seleção de campo.

Por exemplo, isso pode ser usado para excluir alguns campos calculados ou duplicados que aparecem no formulário para ajudar o usuário, mas que não adicionam informações novas.

Opções de data

Padroniza o formato para datas inseridas pelo usuário.

Alterar a aparência dos botões

Um botão pode ter um rótulo, um ícone ou ambos. Em cada estado do mouse (Para cima, Para baixo e Sobreposto), a aparência do botão pode ser alterada. Por exemplo, crie um botão que exiba um rótulo "Início" até o ponteiro do mouse movimentar-se sobre ele, que então exibirá o rótulo "Clique para retornar à Página inicial".

É possível criar ícones de botão com base em qualquer formato de arquivo que o Acrobat DC possa exibir, inclusive PDF, JPEG, GIF e outros formatos de imagem. Independentemente do formato selecionado, será usada a página inteira; para usar somente parte de uma página como ícone, recorte a imagem ou a página antes de realizar esse procedimento. O menor tamanho de página PDF permitido é 1 x 1 pol. (2,54 x 2,54 cm). Para que o tamanho do ícone seja inferior a 2,54 x 2,54 cm, dimensione-o para se ajustar ao tamanho da caixa desenhada com a ferramenta de botão. Clique em Avançado, na guia Opções da caixa de diálogo Propriedades do Botão, para determinar como um ícone de botão será dimensionado para se encaixar dentro do botão.

Layouts de botão
Layouts de botão

A. Somente rótulo B. Somente ícone C. Ícone acima, rótulo embaixo D. Rótulo acima, ícone embaixo E. Ícone à esquerda, rótulo à direita F. Rótulo à esquerda, ícone à direita G. Rótulo sobre o ícone 

Editar um botão

  1. Caso não esteja no modo de edição, selecione Ferramentas > Preparar formulário.

  2. Selecione o campo Botão e execute um dos seguintes procedimentos:
    • Para editar as propriedades do campo do botão, clique no botão duas vezes.

    • Para alterar a aparência dos botões, use as opções de aparência na guia Aparência da caixa de diálogo Propriedades do botão.

    • Para alinhar, centralizar ou distribuir o botão com outros campos de formulário, ou para redimensioná-lo ou duplicá-lo, clique com o botão direito do mouse no botão e escolha uma opção no menu de contexto.

  3. Feche todas as caixas de diálogo abertas, se houver. Clique no ícone de cruz na extremidade direita da barra de ferramentas Preparar formulário para fechar a ferramenta.

Especificação das propriedades de exibição de botões do Acrobat

  1. Caso não esteja no modo de edição, selecione Ferramentas > Preparar formulário.

  2. Clique duas vezes em um botão existente e clique na guia Opções da caixa de diálogo Propriedades do botão.
  3. Em Layout, escolha o tipo desejado de exibição de rótulo. (Para obter informações sobre como dimensionar ícones de botões, consulte o próximo procedimento).
  4. Em Comportamento, especifique como será a exibição do botão quando ele for clicado.
  5. Para definir o rótulo ou o ícone a ser exibido no botão, faça o seguinte:
    • Se a opção de rótulo estiver selecionada no menu Layout, digite o texto na caixa Rótulo.

    • Se uma opção de ícone estiver selecionada no menu Layout, clique em Selecionar ícone, Procurar e selecione o arquivo. (Clique em Limpar para remover o ícone selecionado).

  6. Feche todas as caixas de diálogo abertas, se houver. Clique no ícone de cruz na extremidade direita da barra de ferramentas Preparar formulário para fechar a ferramenta.

Opções de comportamento de botões

Nenhum

Mantém a aparência do botão inalterada.

Empurrar

Especifica as aparências para os estados Para Cima, Para Baixo e Sobrepor do mouse. Selecione uma opção em Estado e especifique uma opção de rótulo ou ícone:

Acima

Determina qual será a aparência do botão quando o botão do mouse não for clicado.

Para baixo

Determina a aparência do botão quando o botão do mouse for clicado, mas antes de ser liberado.

Sobrepor

Determina a aparência do botão quando o ponteiro do mouse for mantido sobre o botão.

Contornar

Realça a borda do botão.

Inverter

Reverte as sombras claras e escuras do botão.

Dimensionar e posicionar botões

  1. Caso não esteja no modo de edição, selecione Ferramentas > Preparar formulário.

  2. Clique duas vezes em um botão existente para abrir a caixa de diálogo Propriedades do botão.
  3. Clique na guia Opções, selecione uma das opções de ícone no menu Layout e clique em Avançado.

    Observação:

    O botão Avançado não estará disponível se você escolher Somente rótulo no menu Layout.

  4. Selecione uma opção no menu Quando redimensionar:

    Sempre

    Dimensiona o ícone conforme definido, independentemente de seu tamanho em relação ao tamanho do botão.

    Nunca

    Mantém o tamanho original do ícone; a borda do botão cortará o ícone se ele não couber. Se a opção Nunca estiver selecionada, as opções de dimensionamento não estarão disponíveis.

    O ícone é muito grande

    Dimensiona o ícone conforme definido, somente se for maior que o botão.

    O ícone é muito pequeno

    Dimensiona o ícone conforme definido somente se for menor que o botão.

  5. No menu Dimensionar, selecione se o ícone deverá ser dimensionado proporcionalmente. Se o ícone não for dimensionado proporcionalmente, talvez fique distorcido.

  6. Para certificar-se de que se as partes superior e inferior ou os lados esquerdo e direito do ícone estão alinhados em relação às bordas do botão, selecione Ajustar aos limites.

  7. Para definir em que local o ícone será posicionado dentro do botão, arraste as setas de rolagem. O posicionamento do ícone é definido de acordo com a porcentagem do espaço preservado entre o ícone e o limite esquerdo do campo e entre o ícone e o limite inferior do campo. A configuração padrão (50, 50) posiciona o ícone no meio do campo. Você pode clicar em Redefinir a qualquer momento para voltar à configuração de posicionamento padrão.

  8. Clique em OK e, em seguida, clique em Fechar.

  9. Para visualizar e testar o botão, clique em Visualizar na extremidade direita da barra de ferramentas. Depois de terminar, clique em Editar para retornar à ferramenta Preparar formulário, ou clique no ícone de cruz na extremidade direita da barra de ferramentas para fechar a ferramenta.

Ocultar um botão do Acrobat DC exceto durante a sobreposição

Em alguns casos, convém deixar a área do botão invisível até que o ponteiro do mouse se mova sobre ele. Exibindo e ocultando alternadamente um botão, é possível criar efeitos visuais interessantes em um documento. Por exemplo, ao mover o ponteiro sobre uma cidade em um mapa, pode ser exibido um mapa detalhado da cidade, que pode ser ocultado quando o ponteiro é deslocado para outra área.

Como mostrar e ocultar ícones
Como mostrar e ocultar ícones

A. Ponteiro fora da área do botão B. Ponteiro entra na área do botão C. Ponteiro sai da área do botão 
  1. Caso não esteja no modo de edição, selecione Ferramentas > Preparar formulário.

  2. Usando a ferramenta Botão , arraste pela área em que você deseja exibir o botão pop-up. Por exemplo, se o arquivo PDF tiver um mapa da França, arraste pela área na qual deseja que um mapa detalhado de Paris seja exibido em pop-up.

  3. Clique duas vezes no botão e, em seguida, clique na guia Opções e selecione Somente ícone no menu Layout.

  4. Selecione Pressionar no menu Comportamento e escolha Sobreposição na lista Estado.

  5. Clique em Escolher ícone e, em seguida, clique em Procurar. Selecione o tipo de arquivo em Arquivo do tipo, navegue até o local do arquivo de imagem e clique duas vezes nele. Neste exemplo, selecione um mapa de Paris. Clique em OK para aceitar a imagem visualizada como o botão.

  6. Clique na guia Aparência. Caso necessário, cancele a seleção de Cor da borda e Cor de preenchimentoe, em seguida, clique em Fechar.

  7. Se você estiver no modo de edição, clique em Visualização. O campo de imagem que foi definido aparece à medida que o ponteiro passa sobre a área do botão, e desaparece quando o ponteiro sai da área.

    Observação:

    Para a imagem ser maior do que a área de sobreposição ou aparecer em um local que não seja o do botão de imagem em pop-up, use a ação Mostrar/Ocultar um Campo. Primeiro, especifique um ícone para o botão a ser exibido e ocultado. Em seguida, crie um segundo botão que se comporte como ponto ativo quando o mouse for colocado sobre ele. Não atribua um ícone à aparência do segundo botão. Em vez disso, use a guia Ações para exibir o primeiro botão quando o ponteiro entrar no segundo botão e ocultá-lo quando o ponteiro sair.

  8. Depois de terminar, clique em Editar para retornar à ferramenta Preparar formulário, ou clique no ícone de cruz na extremidade direita da barra de ferramentas para fechar a ferramenta.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online