Publicação de documentos AS3

  1. Guia do Usuário do Adobe Animate
  2. Introdução ao Animate
    1. Novidades no Animate
    2. Glossário visual
    3. Requisitos de sistema do Animate
    4. Atalhos de teclado do Animate
    5. Trabalhar com vários tipos de arquivo no Animate
  3. Animação
    1. Noções básicas de animação no Animate
    2. Como usar quadros e quadros-chave no Animate
    3. Animação quadro a quadro no Animate
    4. Como trabalhar com animação de interpolação clássica no Animate
    5. Ferramenta Pincel
    6. Guia de movimento
    7. Interpolação de movimento e ActionScript 3.0
    8. Sobre a animação com interpolação de movimento
    9. Animações de interpolação de movimento
    10. Criação de uma animação de interpolação de movimento
    11. Utilização dos quadros-chave de propriedade
    12. Animação de posição com uma interpolação
    13. Editar interpolações de movimento usando o Motion Editor
    14. Edição do caminho de movimento de uma animação de interpolação
    15. Manipulação de interpolações de movimento
    16. Adição de atenuações personalizadas
    17. Criação e aplicação das predefinições de movimento
    18. Configuração de extensões de interpolação de animação
    19. Trabalhar com interpolações de movimento salvas como arquivos XML
    20. Interpolações de movimento e interpolações clássicas
    21. Interpolação de formas
    22. Uso da animação da ferramenta Bone no Animate
    23. Trabalhar com manipulação de caracteres no Animate
    24. Como usar camadas de máscara no Adobe Animate
    25. Como trabalhar com cenas no Animate
  4. Interatividade
    1. Como criar botões com o Animate
    2. Converter projetos do Animate em outros formatos de tipo de documento
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Adicionar interatividade com snippets de código no Animate
    5. Criar componentes HTML5 personalizados
    6. Uso de componentes do HTML5 Canvas
    7. Criação de componentes personalizados: exemplos
    8. Snippets de código para componentes personalizados
    9. Práticas recomendadas - Publicidade com o Animate
    10. Criação e publicação de Realidade virtual
  5. Fluxo de trabalho e espaço de trabalho
    1. Criação e gerenciamento de pincéis
    2. Uso de Google Fonts em documentos HTML5 Canvas
    3. Uso das Bibliotecas da Creative Cloud e do Adobe Animate
    4. Uso dos painéis Palco e Ferramentas do Animate
    5. Fluxo e espaço de trabalho do Animate
    6. Uso de fontes da Web em documentos HTML5 Canvas
    7. Linhas de tempo e ActionScript
    8. Trabalhar com múltiplas linhas de tempo
    9. Definir preferências
    10. Uso de painéis de criação do Animate
    11. Criar camadas na linha do tempo com o Animate
    12. Exportar animações para aplicativos móveis e mecanismos de jogo
    13. Mover e copiar objetos
    14. Modelos
    15. Localização e substituição no Animate
    16. Desfazer, refazer e o painel de Histórico
    17. Atalhos de teclado
    18. Como usar a linha do tempo no Animate
    19. Criação de extensões HTML
    20. Opções de otimização para imagens e GIFs animados
    21. Configurações de exportação para imagens e GIFs
    22. Painel Ativos no Animate
  6. Multimídia e vídeo
    1. Transformação e combinação de objetos gráficos no Animate
    2. Criar e trabalhar com instâncias do símbolo no Animate
    3. Traçado de imagem
    4. Como usar som no Adobe Animate
    5. Exportação de arquivos SVG
    6. Criação de arquivos de vídeo para uso no Animate
    7. Como adicionar vídeos no Animate
    8. Trabalhar com pontos de sinalização de vídeo
    9. Desenhar e criar objetos com o Animate
    10. Remodelação de linhas e formas
    11. Traçados, preenchimentos e gradientes com o Animate CC
    12. Trabalhar com o Adobe Premiere Pro e o After Effects
    13. Painéis de cor no Animate CC
    14. Abrir arquivos do Flash CS6 com o Animate
    15. Trabalho com texto clássico no Animate
    16. Aplicação de ilustração final no Animate
    17. Bitmaps importados no Animate
    18. Gráficos em 3D
    19. Trabalhar com símbolos no Animate
    20. Desenhar linhas e formas com o Adobe Animate
    21. Trabalho com bibliotecas no Animate
    22. Exportação de sons
    23. Seleção de objetos no Animate CC
    24. Trabalho com arquivos AI do Illustrator no Animate
    25. Aplicação de padrões com a ferramenta Pincel de borrifar
    26. Aplicação de modos de mesclagem
    27. Organização de objetos
    28. Automação de tarefas com o menu Comandos
    29. Texto multilíngue
    30. Uso de câmera no Animate
    31. Uso do Animate com o Adobe Scout
    32. Trabalhar com arquivos Fireworks
    33. Filtros gráficos
    34. Som e ActionScript
    35. Preferências de desenho
    36. Desenho com a ferramenta Caneta
  7. Plataformas
    1. Converter projetos do Animate em outros formatos de tipo de documento
    2. Suporte da plataforma personalizada
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Criação e publicação de um documento WebGL
    5. Compactação de aplicativos no AIR para iOS
    6. Publicação de AIR em aplicativos Android
    7. Publicação no Adobe AIR para desktop
    8. Configurações de publicação do ActionScript
    9. Práticas recomendadas - Organização do ActionScript em um aplicativo
    10. Como usar ActionScript com o Animate
    11. Práticas recomendadas - Diretrizes de acessibilidade
    12. Acessibilidade no espaço de trabalho do Animate
    13. Programação e gerenciamento de scripts
    14. Ativação do suporte para plataformas personalizadas
    15. Visão geral do suporte da plataforma personalizada
    16. Criação de conteúdo acessível
    17. Trabalhar com plug-ins personalizados de suporte da plataforma
    18. Depuração do ActionScript 3.0
    19. Ativação do suporte para plataformas personalizadas
  8. Publicação e exportação
    1. Exportação de arquivos do Animate CC
    2. Publicação OAM
    3. Exportação de arquivos SVG
    4. Exportar gráficos e vídeos com o Animate
    5. Publicação de documentos AS3
    6. Exportar animações para aplicativos móveis e mecanismos de jogo
    7. Exportação de sons
    8. Exportação de arquivos de vídeo QuickTime
    9. Controle de reprodução de vídeo externo com o ActionScript
    10. Práticas recomendadas - Dicas para a criação de conteúdo em dispositivos móveis
    11. Práticas recomendadas - Convenções de vídeo
    12. Práticas recomendadas - Diretrizes de criação de aplicativos SWF
    13. Práticas recomendadas - Estruturação de arquivos FLA
    14. Práticas recomendadas para otimizar arquivos FLA para o Animate
    15. Configurações de publicação do ActionScript
    16. Especificar configurações de publicação para o Animate
    17. Exportação de arquivos projetores
    18. Exportar imagens e GIFs animados
    19. Modelos de publicação HTML
    20. Trabalhar com o Adobe Premiere Pro e o After Effects
    21. Compartilhar e publicar animações rapidamente

Visão geral da publicação

É possível reproduzir conteúdo destas formas:

  • Em navegadores da Internet equipados com Flash Player

  • Como aplicativo independente chamado projetor

  • Com o controle Flash ActiveX no Microsoft Office e outros hosts ActiveX

  • Com Flash Xtra in Director® e Authorware® da Adobe®

Por padrão, o comando Publicar cria um arquivo SWF e um documento HTML que insere conteúdo do Flash em uma janela do navegador. O comando Publicar também cria e copia arquivos de detecção para o Macromedia Flash 4 do Adobe e versões posteriores. Se você alterar as configurações de publicação, o Flash irá salvar as alterações com o documento. Depois de criar um perfil de publicação, exporte-o para usá-lo em outros documentos ou para que outras pessoas que estejam trabalhando no mesmo projeto possam usá-lo.

Quando você usa os comandos Publicar, Testar filme ou Depurar filme, o Flash cria um arquivo SWF a partir do arquivo FLA. Você pode exibir os tamanhos de todos os arquivos SWF criados a partir do arquivo FLA atual no Inspetor de propriedades do documento.

O Flash® Player 6 e versões posteriores oferecem suporte à codificação de texto Unicode. Com o suporte para Unicode, os usuários podem exibir texto multilíngue, independentemente do idioma do sistema operacional executado pelo player.

Você pode publicar o arquivo FLA em formatos alternativos, como GIF, JPEG e PNG, com o HTML necessário para exibi-los na janela do navegador. Os formatos alternativos permitem que o navegador mostre a animação e a interatividade do arquivo SWF a usuários que não possuem o Adobe Flash Player pretendido instalado. Quando você publica um arquivo FLA em formatos alternativos, as configurações de cada formato são armazenadas no arquivo FLA.

Você pode exportar o arquivo FLA em vários formatos, de forma semelhante à publicação de arquivos FLA em formatos alternativos; porém, as configurações de cada formato de arquivo não são armazenadas no arquivo FLA.

Alternativamente, crie um documento HTML personalizado com qualquer editor HTML e inclua as tags necessárias para exibir um arquivo SWF.

Para testar como o arquivo SWF funciona antes de publicá-lo, use Testar filme (Controlar > Testar filme > Testar) e Testar cena (Controlar > Testar cena).

Wrapper de HTML para documentos AS3

Você precisa de um documento HTML para reproduzir um arquivo SWF em um navegador da web e especificar configurações do navegador. Para exibir um arquivo SWF em um navegador da web, o documento HTML deve usar as tags object e embed com os parâmetros adequados.

Observação:

Você pode gerar um documento HTML usando as tags object e embed corretas por meio da caixa de diálogo Configurações de publicação e selecionando a opção HTML. Para obter mais informações, consulte Especificar configurações de publicação de documentos HTML.

 

O Animate pode criar o documento HTML automaticamente quando você publica um arquivo SWF.

Detecção da presença do Flash Player

Para que os seus conteúdos publicados do Animate sejam vistos pelos usuários da Web, o Flash Player deve estar instalado no navegador de Web.

Os recursos e artigos a seguir apresentam informações atualizadas de como acrescentar códigos às suas páginas da Web para saber se o Flash Player está instalado, além de incluir conteúdos alternativos na página se não estiver instalado.

Consulte a Ajuda do Flash Player para saber se o Flash Player está instalado ou não.

Publicação para dispositivos móveis

Adobe® AIR® for Android® e iOS® permite que você crie conteúdos atraentes para dispositivos móveis usando a linguagem de script, as ferramentas de desenho e os modelos do ActionScript®. Para obter informações detalhadas sobre a criação para dispositivos móveis, consulte Referência para o desenvolvedor do AIR.

Observação:

Dependendo do dispositivo móvel para o qual você está desenvolvendo, certas restrições são aplicáveis quanto ao suporte de comandos e formatos de som do ActionScript. Para obter mais detalhes, consulte os artigos sobre dispositivos móveis no Centro de desenvolvimento para celulares e dispositivos.

Teste de conteúdo de celular com o Simulador de conteúdo móvel

O Simulador de conteúdo móvel é uma maneira de testar conteúdos criados com o Adobe AIR em um ambiente emulado de Android ou iOS. Com o Simulador de conteúdo de celular, você pode usar o comando Controlar > Testar filme para testar seu arquivo em no AIR Debug Launcher para celulares, o que, por sua vez, inicia o simulador.

Uma vez que a janela do simulador está aberta, você pode enviar entradas para o documento como se estivesse em um dispositivo móvel. As entradas disponíveis incluem:

  • Acelerômetro, eixos X, Y, e Z
  • Ângulo de Limiar de Orientação
  • Toque e gestos, incluindo sensibilidade à pressão
  • Localização geográfica, direção e velocidade.
  • Chaves de hardware (presentes em dispositivos Android)

Publicação de documentos AS3 seguros

O Flash Player 8 e versões posteriores contêm os seguintes recursos que ajudam a garantir a segurança dos documentos do :

Proteção contra estouro de buffer

Habilitado automaticamente, esse recurso impede o uso inadequado intencional de arquivos externos em um documento para substituir a memória do usuário ou inserir código destrutivo, como vírus. Isso impede que um documento leia ou grave dados fora do espaço de memória designado do documento no sistema do usuário.

Correspondência de domínio exato para compartilhar dados entre documentos do

O Flash Player 7 e versões posteriores aplicam um modelo de segurança mais restrito do que versões anteriores. O modelo de segurança foi alterado de duas formas principais entre o Flash Player 6 e Flash Player 7:

Correspondência de domínio exato

O Flash Player 6 permite que os arquivos SWF de domínios semelhantes (por exemplo, www.adobe.com e store.adobe) se comuniquem livremente entre si e com outros documentos. No Flash Player 7, o domínio dos dados a ser acessado deve corresponder exatamente ao domínio do provedor de dados para que os domínios se comuniquem.

Restrição de HTTPS/HTTP

Um arquivo SWF carregado por protocolos não seguros (não HTTPS) não pode acessar conteúdo carregado com um protocolo seguro (HTTPS), mesmo que ambos os protocolos estejam exatamente no mesmo domínio.

Segurança de reprodução local e de rede

O Flash Player 8 e versões posteriores incluem um modelo de segurança que permite determinar a segurança de reprodução local e de rede para arquivos SWF que você publica. Por padrão, os arquivos SWF recebem acesso de leitura a arquivos e redes locais. No entanto, um arquivo SWF com acesso local não pode se comunicar com a rede e não pode enviar arquivos ou informações a nenhuma rede.

Permita que os arquivos SWF acessem recursos de rede, deixando o arquivo SWF enviar e receber dados. Se você conceder ao arquivo SWF acesso a recursos da rede, o acesso local será desabilitado, impedindo que as informações no computador local sejam carregadas na rede.

Para selecionar o modelo de segurança de reprodução local ou de rede para os arquivos SWF publicados, use a caixa de diálogo Configurações de publicação.

Flash Player

O Flash Player reproduz conteúdo do Flash da mesma forma em que ele aparece em um navegador da web ou em um aplicativo host ActiveX. O Flash Player é instalado com o aplicativo Flash. Quando você clica duas vezes no conteúdo do Flash , o sistema operacional inicia o Flash Player, que em seguida reproduz o arquivo SWF. Use o player para tornar o conteúdo visível para usuários que não estão usando um navegador da web ou um aplicativo host ActiveX.

Para controlar o conteúdo no Flash Player, use comandos do menu e a função fscommand()

Use o menu de contexto do Flash Player para imprimir quadros de conteúdo do Flash Pro.

  1. Siga um destes procedimentos:

    • Para abrir um arquivo novo ou existente, selecione Arquivo > Novo ou Abrir.

    • Para alterar a exibição do aplicativo, selecione Exibir > Ampliação e faça uma seleção.

    • Para controlar a reprodução do conteúdo, selecione Controlar ou Reproduzir, Retroceder ou Repetir reprodução.

Atualizar ou reinstalar o Flash Player

Se você está tendo problemas com a instalação do Flash Player, é possível atualizá-lo ou reinstalá-lo. Você pode ir à página de download do Flash Player diretamente do Flash , selecionando Ajuda > Obter última versão do Flash Player.

Se preferir desinstalar o Flash Player primeiro, siga estas etapas:

  1. Fechar seu navegador.
  2. Remover qualquer versão atualmente instalada do Player.

    Para obter instruções, consulte TechNote 14157 na Central de suporte ® em www.adobe.com/go/tn_14157_br.

  3. Siga as instruções na tela para instalar o player.

    Você também pode executar um dos seguintes instaladores na sua pasta Players. Entretanto, o instalador disponível no site da Adobe é normalmente mais atualizado do que os disponíveis na pasta Players.

    • Para o controle ActiveX do Windows® (Internet Explorer ou AOL), execute o arquivo Install Flash Player 9 AX.exe.
    • Para o plug‑in do Windows (Firefox, Mozilla, Netscape, Safari ou Opera), execute o arquivo Install Flash Player 9.exe.
    • Para o plug‑in do Macintosh® (AOL, Firefox, Internet Explorer para Macintosh, Netscape, Opera ou Safari), execute a instalação do Flash Player 10 (Mac OS 9.x) ou a instalação do Flash Player 10 OS X (Mac OS X.x).
    Observação:

    Para verificar a instalação, visite o endereço http://www.adobe.com/br/shockwave/welcome/ do seu navegador da Web.

Configurar um servidor para Flash Player

Para que os usuários vejam o conteúdo do Flash na web, o servidor da web deve ser configurado adequadamente para reconhecer arquivos SWF.

A configuração do servidor estabelece os tipos MIME adequados, para que o servidor possa identificar arquivos com a extensão .swf como arquivos do Flash.

Um navegador que recebe o tipo MIME correto pode carregar o plug-in, o controle e o aplicativo de ajuda adequado para processar e exibir adequadamente os dados de entrada. Se o tipo MIME estiver faltando ou não tiver sido fornecido adequadamente pelo servidor, o navegador poderá mostrar uma mensagem de erro ou uma janela em branco com um ícone de peça de quebra-cabeça.

  • Se seu site estiver estabelecido por meio de um provedor de serviços da Internet (ISP), peça ao provedor para adicionar este tipo MIME ao servidor: aplicativo/x-shockwave-flash com a extensão .swf.

  • Se estiver administrando seu próprio servidor, consulte a documentação do servidor web para obter instruções sobre a adição ou a configuração de tipos MIME.

  • Os administradores de sistema corporativos e empresariais podem configurar o Flash para restringir o acesso ao Flash Player a recursos no sistema de arquivos local. Crie um arquivo de configuração de segurança que limita a funcionalidade do Flash Player no sistema local.

O arquivo de configuração de segurança é um arquivo de texto colocado na mesma pasta do instalador do Flash Player. O instalador do Flash Player lê o arquivo de configuração durante a instalação e segue as diretivas de segurança. O Flash Player usa o objeto System para expor o arquivo de configuração para o ActionScript.

Com o arquivo de configuração, desabilite o acesso do Flash Player à câmera ou ao microfone, limite a quantidade de armazenamento local a ser usado pelo Flash Player, controle o recurso de autoatualização e impeça o Flash Player de ler qualquer coisa do disco rígido local do usuário.

Adição de tipos MIME

Quando um servidor web acessa arquivos, ele deve identificá-los adequadamente como conteúdo do Flash para exibi-los. Se o tipo MIME estiver faltando ou não tiver sido entregue adequadamente pelo servidor, o navegador poderá mostrar mensagens de erro ou uma janela em branco com um ícone de peça de quebra-cabeça.

Se seu servidor não estiver configurado adequadamente, você (ou o administrador do sistema) deverá adicionar os tipos MIME do arquivo SWF aos arquivos de configuração do servidor e associar os seguintes tipos MIME às extensões do arquivo SWF:

  • O aplicativo do tipo MIME/x-shockwave-flash tem a extensão de arquivo .swf.

  • O aplicativo de tipo MIME/futuresplash tem a extensão de arquivo .spl.

Se estiver administrando um servidor, consulte a documentação do software do servidor para obter instruções sobre a adição ou a configuração de tipos MIME. Se não estiver administrando um servidor, entre em contato com o provedor de serviços da Internet, o webmaster ou o administrador do sistema para adicionar as informações do tipo MIME.

Se o site estiver em um servidor Mac OS, você também deverá definir os seguintes parâmetros: Action: Binary; Type: SWFL; e Creator: SWF2.

Otimização do mecanismo de pesquisa para conteúdos em SWF

Em meados de 2008, a Adobe anunciou um avanço significativo na tecnologia do Flash Player, que permite que o conteúdo de texto nos arquivos SWF seja indexado por mecanismos de pesquisa, como o Google e o Yahoo!. Existem várias estratégias que você pode empregar para otimizar a visibilidade de seu conteúdo em SWF para os mecanismos de pesquisa. Essas práticas, como um todo, são conhecidas como otimização para mecanismo de pesquisa (SEO).

Sobre Omniture e Flash

O conteúdo em Flash pode ser integrado ao Omniture SiteCatalyst e ao Omniture Test&Target. O SiteCatalyst ajuda os comerciantes a identificar rapidamente os caminhos mais lucrativos em seu site, determinar os pontos em que os visitantes estão deixando o site e identificar métricas de sucesso críticas para campanhas de marketing online. O Test&Target proporciona aos comerciantes a capacidade de tornar, de maneira contínua, seu conteúdo online mais relevante para seus clientes. O Test&Target oferece uma interface para projeto e execução de testes, criação de segmentos de público e direcionamento de conteúdo.

Os clientes do Omniture podem usar o SiteCatalyst e o Test&Target com Flash baixando e instalando o pacote de extensão do Omniture.

  • Para baixar as extensões do Omniture e acessar instruções de como usá-las, escolha Ajuda > Omniture.

Logotipo da Adobe

Fazer logon em sua conta