Efeitos de animação permitem fazer com que objetos se movam nos seus arquivos SWF exportados. Por exemplo, é possível aplicar uma predefinição de movimento a uma imagem que a faça parecer se deslocar no lado esquerdo da tela enquanto ela gira e encolhe. Use as ferramentas e os painéis a seguir para animar documentos.

Clique no botão Reproduzir para exibir uma animação
Clique no botão Reproduzir para exibir uma animação

Painel Animação

Aplique uma predefinição de movimento e edite configurações como duração e velocidade.

Ferramentas Seleção direta e Caneta

Edite o caminho percorrido pelo objeto animado.

Painel Tempo

Determine a ordem na qual os objetos em uma página são animados.

Painel Visualização

Exiba a animação em um painel do InDesign.

Observação:

Um tipo relacionado de animação que pode ser adicionado no InDesign é um efeito de sobreposição de botão. Para mais informações, consulte Criar botões.

Jeff Witchel, do site Infiniteskills.com, apresenta uma visão geral em Animação de layouts.

Animar um documento com predefinições de movimento

Predefinições de movimento são animações pré-criadas que você pode aplicar aos objetos rapidamente. Use o painel Animação para aplicar predefinições de movimento e alterar configurações de animação, como duração e velocidade. O painel Animação também permite especificar quando um objeto animado é reproduzido.

Essas predefinições de movimento são idênticas às disponíveis no Adobe Flash CS5 Professional. Você pode importar qualquer predefinição de movimento personalizada criada no Flash Professional. Você também pode salvar predefinições de movimento que criou e usá-las no InDesign ou no Flash Professional.

Observação:

Os recursos de animação apenas são compatíveis na exportação para o Adobe Flash Player (.SWF). Eles não são compatíveis na exportação para PDF interativo. Para adicionar efeitos de animação a um arquivo PDF, exporte uma seleção como arquivo SWF no InDesign e insira esse arquivo SWF no documento do InDesign.

  1. Insira o objeto que você deseja animar no documento.

  2. No painel Animação (Janela > Interativo > Animação), escolha uma predefinição de movimento no menu Predefinição.

  3. Especifique opções de predefinição de movimento.

  4. Para editar o caminho do movimento, use as ferramentas Caneta e Seleção direta.

  5. Use o painel Tempo para determinar a ordem dos efeitos de animação.

  6. Use o painel Visualização para visualizar a animação no InDesign.

Para remover a animação de um objeto, selecione esse objeto e clique no ícone Excluir, no painel Animação.

Observação:

Quando determinados efeitos de animação, como o Fade In, são combinados com uma transição ou ondulação de página, a animação pode não ter o mesmo comportamento que o esperado no painel de visualização ou no arquivo SWF exportado. Por exemplo, objetos definidos como "fade in" estarão visíveis ao girar a página quando na verdade eles deveriam estar invisíveis. Para evitar esse conflito, não use transições em páginas com animações e desative a opção Incluir ondulação de página interativa na caixa de diálogo Exportação de SWF. As predefinições de movimento podem não funcionar conforme esperado nas transições e ondulações de páginas, incluindo as opções Aparecer, Fade In, as várias predefinições de Fly-in, Ampliar em 2D e Swoosh.

Converter objetos selecionados em um caminho de movimento

Você pode criar uma animação selecionando um objeto e um caminho e convertendo este último em um caminho de movimento. Se tiver selecionado dois caminhos fechados, como dois retângulos, o caminho na parte superior se tornará o caminho do movimento.

  1. Selecione o objeto que deseja animar e o caminho que deseja usar como caminho do movimento.

    Não é possível converter mais de dois objetos selecionados.

  2. No painel Animação, clique no botão Converter em caminho do movimento .

  3. Altere as configurações no painel Animação.

Opções de predefinição de movimento

As opções de predefinição de movimento aparecem no painel Animação. Clique na opção Propriedades para exibir configurações avançadas.

Nome

Especifique um nome para a animação. É útil especificar um nome descritivo ao configurar uma ação que aciona a animação.

Predefinição

Escolha uma opção na lista de configurações de movimento predefinidas.

Evento(s)

Por padrão, a opção Ativado ao carregar página é selecionada, significando que o objeto animado é reproduzido quando a página é aberta no arquivo SWF. Escolha Ativado ao clicar na página para acionar a animação quando a página for clicada. Escolha Ativado ao clicar (por conta própria) ou Ativado ao inverter (por conta própria) para acionar a animação quando o próprio objeto for clicado ou focalizado com o cursor do mouse, respectivamente. Se você criar uma ação de botão que aciona a animação, a opção Ativado por evento de botão será selecionada. (Consulte Adição de ações aos botões.) É possível especificar vários eventos para iniciar a animação.

Se o evento Ativado ao inverter (por conta própria) for selecionado, também será possível selecionar Reverter ao Mover ponteiro para fora. Essa opção inverte a ação da animação quando o mouse se distancia do objeto.

Criar botão de ativação

Clique nesse botão para acionar a animação a partir de um botão ou objeto existente. Depois de clicar em Criar botão de ativação , clique no objeto que aciona a animação. O objeto é convertido em botão, se necessário, e o painel Botões é aberto.

Duração

Especifique o tempo necessário para a exibição da animação.

Reproduzir

Especifique quantas vezes a animação é reproduzida ou selecione Repetir para fazer com que ela seja reproduzida repetidamente até ser interrompida.

Velocidade

Escolha uma opção para determinar se a velocidade da animação é uma taxa estável (Nenhuma), se ela começa lenta e fica mais rápida (Atenuar) ou se fica mais lenta no final (Não atenuar).

Observação:

As opções a seguir estão disponíveis ao expandir Propriedades.

Animar

Escolha A partir da aparência atual para usar as propriedades atuais do objeto (porcentagem de dimensionamento, ângulo de rotação e posição) como ponto de partida da animação.

Escolha Para aparência atual para usar as propriedades do objeto como ponto final da animação. O uso dessa opção é especialmente útil em apresentações de slides. Por exemplo, objetos que se deslocam de fora da página podem aparecer na página em vez de aparecerem na área de trabalho, melhorando a aparência do documento impresso.

Escolha Para local atual para usar as propriedades do objeto atual como ponto de partida da animação e a posição desse objeto como ponto final. Essa opção é semelhante a A partir da aparência atual, com a diferença de que o objeto termina no seu local atual, e o caminho do movimento é deslocado. Ela é especialmente útil para determinadas predefinições, como desfoques e atenuações, para impedir que o objeto apareça em um estado indesejável no final da animação.

Observação:

Para exibir o proxy no final do caminho do movimento, clique em Mostrar proxy da animação na parte inferior do painel Animação.

Configurações de Animar
Configurações de Animar

A. Objeto e caminho antes da animação B. A partir da aparência atual C. Para aparência atual D. Para local atual 

Girar

Especifique um ângulo de rotação que o objeto completa durante a animação.

Origem

Use o proxy para especificar o ponto de origem do caminho do movimento no objeto animado.

Escala

Especifique um valor de porcentagem para determinar se o objeto aumenta ou diminui de tamanho durante a reprodução.

Opacidade

Escolha uma opção para determinar se a animação permanece sólida (Nenhuma), fica gradualmente visível (Aparecimento gradual) ou fica gradualmente invisível (Desaparecimento gradual).

Visibilidade

Selecione Ocultar até animar ou Ocultar após animação para tornar um objeto invisível antes ou depois da reprodução.

Gerenciar predefinições de movimento

É possível salvar configurações de animação como predefinições de movimento que você pode reutilizar facilmente no InDesign. Também é possível importar predefinições de arquivos XML que podem ser abertos no Flash Professional ou compartilhados com outros usuários do InDesign.

Salvar predefinições de movimento para reutilização

Predefinições personalizadas aparecem na parte superior do menu Predefinições, no painel Animação.

  1. No painel Animação, altere as configurações conforme necessário.

  2. Escolha Salvar no menu do painel Animação.

  3. Digite um nome para a predefinição e clique em OK.

Excluir predefinições de movimento personalizadas

Use a caixa de diálogo Gerenciar predefinições para excluir predefinições de movimento que você salvou, duplicou ou importou. Não é possível excluir as predefinições de movimento entre colchetes, que foram instaladas com o InDesign. Quando uma predefinição de movimento é excluída, ela é removida do menu Predefinições e do computador.

  1. Escolha Gerenciar predefinições no menu do painel Animação.

  2. Selecione a predefinição que deseja excluir e clique em Excluir.

Duplicar predefinições de movimento

  1. Escolha Gerenciar predefinições no menu do painel Animação.

  2. Selecione a predefinição que deseja duplicar e clique em Duplicar.

Salvar predefinições de movimento como arquivos XML

Salvar predefinições de movimento como arquivos XML é útil quando você deseja compartilhá-las com outros usuários do InDesign ou abri-las no Flash Professional.

Quando uma predefinição de movimento é salva como arquivo XML, o caminho do movimento é salvo juntamente com as configurações de Duração, Velocidade, Escala, Rotação e Opacidade.

  1. Escolha Gerenciar predefinições no menu do painel Animação.

  2. Selecione uma predefinição e clique em Salvar Como.

  3. Especifique o nome e o local da predefinição de movimento e clique em Salvar.

Importar predefinições de movimento

Você pode importar predefinições de movimento que foram exportadas do InDesign ou do Flash Professional como arquivos XML.

  1. Escolha Gerenciar predefinições no menu do painel Animação.

  2. Clique em "Carregar".

  3. Clique duas vezes no arquivo .xml que você deseja importar.

Editar um caminho de movimento

Quando você seleciona um objeto que possui animação, o caminho do movimento aparece ao lado desse objeto.

Caminho do movimento
Caminho do movimento

A. Ponto de partida B. Ponto final 
  1. Para editar um caminho de movimento, siga qualquer um destes procedimentos:

    • Use as ferramentas Seleção direta e Caneta para editar um caminho de movimento com o mesmo método utilizado para editar um caminho. Consulte Edição de caminhos.

    • Para criar um caminho de movimento a partir de um caminho existente, selecione um caminho e um objeto e clique no botão Converter em caminho do movimento no painel Animação.

    • Para alterar a direção do caminho, clique em Propriedades no painel Animação e escolha uma configuração no menu Animar. (Consulte Opções de predefinição de movimento.) Também é possível selecionar o caminho do movimento e escolher Objeto > Caminhos > Reverter caminho. Se quiser inverter o caminho sem mover o objeto, remova a animação, inverta o caminho e depois refaça a animação.

Usar o painel Tempo para alterar a ordem da animação

Use o painel Tempo para alterar a ordem na qual os objetos animados são reproduzidos. O painel Tempo lista as animações na página espelhada atual com base no evento de página atribuído a cada animação. Por exemplo, é possível alterar um conjunto de animações que ocorrem quando a página é carregada e depois alterar outro conjunto de animações que ocorrem quando essa página é clicada.

Objetos animados são listados na ordem em que foram criados. As animações listadas para o evento Ativado ao carregar página ocorrem sequencialmente por padrão. As animações listadas para o evento Ativado ao clicar na página são reproduzidas em sequência sempre que a página é clicada.

É possível alterar a ordem das animações, fazer com que os objetos sejam reproduzidos ao mesmo tempo e atrasar as animações.

  1. Escolha Janela > Interativo > Tempo para exibir o painel Tempo.

  2. Para determinar se a temporização de eventos Ativado ao carregar página ou Ativado ao clicar na página deve ser editada, escolha uma opção no menu Evento.

    Ativado ao carregar página e Ativado ao clicar na página somente aparecem quando um ou mais itens estão atribuídos a esse evento.

  3. Para editar a temporização, siga qualquer um destes procedimentos:

    • Para alterar a ordem das animações, arraste itens para cima e para baixo na lista. Os itens na parte superior são animados primeiro.

    • Para atrasar a animação, selecione o item e especifique o número de segundos de atraso.

    • Para reproduzir vários objetos animados juntos, selecione os itens na lista e clique no botão Reproduzir junto  para vinculá-los. Pressione Shift e clique para selecionar um intervalo de itens ou pressione Ctrl (Windows) ou Command (Mac OS) e clique para selecionar itens não adjacentes.

    • Se você decidir que não deseja que um ou mais itens vinculados sejam reproduzidos juntos, selecione-os e clique no botão Reproduzir separadamente .

    • Para reproduzir itens vinculados um número específico de vezes ou repeti-los em loop, selecione todos os itens que estão vinculados e especifique quantas vezes as animações são reproduzidas ou selecione Repetir.

    • Para alterar qual evento aciona a animação, selecione o item e escolha Reatribuir para Ativado ao carregar página ou Reatribuir para Ativado ao clicar na página.

    • Para remover um item do evento atualmente selecionado (como Ativado ao carregar página ou Ativado ao clicar na página), escolha Remover item. Se o item não estiver atribuído a nenhum evento, ele aparecerá na categoria Não atribuído, que pode ser escolhida no menu Evento.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online