用户指南 取消(C)

创建动画

  1. 《Illustrator 用户指南》
  2. 了解 Illustrator
    1. Illustrator 简介
      1. Illustrator 的新增功能
      2. 常见问题
      3. Illustrator 系统要求
      4. 适用于 Apple Silicon 的 Illustrator
    2. 工作区
      1. 工作区基础知识
      2. 创建文档
      3. 工具栏
      4. 默认键盘快捷键
      5. 自定快捷键
      6. 画板简介
      7. 管理画板
      8. 自定义工作区
      9. “属性”面板
      10. 设置首选项
      11. 触控工作区
      12. Illustrator 中的 Microsoft Surface Dial 支持
      13. 恢复、撤消、历史记录和自动化
      14. 旋转视图
      15. 标尺、网格和参考线
      16. Illustrator 中的无障碍功能
      17. 安全模式
      18. 查看图稿
      19. 将 Touch Bar 与 Illustrator 结合使用
      20. 文件和模板
    3. Illustrator 中的工具
      1. 工具概览
      2. 选择工具
        1. 选择
        2. 直接选择
        3. 编组选择
        4. 魔棒
        5. 套索
        6. 画板
      3. 导航工具
        1. 抓住
        2. 旋转视图
        3. 缩放
      4. 绘图工具
        1. 渐变
        2. 网格
        3. 形状生成器
      5. 文本工具
        1. 文字
        2. 路径文字
        3. 垂直文字
      6. 绘图工具
        1. 钢笔
        2. 添加锚点
        3. 删除锚点
        4. 锚点
        5. 曲率
        6. 直线段
        7. 矩形
        8. 圆角矩形
        9. 椭圆
        10. 多边形
        11. 星形
        12. 画笔
        13. 斑点画笔
        14. 铅笔
        15. Shaper
        16. 切片
      7. 修改工具
        1. 旋转
        2. 镜像
        3. 缩放
        4. 切变
        5. 宽度
        6. 自由变换
        7. 滴管
        8. 混合
        9. 橡皮擦
        10. 剪刀
  3. Illustrator iPad 版
    1. Illustrator iPad 版简介
      1. Illustrator iPad 版概述
      2. Illustrator iPad 版常见问题解答
      3. 系统要求 | Illustrator iPad 版
      4. 在 Illustrator iPad 版上可以或无法执行的操作
    2. 工作区
      1. Illustrator iPad 版工作区
      2. 触控快捷键和手势
      3. Illustrator iPad 版的键盘快捷键
      4. 管理应用程序设置
    3. 文档
      1. 在 Illustrator iPad 版中处理文档
      2. 导入 Photoshop 和 Fresco 文档
    4. 选择和排列对象
      1. 创建重复对象
      2. 混合对象
    5. 绘图
      1. 绘制和编辑路径
      2. 绘制和编辑形状
    6. 文字
      1. 处理文字和字体
      2. 在路径上创建文本设计
      3. 添加您自己的字体
    7. 处理图像
      1. 对栅格图像进行矢量化
    8. 颜色
      1. 应用颜色和渐变
  4. 云文档
    1. 基本信息
      1. 使用 Illustrator 云文档
      2. 共享并协作处理 Illustrator 云文档
      3. 升级 Adobe Illustrator 的云存储空间
      4. Illustrator 云文档 | 常见问题
    2. 故障诊断
      1. Illustrator 云文档创建或存储问题故障诊断
      2. 对 Illustrator 云文档问题进行故障诊断
  5. 添加和编辑内容
    1. 绘图
      1. 绘图基础知识
      2. 编辑路径
      3. 绘制像素级优化的图稿
      4. 使用钢笔、曲率或铅笔工具绘制
      5. 绘制简单线段和形状
      6. 图像描摹
      7. 简化路径
      8. 定义透视网格
      9. 符号工具和符号组
      10. 调整路径段
      11. 利用简单 5 步设计花朵
      12. 透视图
      13. 符号
      14. 绘制用于 Web 工作流程的像素对齐路径
    2. 3D 效果和 Adobe Substance 材质
      1. 关于 Illustrator 中的 3D 效果
      2. 创建 3D 图形
      3. 将图稿贴在 3D 对象上
      4. 创建 3D 对象
      5. 创建 3D 文本
    3. 颜色
      1. 关于颜色
      2. 选择颜色
      3. 使用和创建色板
      4. 调整颜色
      5. 使用“Adobe Color 主题”面板
      6. 颜色组(协调)
      7. “颜色主题”面板
      8. 重新着色图稿
    4. 绘画
      1. 关于绘画
      2. 使用填色和描边上色
      3. 实时上色组
      4. 渐变
      5. 画笔
      6. 透明度和混合模式
      7. 为对象应用描边
      8. 创建和编辑图案
      9. 网格
      10. 图案
    5. 选择和排列对象
      1. 选择对象
      2. 图层
      3. 编组和扩展对象
      4. 移动、对齐和分布对象
      5. 堆叠对象    
      6. 锁定、隐藏和删除对象
      7. 复制对象
      8. 旋转和镜像对象
    6. 改变对象形状
      1. 裁切图像
      2. 变换对象
      3. 组合对象
      4. 剪切、分割和裁切对象
      5. 操控变形
      6. 缩放、倾斜和扭曲对象
      7. 混合对象
      8. 使用封套改变形状
      9. 使用效果改变对象形状
      10. 使用 Shaper 和形状生成器工具构建新的形状
      11. 使用实时转角
      12. 增强的支持触摸式变形工作流程
      13. 编辑剪贴蒙版
      14. 实时形状
      15. 使用形状生成器工具创建形状
      16. 全局编辑
    7. 文字
      1. 添加文本并使用文字对象
      2. 创建项目符号列表和编号列表
      3. 管理文本区域
      4. 字体和排版
      5. 设置文字格式
      6. 导入和导出文本
      7. 设置段落格式
      8. 特殊字符
      9. 创建路径文字
      10. 字符和段落样式
      11. 制表符
      12. 文本和文字
      13. 查找缺失字体(Typekit 工作流程)
      14. 从 Illustrator 10 更新文本
      15. 阿拉伯语和希伯来语文字
      16. 字体 | 常见问题解答和故障排除提示
      17. 创建 3D 文本效果
      18. 创意排版设计
      19. 缩放和旋转文字
      20. 行距和字距
      21. 连字和换行
      22. 文本增强功能
      23. 拼写和语言词典
      24. 设置亚洲字符格式
      25. 亚洲语言脚本书写器
      26. 使用混合对象创建文本设计
      27. 使用图像描摹创建文本海报
    8. 创建特殊效果
      1. 使用效果
      2. 图形样式
      3. 创建投影
      4. 外观属性
      5. 创建素描和马赛克
      6. 投影、发光和羽化
      7. 效果小结
    9. Web 图形
      1. 创建 Web 图形的最佳做法
      2. 图表
      3. SVG
      4. 创建动画
      5. 切片和图像映射
  6. 导入、导出和存储
    1. 导入
      1. 置入多个文件
      2. 管理链接和嵌入文件
      3. 链接信息
      4. 取消嵌入图像
      5. 从 Photoshop 导入图稿
      6. 导入位图图像
      7. 导入 Adobe PDF 文件
      8. 导入 EPS、DCS 和 AutoCAD 文件
    2. Illustrator 中的 Creative Cloud Libraries 
      1. Illustrator 中的 Creative Cloud Libraries
    3. 保存
      1. 存储图稿
    4. 导出
      1. 在 Photoshop 中使用 Illustrator 图稿
      2. 导出图稿
      3. 收集资源并批量导出
      4. 打包文件
      5. 创建 Adobe PDF 文件
      6. 提取 CSS | Illustrator CC
      7. Adobe PDF 选项
      8. 文件信息和元数据
  7. 打印
    1. 准备打印
      1. 设置打印文档
      2. 更改页面大小和方向
      3. 指定用于裁切或对齐的裁切标记
      4. 大型画布快速入门
    2. 打印
      1. 叠印
      2. 使用颜色管理进行打印
      3. PostScript 打印
      4. 打印预设
      5. 印刷标记和出血
      6. 打印和存储透明图稿
      7. 陷印
      8. 打印分色
      9. 打印渐变、网格和颜色混合
      10. 白色叠印
  8. 任务自动化
    1. 使用“变量”面板合并数据
    2. 脚本的自动化
    3. 动作的自动化
  9. 故障诊断 
    1. 崩溃问题
    2. 崩溃后恢复文件
    3. 文件问题
    4. 支持的文件格式
    5. GPU 设备驱动程序问题
    6. Wacom 设备问题
    7. DLL 文件问题
    8. 内存问题
    9. 首选项文件问题
    10. 字体问题
    11. 打印机问题
    12. 与 Adobe 共享崩溃报告
    13. 改进 Illustrator 性能

关于 Flash 图形

Flash (SWF) 文件格式是一种基于矢量的图形文件格式,它用于适合 Web 的可缩放小尺寸图形。由于这种文件格式基于矢量,因此,图稿可以在任何分辨率下保持其图像品质,并且非常适于创建动画帧。在 Illustrator 中,可以在图层上创建单独的动画帧,然后将图像图层导出到网站上使用的单独帧中。也可以在 Illustrator 文件中定义符号以减小动画的大小。在导出后,每个符号仅在 SWF 文件中定义一次。

您可以使用 “导出”命令 或“存储为 Web 和设备所用格式”命令,将图稿存储为 SWF 文件。这两个命令的优点包括:

导出 (SWF) 命令

对动画和位图压缩进行最大程度的控制。

存储为 Web 和设备所用格式命令

对在切片布局中混合使用 SWF 和位图格式进行较大程度的控制。与“导出 (SWF)”命令相比,此命令提供的图像选项更少 , 但它可以使用“导出”命令上次所用的设置。

在准备将存储为 SWF 的图稿时,请牢记以下信息:

  • 要在使用符号时尽量减小文件大小,请为“符号”面板中的符号(而不是图稿中的符号实例)应用效果。

  • 使用“符号着色器”和“符号样式器”工具会导致 SWF 文件更大,因为 Illustrator 必须创建每个符号实例的副本以保持它们的外观。

  • 具有 8 个以上色标的网格对象和渐变会被栅格化,并将显示为以位图填充的形状。色标少于 8 个的渐变被作为渐变导出。

  • 图案被栅格化为小图像,其大小为图案作品的大小,并被拼贴以填充作品。

  • 如果位图对象超出切片边界,那么整个对象包含于导出的文件中。

  • SWF 仅支持圆头端点和连接。导出到 SWF 后,斜角或方形端点和连接将变为圆角。

  • 图案填充的文本和图案填充的描边将转换为路径,并使用图案进行填充。

  • 虽然导出到 SWF 时文本保留了它的很多特性,但会丢失某些信息。将 SWF 文件导入到 Flash 时,不会保留行距、字偶间距和字符间距, 而是将文本断开为单独记录以模拟行距外观。随后在 Flash Player 中播放 SWF 文件时,将保留文件中的行距、字偶间距和字符间距的外观。如果希望将文本导出为路径,请在“SWF 选项”对话框中选择“将文本导出为轮廓”,或者在导出到 SWF 之前选择“创建轮廓”命令先将文本转换为轮廓。

创建 Flash 动画

Illustrator 中有许多可用来创建 Flash 动画的方法。最容易的一种是将每个动画帧放置在不同的 Illustrator 图层上,并在导出图稿时选择“AI 图层到 SWF 帧”选项。

  1. 创建要制成动画的图稿。可以使用符号来减小动画的文件大小,并简化您的作品。
  2. 为动画中的每一帧创建单独的图层。

    可以通过将基本图稿粘贴到新图层然后编辑此图稿来完成此操作。或者,可以使用“释放到图层”命令自动生成包含累积建立的对象的图层。

  3. 确保图层的顺序与动画帧播放的顺序一致。
  4. 执行下列操作之一:
    • 选择“文件”>“导出”,选择“Flash (SWF)”作为格式,然后单击“导出”。在“SWF 选项”对话框中,选择“导出为”中的“AI 图层到 SWF 帧”。设置其他动画选项,然后单击“确定”。

    • 选取“文件”>“存储为 Web 和设备所用格式”。从“优化的文件格式”菜单中选取“SWF”。从“导出类型”菜单中,选取“AI 图层到 SWF 帧”。设置其他选项,然后单击“存储”。

使用 Illustrator 和 Flash

可以将 Illustrator 图稿移到 Flash 编辑环境中,或者将其直接移到 Flash Player 中。您可以复制和粘贴图稿、以 SWF 格式存储文件,或者将图稿直接导出到 Flash。另外,Illustrator 还提供了对 Flash 动态文本和影片剪辑符号的支持。

也可以使用 Device Central 来查看 Illustrator 图稿在各种手持设备上的 Flash Player 中的显示效果。

粘贴 Illustrator 图稿

在 Illustrator 中,可以方便、快速且无缝地创建图形丰富的图稿、复制图稿并将其粘贴到 Flash 中。

将 Illustrator 图稿粘贴到 Flash 时,将保留以下属性:

  • 路径和形状

  • 可伸缩性

  • 描边粗细

  • 渐变定义

  • 文本(包括 OpenType 字体)

  • 链接的图像

  • 符号

  • 混合模式

另外,Illustrator 和 Flash 还通过以下方式支持粘贴的图稿:

  • 在 Illustrator 图稿中选择整个顶层图层并将其粘贴到 Flash 时,将保留这些图层及其属性(可视性和锁定)。

  • 在 Flash 中,非 RGB Illustrator 颜色(CMYK、灰度和自定)将转换为 RGB。RGB 颜色将按预期方式进行粘贴。

  • 导入或粘贴 Illustrator 图稿时,可以使用各种不同的选项将效果(如文本上的投影)保存为 Flash 滤镜。

  • Flash 保留 Illustrator 蒙版。

从 Illustrator 中导出 SWF 文件

从 Illustrator 中,可以导出与从 Flash 导出的 SWF 文件的品质和压缩相匹配的 SWF 文件。

在进行导出时,可以从各种预设中进行选择以确保获得最佳输出,并且可以指定如何处理多个画板、符号、图层、文本以及蒙版。例如,可以指定是将 Illustrator 符号导出为影片剪辑还是图形,或者可以选择通过 Illustrator 图层来创建 SWF 符号。

将 Illustrator 文件导入到 Flash

如果要在 Illustrator 中创建完整的版面,然后使用一个步骤将其导入到 Flash 中,则可以按原有的 Illustrator 格式 (AI) 存储图稿,并在 Flash 中使用"文件">"导入到舞台"或"文件">"导入到库"命令将其导入到 Flash 中(具有较高的保真度)。

如果 Illustrator 文件包含多个画板,在 Flash 的"导入"对话框中选择要导入的画板,并为此画板中各个图层指定设置。所选画板上所有对象导入为 Flash 中的单个图层。如果要从同一 AI 文件中导入另一个画板,此画板上的对象导入为 Flash 中的新图层。

将 Illustrator 图稿作为 AI、EPS 或 PDF 文件导入时,Flash 将保留与粘贴的 Illustrator 图稿相同的属性。另外,如果导入的 Illustrator 文件包含图层,也可以使用以下任何方法来导入它们:

  • 将 Illustrator 图层转换为 Flash 图层

  • 将 Illustrator 图层转换为 Flash 帧

  • 将所有 Illustrator 图层转换为单个 Flash 图层

符号工作流程

Illustrator 中的符号工作流程类似于 Flash 中的符号工作流程。

符号创建

在 Illustrator 中创建符号时,可以使用"符号选项"对话框来命名符号并设置特定于 Flash 的选项:影片剪辑符号类型(Flash 符号的默认类型)、Flash 注册网格位置以及 9 格切片缩放参考线。另外,还可以在 Illustrator 和 Flash 中使用很多相同符号的键盘快捷键(如 F8 键用于创建符号)。

用于符号编辑的隔离模式

在 Illustrator 中双击某个符号,在隔离模式下将其打开以便于进行编辑。在隔离模式下,只能编辑符号实例,画板上的所有其它对象将灰显并且无法使用。在退出隔离模式后,将相应地更新"符号"面板中的符号以及该符号的所有实例。在 Flash 中,符号编辑模式与"库"面板的工作方式类似。

符号属性和链接

通过使用"符号"面板或"控制"面板,您可以方便地为符号实例指定名称、断开实例与符号之间的链接、与其它符号交换符号实例或创建符号副本。在 Flash 中,"库"面板中的编辑功能具有类似的工作方式。

静态、动态以及输入文本对象

将静态文本从 Illustrator 导入到 Flash 时,Flash 会将该文本转换为轮廓。另外,还可以在 Illustrator 中将文本设置为动态文本。通过使用动态文本,您可以在 Flash 中以编程方式编辑文本内容,并且可以方便地管理需要以多种语言本地化的项目。

在 Illustrator 中,您可以将各个文本对象指定为静态、动态或输入文本。Illustrator 和 Flash 中的动态文本对象具有类似的属性。例如,它们都使用影响文本块中所有字符而非单个字符的字距微调;它们以相同方式消除文本锯齿;并且它们都可以链接到包含文本的外部 XML 文件。

Adobe 徽标

登录到您的帐户