当您存储或导出图稿时,Illustrator 将图稿数据写入到文件。数据的结构取决于选择的文件格式。

可将图稿存储为五种基本文件格式 - AI、PDF、EPS、FXG 和 SVG。这些格式称为本机格式,因为它们可保留所有 Illustrator 数据,包括多个画板。(对于 PDF 和 SVG 格式,您必须选择“保留 Illustrator 编辑功能”选项以保留所有 Illustrator 数据。)EPS 和 FXG 可以将各个画板存储为单独的文件。SVG 只存储现用画板;但是,所有画板的内容都会显示。

您还可以以多种文件格式导出图稿,供在 Illustrator 以外使用。这些格式称为非本机格式,因为如果您在 Illustrator 中重新打开文件,Illustrator 将无法检索所有数据。出于这个原因,建议您以 AI 格式存储图稿,直到创建完,然后将图稿导出为所需格式。

注意:

存储包含链接的 EPS 文件的图稿时,如果这些文件以二进制格式存储(例如,Photoshop 的默认 EPS 格式),您可能收到错误消息。在这种情况下,请以 ASCII 格式重新存储 EPS 文件,将链接文件嵌入到 Illustrator 图稿中,或将图稿以 AI 或 PDF 格式存储,而不是 EPS 格式。

有关存储为 Web 所用格式的视频,请观看将图稿存储为 Web 所用格式

用 Illustrator 格式存储

如果您的文档包含多个画板并且您希望存储到以前的 Illustrator 版本中,可以选择将每个画板存储为一个单独的文件,或者将所有画板中的内容合并到一个文件中。

  1. 选择“文件”>“存储为”或“文件”>“存储副本”。

  2. 键入文件名,并选择存储文件的位置。

  3. 选择 Illustrator (*.AI) 作为文件格式,然后单击“存储”。

  4. 在“Illustrator 选项”对话框中设置所需选项,然后单击“确定”。

    版本

    指定希望文件兼容的 Illustrator 版本。旧版格式不支持当前版本 Illustrator 中的所有功能。因此,当您选择当前版本以外的版本时,某些存储选项不可用,并且一些数据将更改。务必阅读对话框底部的警告,这样您可以知道数据将如何更改。

    子集化嵌入的字体,若被使用的字符百分比低于

    指定何时根据文档中使用的字体的字符数量嵌入完整字体(相对于文档中使用的字符)。例如,如果字体包含 1,000 个字符但文档仅使用其中 10 个字符,则您可以确定不值得为了嵌入该字体而额外增加文件大小。

    创建 PDF 兼容文件

    在 Illustrator 文件中存储文档的 PDF 演示。如果希望 Illustrator 文件与其他 Adobe 应用程序兼容,请选择此选项。

    包括链接文件

    嵌入与图稿链接的文件。

    嵌入 ICC 配置文件

    创建色彩受管理的文档。

    使用压缩

    在 Illustrator 文件中压缩 PDF 数据。使用压缩将增加存储文档的时间,因此如果您现在的存储时间很长(8 至 15 分钟)请取消选择此选项。

    将每个画板存储到单独的文件

    将每个画板存储为单独的文件同时还会单独创建一个包含所有画板的主文件。触及某个画板的所有内容都会包括在与该画板对应的文件中。如果需要移动画稿以便可以容纳到一个画板中,则会显示一条警告消息来通知您。如果不选择此选项,则画板会合并到一个文档中,并转换为对象参考线和(在 Illustrator CS3 中)裁剪区域。用于存储的文件的画板基于默认文档启动配置文件的大小。

    透明度选项

    确定当您选择早于 9.0 版本的 Illustrator 格式时,如何处理透明对象。选择“保留路径”可放弃透明度效果并将透明图稿重置为 100% 不透明度和“正常”混合模式。选择“保留外观和叠印”可保留与透明对象不相互影响的叠印。与透明对象相互影响的叠印将拼合。

    注意:如果您的图稿包含复杂重叠区域并且您需要高分辨率输出,请单击“取消”并指定栅格化设置,然后再继续。

用 EPS 格式存储

几乎所有页面版式、文字处理和图形应用程序都接受导入或置入的封装 PostScript (EPS) 文件。EPS 格式保留许多使用 Adobe Illustrator 创建的图形元素,这意味着可以重新打开 EPS 文件并作为 Illustrator 文件编辑。因为 EPS 文件基于 PostScript 语言,所以它们可以包含矢量和位图图形。如果您的图稿包含多个画板,则将其存储为 EPS 格式时,会保留这些画板。

  1. 如果图稿包含透明度(包括叠印)并要求高分辨率输出,请选择“窗口”>“拼合器预览”以预览拼合效果。

  2. 选择“文件”>“存储为”或“文件”>“存储副本”。

  3. 键入文件名,并选择存储文件的位置。

  4. 选择 Illustrator EPS (*.EPS) 作为文件格式,然后单击“存储”。

  5. 要为每个画板创建单独的文件,请单击“使用画板”,并选择“全部”或指定范围。单独的文件存储成一个含全部画板的主 EPS 文件。如果取消选择此选项,则会创建一个保留所有画板的 EPS 文件。

  6. 在“EPS 选项”对话框中设置所需选项,然后单击“确定”。

    版本

    指定希望文件兼容的 Illustrator 版本。旧版格式不支持当前版本 Illustrator 中的所有功能。因此,当您选择当前版本以外的版本时,某些存储选项不可用,并且一些数据将更改。务必阅读对话框底部的警告,这样您可以知道数据将如何更改。

    格式

    确定文件中存储的预览图像的特性。预览图像在不能直接显示 EPS 图稿的应用程序中显示。如果您不希望创建预览图像,请从“格式”菜单中选择“无”。否则,请选择黑白或颜色格式。

    如果您选择 TIFF(8 位颜色)格式,请为预览图像选择背景选项:

    透明

    生成透明背景。

    不透明

    生成实色背景。(如果 EPS 文档将在 Microsoft Office 应用程序中使用,请选择“不透明”。)

    透明度选项

    确定如何处理透明对象和叠印。可用选项根据您在对话框顶部选择的格式版本更改。

    如果您选择 CS 格式,请指定如何存储设置为叠印的重叠颜色,并选择拼合透明度的预设值(或选项集)。单击“自定”以自定拼合器设置。

    如果您选择早于 8.0 的旧版格式,请选择“保留路径”放弃透明效果,并将透明图稿重置为 100% 不透明度和“正常”混合模式。选择“保留外观和叠印”可保留与透明对象不相互影响的叠印。与透明对象相互影响的叠印将拼合。

    嵌入字体(对于其他应用程序)

    嵌入所有从字体供应商获得相应许可的字体。嵌入字体确保如果文件置入到另一个应用程序(例如 Adobe InDesign),将显示和打印原始字体。但是,如果在没有安装相应字体的计算机上的 Illustrator 中打开该文件,将仿造或替换该字体。这样是为防止非法使用嵌入字体。

    注意:选择“嵌入字体”选项会增加存储文件的大小。

    包括链接文件

    嵌入与图稿链接的文件。

    包括文档缩览图

    创建图稿的缩览图图像。缩览图显示在 Illustrator“打开”和“置入”对话框中。

    在 RGB 文件中包括 CMYK PostScript

    允许从不支持 RGB 输出的应用程序打印 RGB 颜色文档。在 Illustrator 中重新打开 EPS 文件时,将保留 RGB 颜色。

    兼容渐变和渐变网格打印

    使旧的打印机和 PostScript 设备可以通过将渐变对象转换为 JPEG 格式来打印渐变和渐变网格。选择此选项可使不存在渐变打印问题的打印机上的打印变慢。

    Adobe PostScript®

    确定用于存储图稿的 PostScript 级别。PostScript 语言级别 2 表示彩色以及灰度矢量和位图图像,并支持用于矢量和位图图形的 RGB、CMYK 和基于 CIE 的颜色模型。PostScript 语言级别 3 提供语言级别 2 没有的功能,包括打印到 PostScript® 3™ 打印机时打印网格对象的功能。由于打印到 PostScript 语言级别 2 设备将渐变网格对象转换为位图图像,因此建议将包含渐变网格对象的图稿打印到 PostScript 3 打印机。

以 SVG 格式存储

SVG 是一种可产生高质量交互式 Web 图形的矢量格式。SVG 格式有两种版本:SVG 和压缩 SVG (SVGZ)。SVGZ 可将文件大小减小 50% 至 80%;但是您不能使用文本编辑器编辑 SVGZ 文件。

当您将图稿存储为 SVG 格式时,网格对象将栅格化。此外,没有 Alpha 通道的图像将转换为 JPEG 格式。具有 Alpha 通道的图像将转换为 PNG 格式。如果文档包含多个画板并且存储为 SVG,则现用画板会被保留。不能将每个画板各存储为一个单独的 SVG 文件。

  1. 如果图稿包含任何 SVG 效果,请选择已经应用 SVG 效果的每一个项目,然后将效果移动到“外观”面板的底部(正好位于“不透明度”条目的上方)。如果 SVG 效果后面还有其他效果,SVG 输出将由栅格对象组成。此外,如果图稿包含多个画板,请选择要导出的画板。

  2. 选择“文件”>“存储为”或“文件”>“存储副本”。

  3. 键入文件名,并选择存储文件的位置。

  4. 选择 SVG (*.SVG) 或 SVG 压缩 (*.SVGZ) 作为文件格式,然后单击“存储”。

  5. 在“SVG 选项”对话框中,设置所需选项,然后单击“确定”:

    SVG 配置文件

    为导出的文件指定 SVG XML 文档类型定义

    SVG 1.0 和 SVG 1.1

    适合将在台式计算机上查看的 SVG 文件。SVG 1.1 是 SVG 规范的完整版本,其中 SVG Tiny 1.1、SVG Tiny 1.1 Plus 和 SVG Basic 1.1 是子集。

    SVG Basic 1.1

    适合将在中型设备(例如手持设备)上查看的 SVG 文件。切记,并非所有手持设备都支持 SVG Basic 配置文件。因此,选择此选项不保证 SVG 文件可在所有手持设备上查看。SVG Basic 不支持非矩形剪切和一些 SVG 滤镜效果。

    SVG Tiny 1.1 和 SVG Tiny 1.1+

    适合要在小型设备(例如手机)上查看的 SVG 文件。切记,并非所有手机都支持 SVG TinySVG Tiny Plus 配置文件。因此,选择这两个选项之一不保证 SVG 文件可在所有小型设备上查看。

    SVG Tiny 1.2

    适合于将在多种设备(从 PDA 和手机到便携式计算机和台式机)上查看的 SVG 文件。

    SVG Tiny 不支持渐变、透明度、剪贴、蒙版、符号、图案、下划线文本、删除线文本、垂直文本或 SVG 滤镜效果。SVG Tiny Plus 包括显示渐变和透明度的功能,但不支持剪贴、蒙版、符号或 SVG 滤镜效果。

    提示:有关 SVG 配置文件的其他信息,请参阅万维网联盟 (WC) 网站 (www.w3.org) 上的 SVG 规范。

    字体类型

    指定如何导出字体:

    Adobe CEF

    使用字体提示以更好渲染小字体。Adobe SVG 查看器支持此字体类型,但其他 SVG 查看器可能不支持。

    SVG

    不使用字体提示。所有 SVG 查看器均支持此字体类型。

    转换为轮廓

    将文字转换为矢量路径。使用此选项可保留文字在所有 SVG 查看器中的视觉外观。

    字体子集

    控制在导出的 SVG 文件中嵌入哪些字形(特定字体的字符)。如果您可以依赖安装在最终用户系统上的必需字体,请从“子集”菜单选择“无”。选择“仅使用的字形”仅包括当前图稿中存在的文本的字形。其他值(通用英文、通用英文使用的字形通用罗马字通用罗马字使用的字形所有字形)在 SVG 文件的文本内容为动态(例如服务器生成的文本或用户交互文本)时有用。

    图像位置

    确定栅格图像直接嵌入到文件或链接到从原始 Illustrator 文件导出的 JPEG 或 PNG 图像。嵌入图像将增大文件大小,但可以确保栅格化图像将始终可用。

    保留 Illustrator 编辑功能

    通过在 SVG 文件中嵌入 AI 文件(产生更大的文件大小)保留特定于 Illustrator 的数据。如果您计划在 Illustrator 中重新打开和编辑 SVG 文件,请选择此选项。请注意,如果您手动更改 SVG 数据,当您重新打开文件时更改不会反映出来。这是因为 Illustrator 读取文件的 AI 部分,而不是 SVG 部分。

    CSS 属性

    确定如何在 SVG 代码中存储样式属性。默认的方法(“演示文稿属性”)在层次的最高点应用属性,可使特定编辑和转换具有最大的灵活性。“样式属性”方法可创建最具可读性的文件,但是可能会增加文件的大小。如果 SVG 代码将用于变换,例如使用可扩展样式表语言变换 (XSLT) 的变换,请选择此方法。“样式属性”<Entity References>方法实现更快速的渲染并减小 SVG 文件大小。与 HTML 文档共享文件时使用“样式元素”方法。通过选择“样式元素”,您可以修改 SVG 文件以便将样式元素移动到同时由 HTML 文件引用的外部样式表文件中;不过,“样式元素”选项同时会降低渲染速度。

    小数位数

    指定 SVG 文件中矢量数据的精度。可以设置 1 到 7 之间的值作为小数位数。更高的值将导致更大的文件大小和更好的图像品质。

    编码

    确定 SVG 文件中的字符编码方式。所有 XML 处理程序都支持 UTF(Unicode 变换格式)编码。(UTF-8 编码是 8 位格式;UTF-16 编码是 16 位格式。) ISO 8859-1 和 UTF-16 编码不保留文件元数据。

    为 Adobe SVG 查看器优化

    保持 Illustrator 数据的最高水平,同时允许手动编辑 SVG 文件。选择此选项可使用更快速的渲染功能,例如 SVG 滤镜效果。

    包含 Adobe Graphics Server 数据

    包括在 SVG 文件中进行变量替代所需的所有信息。

    包含切片数据

    包含切片位置和优化设置。

    包含 XMP

    在 SVG 文件中包含 XMP 元数据。选择“文件”>“信息”或使用 Bridge 浏览器输入元数据。

    输出较少<tspan>元素

    允许 Illustrator 在导出时忽略自动字偶间距调整设置,产生具有较少<tspan>元素的文件。设置此选项创建可编辑性更强且更紧密的 SVG 文件。如果保持自动字偶间距调整文本的外观很重要,请取消选择此选项。

    在路径文本对象上使用<textPath>元素

    导出路径上的文本作为<textPath>元素。但是,请注意,文本在 SVG 查看器中的显示可能与在 Illustrator 中不同,因为这一导出模式不始终保持视觉上的对等。尤其是,溢流文本将在 SVG 查看器中可见。

    显示 SVG 代码

    在浏览器窗口中显示 SVG 文件的代码。

    Web 预览

    在浏览器窗口中显示 SVG 文件。

    Device Central

    在 Device Central 中打开文件以便在特定的移动电话或设备上进行预览。

将图稿存储为 Microsoft Office 所用格式

“存储为 Microsoft Office 所用格式”命令使您可创建一个能在 Microsoft Office 应用程序中使用的 PNG 文件。

  1. 选择“文件”>“存储为 Microsoft Office 所用格式”。

  2. 在“存储为 Microsoft Office 所用格式”对话框中,选择文件的位置,输入文件名,然后单击“保存”。

    注意:

    如果您要自定 PNG 设置,例如分辨率、透明度和背景颜色,请使用“导出”命令而不是“存储为 Microsoft Office 所用格式”命令。您也可以使用“存储为 Web 和设备所用格式”命令将图稿存储为 PNG 格式。

将矢量图形转换为位图图像

关于栅格化

栅格化是将矢量图形转换为位图图像的过程。在栅格化过程中,Illustrator 会将图形路径转换为像素。您所设置的栅格化选项将决定结果像素的大小及特征。

您可以使用“对象”>“栅格化”命令或“栅格化”效果栅格化单独的矢量对象。也可以通过将文档导入为位图格式(例如 JPEG、GIF 或 TIFF)的方式来栅格化整个文档。

栅格化矢量对象

  1. 选择一个或多个对象。

  2. 执行下列操作之一:

    • 若要永久栅格化对象,请选择“对象”> “栅格化”。

    • 若要创建栅格化外观,而不更改对象的底层结构,请选择“效果”>“栅格化”。

  3. 设置栅格化选项,然后单击“确定”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略