用户指南 取消(C)

收集资源并批量导出

  1. 《Illustrator 用户指南》
  2. 了解 Illustrator
    1. Illustrator 简介
      1. Illustrator 的新增功能
      2. 常见问题
      3. Illustrator 系统要求
      4. 适用于 Apple Silicon 的 Illustrator
    2. 工作区
      1. 工作区基础知识
      2. 使用 Illustrator“发现”面板加快学习速度
      3. 创建文档
      4. 工具栏
      5. 默认键盘快捷键
      6. 自定快捷键
      7. 画板简介
      8. 管理画板
      9. 自定义工作区
      10. “属性”面板
      11. 设置偏好设置
      12. 触控工作区
      13. Illustrator 中的 Microsoft Surface Dial 支持
      14. 撤消编辑和管理设计历史记录
      15. 旋转视图
      16. 标尺、网格和参考线
      17. Illustrator 中的无障碍功能
      18. 安全模式
      19. 查看图稿
      20. 将 Touch Bar 与 Illustrator 结合使用
      21. 文件和模板
    3. Illustrator 中的工具
      1. 工具概览
      2. 选择工具
        1. 选择
        2. 直接选择
        3. 编组选择
        4. 魔棒
        5. 套索
        6. 画板
      3. 导航工具
        1. 抓住
        2. 旋转视图
        3. 缩放
      4. 绘图工具
        1. 渐变
        2. 网格
        3. 形状生成器
      5. 文本工具
        1. 文字
        2. 路径文字
        3. 垂直文字
      6. 绘图工具
        1. 钢笔
        2. 添加锚点
        3. 删除锚点
        4. 锚点
        5. 曲率
        6. 直线段
        7. 矩形
        8. 圆角矩形
        9. 椭圆
        10. 多边形
        11. 星形
        12. 画笔
        13. 斑点画笔
        14. 铅笔
        15. Shaper
        16. 切片
      7. 修改工具
        1. 旋转
        2. 镜像
        3. 缩放
        4. 切变
        5. 宽度
        6. 自由变换
        7. 滴管
        8. 混合
        9. 橡皮擦
        10. 剪刀
        11. Dimension
    4. 生成式 AI(在中国大陆不可用)
      1. 使用文本提示生成矢量图形
      2. 使用文本提示重新着色图稿
    5. 快速操作
      1. 复古文字
      2. 霓虹灯文本
      3. 复古文本
      4. 重新着色
      5. 将草图转换为矢量
  3. Illustrator Web 版 (Beta)
    1. Illustrator Web 版 (Beta) 概述
    2. Illustrator Web 版 (Beta) 常见问题解答
    3. 故障排除问题常见问题
    4. Illustrator Web 版 (Beta) 的键盘快捷键
    5. 在 Web 上创建和组合形状
    6. 在 Web 上添加和编辑文本
    7. 在 Web 上应用颜色和渐变
    8. 在 Web 上绘制和编辑路径
    9. 在 Web 上处理云文档
    10. 在 Web 上邀请协作者参与编辑
  4. Illustrator iPad 版
    1. Illustrator iPad 版简介
      1. Illustrator iPad 版概述
      2. Illustrator iPad 版常见问题解答
      3. 系统要求 | Illustrator iPad 版
      4. 在 Illustrator iPad 版上可以或无法执行的操作
    2. 工作区
      1. Illustrator iPad 版工作区
      2. 触控快捷键和手势
      3. Illustrator iPad 版的键盘快捷键
      4. 管理应用程序设置
    3. 文档
      1. 在 Illustrator iPad 版中处理文档
      2. 导入 Photoshop 和 Fresco 文档
    4. 选择和排列对象
      1. 创建重复对象
      2. 混合对象
    5. 绘图
      1. 绘制和编辑路径
      2. 绘制和编辑形状
    6. 文字
      1. 处理文字和字体
      2. 在路径上创建文本设计
      3. 添加您自己的字体
    7. 处理图像
      1. 对栅格图像进行矢量化
    8. 颜色
      1. 应用颜色和渐变
  5. 云文档
    1. 基本信息
      1. 使用 Illustrator 云文档
      2. 共享并协作处理 Illustrator 云文档
      3. 共享文档以供审阅
      4. 升级 Adobe Illustrator 的云存储空间
      5. Illustrator 云文档 | 常见问题
    2. 故障排除
      1. 排除创建或保存 Illustrator 云文档的问题
      2. 为 Illustrator 云文档问题排除故障
  6. 添加和编辑内容
    1. 绘制和标注尺寸
      1. 绘图基础知识
      2. 编辑路径
      3. 绘制像素级优化的图稿
      4. 使用钢笔、曲率或铅笔工具绘制
      5. 绘制简单线段和形状
      6. 绘制矩形和极坐标网格
      7. 绘制和编辑光晕
      8. 图像描摹
      9. 简化路径
      10. 符号工具和符号组
      11. 调整路径段
      12. 利用简单 5 步设计花朵
      13. 创建和编辑透视网格
      14. 在透视网格上绘制和修改对象
      15. 将对象用作符号以重复使用
      16. 绘制用于 Web 工作流程的像素对齐路径
      17. 测量和绘制尺寸
    2. 3D 对象和材质
      1. 关于 Illustrator 中的 3D 效果
      2. 创建 3D 图形
      3. 将图稿贴在 3D 对象上
      4. 创建 3D 文本
      5. 创建 3D 对象
    3. 颜色
      1. 关于颜色
      2. 选择颜色
      3. 使用和创建色板
      4. 调整颜色
      5. 使用“Adobe Color 主题”面板
      6. 颜色组(协调)
      7. “颜色主题”面板
      8. 重新着色图稿
    4. 绘画
      1. 关于绘画
      2. 使用填色和描边上色
      3. 实时上色组
      4. 渐变
      5. 画笔
      6. 透明度和混合模式
      7. 为对象应用描边
      8. 创建和编辑图案
      9. 网格
      10. 图案
    5. 选择和排列对象
      1. 选择对象
      2. 图层
      3. 编组和扩展对象
      4. 移动、对齐和分布对象
      5. 堆叠对象    
      6. 锁定、隐藏和删除对象
      7. 复制和重复对象
      8. 旋转和镜像对象
      9. 缠绕对象
      10. 创建逼真的艺术模型
    6. 改变对象形状
      1. 裁切图像
      2. 变换对象
      3. 组合对象
      4. 剪切、分割和裁切对象
      5. 操控变形
      6. 缩放、倾斜和扭曲对象
      7. 混合对象
      8. 使用封套改变形状
      9. 使用效果改变对象形状
      10. 使用 Shaper 和形状生成器工具构建新的形状
      11. 使用实时转角
      12. 增强的支持触摸式变形工作流程
      13. 编辑剪贴蒙版
      14. 实时形状
      15. 使用形状生成器工具创建形状
      16. 全局编辑
    7. 文字
      1. 添加文本并使用文字对象
      2. 创建项目符号列表和编号列表
      3. 管理文本区域
      4. 字体和排版
      5. 将图像中的文本转换为可编辑文本
      6. 为文本添加基本格式
      7. 为文本添加高级格式
      8. 导入和导出文本
      9. 设置段落格式
      10. 特殊字符
      11. 创建路径文字
      12. 字符和段落样式
      13. 制表符
      14. 查找缺少的字体(Typekit 工作流程)
      15. 阿拉伯语和希伯来语文字
      16. 字体 | 常见问题解答和故障排除提示
      17. 创建 3D 文本效果
      18. 创意排版设计
      19. 缩放和旋转文字
      20. 行距和字距
      21. 连字和换行
      22. 拼写和语言词典
      23. 设置亚洲字符格式
      24. 亚洲语言脚本书写器
      25. 使用混合对象创建文本设计
      26. 使用图像描摹创建文本海报
    8. 创建特殊效果
      1. 使用效果
      2. 图形样式
      3. 外观属性
      4. 创建素描和马赛克
      5. 投影、发光和羽化
      6. 效果小结
    9. Web 图形
      1. 创建 Web 图形的最佳做法
      2. 图表
      3. SVG
      4. 切片和图像映射
  7. 导入、导出和存储
    1. 导入
      1. 置入多个文件
      2. 管理链接和嵌入文件
      3. 链接信息
      4. 取消嵌入图像
      5. 从 Photoshop 导入图稿
      6. 导入位图图像
      7. 导入 Adobe PDF 文件
      8. 导入 EPS、DCS 和 AutoCAD 文件
    2. Illustrator 中的 Creative Cloud Libraries 
      1. Illustrator 中的 Creative Cloud Libraries
    3. 保存
      1. 存储图稿
    4. 导出
      1. 在 Photoshop 中使用 Illustrator 图稿
      2. 导出图稿
      3. 收集资源并批量导出
      4. 打包文件
      5. 创建 Adobe PDF 文件
      6. 提取 CSS | Illustrator CC
      7. Adobe PDF 选项
      8. “文档信息”面板
  8. 打印
    1. 准备打印
      1. 设置打印文档
      2. 更改页面大小和方向
      3. 指定用于裁切或对齐的裁切标记
      4. 大型画布快速入门
    2. 打印
      1. 叠印
      2. 使用颜色管理进行打印
      3. PostScript 打印
      4. 打印预设
      5. 印刷标记和出血
      6. 打印和存储透明图稿
      7. 陷印
      8. 打印分色
      9. 打印渐变、网格和颜色混合
      10. 白色叠印
  9. 任务自动化
    1. 使用“变量”面板合并数据
    2. 脚本的自动化
    3. 动作的自动化
  10. 故障排除
    1. 已知问题
    2. 崩溃问题
    3. 崩溃后恢复文件
    4. 文件问题
    5. 支持的文件格式
    6. GPU 设备驱动程序问题
    7. Wacom 设备问题
    8. DLL 文件问题
    9. 内存问题
    10. 偏好设置文件问题
    11. 字体问题
    12. 打印机问题
    13. 与 Adobe 共享崩溃报告
    14. 改进 Illustrator 性能

了解如何收集资源并批量导出资源。

“导出为多种屏幕所用格式”工作流程是一种全新的方式,可以通过一步操作生成不同大小和文件格式的资源。使用快速导出功能可以更加简单快捷地生成图像作品(图标、徽标、图像和模型等),对于 Web 和移动工作流程而言尤为如此。

例如,在移动设备应用程序开发情景中,用户体验设计师可能需要频繁重新生成更新的图标和徽标。他可以将这些图标和徽标添加到“资源导出”面板中,然后通过单击一次按钮,将其导出为多种文件类型和大小。 

有用的功能:

  • 通过一个快捷操作导出为多种格式和大小。 
  • 导出为一般或自定义大小(比例):1x、2x、3x、0.5x 和 1.5x 等。
  • 对用于生成 PNG 文件的算法进行了修改:
    • 生成 PNG 文件的速度比以往更快。 
    • 提高了 PNG-8 文件的透明度。

可用的格式:

  • PNG(PNG-8、PNG-24)
  • JPEG(JPEG 100%、JPEG 85%、JPEG 50%、JPEG 25%)
  • SVG
  • PDF
  • OBJ
  • USDA
  • GLTF
  • WebP
“导出为多种屏幕所用格式”对话框(“资源”选项卡)。

导出资源(“导出为多种屏幕所用格式”工作流程)

要导出整个画板或个别图稿,请遵循以下步骤。

  1. 执行下列操作之一:

    • 转到文件 > 导出 > 导出为多种屏幕所用格式
    • 右键单击选中的图稿并选择收集以导出

    导出为多种屏幕所用格式对话框中,编辑要在导出图稿时使用的设置。

  2. 选择要导出的范围。可以使用两个选项卡:

    画板

    从可供导出的画板中进行选择。单击画板可将其选中或取消选中。此外,使用鼠标和 Shift 键还可进行多选。

    资源

    在“资源导出”面板中从您已收集的资源中进行选择。
    注意:

    单击缩览图或列表图标可用不同的方式查看项目。

    “导出为多种屏幕所用格式”对话框(“画板”选项卡)。

  3. 根据您所处的选项卡,选择要导出为文件的项目。复选标记指示画板或资源是否处于选中状态。

    画板选项卡

    • 所有:选择所有画板。将单独导出每个画板。
    • 范围:从可在文档中找到的画板中选择要导出的个别画板。例如,“1, 2, 4-6”选择画板 1、2、4、5 和 6。
    • 整篇文档:将整篇文档导出为一个图稿。

    资源选项卡

    • 所有资源:选择此选项以导出在“资源”选项卡中收集的所有资源。
    注意:

    要重新开始,请单击“清除选区”以取消选择所有收集的资源。您可以单击缩览图,开始选择指定图稿。

  4. 指定所导出文件的设置。

    缩放

    指定输出文件的比例系数。

    导出到

    指定导出的文件将放入的文件夹位置。

    导出后打开位置

    请选择此选项以指定是否要使用文件浏览器(资源管理器或访达)打开包含所导出的资源的文件夹。

    后缀

    提供一个后缀以确保输出的文件名唯一。

    格式

    指定需要输出 .png、.svg、.jpg、.webp 还是 .pdf 文件。

    前缀

    为生成的文件名提供画板编号递增编号自定义字符串作为前缀。

    添加比例

    选择添加比例以添加要导出的另一种导出比例或格式。

    删除

    选择 以删除输出类型。

    预设

    • iOS:选择此项以添加一般需要用于 iOS 项目的预设文件输出类型。
    • Android:选择此项以添加一般需要用于 Android 外形规格项目的预设文件输出类型。

    要指定导出文件格式的输出设置,请选择设置

  5. 选择导出画板导出资源

“资源导出”面板

资源导出面板显示从图稿收集的资源。这些资源一般为经常要导出的作品。

比例

指定输出文件的比例系数。

后缀

提供一个后缀以确保输出的文件名唯一。

格式

指定需要输出 .png、.svg、.jpg、.webp 还是 .pdf 文件。

添加比例

选择添加比例以添加要导出的另一种导出比例或格式。

删除

选择 以删除输出类型。

预设

  • iOS:选择此项以添加一般需要用于 iOS 项目的预设文件输出类型。
  • Android:选择此项以添加一般需要用于 Android 外形规格项目的预设文件输出类型。

导出的预设的设置

  • 另存为预设:使您可将导出设置保存为预设。
  • 保存更改:编辑预设中的导出设置后,可保存该预设。
  • 删除预设:使您可删除所选的预设。
  • 导入预设:使您可导入预设。
  • 导出预设使您可导出预设。
带有资源和导出设置的“资源导出”面板。
“资源导出”面板

收集要导出的图稿

可在资源导出面板中收集将作为多个资源或单个资源导出的对象。

收集将作为多个资源导出的图稿

要收集将作为多个资源导出的对象/图层,请将它们添加到资源导出面板(窗口 > 资源导出)。执行下列操作之一:

  • 右键单击该资源,然后选择收集以导出 > 作为多个资源
  • 将图稿拖入资源导出面板。

每次将图稿拖动到资源导出面板时,即会“收集”一个资源。这不会在画板上或在 CC 库中创建重复对象。更新文档中的图稿时,相应的资源也会在资源导出面板中自动更新。

收集将作为单个资源导出的图稿

要收集将作为单个资源导出的对象/图层,请执行以下操作之一:

  • 右键单击该资源,然后选择收集以导出 > 作为单个资源
  • 在按住 Alt/Option 的同时将图稿拖入资源导出面板。

导出资源(“资源导出”面板工作流程)

要使用资源导出面板导出资源,请遵循以下步骤。

  1. 选择窗口 > 资源导出以启动“资源导出”面板。

  2. 资源导出面板中查看所收集的资源。已选中进行导出的资源会有一个边框作为标记。

    注意:

    只有带边框的资源才会被导出。单击缩览图可选择或取消选择资源。

  3. 指定导出设置

  4. 指定导出文件格式的输出设置,从导出资源面板菜单中选择格式设置

  5. 在导出工作流后立即查看导出的文件,并从导出资源面板菜单中选择导出后打开位置

  6. 要生成文件,请选择导出

    导出资源时,Illustrator 默认情况下会根据您选择的缩放选项,在导出位置创建相应的子文件夹。例如,如果您在“资源导出”面板中选择了多种缩放格式(1x、2x 和 3x),以便将文件导出为 PNG,那么 Illustrator 会相应地为导出的文件创建名为 1x、2x 和 3x 的子文件夹。对于不支持缩放选项的格式,Illustrator 根据为导出选择的文件格式为子文件夹命名,例如 SVG 和 PDF。 

    要将文件导出在文件夹中但不创建任何子文件夹,请从资源导出面板菜单导出为多种屏幕所用格式对话框中取消选中创建子文件夹

    注意:

    要更改导出资源的目标文件夹位置或指定文件前缀等详细信息,请使用“导出为多种屏幕所用格式”对话框。单击 可打开“导出为多种屏幕所用格式”对话框。“导出为多种屏幕所用格式”对话框中会保留在“资源导出”面板中设置的所有选项。

所导出的资源的输出设置

通过格式设置对话框,可指定可导出的每种文件类型的输出设置:

  • 导出为多种屏幕所用格式对话框中,选择设置图标以启动格式设置对话框。
  • 资源导出面板中,选择导出资源面板菜单 并选择格式设置

从一点度量到另一点时,所度量的距离将显示在信息面板中。要显示信息面板,请转至窗口>信息。除角度外的所有度量值都以当前为文档设置的度量单位计算。

“格式设置”对话框提供特定于格式的设置。
“格式设置”对话框提供特定于格式的设置。

更多此类内容

有疑问或想法?

询问社区

如果您有疑问,或者希望分享观点,请加入 Adobe Illustrator 社区。我们很乐意倾听您的心声并欣赏您的创意作品。

 Adobe

更快、更轻松地获得帮助

新用户?

Adobe MAX 2024

Adobe MAX
创意大会

10 月 14 日至 16 日迈阿密海滩及线上

Adobe MAX

创意大会

10 月 14 日至 16 日迈阿密海滩及线上

Adobe MAX 2024

Adobe MAX
创意大会

10 月 14 日至 16 日迈阿密海滩及线上

Adobe MAX

创意大会

10 月 14 日至 16 日迈阿密海滩及线上