应用颜色

Adobe InDesign 提供了大量用于应用颜色的工具,包括工具箱、“色板”面板、“颜色”面板、“拾色器”和“控制”面板。

应用颜色时,可以指定将颜色应用于对象的描边还是填色。描边适用于对象的边框或框架,填色适用于对象的背景。将颜色应用于文本框架时,可以指定颜色变化影响文本框架还是框架内的文本。

  1. 通过执行以下操作之一选择要着色的对象:
    • 对于路径或框架,请根据需要使用“选择”工具 或“直接选择”工具
    • 对于灰度图像或单色图像,请单击“内容手形抓取工具”或使用“直接选择工具”。对于灰度图像或单色图像,只能应用两种颜色。
    • 对于文本字符,请使用“文字”工具 以更改单个字词或框架内整个文本的文本颜色。

    注意:

    若要更改虚线、点线或条纹描边中的间隙颜色,请使用“描边”面板。

  2. 在工具箱、“颜色”面板或“色板”面板中,选择“格式针对文本”或“格式针对容器”,以确定将颜色应用于文本还是文本框架。

  3. 在工具箱、“颜色”面板或“色板”面板中,选择“填色”框或“描边”框,以指定对象的填色或描边。(如果选择的是一个图像,“描边”框将不起作用。)
    指定如何在工具箱中应用颜色
    指定如何在工具箱中应用颜色

    A. “填色”框 B. 格式影响容器 C. “描边”框 D. 格式影响文本 
  4. 执行以下操作之一:
    • 使用“色板”面板或“渐变”面板选择一种颜色、色调或渐变。
    • 从“控制”面板的“填色”或“描边”菜单中选择一种颜色、色调或渐变。
    • 双击工具箱或“颜色”面板中的“填色”或“描边”框,以打开“拾色器”。选择所需颜色,然后单击“确定”。

注意:

只要灰度图像中不含 Alpha 通道或专色通道,即可对其应用颜色。如果导入一个带剪切路径的图像,请使用直接选择工具选择该剪切路径,以便仅将颜色应用于剪切区域。

使用拾色器选择颜色

使用“拾色器”可以从色域中选择颜色,或以数字方式指定颜色。可以使用 RGB、Lab 或 CMYK 颜色模型来定义颜色。

  1. 双击工具箱或“颜色”面板中的“填色”或“描边”框,以打开“拾色器”。
  2. 要更改“拾色器”中显示的颜色色谱,请单击字母:R(红色)、G(绿色)、B(蓝色);或 L(亮度)、a(绿色-红色轴)、b(蓝色-黄色轴)。
    拾色器
    拾色器

    A. 原稿颜色 B. 新建颜色 C. 色域 D. 颜色滑动条三角形 E. 色谱 
  3. 要定义颜色,执行以下操作之一:
    • 在色域内单击或拖动。十字准线指示颜色在色域中的位置。
    • 沿颜色色谱拖动颜色滑块三角形,或者在颜色色谱内单击。
    • 在任意文本框中输入值。
  4. 要将该颜色存储为色板,请单击“添加 CMYK 色板”、“添加 RGB 色板”或“添加 Lab 色板”。InDesign 将该颜色添加到“色板”面板中,并使用颜色值作为其名称。
  5. 单击“确定”。

应用上次使用的颜色

工具箱显示上次应用的颜色或渐变。可以直接从工具箱中应用该颜色或渐变。

  1. 选择要着色的对象或文本。
  2. 在工具箱中,根据要着色的文本或对象部分,单击“填色”或“描边”按钮。
  3. 在工具箱中,执行以下操作之一:
    • 单击“颜色”按钮 以应用上次在“色板”或“颜色”面板中选择的纯色。
    • 单击“渐变”按钮 以应用上次在“色板”或“渐变”面板中选择的渐变。
    • 单击“无”按钮 以移去该对象的填色或描边。

移去填色或描边颜色

  1. 选择要移去其颜色的文本或对象。
  2. 在工具箱中,根据要更改的文本或对象部分,单击“填色”或“描边”按钮。
  3. 单击“无”按钮 以移去该对象的填色或描边。

通过拖放应用颜色

应用颜色或渐变的一种简单方法是将其从颜色源拖到对象或面板上。通过拖放,您不必首先选择对象即可将颜色或渐变应用于对象。可以拖动下列各项:

  • 工具箱或面板中的“填色”或“描边”框。

  • “渐变”面板中的“渐变”框。

  • “色板”面板中的色板。

  • 上次使用的色域内颜色色板位于面板中“超出色域”图标 旁边。

可以在下列对象和面板上拖放颜色或渐变:

  • 路径的填色或描边。要在填色或描边上拖放颜色,请在拖动颜色时将拖动图标的中心对准路径的填色或描边,然后释放鼠标按钮。

  • “色板”面板。

 

如果要拖动“色板”面板中的一个或多个色板,或是拖动某个“超出色域”图标旁边的色板,可以将它们拖放到另一个 InDesign 文档窗口中,该窗口会将这些色板添加到此文档的“色板”面板中。

应用颜色色板或渐变色板

  1. 使用“选择”工具 选择一个文本框架或对象框架;或者使用“文本”工具 选择一个文本范围。

  2. 如果没有打开“色板”面板,请选择“窗口”>“颜色”>“色板”。

  3. 在“色板”面板中,选择“填色”框或“描边”框。

  4. 执行以下操作之一:

    • 若要将颜色应用于所选文本,请单击“文本”按钮

    • 若要将颜色应用于所选对象或文本容器(例如,框架或表),请单击“对象”按钮

  5. 单击一个颜色色板或渐变色板。所选颜色或渐变将应用到任何选定的文本或对象,并将在“颜色”面板中以及工具箱的“填色”框或“描边”框中显示。

注意:

可以按照设置其他 InDesign 默认设置的方法,设置默认的填色或描边颜色。选择“编辑”>“全部取消选择”以确保未选定任何对象,然后选择一种颜色。

使用颜色面板应用颜色

尽管建议将“色板”面板与颜色一同使用,但是通过使用“颜色”面板, 您还可以混合颜色。可以随时将当前“颜色”面板中的颜色添加到“色板”面板中。“颜色”面板对于混和未命名的颜色最为有用。

注意:

如果所选对象当前使用的是已命名的色板,则使用“颜色”面板编辑其颜色将只能更改该对象的颜色。如果要编辑整个文档的颜色,请在“色板”面板中双击其色板。

编辑填色或描边颜色

  1. 选择要更改的对象或文本。
  2. 如果未显示“颜色”面板,请选择“窗口”>“颜色”。
  3. 选择“颜色”面板中的“填色”框或“描边”框。
    “颜色”面板
    “颜色”面板

    A. “填色”框 B. “描边”框 C. 格式影响容器 D. 格式影响文本 
  4. 如果选择的是一个文本框架,则请选择“容器”框 或“文本”框 以更改框架内填色或文本的颜色。
  5. 执行以下操作之一:
    • 调节“色调”滑块(如果对象使用“色板”面板中的色板,则默认情况下将显示该滑块)。
    • 在“颜色”面板菜单中选择一个 Lab、CMYK 或 RGB 颜色模型,然后使用滑块更改颜色值。还可以在颜色滑块旁边的文本框中输入数值。
    • 将指针放在颜色条上并单击。
    • 双击“填色”或“描边”框,并从“拾色器”中选择一种颜色。然后单击“确定”。
  6. 如果显示“超出色域警告”图标 ,并且您希望使用与最初指定的颜色最接近的 CMYK 颜色值,则请单击警告图标旁边的小颜色框。

从颜色面板中的颜色创建色板

  1. 在“颜色”面板中,确保活动的“填色”或“描边”框中显示了要添加的颜色。
  2. 在面板菜单中选择“添加到色板”。

循环切换颜色模式

  1. 执行以下操作之一:
    • 在“颜色”面板中,按住 Shift 键并单击面板底部的颜色条。
    • “新建颜色色板”或“色板选项”对话框中,按住 Shift 键并单击颜色框。
    • 在“新建渐变”或“渐变选项”对话框中,选择一个渐变色标,确保在“站点颜色”菜单中已选中 RGB、LAB 或 CMYK,然后按住 Shift 键并单击颜色框。

使用颜色主题工具生成颜色主题

您可以从 InDesign 文档的选定区域、图像或对象中提取颜色主题。还可以从图像、整个图像或整个版面选择颜色。基本上,可以通过图稿中的任何颜色生成颜色主题。使用颜色主题工具选取单个颜色或主题,并将该颜色主题添加到色板面板。

将这些颜色添加到版面,将它们添加到“色板”面板。您还可以将它们存储到 Creative Cloud Libraries

  1. 在“工具”面板上单击“颜色主题”工具。您可以使用快捷键 I 在“颜色主题”工具和“吸管”工具之间进行切换。

    颜色主题工具
    颜色主题工具

  2. 单击版面的任意部分可选取颜色。您还可以利用 Adobe Photoshop、Illustrator 中置入的任何图稿或任何其他文件中的颜色。

    在使用主题工具进行选择之后,即会保留颜色。在选取颜色之后,如果您切换工具以执行某些其他操作(例如绘制任意对象),然后重新选择颜色主题工具,则之前选取的主题将得以保留。除非按 ESC 键关闭面板,否则已选取的主题将被保留以供重复使用。按下 ESC 键将会清除一切内容。

  3. 滚动鼠标可以看到 InDesign 自动标记的区域,您可以通过这些区域创建颜色主题。单击某一部分,InDesign 即会创建颜色主题。

  4. 颜色主题由五种不同颜色组成。单击弹出菜单可查看生成的其他颜色选项。

  5. 颜色主题工具 - 选项
    颜色主题工具 - 选项

    A. 单击可查看所有主题 B. 将当前颜色主题添加到色板 C. 存储到当前的 CC Library 

    颜色主题由五种不同颜色组成。单击弹出菜单(图像中的 A),可查看为同一颜色主题生成的其他主题选项,例如“彩色”、“亮”、“深”和“柔色”。

    如果不喜欢生成的颜色主题,可按 Esc 键并重试,或者按 Alt 键临时切换到“选取”模式以收集新主题。

    按下 Shift 并单击可选取一种(精确)颜色作为主题的基色。将根据 Adobe Color 规则生成以下颜色主题:近似色、单色、三色组合、互补色、合成色、暗色。

  6. 要应用颜色,可以选择“颜色主题”工具上的一种颜色。将鼠标滚动到页面项目。吸管显示为半满状态,单击可更改填色或描边。

    当您将鼠标滚动到文本上时,吸管会更改为文本。您可以对文本应用通过颜色主题工具生成的颜色。

  7. 双击“颜色主题”工具。已选取并添加到色板的颜色支持文档用途,并将自动转换为适当的色彩空间,以便于将其添加到色板或拖放到其他对象上。可供选择的选项有三种:

    1. 按照文档用途转换。
    2. 转换为 CMYK。
    3. 转换为 RGB。
    颜色主题选项
    颜色主题选项

  8. 颜色主题工具 - 选项
    颜色主题工具 - 选项

    A. 单击可查看所有主题 B. 将当前颜色主题添加到色板 C. 存储到当前的 CC Library 

    单击 B 可将这些颜色添加到“色板”面板。颜色主题会作为文件夹添加到“色板”面板。

    要将特定颜色添加到“色板”面板,请按 Alt 并单击“将当前颜色主题添加到色板”按钮。

  9. 颜色主题
    颜色主题

    单击此按钮,面板上选定的主题将会存储到 CC Libraries 面板中当前的 CC 库中。

  10. 您可以应用拾色器、新建色板和编辑色板工作流程中采用十六进制 RGB 编码的颜色值。您也可以使用十六进制 RGB 编码来应用颜色值。可以通过三种方式来应用十六进制颜色值:

    • 使用“新建色板”中的拾色器:从“色板”面板中,单击以展开弹出菜单,然后选择“新建颜色色板”。从“新建颜色色板”对话框的“颜色模式”中,选择“RGB”。
      单击屏幕抓取工具,在屏幕上的任何位置单击鼠标按钮即可查看来自任何来源的十六进制颜色值。单击“添加”可添加颜色色板。
    新建色板 - 十六进制值
    新建色板 - 十六进制值

    • 编辑色板:也可以编辑色板并更改其十六进制值。双击某个色板,从“颜色模式”下拉框中,选择“RGB”。
    • 颜色代理:双击“工具”面板中的颜色代理。您可以在此处选取十六进制值。

使用吸管工具应用颜色

使用“吸管”工具 从 InDesign 文件的任何对象(包括导入图形)复制填色和描边属性(如颜色)。默认情况下,“吸管”工具会载入对象的所有可用的填色和描边属性,并为任何新绘制对象设置默认填色和描边属性。可以使用“吸管选项”对话框更改“吸管”工具所复制的属性。还可以使用“吸管”工具复制文字属性和透明度属性。

注意:

如果属性未在“吸管选项”对话框中列出,则无法使用“吸管”工具复制该属性。

使用吸管工具应用颜色

  1. 选择要更改其填色和描边属性的一个或多个对象。

  2. 选择“吸管”工具

  3. 单击要将其填色和描边属性作为样本的任何对象。这时将显示一个加载了属性的吸管 ,并会自动用所单击对象的填色和描边属性更新所选对象。

  4. 要更改其他对象使其具有相同的属性,请单击带有载入了属性的吸管的对象。如果对象已描边但未填色,请确保单击该对象的轮廓。

在载入“吸管”工具后选取新属性

  1. 在“吸管”工具 处于载入状态时,按 Alt 键 (Windows) 或 Option 键 (Mac OS)。“吸管”工具将反转方向并呈现空置状态 ,表明它已准备好选取新属性。

  2. 按住 Alt 键或 Option 键,单击包含要复制的属性的对象,然后释放 Alt 键或 Option 键,以便可以将新属性应用到另一个对象上。

更改“吸管”工具设置

  1. 在“工具箱”中,双击“吸管”工具

  2. 在“填色设置”和“描边设置”中选择您要使用“吸管”工具复制的属性,然后单击“确定”。

注意:

要只选取对象的填色或描边颜色而不选取其他属性,请按住 Shift 键并使用“吸管”工具单击对象。当您将该颜色应用于其他对象时,根据位于工具栏顶部的是描边还是填色,将仅应用填色或描边颜色。

对灰度图像应用颜色

可以在 InDesign 中为置入的灰度图像添加颜色。

  1. 请确保图像已存储为灰度图像或位图图像,并且图像以 PSD、TIFF、BMP 或 JPG 格式存储。

    在 Photoshop 中,可以选择“图像”>“模式”>“位图”或“图像”>“模式”>“灰度”。

  2. 单击“内容手形抓取工具”或使用“直接选择”工具 以选取图像。

  3. 从“色板”面板或“颜色”面板中选择一种颜色。

PSD 格式的图像可以包含多个图层,但是,底部图层必须是不透明的。在 InDesign 中,无法将颜色应用于具有透明背景的 PSD 图像。此外,灰度图像不能包含 alpha 通道或专色通道。

添加和管理颜色组

颜色组允许您更好地管理颜色方案并且可以跨应用程序交换经常使用的色板。颜色组可以帮助您:

  • 管理颜色色板。
  • 从 Illustrator 的项目中载入颜色组。

添加颜色组

  1. 要创建颜色组,请单击“色板”面板上的“颜色组”图标。或者,也可以从弹出菜单和上下文菜单中创建颜色组。

    新建颜色组
    新建颜色组

    • 输入颜色组的名称。
    • 选择此选项可创建颜色组方案:
      • 选定的色板:如果要在创建时将色板移动到颜色组,则选择此选项。按住 Ctrl (Win) 或 Option (Mac),可以在选择“新建颜色组”选项前选择多个颜色色板。如果未选择色板,则创建一个空的颜色组。
      • 选定的页面项目:选定的页面项目的色板或添加到创建的颜色组的图稿。默认情况下,当选择图稿时,会选中此选项。

    注意:

    要在创建时命名颜色组,您可以在单击“新建颜色组”按钮时,使用其中任一选项或按住 Alt 键 (Win) 或 Option 键 (Mac)。

  2. 您可以从根和其他颜色组中,将多个色板拖放到所创建的颜色组。

  3. 右键单击颜色色板以浏览其他选项。可以切换到“颜色组”视图,并且广泛使用颜色组。单击面板底部的过滤器图标并选择“显示颜色组”。这样可以允许您广泛使用颜色组。在此视图中,根色板和渐变无法显示。

    显示颜色组
    显示颜色组

管理颜色组的各种操作

下列操作可用来管理颜色组。

  • 将色板添加到颜色组:选择颜色组。选择色板并将其拖放到颜色组中。
  • 复制颜色组:可以在上下文菜单及弹出菜单中进行复制。右键单击颜色组并选择“复制颜色组”。颜色组内的所有色板将随颜色组一起被复制。在创建时,不同颜色组的色板不能采用相同的名称,以避免混淆。
  • 取消编组颜色组:可以在上下文菜单以及弹出菜单中完成取消编组操作。右键单击颜色组,然后选择“取消编组颜色组”。在取消编组时,颜色组内的所有色板都将转到颜色组外的根区域。
  • 重命名颜色组:通过在上下文菜单或弹出菜单中使用“颜色组选项”选项,可以重命名颜色组。双击颜色组可编辑其名称。您还可以内联编辑颜色组。
  • 删除颜色组:选择颜色组,右键单击并选择“删除颜色组”。或者,选择颜色组,然后从弹出菜单中选择“删除颜色组”。

注意:

当您删除颜色组时,颜色组内的所有色板都将被删除。

使用选定的页面项目创建颜色组

您可以在文档中选择页面项目图稿,并从页面项目显示的色板中创建颜色组。您可以将页面项目中的色板添加到颜色组中。

  1. 选择文档中的页面项目。

  2. 从弹出菜单或上下文菜单,选择“新建颜色组”。

  3. 在“新建颜色组”对话框中,选择“选定的页面项目”。如果在“色板”面板中选择了多个色板,则默认选中“选定的色板”。

  4. 颜色组适用于所有列表视图(名称、小名称)以及网格视图(小色板、大色板)。一切操作(如创建、拖动色板和颜色组)均可在色板面板内的各种不同视图间执行。

从 ASE 文件中载入和存储色板

ASE 文件可帮助在类似 Adobe Illustrator 的应用程序中导入和导出色板。您可以导入 .ase 文件,以便在“色板”面板中载入颜色组。也可以通过“色板”弹出菜单,将颜色组另存为 .ase 文件。同样,如果颜色组是从 Illustrator 中存储的,则可以在 InDesign 中载入相同的颜色组。

载入色板

  1. 从“色板”面板菜单选择“载入色板”。

  2. 选择存储的 .ase 文件。单击“打开”。

存储色板

您可以将色板或颜色组另存为 .ase 文件。

  1. 选择颜色组或色板。

  2. 从弹出菜单中,选择“存储色板”。

  3. 输入 .ase 文件的名称。单击“存储”。

从 Color 应用程序导入主题

您可以从“颜色”面板中将主题添加到“色板”面板中,以作为 InDesign 中的颜色组。这些主题将被创建为具有主题名称的颜色组。

  1. 选择“窗口”>“颜色”。

  2. 在“浏览”窗口中,选择主题。

    可以执行任何以下操作以将主题导出到 InDesign:

    • 单击主题旁边的箭头,然后选择“添加到色板”面板。                       
    • 单击“添加选定的主题”图标,以便将主题导入到“色板”面板。

     

    “添加色板”图标/选项
    “添加色板”图标/选项

  3. 您还可以转至 Color 中的“创建”选项卡,然后从“选择规则”中选择一条规则,接着单击“将主题添加到色板”图标。

    将主题添加到“色板”菜单
    将主题添加到“色板”菜单

支持旧行为

如果打开的 .idml 文件包含以前版本的颜色组信息,则“色板”面板显示没有颜色组的简单色板列表,因为以前的版本中没有提供颜色组。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略